PDA

View Full Version : [ubuntu] [SOLVED] Display resolution not adjusting



ktechman
May 6th, 2008, 11:19 PM
I switched from glx new to the older driver and tried to enable twinview it was not pleasant. The resolutions were all skewed so I switched back and now its still not right. How do I edit the xorg file and how do I get into it. Would really like to get the twinview working to use Lyricue I think it needs a separate X display

AMD Athlon(tm) 64 X2 Dual Core Processor 5000+
3960 MiB
GCC Ver. 4.1.3 (x86_64-linux-gnu)
Nvidia GForce 7600 dual head dvi/vga

chewearn
May 7th, 2008, 09:21 AM
Use nvidia-settings (if you have not).

sudo nvidia-settings

If you are in Hardy, you need to install nvidia-settings separately:

sudo apt-get install nvidia-settings

Btw, twinview and separate X screens are two different modes.

ktechman
May 7th, 2008, 01:43 PM
I tried that solution and it gave up some friut but not the entire basket you know this should be a cinch but it has become a project all on its own. I did find the tutorial on setting up twinview or seperate X whichever I choose. now if I can only tweak the xorg file correctly for my setup I will be a happy man. Thank you again for your reply

CJ56
May 7th, 2008, 01:54 PM
To get into your xorg.conf have you tried opening the terminal and typing


sudo nautilus

It'll ask you for your password (which doesn't appear on screen, don't worry) and then it opens up a file browser

Go to File System>etc>X11 and the xorg.conf is there to tweak...

chewearn
May 7th, 2008, 02:06 PM
gksu gedit /etc/X11/xorg.conf
will get you into xorg.conf.

Post the file here if you need assistance.

.

ktechman
May 7th, 2008, 09:10 PM
gksu gedit /etc/X11/xorg.conf
will get you into xorg.conf.

Post the file here if you need assistance.


I don't have a clue of what I am doing here can you be very specific please.

.


# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "nVidia Corporation G70 [GeForce 7600 GS]"
Driver "nv"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-96
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation G70 [GeForce 7600 GS]"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Modes "1920x1440" "1920x1200" "1680x1050" "1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
EndSection

chewearn
May 8th, 2008, 03:05 AM
It looks like you are using Gutsy or earlier?

Also, in the xorg.conf, it shows nv driver is used (instead of nvidia; look under Section "Device"). Your nvidia restricted driver is not enabled.


1.
I assumed this file (though using nv driver) still gives you a workable desktop. If so, make a back-up, which you can fall back to in case things get messed up later.

To back-up to a file called "xorg.conf.backup1":

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup1Later, if you happened to messed up and could not get into a working desktop, boot into safe mode (press ESC during the boot prompt, you will get a menu to select safe mode). Then run this command to restore the back-up:


cp /etc/X11/xorg.conf.backup1 /etc/X11/xorg.confNote:
In safe mode, you have root privilege, so there is no need for sudo infront of cp.


2.
Now, we will try to enable nvidia restricted driver; run this command to auto-configure an xorg.conf that has nvidia selected:


sudo nvidia-xconfigReboot. Look closely, ensure that nvidia driver is indeed used, and you are not thrown into safe graphical mode.


3.
If the new auto-configured xorg.conf works, back-up the new file to xorg.conf.backup2 (see point 1 above for instruction).

You can now run nvidia-settings to configure twinview or separate X screens. Note again: you can choose one, not both at the same time).

Run:

sudo nvidia-settingsThe sudo is important, as it allows you to write your changes to the xorg.conf.



Hope it works. If it doesn't, the more info you can post here, the better we can understand the issue you faced. I mentioned this last part because you are not very good as describing (in details :wink:) what you have done so far (I'm guessing a lot and it's not helping very much if I guess wrongly). :wink:

.

ktechman
May 8th, 2008, 06:20 PM
Thank you I finally figured out that my 19" wasn't set as a dedicated X and even though I enabled the Nvidia driver at one time it was unticked so I enabled it. Question: Why does the screen stretch across both screens. One aside, under "Section Device" "device1" it shows "vesa" as the driver and then says "screen 1" whats that all about? And the "metamodes" don't include the proper resolution for the 32 which is 1280x720 it just has the auto select along with the 1440x900 selection.
One other question is there any way to get the computer to recognize my screens fully instead of generic lcd and failsafe.



# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder26) Thu Feb 14 18:14:18 PST 2008

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder26) Thu Feb 14 18:13:41 PST 2008
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
Load "v4l"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "Monitor"
Identifier "Failsafe Monitor"
VendorName "Generic LCD Display"
ModelName "LCD Panel 1440x900"
HorizSync 31.5 - 56.0
VertRefresh 56.0 - 65.0
Gamma 1
ModeLine "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
ModeLine "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
ModeLine "1280x768@60" 80.1 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
ModeLine "1280x720@60" 74.5 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
ModeLine "1280x800@60" 83.5 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
ModeLine "1440x900@60" 106.5 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
EndSection

Section "Monitor"

#
Identifier "monitor1"
VendorName "Generic LCD Display"
ModelName "LCD Panel 1024x768"
HorizSync 31.5 - 48.0
VertRefresh 56.0 - 65.0
Gamma 1
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
ModeLine "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
ModeLine "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
ModeLine "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Acer P191W"
HorizSync 30.0 - 83.0
VertRefresh 55.0 - 75.0
EndSection

Section "Device"
Identifier "Failsafe Device"
Driver "nvidia"
BoardName "vesa"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"

#
Identifier "device1"
Driver "vesa"
BoardName "vesa"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7600 GS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Failsafe Device"
Monitor "Failsafe Monitor"
DefaultDepth 24
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
SubSection "Display"
Virtual 1440 900
Depth 24
Modes "1440x900@60" "1280x800@60" "1280x720@60" "1280x768@60" "800x600@60" "800x600@56"
EndSubSection
EndSection

Section "Screen"

#
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "800x600@60" "1024x768@60" "800x600@56" "640x480@60"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "metamodes" "DFP: 1440x900@60 +0+0, CRT: nvidia-auto-select +1440+0; DFP: 1280x800@60 +0+0, CRT: nvidia-auto-select +1280+0; DFP: 1280x720@60 +0+0, CRT: nvidia-auto-select +1280+0; DFP: 1280x768@60 +0+0, CRT: nvidia-auto-select +1280+0; DFP: 800x600@60 +0+0, CRT: nvidia-auto-select +800+0; DFP: 800x600@56 +0+0, CRT: nvidia-auto-select +800+0"
EndSection

chewearn
May 9th, 2008, 03:05 AM
Your xorg.conf has become quite messed-up. I could spend an hour trying to decipher what's going on, but I'm not going to. :wink:

If you are adventurous you could try clean it up; but back-up this one first (since it's working).

.

ktechman
May 9th, 2008, 03:25 AM
What is a good guide to get it back into shape? I have it backed up. Adventure is my middle name.