PDA

View Full Version : [ubuntu] Resolution issue with Vizio L37HDTV10A



odinb
May 4th, 2008, 09:27 PM
Hi!

Have a HTPC that I recently built, and are now installing OS on it.
I have installed Ubuntu Hardy 8.04.

My Videocard is the MSI NX7300LE 256MB RAM with an Nvidia Geforce 7300-chipset.

The screen is my 37 inch LCD, Vizio L37HDTV10A.

Using the opensource-drivers that installs automatically when installing Ubuntu, I get max resolution of 800x600.

Running proprietary drivers from Nvidia, installed via the wizard that pops up automatically after install of the OS, I get 640x480.

The LCD has native resolution of 1366x768 and also supports 1280x768, 1024x768, 800x600, 720x400, 640x480.

Have tried tinkering with the xorg.conf file to accomplish this, but to no avail. Want to have Compiz Fusion working, and also would like to run native resolution of 1366x768.

Anyone have any ideas what is causing this, and how to fix it?

Regards,

//Odin

odinb
May 5th, 2008, 02:36 AM
Found some hints on the mythTV-pages for a different Vizio, the Vizio VX37L, and now have the resolution at 1366x768.
http://www.mythtv.org/wiki/index.php/Vizio_VX37L

Problem is that the picture is "pushed" up into the right upper corner. Need to adjust it down and to the left a bit.

What values do I need to adjust to accomplish that?

Edit:
Found the application xvidtune (http://howto-pages.org/ModeLines/), and have now tuned the vtimings
from the ones on the mythTV-page referenced above.

Now just have a bit of a cropping on the right side, have not figured out how to fix that yet..

Edit2: Easy fix! Just change from 1366 to 1360 on the resolution, and it is now in working order!

//Odin


My working xorg.conf:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "NVIDIA GeForce 7 Series"
Busid "PCI:1:0:0"
Driver "nv"
Screen 0
Vendorname "NVIDIA"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
Option "ModeValidation" "NoWidthAlignmentCheck"
# Important!!! need this option to use nvidia card at 1360 x 768
EndSection

Section "Monitor"
Identifier "Configured Monitor"
VendorName "VIZIO"
ModelName "VIZIO L37HDTV"
HorizSync 31-70
VertRefresh 50-85
Mode "1360x768" # vfreq 59.815Hz, hfreq 47.553kHz
DotClock 85.500000
HTimings 1360 1494 1624 1798
VTimings 768 770 776 803
Flags "-HSync" "+VSync"
EndMode
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
Option "DPI" "100 x 100"
Defaultdepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1360x768"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1360x768"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
Modes "1360x768"
EndSubSection

EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection
Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection
Section "device" #
Identifier "device1"
Boardname "NVIDIA GeForce 7 Series"
Busid "PCI:1:0:0"
Driver "nv"
Screen 1
Vendorname "NVIDIA"
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
EndSection
Section "monitor" #
Identifier "monitor1"
Gamma 1.0
EndSection
Section "ServerFlags"
EndSection

Chambers
October 22nd, 2009, 02:34 PM
I am having the same issue with the screen going further from the viewable area. I will try these steps this weekend when I am rebuilding my xbmc ubuntu box, thanks so much!

Chambers
October 28th, 2009, 02:16 AM
Unfortunately this didn't work with the new Ubuntu 9.10 I basically copy and pasted your xorg.conf and it's still outside of the viewable screen. Any other ideas?

odinb
November 5th, 2009, 06:18 AM
You probably need to use Modelines to figure out your specifics.(http://howto-pages.org/ModeLines/)