PDA

View Full Version : [ubuntu] Xine-UI defaults to sound volume to 0%



Mr. Sunshine
May 4th, 2008, 03:34 AM
I'm running Hardy AMD64.

Xine-UI is my favorite video player, but the version included in Hardy starts up with the sound volume at 0%. Not muted, just at 0%. This is very annoying since I have to put the volume back at 100% every time I open a video.

I didn't have this problem with Gutsy. It always started at 80% (in order to avoid distortion)

I'd like to make it start at 100%, but I can't, even after fiddling with the audio options. How can I fix it?

zir0n
May 5th, 2008, 10:57 PM
I'm having the same problem, xine-ui with gutsy worked fine, but after i installed Hardy, the volume resets to 0 everytime i open it. I have already fiddled around with startup volume setting in the config file located in ~/.xine/config and also manipulating it through the GUI settings as well as the Restore Volume level at start up setting. I'm going to try to compile from source later tonight to see if its just the package version messing up.

gulper_eel
May 17th, 2008, 10:42 PM
I'm having the same problem in Hardy 8.04 x86. Xine gui defaults to zero volume at launch. Any ideas?

zir0n
May 18th, 2008, 01:37 AM
I've put a bug report on Launchpad, hopefully this issue gets resolved. No luck in compiling from source. I run into a problem in the .configure part. Ubuntu's libxine package is named libxine1 and messes with the .configure because its looking for libxine, not libxine1. Still trying to fix it messing with the PKG_CONFIG_PATH environment variable. here is the bug link

https://bugs.launchpad.net/ubuntu/+source/xine-ui/+bug/231507

zir0n
May 22nd, 2008, 08:22 AM
It seems to be working fine now, perhaps a new update fixed the problem...

zir0n
May 26th, 2008, 08:08 AM
Actually its not fixed yet... It's acting very weird, sometimes the volume setting will be to what I put in the xine config file and sometimes its at 0%. Its very random. I will try to see why its only doing it sometimes.

zir0n
July 14th, 2008, 05:19 AM
A user named Oliver Joos over at launchpad bugs (https://bugs.launchpad.net/ubuntu/+source/xine-ui/+bug/231507) found that if u modify this string in your "~/.xine/config" using your favorite text editor it will fix the problem.


#audio.pulseaudio_device:

to


audio.pulseaudio_device:pulseaudio

mlord
August 9th, 2010, 12:14 AM
If, like me, you've already nuked pulseaudio from your system, then xine needs to be told to use ALSA for playback.

So.. in ~/.xine/config set it as follows:

audio.driver:alsa

Works for me!

adamf663
April 15th, 2011, 05:41 PM
For me, I had to set gui.audio_mixer_method:Software, then manually
set the xine playback stream to halfway. Hopefully phonon/pulseaudio
will remember.

bugritall
August 20th, 2012, 01:42 PM
Using the config settings below, xine always starts up with volume at 30:


# startup audio volume
# [0..100], default: 50
audio.volume.mixer_volume:30

# restore volume level at startup
# bool, default: 0
audio.volume.remember_volume:1


It still doesn't remember my previous volume setting, however.