PDA

View Full Version : [ubuntu] openGL & Nvidia issue



lessgov2007
May 3rd, 2008, 07:13 PM
Older Compaq Presario running "Hardy" only...
e-GeForce 6200 video card.

I'm having problems getting any openGL apps to run while using any of the nvidia drivers in Hardy. The first couple of days with "Hardy" everything worked, openGL, desktop effects, etc, using the nvidia-glx-new drivers.

Last night I made the mistake of typing compiz into a terminal. I never thought this would effect anything... Here's what it did.

haunted@ubuntu:~$ compiz
Checking for Xgl: not present.
Detected PCI ID for VGA: 00:03.0 0300: 10de:0221 (rev a1) (prog-if 00 [VGA controller])
01:00.0 0300: 5333:8a26 (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: Illegal instruction
not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: Illegal instruction
not present.
aborting and using fallback: /usr/bin/metacity
Window manager warning: "" found in configuration database is not a valid value for keybinding "toggle_shaded"

My curiosity got me into this mess. I don't know a whole lot about Linux. I don't even understand what typing "compiz" could have done.

Note: My video card has both a DVI out & VGA out. I'm using the DVI (digital) only. No VGA output. If that helps...

Right now everything is fine except anything that uses openGL such as many of Ubuntu's screen savers. When I say OpenGL is not working I mean it tries but only shows a blank screen.

Also it will not enable desktop effects. (Not that I like it anyway) but perhaps this can clue something....It only runs through it's little thing and says "desktop effects could not be enabled"

I have tried removing and reinstalling the Nvidia drivers. The funny thing is when I get rid of the drivers then Ubuntu uses it's own NV driver. OpenGL works fine but not Desktop Effects. Naturally I want to use the Nvidia driver so my card uses it's GPU...

I not sure what other information may be needed. Thanks for any help...

Zorael
May 3rd, 2008, 07:26 PM
I'd try this.

$ sudo aptitude purge nvidia-glx-new nvidia-glx nvidia-glx-legacy
$ sudo aptitude install nvidia-glx-new
$ sudo nvidia-xconfig -d 24 --add-argb-glx-visuals --allow-glx-with-composite --randr-rotation
Then reboot or restart X (with Ctrl+Alt+Backspace). Reboot is only needed if no nvidia drivers were installed, in which case merely restarting X won't work. So might want to reboot to cover everything.

lessgov2007
May 3rd, 2008, 07:59 PM
I just tried your suggestion and it's still doing the same thing... The new Xorg file gave me the option to rotate my screen through NVidia XServer Settings... Which, is really strang to type sideways :)

Thanks, got anymore idea's?

Zorael
May 3rd, 2008, 08:07 PM
Could you post the content of your xorg.conf, then?

Also, the terminal output of this command.

$ glxinfo | grep -i rendering

lessgov2007
May 3rd, 2008, 08:15 PM
The last code you posted "glxinfo | grep -i rendering" doesn't do anything on my computer.

ubuntu:~$ glxinfo | grep -i rendering
ubuntu:~$

Same thing as root...

My Xorg.Conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Feb 14 18:20:37 PST 2008

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "int10"
Load "vbe"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "DELL E228WFP"
Option "DPMS"
EndSection

Section "Device"
Identifier "nVidia Corporation NV44A [GeForce 6200]"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV44A [GeForce 6200]"
Monitor "DELL E228WFP"
DefaultDepth 24
Option "NoLogo" "True"
Option "AllowGLXWithComposite" "True"
Option "RandRRotation" "True"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 1
Modes "1680x1050" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1680x1050" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1680x1050" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1680x1050" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1680x1050" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1680x1050" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Zorael
May 3rd, 2008, 08:26 PM
Gleh, upgraded? :>


$ sudo mv /etc/X11/xorg.conf /etc/X11/xorg.backup0805
$ sudo dpkg-reconfigure xserver-xorg
$ sudo nvidia-xconfig -d 24 --add-argb-glx-visuals --allow-glx-with-composite --randr-rotation

lessgov2007
May 3rd, 2008, 08:41 PM
After doing your last code it created another new Xorg.conf. This one is smaller but has not changed anything. The issue with OpenGL continues.

Here's the new one...

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Feb 14 18:20:37 PST 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "AllowGLXWithComposite" "True"
Option "RandRRotation" "True"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Zorael
May 3rd, 2008, 08:55 PM
Well, I'm at a loss. Purging and reinstalling Compiz might help with that particular app, but I don't know where else to look if you're not getting acceleration from the drivers at all.

$ sudo aptitude purge ~ncompiz ~nemerald ~nberyl ~nlibdeco xserver-xgl
$ sudo aptitude install compiz compizconfig-settings-manager emerald

Galban
May 3rd, 2008, 09:44 PM
Hi lessgov2007, I have exactly the same problem here. Looking forward for any rescuer helping because i have been crying this very same problem in many others threads and my own, and the low responsiveness makes me believe that there is not much people having troubles to get desktop effects up and running on their Nvidia's GPU. Curiously, you lessgov2007 and myself, we both have the same GPU GeForce 6200, what makes believe that, the problem could be simple, this GPU is NOT, some how, been supported by this version of driver, you know, kind of: " ...GeForce 6 series it's too old now, here's the time to spend some money for a new one, Nvidia's employees they have to pays their bills too... [-X[-(" , I dont know. But, there one thing that gives me hope, you lessgov2007 you said at you post #1 : "" The first couple of days with "Hardy" everything worked, openGL, desktop effects, etc, using the nvidia-glx-new drivers."". Wow!! I was not that lucky. Me, right after a fresh install of Hardy, any driver, repos, Envy nor Nvidia, gives me the same behavior like you are having since you did type the "compiz"into a terminal. Well my friend, let's pry cause this has been giving me headaches since the Beta release of Hardy. [-o<

Galban
May 3rd, 2008, 10:09 PM
Thank you very much Zorael for trying to help, that's all about here, people like you helping or trying to do so. Definitely, in this case I don't think the problem is "Compiz", It's any software needing graphics acceleration via OpenGL.

lessgov2007
May 9th, 2008, 03:17 AM
I have spent a lot of time trying to get my NVidia 6200 working correctly with compiz and OpenGL in Hardy. I have reformatted my hard disk multiple times to ensure fresh install with each attempt to get everything working.

I tried every bit of advice from this forum, from NVidia, Google searches, etc... Nothing worked including EnvyNG....

I finally got it to work as it should. Here's where I was going wrong. Don't use the Restricted Manager to enable or disable the NVidia driver. Ignore it completely. Better yet, remove it from the menu list.

First you must install EnvyNG... Tell EnvyNG to uninstall your NVidia driver even if you have already done so... It's for good measure... When EnvyNG finishes it will ask you to restart, say NO! Close EnvyNG and open the terminal. run "sudo apt-get autoremove"

Now you need to make a fresh xorg.conf file. If you are running high resolutions then run "sudo dpkg-reconfigure -phigh xserver-xorg" Otherwise you can run "sudo dpkg-reconfigure xserver-xorg" Follow the on screen instructions. After that is finished fully restart you computer.

If you computer restarts in low resolution mode. It will prompt you to choose to configure, continue, or shutdown. Choose continue...

Run EnvyNG again but, do not select "Install the NVIDIA Driver (Automatic Hardware Detection) you want to select "Install the NVIDIA Driver (Manual Selection of the Driver)... Below you can select the version you wish to install. Choose "96.43.05 and install.

I did not run NVidia-xconfig or change my xorg.conf in any way. After restarting multiple times it has not caused any errors. OpenGL & Compiz are now working good.

The reason for this is the NVidia New driver is causing the issue. I don't know what that issue is but, it doesn't work with the NVidia 6200. NVidia will tell you to use the New Driver as well, don't. Use the older NVidia-GLX driver.

Note: If you tell Restricted Drivers Manager to Enable to driver it will list then no more 3D for you... It installed the new driver which, doesn't work with these cards. However, works great with these cards in Feisty. Restricted Drivers manager will say you have no driver installed. Just ignore it, it's a trap.

If you have a different card and simular issues don't be afraid to try you can always uninstall and switch to the new one.

Galban
May 9th, 2008, 05:18 AM
Nice lessgov2007, I'll be trying this later on. Thank you for sharing this. :)

rich257
May 9th, 2008, 08:42 PM
I have been unable to get GLX working with my nvidia 6200 on Hardy even though it worked on Gutsy. The solution was as above, to use the driver version 96.43.05 and then it works just fine.

I used EnvyNG and manually specified the driver as this version and let it do its thing.

Galban
May 10th, 2008, 03:04 PM
That's it! lessgov2007, you are right, your HOW-TO in your post #11 is the solution to fix this issue with all Nvidia GeForce 6200 GPU's and the "new" drivers from Nvidia coming with Hardy. Nice job, and THANK YOU very much for sharing this and giving me the chance to don't loose my faith in Ubuntu (Linux). I'm saying this because I use to have an Ati video card, and switched to Nvidia blaming Ati for the hard time I use to have getting their GPU to work on accelerated graphic mode. Now with this issue I'm realizing how unequal still being the hardware support on linux. I'm still believing that Ubuntu have the better general support from community and developers comparing to others distros. It's unbelievable how much linux has progress and from how far it comes just with the benevolence effort from people that just loves programing and computers.And it is evident the big effort that Ubuntu's developers has manage to make of this distro the best and the most popular alternative ever to windows. Even though it's a bit disappointing to see that Ubuntu still being a NOT "ready and easy to use" operating system for the ordinary, beginner PC user. I'd been playing with linux for not less than 7 years, and in this occasion it was hard time to me, once again, like at every new realease of Ubuntu, to get my graphics in accelerated mode with easy. One day we gonna ge it!! :)

LucidLoon
May 11th, 2008, 03:42 AM
I've got a Nvidia 6200 card also. I installed quake3 and couldn't get it to work so I started searching the forums. In trying to undertand the problem I found compiz doesn't work and enabling visual effects doesn't work either. I've installed xserver.xgl and that didin't help. I've played with different drivers, No luck. I don't have a solution (yet) but I hope this adds to the body of evidence that there's something odd about the 6200 card. I think I'm going to use it as an excuse to buy a newer card.

I'd like to update this...I uninstalled the Nvidia-gxl-new driver and installed the Nvidia-gxl driver from the package manager. I've enabled the visual effects without receiving the "cannot be enabled" notice and my OpenGL issues seem to be solved. Now dragging my windows around the screen isn't working. I'll figure that part out tomorrow. Figuring out the driver issue made my head hurt.

Galban
May 11th, 2008, 05:46 AM
I've got a Nvidia 6200 card also. I installed quake3 and couldn't get it to work so I started searching the forums. In trying to undertand the problem I found compiz doesn't work and enabling visual effects doesn't work either. I've installed xserver.xgl and that didin't help. I've played with different drivers, No luck. I don't have a solution (yet) but I hope this adds to the body of evidence that there's something odd about the 6200 card. I think I'm going to use it as an excuse to buy a newer card.

LucidLoon don't look too far #-o. Right here in this thread it is the solution for our problem; all the people using Nvidia's GeForce 6200 with Hardy read the post number 11. That How-To fix the problem. :)

shields
October 18th, 2008, 12:07 AM
Post #11 is great, but it doesn't seem to work with my nVidia card... the "nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev a1)".

Any thoughts on how this concept can be applied to that card in Ubuntu 8.04.1?

Thanks.

dj_flx
April 9th, 2009, 09:06 PM
ARG

I just got a PNY GeForce 6200 AGP and tried the steps in #11. I still get a black screen after the xubuntu loading screen.

Flocculus
July 13th, 2009, 03:20 AM
This is still a good solution. Thank you, lessgov2007. I had tried a lot of combinations to get direct rendering working on my 6200 card, and this is the only one that did it. My only glitch was that the uninstall/install didn't work for me in the GUI EnvyNG. The text version worked fine, though. Thanks again.