PDA

View Full Version : [ubuntu] Visual Effects removes my title bars???



gear_head
May 3rd, 2008, 06:49 AM
Just upgraded to 8.04 (Hardy)
I seem to have the nvidia driver properly installed as I get this "nvidia" splash screen just before the login pops up.

But When I go into System->Preferences->Appearance and activate visual effects, the title bars on all open windows disappear. I tried rebooting to no avail. The titlebars return when I turn off visual effects.

Any Idea what's going on here?

comandrei
May 3rd, 2008, 06:49 AM
try running emerald --replace & from a terminal

gear_head
May 3rd, 2008, 07:05 AM
try running emerald --replace & from a terminal

...and then what?

This just kinda pauses and doesn't seem to do anything.

joselin
May 3rd, 2008, 07:22 AM
Do

compiz --replace &
in a terminal window and post the output.

Regards

gear_head
May 3rd, 2008, 07:25 AM
Do

compiz --replace &
in a terminal window and post the output.

Regards


jason@home-bass:~$ compiz --replace &
Checking for Xgl: [1] 6225
jason@home-bass:~$ not present.
Detected PCI ID for VGA: 00:09.0 0300: 10de:0172 (rev a3) (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1024x768) to maximum 3D texture size (2048): Passed.
Checking for nVidia: present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting gtk-window-decorator
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (wall) - Error: Couldn't create cairo context for switcher
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (wall) - Error: Couldn't create cairo context for switcher
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (wall) - Error: Couldn't create cairo context for switcher
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (wall) - Error: Couldn't create cairo context for switcher
GConf backend: There is an unsupported value at path /apps/compiz/plugins/scale/allscreens/options/initiate_edge. Settings from this path won't be read. Try to remove that value so that operation can continue properly.
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (resizeinfo) - Warn: Bind Pixmap to Texture failure
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (resizeinfo) - Warn: Bind Pixmap to Texture failure
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32

KaliVoid
May 3rd, 2008, 07:31 AM
Hi
i had the same problem

add :
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"

to your xorg.conf in Section "Device" & ctrl+alt+Bckspace to start gdm

this is my Section "Device" :
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce4 MX 440"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
EndSection

joselin
May 3rd, 2008, 07:41 AM
Try changing the Defaultdepth directive to 24 instead of 32.


Section "Screen"
Identifier "Default Screen"
Device "nVidia..."
Monitor "Generic Monitor"
Defaultdepth 24
EndSection


And add the following to your /etc/X11/xorg.conf:

Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"

Regards

joselin
May 3rd, 2008, 07:42 AM
Forget to say that you must restart your X server after doing it.

Regards

gear_head
May 3rd, 2008, 08:03 AM
Cool, that got it. thanks guys!