PDA

View Full Version : [ubuntu] Accents and Umlauts



Sparragus
May 3rd, 2008, 12:28 AM
Hey everyone. I recently installed Ubuntu (8.04) for the first time on my Mac Book Core Duo. I have been able to fix a couple of things, but something I still haven't figured out is how to to the accented vocals, the n with the ~ above, and the umlauts, more specifically u umlaut. :confused:

Any help is highly appreciated.

buschi
May 20th, 2008, 07:25 AM
hi!

you can set up a compose key. hitting <compose key>, then ~, then n will give you a . system -- preferences -- keyboard -- layout options -- compose key position -- choose! is <compose key>, then ", then u.

alternatively, you can go a bit deeper and assign those characters to alt+n, alt+u etc. check the links on http://www.thamnos.de/computer-corner/keyboard-layout/ for that.

good luck,
sebastian.

Halsnalle
June 15th, 2008, 04:50 PM
hi!
you can set up a compose key. hitting <compose key>, then ~, then n will give you a . system -- preferences -- keyboard -- layout options -- compose key position -- choose! is <compose key>, then ", then u.

alternatively, you can go a bit deeper and assign those characters to alt+n, alt+u etc. check the links on http://www.thamnos.de/keyboard.htm for that.


But both solutions are rather illogical, in my opinion.

On both Mac and Win, I'd just press, for example, the desired accent key [] and then the desired letter key [E] to produce an accented . The Alt- and <compose key>-solutions are far less intuitive. Also, pressing two keys beats pressing three...

Sparragus
June 15th, 2008, 05:29 PM
On both Mac and Win, I'd just press, for example, the desired accent key [] and then the desired letter key [E] to produce an accented .

And how do you do that? :)

Halsnalle
June 15th, 2008, 06:24 PM
No idea, that's what I came here looking for... ;)

buschi
June 15th, 2008, 08:35 PM
hey!

if you were into any programming, you would probably prefer these accents to just produce accents if not told otherwise with a "compose" before... (just to make the point that for some people this is an intended feature)

otherwise, just switch off the "nodeadkeys" option.

sebastian.

Halsnalle
June 16th, 2008, 08:38 PM
@Buschi: And how do I switch off the nodeadkeys option?

buschi
June 17th, 2008, 08:30 AM
system -- preferences -- keyboard -- layouts -- add

choose your layout and as variant "with dead keys". set this as default.

sebastian.

Halsnalle
June 22nd, 2008, 07:43 PM
system -- preferences -- keyboard -- layouts -- add

choose your layout and as variant "with dead keys". set this as default.

sebastian.

Thanks, but that does not work for me. I've tried several different settings available for my language, but they don't seem to change my de facto keyboard layout. No matter which layout I choose, I can't type "e" and other accented characters the way I'd like to...

buschi
June 25th, 2008, 10:33 AM
... I've tried several different settings available for my language, but they don't seem to change ...

did you try to remove the unwanted entries so that the only one displayed is the one you actually want? that seems to work here...

Halsnalle
June 25th, 2008, 07:39 PM
did you try to remove the unwanted entries so that the only one displayed is the one you actually want? that seems to work here...

Thanks! That solved it!

Halsnalle
June 25th, 2008, 07:39 PM
Thanks! That solved it!

erginemr
June 27th, 2008, 04:00 PM
@buschi,

Great tip, that also put an end to my suffers in French & Spanish. Thank you!!

everfine
March 9th, 2009, 05:33 AM
Wait?! What solved it? I added USA International with dead keys. Now what do I do to get accents?!?!

Halsnalle
March 9th, 2009, 09:46 AM
Wait?! What solved it?

For me, what solved it was removing the unwanted keyboard layouts, as suggested by Buschi.

cyberdork33
March 9th, 2009, 02:08 PM
Wait?! What solved it? I added USA International with dead keys. Now what do I do to get accents?!?!
According to the posts on the first page of this thread, you also need to set a key as the compose key in system -- preferences -- keyboard -- layout options

Lupi
March 21st, 2009, 04:09 AM
I can make the following accents: , , ə, , , using the Window key, How can I type the circumflex accents, though?

mkvnmtr
March 21st, 2009, 06:41 PM
That all sounds complicated to me. I just switch keyboard layouts between spanish and English with an applet in the top panel. You have to enable the keyboards you wish to use under keyboard/ pref under system.

Immortaly007
May 8th, 2009, 01:10 PM
Yay it worked for me as well :D etc!! (But i did have to remove the other keyboard layout from the list first).

So for those of you still wondering how to do it:
System - Preferences - Keyboard - Layout - Choose layout (for example VS) and then as variant choose VS international (with Dead Keys).
After you done that delete the other keyboard layouts from the list and voila!

buschi
May 8th, 2009, 02:17 PM
... How can I type the circumflex accents, though?

for me, Windows key & ^ & letter give the circumflex:

Lupi
May 8th, 2009, 05:31 PM
Changing layouts works excellent for me with only one slight hurdle. I have to open the Keyboard Preferences every time I want the system to change to a new keyboard layout. If I could do it from the same window numerous times, it would be great. Other than that, it works very well.