PDA

View Full Version : [ubuntu] [SOLVED] formatted NTFS to EXT3 now can't mount



O||y
May 2nd, 2008, 09:30 PM
Hi

I backed up all the data of one of my NTFS drives, then formatted it to etx3 filesystem hoping it would perform better for my particular usage. Unfortunately, the drive does not now mount when I restart (and gives me an error when I click it telling me I do not have permission to mount the volume). The only way I have found (being a n00b and all) is to run gparted and make that mount it.

Is there a more permanent way to get the drive mounted?

A note, whether useful or not: The old NTFS used to mount as /media/DOWNLOADS and now when I mount it in gparted, it also wants to use the same path: could this be the root of my problem?

Any help would be much appreciated - a code to 'wang' in to Terminal for a permanent cure even more appreciated! hehe

Thanks in advance...

O||y

mikewhatever
May 2nd, 2008, 09:58 PM
You need to edit your fstab to automount the new partition.
For general information and example on how to do it look here --> http://psychocats.net/ubuntu/mountlinux.
If you need any help post the outputs of the following:
<sudo fdisk -l>
<cat /etc/fstab>

O||y
May 2nd, 2008, 11:40 PM
Thanks for your quick reply. I looked at the post, but I can see one fundamental problem in fstab: the drive sdb1 is showing as NTFS-3g still.


olly@Olleh:~$ sudo fdisk -l

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0aed0aec

Device Boot Start End Blocks Id System
/dev/sda1 * 1 3916 31455238+ 7 HPFS/NTFS
/dev/sda2 3917 7651 30001387+ 83 Linux
/dev/sda3 7652 7713 498015 82 Linux swap / Solaris
/dev/sda4 7714 30401 182241360 7 HPFS/NTFS

Disk /dev/sdb: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000168cb

Device Boot Start End Blocks Id System
/dev/sdb1 1 30401 244196001 83 Linux

Disk /dev/sdc: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0005b73b

Device Boot Start End Blocks Id System
/dev/sdc1 1 30401 244196001 7 HPFS/NTFS
olly@Olleh:~$


and


olly@Olleh:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda2 :
UUID=b15dff4f-ce6c-4d4d-8067-7286a891c8d0 / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sda3 :
UUID=c476259c-aa17-48e8-a009-8347decf6991 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/sdc1 /media/GAMES\040&\040PORN ntfs-3g defaults,locale=en_GB.UTF-8 0 0
/dev/sda4 /media/PROGS\040&\040PICS ntfs-3g defaults,locale=en_GB.UTF-8 0 0
/dev/sda1 /media/WINDOWS ntfs-3g defaults,locale=en_GB.UTF-8 0 0
/dev/sdb1 /media/DOWNLOADS ntfs-3g defaults,locale=en_GB.UTF-8 0 0
olly@Olleh:~$


The above one doesn't seem to match up - the top one says the file system is linux, yet the lower one shows it as /media/downloads ntfs-3g

arrrrgh - do i edit that file using the
sudo nano /etc/fstab command? If so, please can you tell me what to change it to? I am too much of a n00b to quite understand yet. I know that it should be something like sda2's line above
UUID=b15dff4f-ce6c-4d4d-8067-7286a891c8d0 / ext3 relatime,errors=remount-ro 0 1

Would it work to replace the line
/dev/sdb1 /media/DOWNLOADS ntfs-3g defaults,locale=en_GB.UTF-8 0 0
with

/dev/sdb1 /media/DOWNLOADS ext3 defaults 0 0

then


sudo mount -a then change permissions etc?

One day I won't be a n00b! haha

Thanks... :'(

mikewhatever
May 3rd, 2008, 12:00 AM
Yes, I think you got it exactly right. Backup fstab just in case with <sudo cp /etc/fstab /etc/fstab_backup>.

O||y
May 3rd, 2008, 12:02 AM
Excellent. I will do it now and let you know how I get on. Thanks for your help.

edit:

I did the following


olly@Olleh:~$ sudo nano /etc/fstab
olly@Olleh:~$ sudo mount -a
olly@Olleh:~$ sudo chown -R olly:Olleh /media/DOWNLOADS
chown: invalid group: `olly:Olleh'
olly@Olleh:~$ sudo chown -R olly:olly /media/DOWNLOADS
olly@Olleh:~$ sudo chmod -R 755 /media/DOWNLOADS
olly@Olleh:~$


and it looks like I can now access the folder :D Its shows wrong under the Places menu up top and on desktop as 250.1CB media but I will change that somehow LOL

Thank you for your help mikewhatever

O||y
May 3rd, 2008, 12:43 AM
Last update cause it's all done now: I used the following command to change the disk label:


sudo e2label /dev/sdb1 DOWNLOADS

then a quick restart and all is hunkey-dorey and showing just how I like :D