PDA

View Full Version : [ubuntu] Vista won't mount (wrong permissions?)



the8thstar
April 30th, 2008, 05:00 PM
Hello all,

A peculiar problem happened to me after I installed the NTFS configuration tool: now I can't access the Vista partition of my computer through Nautilus like I used to.

I enclosed the screens to show you what the problem is. Any ideas on how I could solve this problem?

Thanks in advance!

lswest
April 30th, 2008, 05:09 PM
can you mount it manually?

sudo mkdir /media/Vista\ Drive
sudo mount /dev/sd?? /media/Vista\ Drive where sd?? is the name of your drive (e.g. sda1)

bigken
April 30th, 2008, 05:11 PM
have you tired booting into windows sometimes its caused through a unclean shut down

the8thstar
April 30th, 2008, 06:33 PM
Thank you both for your replies.

I restarted the computer. Vista was fine.

After rebooting in Ubuntu, I ran the following commands as lswest advised:


sudo mkdir /media/Vista\ Drive
sudo mount /dev/sd?? /media/Vista\ Drive

From there, I can access the Vista partition again.

To inquire a bit further, I ran:


sudo fdisk -l

and got:



Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000b5f6e

Device Boot Start End Blocks Id System
/dev/sda1 1 811 6514326 83 Linux
/dev/sda2 812 5776 39881362+ 83 Linux
/dev/sda3 * 5777 8653 23102464 7 HPFS/NTFS

which is coherent.

I also ran:


sudo gedit /etc/fstab

which gave me:



# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda1 :
UUID=b4e6eff7-9ae6-4ea2-af4b-65aedeee0a6c / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sda2 :
UUID=55346f1c-dca7-43e8-9ef1-9f4a4d5b2d41 /home ext3 relatime 0 2
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/home/the8thstar/2048Mb.swap none swap sw 0 0
/dev/sda3 /media/Vista ntfs-3g defaults,locale=en_US.UTF-8 0 0

The Vista partition is there.

I really don't know what happened before. :confused: