PDA

View Full Version : [ubuntu] 02:00.0 Ethernet controller: Attansic Technology Corp. Unknown device 1026 (rev b0)



pdelahun
April 27th, 2008, 09:58 AM
Hi all

I am having problems with my ethernet port on both Hardy and Gutsy:

It says "Unknown device" on both:

02:00.0 Ethernet controller: Attansic Technology Corp. Unknown device 1026 (rev b0)

I did a bit of research and it seems Attansic where bought by Atheros. Ubuntu lists the card as Attansic and Windows Vista lists it as Attansic.

I am guessing the Attansic network drivers are not included in gutsy or hardy. The only linux drivers i could find where:
http://support.asus.com/download/download.aspx?product=1&SLanguage=us-en&type=map&model=P5KPL-CM

But the files seem to be corrupt:

Can anyone help, i will pay !!!

I have included the output from:

ifconfig -a
lspci -vvnn
dmesg


ifconfig -a

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1532 errors:0 dropped:0 overruns:0 frame:0
TX packets:1532 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:76600 (74.8 KB) TX bytes:76600 (74.8 KB)

wlan0 Link encap:Ethernet HWaddr 00:1d:e0:84:8f:9f
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wmaster0 Link encap:UNSPEC HWaddr 00-1D-E0-84-8F-9F-00-00-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)



lspci -vvnn

02:00.0 Ethernet controller [0200]: Attansic Technology Corp. Unknown device [1969:1026] (rev b0)
Subsystem: Acer Incorporated [ALI] Unknown device [1025:0145]
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR+ <PERR-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 5
Region 0: Memory at f6000000 (64-bit, non-prefetchable) [size=256K]
Region 2: I/O ports at 3000 [size=128]
Capabilities: <access denied>



dmesg as attachment

chili555
April 27th, 2008, 03:24 PM
I am guessing the Attansic network drivers are not included in gutsy or hardy. The only linux drivers i could find where:
http://support.asus.com/download/dow...model=P5KPL-CM

But the files seem to be corrupt:
What errors are you encountering? With a bit of work, I was able to get the Makefile to make without error.
KBUILD_NOPEDANTIC=1 make

brundles
April 28th, 2008, 02:43 PM
What errors are you encountering? With a bit of work, I was able to get the Makefile to make without error.
KBUILD_NOPEDANTIC=1 make

Which version of the drivers are you building and on which release?

I've been trying to build the Atheros drivers for the Attansic L1 (l1-linux-v1.2.40.2) and while the KBUILD_NOPEDANTIC option gets past the CFLAGS check, there seem to be some kernel changes between 2.6.22 and 2.6.24 (i.e. Gutsy to Hardy) which stop the driver building.


at_main.c:367: error: implicit declaration of function 'SET_MODUILE_OWNER'

chili555
April 28th, 2008, 03:07 PM
Do you have the headers and 'build-essential' installed? I tried the file the original poster quoted and got:
chili@LAPTOP60:~/LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src$ KBUILD_NOPEDANTIC=1 make
make -C /lib/modules/2.6.24-16-generic/build SUBDIRS=/home/chili/LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.24-16-generic'
Building modules, stage 2.
MODPOST 1 modules
make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-16-generic'As you can see by the kernel version, I am running Hardy.

brundles
April 28th, 2008, 03:35 PM
Do you have the headers and 'build-essential' installed? I tried the file the original poster quoted and got:
chili@LAPTOP60:~/LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src$ KBUILD_NOPEDANTIC=1 make
make -C /lib/modules/2.6.24-16-generic/build SUBDIRS=/home/chili/LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.24-16-generic'
Building modules, stage 2.
MODPOST 1 modules
make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-16-generic'As you can see by the kernel version, I am running Hardy.

Yes to the headers and yes to build-essential.

Looking at the output, you're using a different driver though. Where is that one from?

chili555
April 28th, 2008, 04:28 PM
http://dlsvr03.asus.com/pub/ASUS/mb/socket775/P5KPL-CM/LinuxDrivers.zip

Essentially, where the original poster referred. I don't have this card, however I, and future searchers, will be excited to know if it works.

pdelahun
April 28th, 2008, 09:41 PM
Hi Guys

Thank you, thank you so much !!!

I have got it working !!!

Ok first the network card is Atheros(R) AR8121/AR8113 PCI-E

Ok these are the steps i followed to get it working!

1) I installed ubuntu hardy 64bit, i has build-essential package installed
2) Then i downloaded the linux driver from: http://support.asus.com/download/download.aspx?product=1&SLanguage=us-en&type=map&model=P5KPL-CM
(as per my original post)
3) I then transfered the driver via usb stick to my laptop and unpacked the zip. (Actually i unpacked it on windows first as it has a .rar file that i could not unpack on linux Then i packed it up again on windows).
4) cd into <HOME_DIR>/LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src
5) then i ran: sudo KBUILD_NOPEDANTIC=1 make
6) then i ran: sudo KBUILD_NOPEDANTIC=1 make install
7) that worked and put a driver in /lib/modules/2.6.24-16-generic/kernel/drivers/net/atl1e/at1le.ko
8 ) i cd into that director and i run: sudo insmod ./atl1e.ko

That is it !!! it worked as soon as i plugged in network card.

Thank you all so much !!!! I hope this helps everyone else ;)

chili555
April 28th, 2008, 09:55 PM
Glad it's working. Good job and thanks for posting so the searchers can learn from your experience.
it has a .rar file that i could not unpack on linux
sudo apt-get install unrar
unrar e your_file.rarGood luck and have fun!

pdelahun
May 25th, 2008, 10:24 AM
Note i currently have ubuntu 32 bit not 64 bit but the same instructions still work.

tuxfire
May 25th, 2008, 05:30 PM
same problem solved on a acer 6920G-814G32Bn

thank you

dalesd
June 29th, 2008, 10:11 PM
Hi Guys

Thank you, thank you so much !!!

I have got it working !!!

Ok first the network card is Atheros(R) AR8121/AR8113 PCI-E

Ok these are the steps i followed to get it working!

1) I installed ubuntu hardy 64bit, i has build-essential package installed
2) Then i downloaded the linux driver from: http://support.asus.com/download/download.aspx?product=1&SLanguage=us-en&type=map&model=P5KPL-CM
(as per my original post)
3) I then transfered the driver via usb stick to my laptop and unpacked the zip. (Actually i unpacked it on windows first as it has a .rar file that i could not unpack on linux Then i packed it up again on windows).
4) cd into <HOME_DIR>/LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src
5) then i ran: sudo KBUILD_NOPEDANTIC=1 make
6) then i ran: sudo KBUILD_NOPEDANTIC=1 make install
7) that worked and put a driver in /lib/modules/2.6.24-16-generic/kernel/drivers/net/atl1e/
8 ) i cd into that director and i run: sudo insmod ./atl1e.ko

That is it !!! it worked as soon as i plugged in network card.

Thank you all so much !!!! I hope this helps everyone else ;)

Thank you pdelahun for the step-by-step instructions. They worked perfectly. I just got my network working on my new computer with an Asus P5Q Pro motherboard. Immediately after step 8, the Network Settings monitor showed that it was seeking an IP address. I'm posting this from my new PC. :)

Just a quick followup. I ran the Update Manager after getting on line, and after I rebooted, I lost my network. I re-ran the above, but this time I changed line 7 to: /lib/modules/2.6.24-19-generic/kernel/drivers/net/atl1e/
then sudo insmod ./atl1e.ko and it worked like a charm.

cait
June 30th, 2008, 02:10 AM
I spent all day today trying to figure this out with no luck. I finally found your post, and it worked! Thanks so much!!

johann_p
June 30th, 2008, 01:47 PM
Do I understand this correctly that Hardy does not support the network controller on P5Q out of the box and manual compilation is required?

As far as I am concerned that is unacceptable. Doesnt that mean that a new compile with unsure results is necessary each time there is a kernel update with the update manager?

chili555
July 1st, 2008, 12:16 AM
Do I understand this correctly that Hardy does not support the network controller on P5Q out of the box and manual compilation is required?

As far as I am concerned that is unacceptable. Doesnt that mean that a new compile with unsure results is necessary each time there is a kernel update with the update manager?Out of the box, Ubuntu and, as far as I know, all distributions, load the module atl1. The trouble is that the built-in module doesn't work well or at all.

The developers are, I'm quite sure, aware of this, and we hope a fix is in the works. The next kernel could, for all we know, include a new atl1e module.

In the meantime, compilation of the module from source, from Asus's website, is quite easy if you have build-essential and linux-headers-generic installed. I did it myself in 10 minutes without error. Yes, it will require a recompile every new kernel.

If this is unacceptable to you, your course is clear. Return the motherboard or buy a $15 NIC that is fully supported.

Will the day come when every piece of hardware, even that which was invented last Friday, is supported out of the box? No, I'm afraid not. Will the day come when your Attansic is supported out of the box? Yes, I'm certain.

john82q
July 2nd, 2008, 01:20 AM
But hang on, out of the box 8.04 appears to load atl2!!
john@john-desktop:/home$ sudo lshw -C network
*-network
description: Ethernet interface
product: L2 100 Mbit Ethernet Adapter
vendor: Attansic Technology Corp.
physical id: 0
bus info: pci@0000:02:00.0
logical name: eth1
version: a0
serial: 00:1e:8c:d0:8e:99
capacity: 100MB/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=ATL2 driverversion=1.0.40.2 firmware=L2 latency=0 link=no module=atl2 multicast=yes port=twisted pair


That said my networking still wont work see my post
http://ubuntu-utah.ubuntuforums.org/showthread.php?t=845713



john

pizzuco
July 10th, 2008, 01:34 PM
Same problem solved on a Acer AS8920G-834G32BN, too. But I still live with no sound... (Kernel modules: snd-hda-intel) but this is OT...

I use OpenSuSE 11.0 x86-64 version (updated by yum with base repositories and many OpenSuSE build service repositories).

Thank you too,

Carlo

p.s.

- The kernel modules "atl1" until version 2.0.7 and 2.1.3 (e.g. atl1-2.1.3-linux-2.6.25-standalone.tar.gz) doesn't still support L1E (e.g. 0x1026 device, PCI Express Gigabit Ethernet chip); you could find them here http://atl1.sourceforge.net/ However, this is a very useful page. (In this GPL module a "grep 1026 *" in the src directory fail, however I recompile and update my kernel atl1 module to 2.1.3 version)

- Always there (http://atl1.sourceforge.net/) you could find vendor (Atheros/Attansic) driver (e.g. l1-linux-v1.2.40.2.tar.gz), but they still doesn't support L1E (PCI Express Gigabit Ethernet chip); checked by "grep 1026 *" in the src directory

- Always there (http://atl1.sourceforge.net/) you may be able to browse the directories too ftp://ftp.hogchain.net/pub/linux/attansic

- As you could see here http://lkml.org/lkml/2008/6/27/642 Atheros is patching atl1 module to full support the L1E Gigabit Ethernet, but in my current kernel (2.6.25.9-0.2-default) there still is atl1 version 2.0.7 (used "modinfo atl1")... I think 2.1.4, or so, module version will soon integrate L1E support

- Asus download driver created by Atheros (l1e-l2e-linux-v1.0.0.4) is, at present, the only one supporting L1E (and L2E too, it seems) PCI Express chips; his compiled module is named "atl1e" (here a "grep 1026 *" in the src directory success!). It's very lucky that Asus support and believe in linux

- It's a pity that Acer does NOT! :(

- However it's also a pity that Atheros doesn't explicity get us able to direclty download his current source driver from his support site (http://support.atheros.com/)!!! :(

Hope will help and clarify :)

mwgnz
July 12th, 2008, 10:33 AM
Just a note to say that these instructions worked on yet another P5Q Pro.

Keep up the good work!

M

NineseveN
July 25th, 2008, 05:13 PM
Worked fine for a P5Q.

NineseveN
July 25th, 2008, 05:51 PM
The instructions posted by pdelahun, but I edited them for clarity in case people are a bit more green to this than others:


1) From a PC with a working internet connection, download the linux driver from: http://support.asus.com/download/download.aspx?product=1&SLanguage=us-en&type=map&model=P5KPL-CM. Hit the "drivers" page and find the linux driver in the list of files (will download a .zip archive named LinuxDrivers.zip).

2) Inside the zip file is a .rar archive that you'll need to extract, so you'll need to be able to open .rar archives. If you're working from a Windows PC to download the driver, there are a number of applications out there to do this. If you're using a Linux PC to download the driver, then just get “unrar” (it's in the Ubuntu the repositories).

3) The .rar archive is inside the L1e_Lan folder (l1e-l2e-linux-v1.0.0.4.rar), you'll want to extract the contents to a folder named l1e-l2e-linux-v1.0.0.4 – so your newly created folder (named l1e-l2e-linux-v1.0.0.4) should contain a folder named src and 4 individual files (atl1e.7, copying, ldistrib.txt and readme). Make sure you put the l1e-l2e-linux-v1.0.0.4 folder inside the L1e_Lan (your folder structure should look like this; LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src.

4) Install Ubuntu hardy (32 or 64bit), make sure you also install the build-essential package from the CD (you can do this through synaptic after choosing the CD as the source).

5) Transfer the folders from your PC with the working internet connection (where you did the work with the .rar file) via usb stick, external USB drive or whatever to the PC you installed Ubuntu 8.04 on (you can zip the file before you transfer or just transfer the entire Linux Driver folder. Just put it in your /home directory.

6) Open a terminal and cd (change directory) into that folder by running: cd <HOME_DIR>/LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src (where <HOME_DIR> is your home directory, i.e. /home/username/

7) run: sudo KBUILD_NOPEDANTIC=1 make

8) run: sudo KBUILD_NOPEDANTIC=1 make install

9) This should put a driver in /lib/modules/2.6.24-16-generic/kernel/drivers/net/atl1e/. The driver is the at1le.ko file. Keep in mind, if you are running a different kernel, the 2.6.24-16-generic folder will be named after that kernel (i.e., mine is 2.6.24.19-generic because that's the kernel I'm running), so when you CD into the directory below, make sure you use the right kernal number for the folder name.

10) From the terminal, cd into that directory (/lib/modules/2.6.24-16-generic/kernel/drivers/net/atl1e/) and run: sudo insmod ./atl1e.ko (again, since I was running a different kernel, I cd'd into /lib/modules/2.6.24-19-generic/kernel/drivers/net/atl1e/)


That's it. The driver should be up and running. Whenever you update to a new kernel, I believe that you'll have to do this all over again, but it works for now until the kernel actually supports this chip by default. To me, it's not that big of a deal, I just kept the folders with the drivers inside my home directory for later use.

alex199020
July 27th, 2008, 01:28 PM
Recently decided to try out linux as i had a spare HD lying around. Im running a P5Q motherboard and came across the network problem.
Tryed doing the above but can you please explain what you mean by "CD into" and i presume <home_dir> is the home folder?
Very new to linux so please excuse the idiotic questions :)
Thanks!

NineseveN
July 27th, 2008, 05:09 PM
cd is a command to change the directory. So in the terminal, you'd type
cd /home/username/LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src where username is your username.

I guess that part is confusing as I didn't say to open a terminal until after that. Sorry.

tritium3
August 8th, 2008, 10:10 PM
# lshw -C network
*-network
description: Ethernet interface
product: Attansic Technology Corp.
vendor: Attansic Technology Corp.
physical id: 0
bus info: pci@0000:03:00.0
logical name: eth0
version: b0
serial: MAC address obfuscated
size: 100MB/s
capacity: 100MB/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation

My machine is an Asus Eee PC 1000H, I'm running Ubuntu 8.04 (Hardy Heron), and building the kernel module worked for me too, as follows:

cd to the "src" directory in the module source tree

sudo KBUILD_NOPEDANTIC=1 make
sudo KBUILD_NOPEDANTIC=1 make install

No need for me to do the "insmod"; instead, edit /etc/modules and add on a line by itself, "atl1e" (without quotes), as the first non-comment line.

Also, in my case, before building the module, udev had added a bunch of lines for "newly discovered" ethernet cards with all different MAC addresses, (see http://ubuntuforums.org/showthread.php?p=3869356 but do NOT change 75-persistent-net-generator.rules as that post says) so I had to edit /etc/udev/rules.d/70-persistent-net.rules and delete ALL lines for ethernet devices named eth0, eth1, eth2, etc.

tritium3
August 8th, 2008, 10:13 PM
# lshw -C network
*-network
description: Ethernet interface
product: Attansic Technology Corp.
vendor: Attansic Technology Corp.
physical id: 0
bus info: pci@0000:03:00.0
logical name: eth0
version: b0
serial: MAC address obfuscated
size: 100MB/s
capacity: 100MB/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation

My machine is an Asus Eee PC 1000H, I'm running Ubuntu 8.04 (Hardy Heron), and building the kernel module worked for me too, as follows:

cd to the "src" directory in the module source tree

sudo KBUILD_NOPEDANTIC=1 make
sudo KBUILD_NOPEDANTIC=1 make install

No need for me to do the "insmod"; instead, edit /etc/modules and add on a line by itself, "atl1e" (without quotes), as the first non-comment line.

Also, in my case, before building the module, udev had added a bunch of lines for "newly discovered" ethernet cards with all different MAC addresses, (see http://ubuntuforums.org/showthread.php?p=3869356 but do NOT change 75-persistent-net-generator.rules as that post says) so I had to edit /etc/udev/rules.d/70-persistent-net.rules and delete ALL lines for ethernet devices named eth0, eth1, eth2, etc.

tritium3
August 8th, 2008, 11:42 PM
This worked for me too on an Asus Eee PC 1000H running Ubuntu 8.04 (Hardy), with a few changes from what others have posted:

tritium3
August 8th, 2008, 11:44 PM
Why

tritium3
August 8th, 2008, 11:51 PM
The driver source is at:
http://support.asus.com/download/download.aspx?product=1&SLanguage=us-en&type=map&model=P5KPL-CM (look for OS: Linux and Description: Support Linux Drivers, unzip it, then unrar the LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4.rar file.

tritium3
August 8th, 2008, 11:53 PM
The file you download is LinuxDrivers.zip

tritium3
August 9th, 2008, 12:07 AM
Ne

tritium3
August 11th, 2008, 07:53 PM
I've uploaded an updated driver source file (Version 1.0.1.0) from Jie Yang at Atheros.

tritium3
August 12th, 2008, 12:27 AM
md5sum for l1e-linux-v1.0.1.0.tar.gz above: d83196e507f9b2bea47514ba97fffd6f

sha1sum for l1e-linux-v1.0.1.0.tar.gz above: 1f6a1ee6280add6e4c8d2f110ecd176c6f0e9134

lannatwin
August 13th, 2008, 07:34 PM
Um..., build-essential isn't on the 64bit live cd. Any way I can get it with this windows machine and install on the ubuntu box? Thanks for any assistance.


The instructions posted by pdelahun, but I edited them for clarity in case people are a bit more green to this than others:


1) From a PC with a working internet connection, download the linux driver from: http://support.asus.com/download/download.aspx?product=1&SLanguage=us-en&type=map&model=P5KPL-CM. Hit the "drivers" page and find the linux driver in the list of files (will download a .zip archive named LinuxDrivers.zip).

2) Inside the zip file is a .rar archive that you'll need to extract, so you'll need to be able to open .rar archives. If you're working from a Windows PC to download the driver, there are a number of applications out there to do this. If you're using a Linux PC to download the driver, then just get “unrar” (it's in the Ubuntu the repositories).

3) The .rar archive is inside the L1e_Lan folder (l1e-l2e-linux-v1.0.0.4.rar), you'll want to extract the contents to a folder named l1e-l2e-linux-v1.0.0.4 – so your newly created folder (named l1e-l2e-linux-v1.0.0.4) should contain a folder named src and 4 individual files (atl1e.7, copying, ldistrib.txt and readme). Make sure you put the l1e-l2e-linux-v1.0.0.4 folder inside the L1e_Lan (your folder structure should look like this; LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src.

4) Install Ubuntu hardy (32 or 64bit), make sure you also install the build-essential package from the CD (you can do this through synaptic after choosing the CD as the source).

5) Transfer the folders from your PC with the working internet connection (where you did the work with the .rar file) via usb stick, external USB drive or whatever to the PC you installed Ubuntu 8.04 on (you can zip the file before you transfer or just transfer the entire Linux Driver folder. Just put it in your /home directory.

6) Open a terminal and cd (change directory) into that folder by running: cd <HOME_DIR>/LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src (where <HOME_DIR> is your home directory, i.e. /home/username/

7) run: sudo KBUILD_NOPEDANTIC=1 make

8) run: sudo KBUILD_NOPEDANTIC=1 make install

9) This should put a driver in /lib/modules/2.6.24-16-generic/kernel/drivers/net/atl1e/. The driver is the at1le.ko file. Keep in mind, if you are running a different kernel, the 2.6.24-16-generic folder will be named after that kernel (i.e., mine is 2.6.24.19-generic because that's the kernel I'm running), so when you CD into the directory below, make sure you use the right kernal number for the folder name.

10) From the terminal, cd into that directory (/lib/modules/2.6.24-16-generic/kernel/drivers/net/atl1e/) and run: sudo insmod ./atl1e.ko (again, since I was running a different kernel, I cd'd into /lib/modules/2.6.24-19-generic/kernel/drivers/net/atl1e/)


That's it. The driver should be up and running. Whenever you update to a new kernel, I believe that you'll have to do this all over again, but it works for now until the kernel actually supports this chip by default. To me, it's not that big of a deal, I just kept the folders with the drivers inside my home directory for later use.

NineseveN
August 13th, 2008, 07:56 PM
Um..., build-essential isn't on the 64bit live cd. Any way I can get it with this windows machine and install on the ubuntu box? Thanks for any assistance.

I used the 8.04 64bit Live CD...?

But, in any event; two threads come to mind.

1. Pretty much what I did - http://ubuntuforums.org/showthread.php?t=381532

and

2. If it's really not on the CD, download to windows - http://ubuntuforums.org/showthread.php?t=322190


I know it's been a few weeks, but I can't imagine where I got it from if it wasn't on the CD when I installed 64bit 8.04. :confused:

lannatwin
August 14th, 2008, 05:28 AM
Thank you very much!

After poking around the CD, I found it. I also needed to install linux-libc-dev before I could install build-essential. All is now working!

Cheers.


I used the 8.04 64bit Live CD...?

But, in any event; two threads come to mind.

1. Pretty much what I did - http://ubuntuforums.org/showthread.php?t=381532

and

2. If it's really not on the CD, download to windows - http://ubuntuforums.org/showthread.php?t=322190


I know it's been a few weeks, but I can't imagine where I got it from if it wasn't on the CD when I installed 64bit 8.04. :confused:

NineseveN
August 14th, 2008, 06:25 AM
Thank you very much!

After poking around the CD, I found it. I also needed to install linux-libc-dev before I could install build-essential. All is now working!

Cheers.

That actually makes sense, when I did it via Synaptic it installed the dependencies for me IIRC...I must've forgot. Glad you got it working...it really isn't that hard now is it?

Hell, I had to mess around with my Windows XP install than I did Ubuntu 8.04. :)

aquacrusher
August 22nd, 2008, 09:02 AM
Following your instructions, I rocked out in terminal (first time) and got the ethernet working on my Acer Aspire 8920 (8920g 6983).

Also, it had a .19 in the version number instead of a 16, and I had to unlock in the network settings area and switch from the default roaming to DHCP

Most awesome!

Thanks posters

dodgypingu
August 22nd, 2008, 03:22 PM
Rad! This thread solved my ethernet issues. I'm running an Asus P5QL-E motherboard.

Took me a while to find this, so allow me to add some keywords to the thread...

Linux drivers Asus P5QL-E motherboard ethernet network Intel Corporation ICH10 Attansic 1026 Atheros L1E P5Q

coolen
August 23rd, 2008, 01:54 AM
Ahh, thank you so much! I'm on holiday, walked into an Internet cafe, only to discover that my ethernet card didn't work :O

Five minutes, I'm up and running, and no need to reboot. Cheers!

soundoff
August 26th, 2008, 10:46 PM
Thankyou guys!

Asus P5Q

Followed the instructions given in post #19 (http://ubuntuforums.org/showpost.php?p=5456722&postcount=19) and used the drivers given in post #29 (http://ubuntuforums.org/showpost.php?p=5568394&postcount=29)

Worked perfectly on a clean install of Ubuntu 8.04, and also after upgrading to the -19 kernel.

Very happy!!

lyeoh
August 30th, 2008, 04:38 AM
Hi, with both the latest and original asus driver I get slow samba performance - not really faster than 100Mbit/s (fluctuates from 7MB/sec to 12MB/sec) downloading from Ubuntu to Windows - both using the onboard LAN and Asus P5KPL-CM motherboards.

When I use a DLink 530T on Ubuntu (keeping Windows on the same config) I get 38MByte/sec for samba.

Oh well, at least it works and so far hasn't crashed my system.

Maybe it's some samba tuning.

gerix
September 7th, 2008, 01:46 PM
Thankyou guys. My motherboard is a P5Q. I have compiled kernel 2.6.26-3 , from Kubuntu 8.04. These instructions helped me to get the Attansic driver going with the new kernel.

When compiling that l2-linux-v1.0.40.4 drivr, I had to alter the Makefile to avoid error messages about CFLAGS.

Also I discovered that adding extra lines to the netwk 'interfaces' file (e.g. adding an eth0 entry below lo) can stuff up KNetworkManager.

rictic
September 8th, 2008, 10:22 AM
Thank you so much for this information! I just got a new system and after puzzling over a number of sites with some of this information, I wasn't having any luck.

Reiterating keywords so that others can find: linux ubuntu drivers atheros ar8121/ar8113/ar8114 PCI-E Ethernet Controller integrated gigabit

armsteadj1
September 10th, 2008, 04:55 PM
This driver seems to be broke for the newest release of the kernel 2.6.24-21, It seems to run the same but once i do "insmod ./atl1e.ko" it just searches for connection and sooner or later will lock up my system.. any ideas?

poriajay
September 15th, 2008, 06:09 PM
Hi All,

Above solution by pdelahun worked for me also. I have Asus P5Q Pro Mobo.
Thanks a lot pdelahun.

-Jayesh

brdokoky
September 16th, 2008, 07:20 PM
Hi , is working for me as well , just do somebody know whats wrong, In my system monitor does'nt show sending speed.

webweaver
September 23rd, 2008, 08:29 AM
Thanks for the useful instructions and links. However, not as much joy for me as others seem to have had.

I'm using Ubuntu Server 8.04.1 64 bit, and after following the instructions above (with some minor variations to get required packages installed from the LiveCD), I type ifconfig in the commandline and still only lo is visible... no eth0

Anyone have any suggestions?

EDIT: This may help you to help me (the "DISABLED" is a bit of a red flag...)


*-network DISABLED
description: Ethernet interface
product: Attansic Technology Corp.
vendor: Attansic Technology Corp.
physical id: 0
bus info: pci@0000:02:00.0
logical name: eth0
version: b0
serial: 00:22:15:0e:df:0b
capacity: 1GB/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=ATL1e driverversion=1.0.1.0 firmware=L1e latency=0 link=no module=atl1e multicast=yes port=twisted pair

webweaver
September 23rd, 2008, 08:55 AM
Ok, so I've added a few lines to my /etc/network/interfaces, and that seems to have gotten rid of the "DISABLED".

I added the following:


auto eth0
iface eth0 inet static
address 192.168.1.7
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.254


Now I can ping the other machines on my network too... but can't get out to www.google.com, or anywhere else...

So I guess that's progress? Anyone have any further hints for me?

UPDATE: I can ping 74.125.19.103 (www.google.com's IP address), but still can't ping www.google.com...

webweaver
September 23rd, 2008, 09:14 AM
So anyway, I've fixed my own problem... was pretty noob-ish, but maybe someone else will get something out of it.

All I had left to do was create myself an /etc/resolv.conf, with the following inside:


nameserver 192.168.1.254


Now I'm all systems go!

tjkoch
October 1st, 2008, 01:37 AM
Great info thanks!

nicbul
October 12th, 2008, 09:03 PM
Has anyone had success setting up the drivers in Ubuntu studio?

I've got these drivers to work very easily in straight Hardy 8.04x64 but I can't seem to do it in Studio. The drivers install fine but the network card is still not recognized.

I believe Ubuntu Studio uses kernel 2.6.24-19-rt.

As well, I had to install linux-source in order to get the make command working.

no0ne
October 15th, 2008, 06:58 AM
This driver seems to be broke for the newest release of the kernel 2.6.24-21, It seems to run the same but once i do "insmod ./atl1e.ko" it just searches for connection and sooner or later will lock up my system.. any ideas?
This is caused by and older version (<1.0.1.0) of the atl1e driver under kernel 2.6.24-21. Update your driver to the most recent version (1.0.1.0) (http://jan.ucc.nau.edu/wal2/l1e-linux-v1.0.1.0.tar.gz) by following this guide (http://jan.ucc.nau.edu/wal2/atheros_attansic.html).

surml
October 15th, 2008, 03:27 PM
Thanks for the hint with the driver version - loaded - built - worked :)

Chobo-Mog
October 16th, 2008, 11:01 PM
The instructions posted by pdelahun, but I edited them for clarity in case people are a bit more green to this than others:


1) From a PC with a working internet connection, download the linux driver from: http://support.asus.com/download/download.aspx?product=1&SLanguage=us-en&type=map&model=P5KPL-CM. Hit the "drivers" page and find the linux driver in the list of files (will download a .zip archive named LinuxDrivers.zip).

2) Inside the zip file is a .rar archive that you'll need to extract, so you'll need to be able to open .rar archives. If you're working from a Windows PC to download the driver, there are a number of applications out there to do this. If you're using a Linux PC to download the driver, then just get “unrar” (it's in the Ubuntu the repositories).

3) The .rar archive is inside the L1e_Lan folder (l1e-l2e-linux-v1.0.0.4.rar), you'll want to extract the contents to a folder named l1e-l2e-linux-v1.0.0.4 – so your newly created folder (named l1e-l2e-linux-v1.0.0.4) should contain a folder named src and 4 individual files (atl1e.7, copying, ldistrib.txt and readme). Make sure you put the l1e-l2e-linux-v1.0.0.4 folder inside the L1e_Lan (your folder structure should look like this; LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src.

4) Install Ubuntu hardy (32 or 64bit), make sure you also install the build-essential package from the CD (you can do this through synaptic after choosing the CD as the source).

5) Transfer the folders from your PC with the working internet connection (where you did the work with the .rar file) via usb stick, external USB drive or whatever to the PC you installed Ubuntu 8.04 on (you can zip the file before you transfer or just transfer the entire Linux Driver folder. Just put it in your /home directory.

6) Open a terminal and cd (change directory) into that folder by running: cd <HOME_DIR>/LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src (where <HOME_DIR> is your home directory, i.e. /home/username/

7) run: sudo KBUILD_NOPEDANTIC=1 make

8) run: sudo KBUILD_NOPEDANTIC=1 make install

9) This should put a driver in /lib/modules/2.6.24-16-generic/kernel/drivers/net/atl1e/. The driver is the at1le.ko file. Keep in mind, if you are running a different kernel, the 2.6.24-16-generic folder will be named after that kernel (i.e., mine is 2.6.24.19-generic because that's the kernel I'm running), so when you CD into the directory below, make sure you use the right kernal number for the folder name.

10) From the terminal, cd into that directory (/lib/modules/2.6.24-16-generic/kernel/drivers/net/atl1e/) and run: sudo insmod ./atl1e.ko (again, since I was running a different kernel, I cd'd into /lib/modules/2.6.24-19-generic/kernel/drivers/net/atl1e/)


That's it. The driver should be up and running. Whenever you update to a new kernel, I believe that you'll have to do this all over again, but it works for now until the kernel actually supports this chip by default. To me, it's not that big of a deal, I just kept the folders with the drivers inside my home directory for later use.

Thanks for this guide! Its worked well for several weeks now, on 2.6.24-19, and has saved me from having to add in an extra Ethernet card. ^__^

Be cautious updating, though. Unfortunately, when I updated to Kernel 2.6.24-21 the driver stopped working and disappeared from the third-party drivers list. When I tried reinstalling it, the computer locked up each attempt after the final step typing sudo insmod ./atl1e.ko. After this lock up, and forced restart, Ubuntu would freeze on the loading screen. This was easily fixed by selecting the previous kernel version at the GRUB Loader screen, entering Synaptic and removing the 2.6.24-21 kernel.

The silver lining is the fact that this network card driver works perfectly fine, out of the box, so far on the 8.10 Intrepid Ibex beta Live CD's, so the original driver problem has been fixed.

mar.don
October 18th, 2008, 11:12 AM
Thanks for this guide! Its worked well for several weeks now, on 2.6.24-19, and has saved me from having to add in an extra Ethernet card. ^__^

Be cautious updating, though. Unfortunately, when I updated to Kernel 2.6.24-21 the driver stopped working and disappeared from the third-party drivers list. When I tried reinstalling it, the computer locked up each attempt after the final step typing sudo insmod ./atl1e.ko. After this lock up, and forced restart, Ubuntu would freeze on the loading screen. This was easily fixed by selecting the previous kernel version at the GRUB Loader screen, entering Synaptic and removing the 2.6.24-21 kernel.

The silver lining is the fact that this network card driver works perfectly fine, out of the box, so far on the 8.10 Intrepid Ibex beta Live CD's, so the original driver problem has been fixed.

I had same problem with the kernel 2.6.24-21. Exist a driver, which is function with this kernel?

Rexcellent
October 24th, 2008, 11:33 PM
The silver lining is the fact that this network card driver works perfectly fine, out of the box, so far on the 8.10 Intrepid Ibex beta Live CD's, so the original driver problem has been fixed.

Hello, sorry if I'm ressurrecting an old post. I myself have had limited success with Ubuntu 8.10 beta server 64-bit and the Atheros L1e network card. On a fresh install, I get "No network interfaces detected" during setup. Once setup is complete, I can login and start the network interface using:


sudo /etc/init.d/networking restart

but the connection drops frequently and randomly.

A. Has anyone else experienced this?
B. Should I post a new topic with more details?
C. Should I post elsewhere in the hopes this might be resolved before 8.10 release date?

Thanks,
Rex

Tvanover
October 24th, 2008, 11:36 PM
I am not using 64bit ubuntu but 32bit ubuntu. also the previously mentioned link http://support.asus.com/download/download.aspx?product=1&SLanguage=us-en&type=map&model=P5KPL-CM does not seem to work anymore. I choose linux in the drop down and it returns no results.

Rexcellent
October 26th, 2008, 11:58 AM
This is caused by and older version (<1.0.1.0) of the atl1e driver under kernel 2.6.24-21. Update your driver to the most recent version (1.0.1.0) (http://jan.ucc.nau.edu/wal2/l1e-linux-v1.0.1.0.tar.gz) by following this guide (http://jan.ucc.nau.edu/wal2/atheros_attansic.html).

This is taken from a previous post in this thread. It appears (to me anyway) that this driver is newer than the one in the Ubuntu 8.10 Release Candidate. I think the RC has Atheros l1e driver version 1.0.0.7, although I could be mistaken.

I did a BIOS update of my ASUS P5KPL-CM board to rev. 0514 but a fresh install of Ubuntu using the release candidate still could not detect any network adapters.

Compiling the driver under 8.04 worked flawlessly, so I think I will start a new topic detailing my findings, but only after I try compiling the Atheros L1E driver under 8.10 RC.

Cheers,
Rex

rampageoberon
November 10th, 2008, 04:35 PM
I am not using 64bit ubuntu but 32bit ubuntu. also the previously mentioned link http://support.asus.com/download/download.aspx?product=1&SLanguage=us-en&type=map&model=P5KPL-CM does not seem to work anymore. I choose linux in the drop down and it returns no results.

It seems that ASUS have broken things rather badly. There's no downloads for any OS on quite a few models that I randomly checked.

derekshaw
November 11th, 2008, 11:25 PM
I am not using 64bit ubuntu but 32bit ubuntu. also the previously mentioned link http://support.asus.com/download/download.aspx?product=1&SLanguage=us-en&type=map&model=P5KPL-CM does not seem to work anymore. I choose linux in the drop down and it returns no results.

yes, the asus site is quite a piece of work. Since I spent so long trying to find it, here's what I (think) I did....

picked the download link, which took me here:
http://support.asus.com/download/download.aspx
filled in the fields
Product: Motherboard
select series: Socket 775
select models: P5KPL-CM

clicked "search"

the stupid javascript pop-up came up asking for an OS. I chose Linux

This time it found 24 files. In the "others" category there is one, described as "Support Linux Drivers". This appears to be the file described in an earlier post.

If it is not the correct one, I will come back here and edit this post.

Cheers!
d.

-::Bas::-
November 14th, 2008, 10:12 AM
Thanks boys and girls for the input!
I've jut compiled and injected the driver for my new motherboard.
Working like a charm.

To contribute to the community I'm hosting the driver on my website; http://www.bas-r.nl/atheros_lan_driver/

derekshaw
November 15th, 2008, 03:15 AM
I've jut compiled and injected the driver for my new motherboard. Working like a charm.]

Do you mind posting what kernel and version you are using?

Using hardy (8.04) I couldn't get anything higher than kernel 2.6.24-19 working (that is, 2.6.24-21 choked whenever that driver was re-compiled for it). (see http://ubuntuforums.org/showthread.php?t=973789&page=2)

So if you're past 2.6.24-19, I'd like to know how, since I now have a client computer that is a "special case" (and I hate that 'cause it'll come back to bite me sometime when I've forgotten all about it).

-::Bas::-
November 17th, 2008, 06:27 PM
Im on 2.6.24-21.43, and it works after using these instuctions:

The instructions posted by pdelahun, but I edited them for clarity in case people are a bit more green to this than others:


1) From a PC with a working internet connection, download the linux driver from: http://www.bas-r.nl/atheros_lan_driver/.

2) Inside the zip file is a .rar archive that you'll need to extract, so you'll need to be able to open .rar archives. If you're working from a Windows PC to download the driver, there are a number of applications out there to do this. If you're using a Linux PC to download the driver, then just get “unrar” (it's in the Ubuntu the repositories).

3) The .rar archive is inside the L1e_Lan folder (l1e-l2e-linux-v1.0.0.4.rar), you'll want to extract the contents to a folder named l1e-l2e-linux-v1.0.0.4 – so your newly created folder (named l1e-l2e-linux-v1.0.0.4) should contain a folder named src and 4 individual files (atl1e.7, copying, ldistrib.txt and readme). Make sure you put the l1e-l2e-linux-v1.0.0.4 folder inside the L1e_Lan (your folder structure should look like this; LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src.

4) Install Ubuntu hardy (32 or 64bit), make sure you also install the build-essential package from the CD (you can do this through synaptic after choosing the CD as the source).

5) Transfer the folders from your PC with the working internet connection (where you did the work with the .rar file) via usb stick, external USB drive or whatever to the PC you installed Ubuntu 8.04 on (you can zip the file before you transfer or just transfer the entire Linux Driver folder. Just put it in your /home directory.

6) Open a terminal and cd (change directory) into that folder by running: cd <HOME_DIR>/LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src (where <HOME_DIR> is your home directory, i.e. /home/username/

7) run: sudo KBUILD_NOPEDANTIC=1 make

run: sudo KBUILD_NOPEDANTIC=1 make install

9) This should put a driver in /lib/modules/2.6.24-16-generic/kernel/drivers/net/atl1e/. The driver is the at1le.ko file. Keep in mind, if you are running a different kernel, the 2.6.24-16-generic folder will be named after that kernel (i.e., mine is 2.6.24.19-generic because that's the kernel I'm running), so when you CD into the directory below, make sure you use the right kernal number for the folder name.

10) From the terminal, cd into that directory (/lib/modules/2.6.24-16-generic/kernel/drivers/net/atl1e/) and run: sudo insmod ./atl1e.ko (again, since I was running a different kernel, I cd'd into /lib/modules/2.6.24-19-generic/kernel/drivers/net/atl1e/)

-::Bas::-
November 17th, 2008, 06:30 PM
Im on 2.6.24-21.43, and it works after using these instuctions:

The instructions posted by pdelahun, but I edited them for clarity in case people are a bit more green to this than others:


1) From a PC with a working internet connection, download the linux driver from: http://www.bas-r.nl/atheros_lan_driver/.

2) Inside the zip file is a .rar archive that you'll need to extract, so you'll need to be able to open .rar archives. If you're working from a Windows PC to download the driver, there are a number of applications out there to do this. If you're using a Linux PC to download the driver, then just get “unrar” (it's in the Ubuntu the repositories).

3) The .rar archive is inside the L1e_Lan folder (l1e-l2e-linux-v1.0.0.4.rar), you'll want to extract the contents to a folder named l1e-l2e-linux-v1.0.0.4 – so your newly created folder (named l1e-l2e-linux-v1.0.0.4) should contain a folder named src and 4 individual files (atl1e.7, copying, ldistrib.txt and readme). Make sure you put the l1e-l2e-linux-v1.0.0.4 folder inside the L1e_Lan (your folder structure should look like this; LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src.

4) Install Ubuntu hardy (32 or 64bit), make sure you also install the build-essential package from the CD (you can do this through synaptic after choosing the CD as the source).

5) Transfer the folders from your PC with the working internet connection (where you did the work with the .rar file) via usb stick, external USB drive or whatever to the PC you installed Ubuntu 8.04 on (you can zip the file before you transfer or just transfer the entire Linux Driver folder. Just put it in your /home directory.

6) Open a terminal and cd (change directory) into that folder by running: cd <HOME_DIR>/LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src (where <HOME_DIR> is your home directory, i.e. /home/username/

7) run: sudo KBUILD_NOPEDANTIC=1 make

run: sudo KBUILD_NOPEDANTIC=1 make install

9) This should put a driver in /lib/modules/2.6.24-16-generic/kernel/drivers/net/atl1e/. The driver is the at1le.ko file. Keep in mind, if you are running a different kernel, the 2.6.24-16-generic folder will be named after that kernel (i.e., mine is 2.6.24.19-generic because that's the kernel I'm running), so when you CD into the directory below, make sure you use the right kernal number for the folder name.

10) From the terminal, cd into that directory (/lib/modules/2.6.24-16-generic/kernel/drivers/net/atl1e/) and run: sudo insmod ./atl1e.ko (again, since I was running a different kernel, I cd'd into /lib/modules/2.6.24-19-generic/kernel/drivers/net/atl1e/)

dalesd
November 17th, 2008, 07:07 PM
1) From a PC with a working internet connection, download the linux driver from: http://support.asus.com/download/dow...model=P5KPL-CM.

Thanks, Bas, but this link doesn't work. Could you post the correct link, please?

abcruz3
November 18th, 2008, 10:47 AM
I was able to successfully install my Atheros AR81XX Ethernet Controller using the instructions above, but I got my Linux driver here:

http://partner.atheros.com/Drivers.aspx


Check under AR81Family Linux Driver. Hope this helps.

tojaiswal
November 21st, 2008, 07:43 PM
Thanks alot it did work.

TylerD75
December 23rd, 2008, 06:11 PM
Hi Guys

Thank you, thank you so much !!!

I have got it working !!!

Ok first the network card is Atheros(R) AR8121/AR8113 PCI-E

Ok these are the steps i followed to get it working!

1) I installed ubuntu hardy 64bit, i has build-essential package installed
2) Then i downloaded the linux driver from: http://support.asus.com/download/download.aspx?product=1&SLanguage=us-en&type=map&model=P5KPL-CM
(as per my original post)
3) I then transfered the driver via usb stick to my laptop and unpacked the zip. (Actually i unpacked it on windows first as it has a .rar file that i could not unpack on linux Then i packed it up again on windows).
4) cd into <HOME_DIR>/LinuxDrivers/L1e_Lan/l1e-l2e-linux-v1.0.0.4/src
5) then i ran: sudo KBUILD_NOPEDANTIC=1 make
6) then i ran: sudo KBUILD_NOPEDANTIC=1 make install
7) that worked and put a driver in /lib/modules/2.6.24-16-generic/kernel/drivers/net/atl1e/at1le.ko
8 ) i cd into that director and i run: sudo insmod ./atl1e.ko

That is it !!! it worked as soon as i plugged in network card.

Thank you all so much !!!! I hope this helps everyone else ;)


THANK YOU!

This worked like a charm on an Asus P5Q Motherboard and Sabayon 3.5.1 (Kernel 2.6.26 SMP x86_64) as well.

Cheers,
TylerD75

dalesd
December 23rd, 2008, 06:24 PM
I'd like to report that when I upgraded from Hardy to Intrepid, the Ethernet just worked right out of the box.

oygle
December 28th, 2008, 01:26 PM
I'd like to report that when I upgraded from Hardy to Intrepid, the Ethernet just worked right out of the box.

I just 'lost' the lan card (the one reported in this thread) after applying 146 hardy updates. The 'plan' was to then upgrade to Intrepid with the alternate CD.

Maybe I should just do the upgrade and see what happens ?

Oygle

rozsko
January 28th, 2009, 09:28 AM
Hello Everyone,

First of all thanks for this thread, because it gave me hope that it will work. However I could not get this working yet and I would need some idea how to go forward.
Here it comes what I've done so far:
(I have an Asus P5Q Pro motherboard and a 64 bit Ubunu Studio Hardy installed.)

1. I got build-essential installed (downloaded all the repositories from http://archive.ubuntu.com/ubuntu/dists/hardy, copied them to my home folder and added the path to /etc/apt/sources - details: https://help.ubuntu.com/community/AptGet/Offline/Repository?action=show&redirect=SuiteCodename)
2. Followed the steps exactly as described in previous posts however I had to modify the makefile in src directory because I got "Linux kernel source not found" error. So I modified one of the path values (line#50) to /usr/src/linux-headers-2.6.24-19-generic. I think (but correct me if I am wrong) it is because uname -r gives back 2.6.24-19-rt but there is no source folder with such a name.
Then I got an other error saying "Linux kernel source not configured - missing version.h" so I did
sudo cp /usr/src/linux-headers-2.6.24-19/include/linux/version.h /boot/vmlinuz.version.h
sudo cp /usr/src/linux-headers-2.6.24-19/include/linux/autoconf.h /boot/vmlinuz.autoconf.h
then I could run
sudo KBUILD_NOPEDANTIC=1 make and

sudo KBUILD_NOPEDANTIC=1 make install succesfully.
(this was the point where I thought it will work, only one step was missing:p)
3. But at the last step (sudo insmod ./atl1e.ko) I got an error saying "invalid module". After some googleing I tried to put "atl1e" into /etc/modules and restarted the machine. Then did dmesg|grep Atheros but no result was given back, just like sudo modprobe -l atl1e did not give any result.

So please give me some idea how to go forward to solve this problem, because I spent already more then two nights trying to get this installed with no real success.
Thanks a lot in advance.

Please remember that I have internet connection only through Win XP so please don't suggest any Linux command which would need internet connection.

rozsko
January 28th, 2009, 11:24 PM
DONE
This post is coming from my 64-bit Hardy Studio running on P5QPro. :lolflag:

So the problem was that I used the -generic kernel headers, because that was the only one I could find in the folder structure.
Anyway it was a bit strange that I had to modify the makefile because "it is not able to handle the -rt kernel" and I had the feeling that I might use incorrect headers to build the driver modul and that is why I get the error message in the last step.
So did some more googling and found out that I can download the linux-headers-2.6.24-19-rt from the same archive link what I mentioned in my previous post.
Further more I found out that I need to add the hardy-update repository to /etc/apt/sources.list because that is where apt-get look for the kernel headers.
After running
sudo apt-get install linux-headers-2.6.24-19-rt I got an error saying can't find the specified file and the missing file was the linux-headers-2.6.24-19-rt_2.6.24-19.41_amd64.deb file, what I already downloaded from the archive, but did not use it because I thought it is already part of the hardy-update repository.
So I managed to install the -rt headers, copied the correct version.h and autoconf.h to /boot, reran all the steps mentioned in the previous posts and everything was working perfectly fine.
In addition to step#10 I had to enable the LAN card in System -> Administration -> Network and configured to use DHCP and now I am writing this post to you so others may learn from my mistake and get this done on Ubuntu Studio as well.
By the way could you guys let me know how could I do the last step from the Terminal? I mean enabling the LAN card and set it to DHCP. ifconfig did not show eth0 before enabling it from the GUI.

Thanks

NJC
April 3rd, 2009, 07:24 AM
I was able to successfully install my Atheros AR81XX Ethernet Controller using the instructions above, but I got my Linux driver here:

http://partner.atheros.com/Drivers.aspx


I tried to install this in Ubuntu 8.04 and it bombed with an error message. I can't install build essentials because I don't have network access in Ubuntu. Not sure what to do next.

chili555
April 3rd, 2009, 01:13 PM
I tried to install this in Ubuntu 8.04 and it bombed with an error message. I can't install build essentials because I don't have network access in Ubuntu. Not sure what to do next.Do you have your original istall disk for 8.04? Drop it in the CD tray and do the following commands:
sudo apt-cdrom add
sudo apt-get update
sudo apt-get install build-essentialIt will think a long time about your CD and then it will complain like crazy when it can't find the on-line repositories, but then, if all goes right, it will find build-essential on the CD and install it.

NJC
April 3rd, 2009, 05:13 PM
Thanks - will try when I get home tonight.

NJC
April 4th, 2009, 05:49 AM
sudo apt-cdrom add
sudo apt-get update
sudo apt-get install build-essential
This wouldn't pull it off the CD. This is frustrating ... :mad:

NJC
April 7th, 2009, 12:34 AM
Looks like a fix is committed for 8.04.3 if I am reading this correctly.

https://bugs.launchpad.net/ubuntu/+source/linux-ubuntu-modules-2.6.24/+bug/341183

chili555
April 7th, 2009, 12:42 AM
Looks like a fix is committed for 8.04.3 if I am reading this correctly.

https://bugs.launchpad.net/ubuntu/+source/linux-ubuntu-modules-2.6.24/+bug/341183
Add support for Atheros(R) AR8121/AR8113/AR8114/AR8131/AR8132 PCI-E Ethernet NICs for HardyThis is not the same thing as an Attansic NIC and we are way past Hardy.

NJC
April 7th, 2009, 04:21 AM
post deleted.

NJC
April 7th, 2009, 06:31 AM
The instructions posted by pdelahun, but I edited them for clarity in case people are a bit more green to this than others:

Thanks NineseveN and pdelahun for the instructions. As far as being green ):P, well that applies to me ... and I appreciated the extra clarity.

After MUCH gnashing of teeth, I successfully installed driver on a P5KPL-CM motherboard. I was able to use a NetMate USB - Ethernet to establish an internet connection. And downloading the correct linux headers package, it worked.

Skip Da Shu
April 26th, 2009, 09:17 AM
DONE ...
By the way could you guys let me know how could I do the last step from the Terminal? I mean enabling the LAN card and set it to DHCP. ifconfig did not show eth0 before enabling it from the GUI.

Thanks Isn't this and edit to /etc/network/interfaces ?

mikepre
May 18th, 2009, 06:27 PM
Thank you very much, it worked perfect in a desktop PC with Ubuntu 8.04 32 bit...Asus P5KPL-CM motherboard and Attansic netowrk card

):P

Michael

chaosdesigner
June 27th, 2009, 02:11 PM
first of all thank you very much for the help, but i unfortunatly havent really got it working.

I have the new ausus Eeepc 1008HA and i got the wireless to work with the 'linux-ubuntu-modules' but the wired lan still doesnt work. Ive done the steps just liek you said them but the lad still doesnt work.

The netbook has the Atheros AR8132 Network card..

Any Ideas on how to solve this?

Thank you alot.

Jakob

expatal
August 4th, 2009, 10:20 PM
Seconded Jakob. Also the proud owner of a brand new Asus Eee Pc 1008HA. Exactly the same problem as you with the Atheros AR8132 PCI-E Fast Ethernet adaptor in Jaunty (9.04). It is not recognised by Ubuntu, no doubt because no suitable kernel module is loaded. It worked under the initially installed kernel (2.6.28-11-generic), but not under the current one (2.6.28-14-generic).

(I had used the method posted here: http://ubuntuforums.org/showthread.php?t=1219931, but Atheros doesn't seem yet to have a version for the later kernel.)

Also, seems to be bad news :sad: for the video controller on this machine (Intel GMA500), but that's not for this thread.

Good luck,

Alan

expatal
August 5th, 2009, 11:35 AM
I have the new ausus Eeepc 1008HA and i got the wireless to work with the 'linux-ubuntu-modules' but the wired lan still doesnt work. Ive done the steps just liek you said them but the lad still doesnt work.

The netbook has the Atheros AR8132 Network card..

Any Ideas on how to solve this?

To Chaosdesigner:

I just managed to do it, despite what I said yesterday.

Just follow the instructions here: http://ubuntuforums.org/showthread.php?t=1219931 - the only reason I failed to make it work the second time was that I had performed the `make' under an earlier kernel and there was stuff hanging around in the system. So before executing `make' this time, I did a `make clean' and all went well. I now have both wireless and wired working on my eeepc 1011HA!

Good luck.

RpDPMS
August 10th, 2009, 08:14 AM
i have a Aspire One with the same LAN card i am running ubuntu: 2.6.28-14-generic I have the drivers and have tried what seems like everything i keep getting error messages seen here

ray@AspireOne:~/drv/src$ sudo KBUILD_NOPEDANTIC=1 make install
make -C /lib/modules/2.6.28-14-generic/build SUBDIRS=/home/ray/drv/src modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.28-14-generic'
Building modules, stage 2.
MODPOST 1 modules
make[1]: Leaving directory `/usr/src/linux-headers-2.6.28-14-generic'
gzip -c ../atl1e.7 > atl1e.7.gz
# remove all old versions of the driver
find /lib/modules/2.6.28-14-generic -name atl1e.ko -exec rm -f {} \; || true
find /lib/modules/2.6.28-14-generic -name atl1e.ko.gz -exec rm -f {} \; || true
install -D -m 644 atl1e.ko /lib/modules/2.6.28-14-generic/kernel/drivers/net/atl1e/atl1e.ko
/sbin/depmod -a || true
install -D -m 644 atl1e.7.gz /usr/share/man/man7/atl1e.7.gz
man -c -P'cat > /dev/null' atl1e || true
man:
cannot write to /var/cache/man/cat7/atl1e.7.gz in catman mode
atl1e.


what am i doing wrong? I am very new to linux just started playing with it Tuesday..... im already an addict.

chili555
August 10th, 2009, 02:57 PM
what am i doing wrong?I am not sure you did anything wrong. It appears to have installed correctly except for the manual page. We have a very strong tradition of never, ever reading the man page to help solve a problem, so the lack of a man page is really no issue. Nevertheless, it exists in the folder you extracted, so you can read it, although it's not in the conventional location.

More importantly, can you do:
sudo modprobe atl1eDoes your ethernet interface spring to life?

Hawk__0
September 30th, 2009, 08:39 PM
I am having problems with this in ubuntu server 9.04.

uname -a:

Linux backup-server 2.6.28-15-server #49-Ubuntu SMP Tue Aug 18 20:09:37 UTC 2009 x86_64 GNU/Linux


error:

/opt/src# KBUILD_NOPEDANTIC=1 make
Makefile:63: *** Linux kernel source not found. Stop.



ls /usr/src
linux-source-2.6.28 linux-source-2.6.28.tar.bz2

Help would be greatly appreciated


EDIT:

I also tried this:

root@backup-server:/opt/src# make -C /lib/modules/2.6.28-15-server/build SUBDIRS=/opt/src modules
make: *** /lib/modules/2.6.28-15-server/build: No such file or directory. Stop.
root@backup-server:/opt/src# ls /lib/modules/2.6.28-15-server/
initrd modules.ccwmap modules.inputmap modules.pcimap modules.usbmap
kernel modules.dep modules.isapnpmap modules.seriomap volatile
modules.alias modules.dep.bin modules.ofmap modules.symbols
modules.alias.bin modules.ieee1394map modules.order modules.symbols.bin
root@backup-server:/opt/src#