PDA

View Full Version : [ubuntu] Installing BCM94311MCG wlan mini-PCI on 7.10 & 8.04 - Broadcom wifi on a HP dv9000



Pages : [1] 2

jlandaw
April 27th, 2008, 06:39 AM
I'm making this Thread to Help others with the problem I had installing my BCM94311MCG wlan mini-PCI.

I have a HP dv9000 (dv9428nr) Running Ubuntu 7.10(32 bit)
Update: Now running Ubuntu 8.04 LTS 64 bit -it is working but I had a little trouble setting up... I am including a bug-fix that any hardy (8.04) users should use before going forward*


Note: If the output for “lspci | grep Broadcom” is :

“03:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)”

Then this tutorial will work (baring some bug or alternate configuration you have tried to set up already).

Here is a list of computers that this tutorial has already worked on:
Hp dv2000:
HP dv2415nr
HP dv2418nr

HP dv6000:
HP dv6258se
HP dv6408nr
HP dv6420
HP dv6423om
HP dv6607nr
HP dv6625us
HP dv6636nr
HP dv6660se

HP dv9000:
HP dv9205us
HP dv9428nr

HP tx1000:
HP tx1305
HP tx1499

HP zv5000


Compaq Presario V3000
Compaq Presario V6000
Compaq Presario F500
Compaq Presario F562LA
Compaq Presario F700

Compaq 6515b
Compaq 6720s

Dell Inspiron 1501
Dell Inspiron 9400
Dell Inspiron E1705
Dell Latitude 131L

Acer Extensa 4420-5237


I do believe this will work with almost all hp dv**** and Compaq's (some forums show this to also work with dells...
Edit: If you read the replies to this post they show that many different HP's, Compaq's and Dells all can work by using this method.
Everything I put in here i have taken form other thread/forums, but none were set up in a way that a noob (Beginner) could follow easily.

First we need to do a few things.

You need to have a internet connection, wired since your wifi is not working yet :)

whenever you see the command "sudo" you will have to enter you password (the characters will not appear as you type.)

Step 1

You will need to download the drivers we will use later.
Download it Here (http://www.mediafire.com/?zyjnqmklzm1).
Edit: Thanks to rabalder and MrPickle for the non-rapidshare link


Step 2

You do not have to download the next file, we will do later on, in the instillation.
Go here (http://sourceforge.net/project/showfiles.php?group_id=93482) and write down the latest stable release number. On May 27, 2008 the release number was 1.53

Step 3

If you enabled the restricted drivers disable them

System --> Administration --> Restricted Drivers Manager


I guess if you never tried to use them you could try before going thru this...

One more important thing... make sure that you know what way the wifi switch must go to be on... If its off you will never get online (I just went step by step with someone, and we faild to think of the fact that his wifi card was switch off... :mad: ) Its an easy thing to miss.
On my Hpdv9000, the switch is on if it is to the right. ===>

Step 4

Next we need to uninstall ndiswrapper & bcm43xx-fwcutter

Open a Terminal (Applications --> Accessories --> Terminal)

Copy each line into the terminal separately (do each line separately in every step)
(you can use ctrl+c to copy out of Firefox, but you have to use either ctrl+alt+v or shift+insert to paste into the terminal.)


sudo apt-get remove ndiswrapper-common ndiswrapper-utils-1.9

sudo apt-get remove bcm43xx-fwcutter

The step is complete even if it does not remove anything (you may not have had those packets installed)


*If you are using Hardy you should run the following bug fix before proceading:


echo -e '\n#hardy ssb bug-fix\nrmmod b43\nrmmod b44\nrmmod ssb\nrmmod ndiswrapper\nmodprobe ndiswrapper\nmodprobe ssb\nmodprobe b44' | sudo tee -a /etc/init.d/rc.local

Edit: I updated the bug fix May 3, 2008 to add the line "modprobe b44", due to the fact that it was missing( this allows your wired lan to be configured.) Thank you to Ayuthia and the Ubuntu documentation site (https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Feisty_No-Fluff#head-cbc75fcb762da2057fa8dbe904358e4b611353c0).



Step 5

Now you need to Blacklist the bcm43xx file

In the terminal you can put the following line and a text editor will pop up with the file we need to edit.


sudo gedit /etc/modprobe.d/blacklist

At the end add

blacklist bcm43xx
Do not put a # in front of it.

*In hardy bcm43xx is already blacklisted, but you need to add:

blacklist b43


You can put it under the blacklist bcm43xxline

Save the file and close the editor



Step 6

If you are reading this from the web and you have not saved it or printed it, you may want to bookmark this page...(I always leave the page open and press shutdown. After you reboot, if you open Firefox it will ask you if you want to resort the session, click yes and you will be right back here....)

Reboot your computer,


Step 7

Lets get the drivers ready to use
Find the file you downloaded and move it to your home folder

your home folder is /home/yourusername

Just in case you missed it... yourusername is your "user name"... whatever you use to log on...
You can right click it wherever it is, copy it and then go to the home folder from places and paste it

next open a terminal and type

tar -xzvf WLANBroadcom.tar.gz
Check and see, there should be a folder in you home folder called WLANBroadcom

you could also accomplish this by extracting the download to you home folder...

Step 8

The next step is going to take some editing on your part,

First type in the terminal the following
uname -rand write down or copy to text editor (Application--> Accessories--> Text Editor)
the output
you should get something like;

2.6.22-14-generic


Step 9

Install ndiswrapper from source


Now you need to edit five things the following before you put it into the terminal


sudo apt-get update

sudo apt-get install build-essential

sudo apt-get install linux-headers-`uname -r`

sudo ln -s /usr/src/linux-`uname -r` /lib/modules/`uname -r`/build

mkdir -p ~/bcm43xx/ndiswrapper

cd ~/bcm43xx/ndiswrapper

sudo wget http://downloads.sourceforge.net/ndiswrapper/ndiswrapper-1.53.tar.gz

tar xvzf ndiswrapper-1.53.tar.gz

cd ndiswrapper*

make distclean

make

sudo make install

All three 'uname -r' need to be replaced with the output you got in step 8 (no " quotes should be in the code)

ie on the third line i put

sudo apt-get install linux-headers-2.6.22-14-generic

The other two highlighted items need to be the release number you got in step 2
If it is still 1.53 just leave them like that.

Step 10

Now we are going to install the drivers

In the terminal type


cd /home/yourusername/WLANBroadcom/
sudo ndiswrapper -i bcmwl5.inf
ndiswrapper -l

Again yourusername is your "username"


Step 11

Now we need to add ndiswrapper to the modules file

sudo gedit /etc/modules

just add the following at the end of the file and save and close it.

ndiswrapper


Step 12


Enter in terminal

sudo modprobe ndiswrapper

sudo ndiswrapper -m



Now you can reboot again, and it should work.


Thanks to :
invaleed (http://invaleed.wordpress.com/2007/11/20/install-bcm94311mcg-wlan-mini-pci-ubuntu-710/)
anomsuratno (http://linuxsalatiga.wordpress.com/2008/04/24/bcm43xx-ndiswrapper-in-hardy/)
doorknob60 (http://ubuntuforums.org/showthread.php?t=768017)
Enjoy

italomaia
April 27th, 2008, 07:46 AM
Thank you very much dude! It worked like a charm in my Hardy Heron! /

jlandaw
April 27th, 2008, 09:45 AM
No problem, glad to help

zspace
April 28th, 2008, 05:37 AM
I just tried all of this on my HP dv6000 (same wireless model though) and it worked fine. I had to run step 9 line by line though, if I put it in all at once I got an error.
But it did work, I restated and just before login the little light turned blue.
I have no problems detecting signal strength, its kicking up my dorms wireless router at almost full strength and the one down the street shows up as a weaker signal.

Thanks a bunch!

-zspace

jlandaw
April 28th, 2008, 05:41 AM
Great to hear its working!!

knaveman
April 28th, 2008, 06:51 AM
gracias beyond words. I was ready to leave ubuntu over all this. confirm working on HP Pavillion DV6607nr broadcom BCM94311mcg (rev 2)

Alvarin
April 29th, 2008, 01:48 PM
Thank you wery much for the solution . It worked for some , unfortunately , it did not work for me ...
I have BCM94311MCG on my Presario F500 , running Hardy Heron ...

crobinson55331
April 29th, 2008, 04:01 PM
Thanks a bunch - I am replying wirelessly. This was may last hurdle before committing to Ubuntu 8.04 as my business machine for my next trip to Asia. Now i can go with confidence.

HP Pavillion dv6258se

zackymcharvest
April 29th, 2008, 07:15 PM
BCM94311MCG wlan mini-PCI (rev 02)<---? will it work on this? I have a HP tx1000(tx1499)and its had many problems...will this work on (rev 02)? I am afraid to do this due to my bad experance with this(i have had to reinstall 4 times today) because every time i try a method it breaks all future attempts to get the wifi working. so (rev 02)??

Ayuthia
April 29th, 2008, 07:55 PM
BCM94311MCG wlan mini-PCI (rev 02)<---? will it work on this? I have a HP tx1000(tx1499)and its had many problems...will this work on (rev 02)? I am afraid to do this due to my bad experance with this(i have had to reinstall 4 times today) because every time i try a method it breaks all future attempts to get the wifi working. so (rev 02)??There is a good chance that this one will work. Most HP laptops seem to be able to use the same driver. NDISwrapper is most likely the way to go right now for you because I have heard that the patch that allows the 4311 rev 02 chipset to work with this kernel and the b43 driver could not be applied because it breaks most of the other chipsets.

jlandaw
April 30th, 2008, 05:55 AM
BCM94311MCG wlan mini-PCI (rev 02)<---? will it work on this? I have a HP tx1000(tx1499)and its had many problems...will this work on (rev 02)? I am afraid to do this due to my bad experance with this(i have had to reinstall 4 times today) because every time i try a method it breaks all future attempts to get the wifi working. so (rev 02)??
Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)

My HPdv9000 has the same hardware so it will work:

lspci | grep Broadcom


03:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)

ECted
April 30th, 2008, 06:52 AM
So I did this and my wireless connection in still not showing up when I go to System --> Administration --> Network. It still only shows my wired connection and point to point connection. Is there something Im missing?

--ted

jlandaw
April 30th, 2008, 08:27 AM
First are you sure you did everything, next what is the output for;


lspci | grep Broadcom

VerballyCopulating
April 30th, 2008, 11:46 AM
How would it be possible to do this WITHOUT an Internet connection? Unfortunately for me, WiFi is the only possibility at the moment. (I have a working connection in Vista and can import files to my Linux partition)

All these posts seem to me like "Here's how you get your Internet working, but one caveat, you need a working Internet connection first!"

Alvarin
April 30th, 2008, 12:39 PM
I do have wired conneciton too , and if anyone can help me , my output for posed question is -

03:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)

jlandaw
May 1st, 2008, 04:00 AM
Ok Alvarin,

I'm trying to think of why this is not working for you.

Do you get any errors when you are doing any of the steps?

I'll try to help you, but from what i know, if you do everything in order, it will work...

BlueFeast
May 1st, 2008, 04:03 AM
when i did this, it made my menu when clicking on the two black monitors to

"- Wired Network
_______________Wireless Networks___________
Connect to Other wireless Network...
Create New wireless Network...
-------------------------------------------
Connect to 802.1X Protected Wired Network....
Manual Configuration"

and tells me i can use wireless but the light is still orange, maybe i dont know how to search for networks?

the output is "03:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)" when i put in
lspci | grep Broadcom\ Corporation

jlandaw
May 1st, 2008, 04:03 AM
How would it be possible to do this WITHOUT an Internet connection? Unfortunately for me, WiFi is the only possibility at the moment. (I have a working connection in Vista and can import files to my Linux partition)

All these posts seem to me like "Here's how you get your Internet working, but one caveat, you need a working Internet connection first!"

I am not sure, but I am working on finding out for you.

I will tell you either way soon.

Alvarin
May 1st, 2008, 07:53 AM
These thing are so finicky it could be anything... I was jsut talking to someone and they forgot to put their wifi switch in the on position, so thats where i would start.

If you have a wired connection, then use it to do all the steps...

I have redone it twice , but now it WORKS !!!
There was no difference between my last attempt and the two attempts before it , but whatever .

Thank you so much !!

daveerickson
May 1st, 2008, 11:31 PM
jlandaw, you are the man! Thank you for compiling this information together in one easy to use place. I used this to get the wireless working on my sisters dv2000, specifically a dv2418nr, on hardy. I could not be more pleased. :)

das7002
May 3rd, 2008, 06:13 AM
Hey this worked on my Acer Extensa 4420-5237(running hardy heron the wifi did not allow 7.04 and 7.10 to boot bcmw43xx_microcode.fw hardy heron no problem) just one edit to what is said for me it works best if you do not add
'blacklist b43' but follow the rest the light may come on and then shut off during boot up but who cares if it is on or off if it works:lolflag: anyway thanks, (openSUSE 10.3 is great but does not have Add/Remove programs that gets all the dependencies and ubuntu can use my internal wireless so go ubuntu:KS)

agentdave
May 3rd, 2008, 06:48 PM
Thank you so much for this post! It worked in the first try when various other methods were dead ends.

I'm currently using an HP dv2415nr notebook with the 64-bit (AMD64) version of Ubuntu 8.04 - Hardy Heron.

My output in "lspci | grep Broadcom" gives:
...Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)

As the post describes, this should work with most all HP Pavilion dv2000, dv6000, dv9000 or most Compaq Presario notebooks manufactured within the last year or two which use Broadcom wireless cards (I know, because I work at a major retailer as a technician and not much has changed on these computers internally since they started using the sleeker-looking chassis).

I searched far and wide for a solution to this problem after my own attempts failed, and I am ecstatic that this worked so easily! And on the 64-bit platform!

[ NOTE: I hope you don't mind my doing so, but the somewhat obvious or redundant information I included in this reply is so that others who experience this problem might be able to more easily find information when they perform searches on the forums. ]

Thank you again!

Ayuthia
May 3rd, 2008, 09:42 PM
jlandaw - Can you post your lspci -nn? I just realized that you posted that you have a BCM94311MCG, but you did not mention which revision you are using. I just want to confirm that it is a rev 01 instead of an 02. From what I understand is that the rev 02 is having problems with the b43 driver (even with your fixes).

jlandaw
May 4th, 2008, 02:11 AM
"lspci | grep Broadcom" output

03:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)

This works with rev 02

Ayuthia
May 4th, 2008, 03:53 AM
"lspci | grep Broadcom" output

03:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)

This works with rev 02

Can you also post the "lspci -nn |grep Broadcom" output? I want to see the chipset to see the 14e4:43xx number. Thanks!

jlandaw
May 4th, 2008, 04:04 AM
Can you also post the "lspci -nn |grep Broadcom" output? I want to see the chipset to see the 14e4:43xx number. Thanks!

03:00.0 Network controller [0280]: Broadcom Corporation BCM94311MCG wlan mini-PCI [14e4:4311] (rev 02)

MrPickle
May 4th, 2008, 07:52 PM
Could you upload the files somewhere else please, I had to wait half an hour to download then it asked me for 4 letters with a cat (??)

Omg, screw rapidshare >:( It's telling me I'm already downloading something when I'm not and it's saying I've entered the code too many times when I haven't even entered it once.

viralbug
May 6th, 2008, 10:41 AM
thanks a lot man! this works perfectly on my hp pavillion dv2000! :D

drunkmatador
May 6th, 2008, 11:48 AM
Ha! Oh man I don't even believe it.. finally, wireless working on my notebook!

Thanks a million, just when I thought none of these tutorials would work. Now I just cross my fingers and hope I don't see any of the problems with random disconnects and low signal strength. :)

ArsHermetica
May 6th, 2008, 03:00 PM
Thank you so much. Worked like a charm

Dell Inspiron 1501 Hardy Heron

dj_aj
May 6th, 2008, 03:43 PM
Hello,

Thank you for this perfect guide!
Got the wireless working on my HP DV6423OM in no time. I think it runs a Broadcom 4311.
Just following the steps in the guide was exactly what I needed to do...
thanks again..

nettobr
May 6th, 2008, 04:05 PM
Very Good...

It works on my DELL 131L.... on Kubuntu 8.04 LTS

Thanks,

NettoBR

vikramsharma
May 7th, 2008, 04:43 AM
I'm making this Thread to Help others with the problem I had installing my BCM94311MCG wlan mini-PCI.

I have a HP dv9000 (dv9428nr) Running Ubuntu 7.10(32 bit)(Update: Now running Hardy 64 bit -is working but I had a little trouble setting up... I am including a bug-fix that any hardy users should use before going forward*)

I do believe this will work with almost all hp dv**** and Compaq's (some forums show this to also work with dells...

Everything I put in here i have taken form other thread/forums, but none were set up in a way that a noob (Beginner) could follow easily.

First we need to do a few things.

You need to have a internet connection, wired since your wifi is not working yet :)

whenever you see the command "sudo" you will have to enter you password (the characters will not appear as you type.)

Step 1

You will need to download the drivers we will use later.
Download it here (http://rapidshare.com/files/70969505/WLANBroadcom.tar.gz). It is free,just click the free button, and then click download via ******** (******** can be any one of the choices)

Step 2

You do not have to download the next file, we will do later on, in the instillation.
Go here (http://sourceforge.net/project/showfiles.php?group_id=93482) and write down the latest stable release number. On April 21, 2008 the release number was 1.52

Step 3

If you enabled the restricted drivers disable them

System --> Administration --> Restricted Drivers Manager


I guess if you never tried to use them you could try before going thru this...

One more important thing... make sure that you know what way the wifi switch must go to be on... If its off you will never get online (I just went step by step with someone, and we faild to think of the fact that his wifi card was switch off... :mad: ) Its an easy thing to miss.
On my Hpdv9000, the switch is on if it is to the right. ===>

Step 4

Next we need to uninstall ndiswrapper & bcm43xx-fwcutter

Open a Terminal (Applications --> Accessories --> Terminal)

Copy each line into the terminal separately (do each line separately in every step)
(you can use ctrl+c to copy out of Firefox, but you have to use either ctrl+alt+v or shift+insert to paste into the terminal.)


sudo apt-get remove ndiswrapper-common ndiswrapper-utils-1.9

sudo apt-get remove bcm43xx-fwcutter

The step is complete even if it does not remove anything (you may not have had those packets installed)


*If you are using Hardy you should run the following bug fix before proceading:


echo -e '\n#hardy ssb bug-fix\nrmmod b43\nrmmod b44\nrmmod ssb\nrmmod ndiswrapper\nmodprobe ndiswrapper\nmodprobe ssb\nmodprobe b44' | sudo tee -a /etc/init.d/rc.local

Edit: I updated the bug fix May 3, 2008 to add the line "modprobe b44", due to the fact that it was missing( this allows your wired lan to be configured.) Thank you to Ayuthia and the Ubuntu documentation site (https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Feisty_No-Fluff#head-cbc75fcb762da2057fa8dbe904358e4b611353c0).



Step 5

Now you need to Blacklist the bcm43xx file

In the terminal you can put the following line and a text editor will pop up with the file we need to edit.


sudo gedit /etc/modprobe.d/blacklist

At the end add

blacklist bcm43xx
Do not put a # in front of it.

*In hardy bcm43xx is already blacklisted, but you need to add:

blacklist b43


You can put it under the blacklist bcm43xxline

Save the file and close the editor



Step 6

If you are reading this from the web and you have not saved it or printed it, you may want to bookmark this page...(I always leave the page open and press shutdown. After you reboot, if you open Firefox it will ask you if you want to resort the session, click yes and you will be right back here....)

Reboot your computer,


Step 7

Lets get the drivers ready to use
Find the file you downloaded and move it to your home folder

your home folder is /home/yourusername

Just in case you missed it... yourusername is your "user name"... whatever you use to log on...
You can right click it wherever it is, copy it and then go to the home folder from places and paste it

next open a terminal and type

tar -xzvf WLANBroadcom.tar.gz
Check and see, there should be a folder in you home folder called WLANBroadcom

you could also accomplish this by extracting the download to you home folder...

Step 8

The next step is going to take some editing on your part,

First type in the terminal the following
uname -rand write down or copy to text editor (Application--> Accessories--> Text Editor)
the output
you should get something like;

2.6.22-14-generic


Step 9

Install ndiswrapper from source


Now you need to edit five things the following before you put it into the terminal


sudo apt-get update

sudo apt-get install build-essential

sudo apt-get install linux-headers-`uname -r`

sudo ln -s /usr/src/linux-`uname -r` /lib/modules/`uname -r`/build

mkdir -p ~/bcm43xx/ndiswrapper

cd ~/bcm43xx/ndiswrapper

sudo wget http://downloads.sourceforge.net/ndiswrapper/ndiswrapper-1.52.tar.gz

tar xvzf ndiswrapper-1.52.tar.gz

cd ndiswrapper*

make distclean
make
sudo make install

All three 'uname -r' need to be replaced with the output you got in step 8 (no " quotes should be in the code)

ie on the third line i put

sudo apt-get install linux-headers-2.6.22-14-generic

The other two highlighted items need to be the release number you got in step 2
If it is still 1.52 just leave them like that.

Step 10

Now we are going to install the drivers

In the terminal type


cd /home/yourusername/WLANBroadcom/
sudo ndiswrapper -i bcmwl5.inf
ndiswrapper -l

Again yourusername is your "username"


Step 11

Now we need to add ndiswrapper to the modules file

sudo gedit /etc/modules

just add the following at the end of the file and save and close it.

ndiswrapper


Step 12


Enter in terminal

sudo modprobe ndiswrapper

sudo ndiswrapper -m



Now you can reboot again, and it should work.


Thanks to :
invaleed (http://invaleed.wordpress.com/2007/11/20/install-bcm94311mcg-wlan-mini-pci-ubuntu-710/)
anomsuratno (http://linuxsalatiga.wordpress.com/2008/04/24/bcm43xx-ndiswrapper-in-hardy/)
doorknob60 (http://ubuntuforums.org/showthread.php?t=768017)
Enjoy

Thanks a lot buddy your advice really helped me out, now I have wireless working flawlessly on my laptop.

alaya.zied
May 7th, 2008, 03:29 PM
I add a thanks from me jlandaw :o

it work for me
I have a dv6420 with Broadcom BCM94311MCG.

after the final reboot it detect the wireless network and I have an excellent signal

when I try a little ping, I have:

ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted
:confused:

I stopped ufw (new firewall on hardy) and I have now:

64 bytes from 172.16.1.1: icmp_seq=1 ttl=64 time=16.4 ms
64 bytes from 172.16.1.1: icmp_seq=2 ttl=64 time=11.7 ms
64 bytes from 172.16.1.1: icmp_seq=3 ttl=64 time=22.4 ms

now I can enjoy my Hardy
:popcorn:

Axis
May 8th, 2008, 09:32 PM
Hello you responded to my topic about my wireless not working before. I am using a compaq presario f500 with 8.04. Well I followed your steps and my wireless is on now. I just can't connect to anything. I can see the networks that are broadcasting and I can't seem to connect to any of them. I have tried removing encryption but it didn't change my results at all. If it matters the wireless light is on now, and all of my programs (and ubuntu) recognize that I have wireless. Just can't connect

Thanks,
Axis

EDIT:
It appears to work fine if you enable roaming mode and select your networks that way.Very glad to see this finally working it means so much to me, thanks a ton man!

tlxreed
May 10th, 2008, 07:26 AM
This thread works great for me on a dv9000. I had to turn off WPA Personal on my router to get a connection, but I'm surfing wirelessly now. Thanks!

txcrackers
May 11th, 2008, 07:14 AM
The Wife is now happy - got her 4311 working again. One change is that I actually used the ndiswrapper package from the repositories, instead of building it. (Laptop is a Compaq v6000.)

Lori Whitty
May 14th, 2008, 10:20 AM
All I can say is THANK YOU...THANK YOU...THANK YOU!!!!! I am BRAND NEW to linux and ubuntu and have spent the last day and a half researching how to make my wireless work. I tried MANY other ways but yours FINALLY did it for me. I'm EXTREMELY grateful for your post. My wireless is working beautifully now.

I'm a much happier new user thanks to your post. :)

Infini
May 16th, 2008, 01:59 PM
Still not working... No matter what I try nothing ever works. I can see the network but it won't connect. I enter the passphrase and one of the little things go green while the other remains grey and then it prompts me for the passphrase again after trying for a while.

newbreed
May 16th, 2008, 08:35 PM
dude... DUDE!...sweet. worked great, just won tut of the year, thanks.

lola23
May 17th, 2008, 12:20 AM
Still no luck for me :( I can see my WEP network but can't connect, it tries to apply the WEP key and fails.

Hardy on Dell Inspiron E1505 with Broadcom BCM94311MCG card. Output of lspci -nn:

0b:00.0 Network controller [0280]: Broadcom Corporation BCM94311MCG wlan mini-PCI [14e4:4311] (rev 01)

Tried nuking the network manager and installing wcid as suggested in one of the threads - better interface, still doesn't work.

Really lost at this point... re-installed Hardy, ndiswrapper and bcmwl5, doesn't seem to help.

Any suggestions? :confused: Thanks!

Ayuthia
May 17th, 2008, 01:05 AM
Still no luck for me :( I can see my WEP network but can't connect, it tries to apply the WEP key and fails.

Hardy on Dell Inspiron E1505 with Broadcom BCM94311MCG card. Output of lspci -nn:

0b:00.0 Network controller [0280]: Broadcom Corporation BCM94311MCG wlan mini-PCI [14e4:4311] (rev 01)

Tried nuking the network manager and installing wcid as suggested in one of the threads - better interface, still doesn't work.

Really lost at this point... re-installed Hardy, ndiswrapper and bcmwl5, doesn't seem to help.

Any suggestions? :confused: Thanks!

What does lshw -C network, ndiswrapper -v, and ndiswrapper -l show?

Praxicoide
May 17th, 2008, 05:14 AM
No luck on a Compaq Presario V3000 with a Broadcom 4311 (rev 02).

It istalled the driver, but still no wireless. iwconfig just shows lo and eth0 (no wlan0).

ndiswrapper -l states:
bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: bcm43xx)

EDIT:

lshw -C network

product: BCM94311MCG wlan mini-PCI
wendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:04:00.0
version: 02
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: driver_b43-pci-bridge latency=0 module=ssb

hmm....it seems I have the b43 driver? I blacklisted it as indicated, but maybe the bugfix wasn't successful. What can I do?

lola23
May 17th, 2008, 11:19 PM
What does lshw -C network, ndiswrapper -v, and ndiswrapper -l show?

lshw -C network


*-network DISABLED
description: Wireless interface
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:0b:00.0
logical name: wlan0
version: 01
serial: 00:16:ce:3a:af:b3
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.52+Broadcom,10/12/2006, 4.100. latency=0 link=no module=ndiswrapper multicast=yes wireless=IEEE 802.11g
*-network
description: Ethernet interface
product: BCM4401-B0 100Base-TX
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: eth0
version: 02
serial: 00:15:c5:16:d1:5c
size: 100MB/s
capacity: 100MB/s
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=b44 driverversion=2.0 duplex=full ip=192.168.1.34 latency=64 link=yes module=ssb multicast=yes port=twisted pair speed=100MB/s



ndiswrapper -v


utils version: '1.9', utils version needed by module: '1.9'
module details:
filename: /lib/modules/2.6.24-16-generic/ubuntu/misc/ndiswrapper/ndiswrapper.ko
version: 1.52
vermagic: 2.6.24-16-generic SMP mod_unload 586


ndiswrapper -l


bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: ssb)


I guess it's showing that my wlan0 (wireless) is disabled??

Ayuthia
May 18th, 2008, 01:09 AM
lshw -C network


*-network DISABLED
description: Wireless interface
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:0b:00.0
logical name: wlan0
version: 01
serial: 00:16:ce:3a:af:b3
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.52+Broadcom,10/12/2006, 4.100. latency=0 link=no module=ndiswrapper multicast=yes wireless=IEEE 802.11g
*-network
description: Ethernet interface
product: BCM4401-B0 100Base-TX
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: eth0
version: 02
serial: 00:15:c5:16:d1:5c
size: 100MB/s
capacity: 100MB/s
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=b44 driverversion=2.0 duplex=full ip=192.168.1.34 latency=64 link=yes module=ssb multicast=yes port=twisted pair speed=100MB/s



ndiswrapper -v


utils version: '1.9', utils version needed by module: '1.9'
module details:
filename: /lib/modules/2.6.24-16-generic/ubuntu/misc/ndiswrapper/ndiswrapper.ko
version: 1.52
vermagic: 2.6.24-16-generic SMP mod_unload 586


ndiswrapper -l


bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: ssb)


I guess it's showing that my wlan0 (wireless) is disabled??

You are one of the people that needs to have ssb so that your wired ethernet card will work. If you look at your other card, you will see the b44 driver. That driver needs ssb.

Just for now, I would try to remove ssb just to see if you can just get your wireless back up:

sudo modprobe -r b43 b44 ssb ndiswrapper
sudo modprobe ndiswrapper
If it doesn't work, you can enable your wired connection again by:

sudo modprobe b44. If it does, try connecting your wired again.

sixstorm
May 18th, 2008, 09:49 PM
OMG! Thank you so much for this guide, I've been going crazy having to wire my laptop connection up every time.

MODS - STICKY THIS THREAD!!!!

lola23
May 19th, 2008, 02:05 AM
You are one of the people that needs to have ssb so that your wired ethernet card will work. If you look at your other card, you will see the b44 driver. That driver needs ssb.

Just for now, I would try to remove ssb just to see if you can just get your wireless back up:

sudo modprobe -r b43 b44 ssb ndiswrapper
sudo modprobe ndiswrapper
If it doesn't work, you can enable your wired connection again by:

sudo modprobe b44. If it does, try connecting your wired again.

That didn't seem to help :( So you are saying that my problem is a conflict between ssb for wired ethernet card and wireless drivers??

Ayuthia
May 19th, 2008, 04:04 AM
That didn't seem to help :( So you are saying that my problem is a conflict between ssb for wired ethernet card and wireless drivers??
No, the new Broadcom drivers are now using ssb which is causing a conflict with NDISwrapper. The new Broadcom drivers are b43 (wireless) and b44 (wired).

The reason why I asked you to do this was to make sure that there was not a conflict. Since NDISwrapper still did not start up even though we removed the b44 and ssb drivers, we know that the wired card is not causing any problems.

Yours almost looks like your wireless is turned off. Do you have a switch to turn it on? If it is on, what happens when you go to the Terminal and type:

sudo ifconfig wlan0 up
sudo iwlist scan

jokobe
May 19th, 2008, 12:49 PM
This was really helful, sticked to your howto and it was working...

Ayuthia
May 19th, 2008, 03:02 PM
No luck on a Compaq Presario V3000 with a Broadcom 4311 (rev 02).

It istalled the driver, but still no wireless. iwconfig just shows lo and eth0 (no wlan0).

ndiswrapper -l states:
bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: bcm43xx)

EDIT:

lshw -C network

product: BCM94311MCG wlan mini-PCI
wendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:04:00.0
version: 02
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: driver_b43-pci-bridge latency=0 module=ssb

hmm....it seems I have the b43 driver? I blacklisted it as indicated, but maybe the bugfix wasn't successful. What can I do?

Can you post your ndiswrapper -v and lspci -nn? The fix is not always necessary. The fix is needed if your wired card uses the b44 driver. Once you post the information, we can then test NDISwrapper by removing the necessary modules and loading ndiswrapper. When that is working, we can then configure the rest.

Praxicoide
May 20th, 2008, 05:24 AM
I redid the guide and wireless works! Sorry for not updating sooner.

Thank you very much all involved. the configuration field on the lshw -C network now says ndiswrapper, not ssb like before.

imnotatfault
May 20th, 2008, 11:08 PM
I followed the guide to a T. Rebooted and successfully found all network. Connected and was on my way, or so I thought. The internet, while functional, is crawling.

I'm currently downloading package files from between 1 and 3kb/s(not a typo). I am at my wit's end.

Edit: Here's some info that may help (maybe?)
I'm running an Asus Barebones V2-M2V890 AMD with an Athlon Sempron Dual Core
installed 8.04 Hardy Heron i386 and used the bug fix in the guide
ASUS WL-138G V2 (Broadcom 4318 Air Force One 54G
I used Step 2a and did not have to compile ndiswrapper from source.

After installation, networks were viewable and speeds actually seemed normal for a second. Then I rebooted and that brought me to the 3kb/s realm (4kb/s on network transfers between computers).

ygrof
May 21st, 2008, 12:32 AM
What a detailed guide! Great for Linux noobs like me:)

Thank you so much for putting this up! I had been trying for days to get the wireless working on my HP tx1305...what a relief when the light finally turned blue!

Tavish
May 21st, 2008, 04:22 AM
This is amazing, thanks so much! It works like a charm now!

HP Compaq 6515b

sherwin
May 21st, 2008, 03:11 PM
Thank you, thank you, thank you! Perfect on Pavilion dv6625us with 8.04. I wish I'd seen this thread first instead of wasting hours following other people's instructions!

Troca
May 23rd, 2008, 02:10 AM
Holy ******* **** it worked !!!! Thank you so much i want to make sweeeeet love to you almost. This was driving me nuts tryed several tutorials be4 i read yours and yours is the only easyone to follow for a beginner like me pluss it works THANK YOU SOOOOOOOOOOOO MUTCH dude

doctored
May 23rd, 2008, 01:02 PM
Thanks! I was getting very mixed up with advice from all over the place, but your idiot-proof (I'm proof of that) guide WORKED!! (on a Compaq Presario F500).

Troca
May 23rd, 2008, 03:12 PM
same laptop as me doctored and yes this tutorial rocks !!! :)

SonicSteve
May 24th, 2008, 01:16 AM
Hi folks,
I really hope someone can help me with this. I'm having problems installing Ndiswrapper. I had this working under gutsy gibbon 7.10. However it had other issues which Hardy Heron 8.04 solved, sound card related.

I'm using a Compaq F700 based Laptop. It is definately using the broadcom 94311 r.2 wireless adapter.

I've successfully done all the steps up to;
make distclean
make
sudo make install

I believe that the make distclean command worked properly but the make and make install commands have errors. This is the output from all 3 commands, it's a bit lengthy.
You'll notice that I used sudo in front of distclean, this was an act of desperation and it seems to have had no consequence.


steve@Compaq-buntu:~/bcm43xx/ndiswrapper/ndiswrapper-1.49$ sudo make distclean
make -C driver clean
make[1]: Entering directory `/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/driver'
rm -rf ndiswrapper.ko ndiswrapper.o crt.o hal.o iw_ndis.o loader.o ndis.o ntoskernel.o ntoskernel_io.o pe_linker.o pnp.o proc.o rtl.o wrapmem.o wrapndis.o wrapper.o usb.o divdi3.o usb.o win2lin_stubs.o \
divdi3.o workqueue.o .*.ko.cmd .*.o.cmd compat.h \
ndiswrapper.mod.[oc] *~ .tmp_versions Modules.symvers Module.symvers
make[1]: Leaving directory `/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/driver'
make -C utils clean
make[1]: Entering directory `/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/utils'
rm -f *~ *.o loadndisdriver
make[1]: Leaving directory `/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/utils'
rm -f *~
rm -fr ndiswrapper-1.49 ndiswrapper-1.49.tar.gz patch-stamp
make -C driver distclean
make[1]: Entering directory `/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/driver'
rm -rf ndiswrapper.ko ndiswrapper.o crt.o hal.o iw_ndis.o loader.o ndis.o ntoskernel.o ntoskernel_io.o pe_linker.o pnp.o proc.o rtl.o wrapmem.o wrapndis.o wrapper.o usb.o divdi3.o usb.o win2lin_stubs.o \
divdi3.o workqueue.o .*.ko.cmd .*.o.cmd compat.h \
ndiswrapper.mod.[oc] *~ .tmp_versions Modules.symvers Module.symvers
rm -f *_exports.h .\#* win2lin_stubs.h built-in.o
make[1]: Leaving directory `/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/driver'
make -C utils distclean
make[1]: Entering directory `/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/utils'
rm -f *~ *.o loadndisdriver
rm -f .\#*
make[1]: Leaving directory `/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/utils'
rm -f .\#*
steve@Compaq-buntu:~/bcm43xx/ndiswrapper/ndiswrapper-1.49$ sudo make
make -C driver
make[1]: Entering directory `/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/driver'
make -C /usr/src/linux-headers-2.6.24-17-generic SUBDIRS=/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/driver
make[2]: Entering directory `/usr/src/linux-headers-2.6.24-17-generic'
scripts/Makefile.build:46: *** CFLAGS was changed in "/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/driver/Makefile". Fix it to use EXTRA_CFLAGS. Stop.
make[2]: *** [_module_/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/driver] Error 2
make[2]: Leaving directory `/usr/src/linux-headers-2.6.24-17-generic'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/driver'
make: *** [all] Error 2
steve@Compaq-buntu:~/bcm43xx/ndiswrapper/ndiswrapper-1.49$ sudo make install
make -C driver install
make[1]: Entering directory `/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/driver'
make -C /usr/src/linux-headers-2.6.24-17-generic SUBDIRS=/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/driver
make[2]: Entering directory `/usr/src/linux-headers-2.6.24-17-generic'
scripts/Makefile.build:46: *** CFLAGS was changed in "/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/driver/Makefile". Fix it to use EXTRA_CFLAGS. Stop.
make[2]: *** [_module_/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/driver] Error 2
make[2]: Leaving directory `/usr/src/linux-headers-2.6.24-17-generic'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/home/steve/bcm43xx/ndiswrapper/ndiswrapper-1.49/driver'
make: *** [install] Error 2
steve@Compaq-buntu:~/bcm43xx/ndiswrapper/ndiswrapper-1.49$


Take note of all the "Error 2" remarks. Does anyone know what's going wrong with this? Please help me, I don't want to use Vista, and I know this can work if Ndiswrapper would just install.

Ayuthia
May 24th, 2008, 01:29 AM
Take note of all the "Error 2" remarks. Does anyone know what's going wrong with this? Please help me, I don't want to use Vista, and I know this can work if Ndiswrapper would just install.
The errors show up because you are using version 1.49 of NDISwrapper. Versions 1.50 and higher support the 2.6.24 kernel (The one that is used in Hardy). You might try using the 1.52 version from NDISwrapper or just use the ones from the repositories (or the Hardy liveCD).

SonicSteve
May 24th, 2008, 01:44 AM
The errors show up because you are using version 1.49 of NDISwrapper. Versions 1.50 and higher support the 2.6.24 kernel (The one that is used in Hardy). You might try using the 1.52 version from NDISwrapper or just use the ones from the repositories (or the Hardy liveCD).

It's times like this I love the Ubuntu community. These errors were happening because I'm using the same home folder that I had from Gutsy Gibbon. Remember I said that I had this working with that version? The generic directory calls used in the tutorial found the 1.49 folder because it was first. So all the make commands were happening in that folder instead of the 1.52 folder!

It works, thank you so much Ayuthia thank you thank you thank you.

In the words of Dr. Frankenstein, (which my wife just called because of my silly evil laugh that she over heard when things started working)

ITS ALIVE!!!

fjcurcio
May 24th, 2008, 06:01 PM
I have an HP Pavillion DV6000. Dumped Vista, installed Hardy; all good except wireless!

when i do an lspci - there is NO sign of a wireless card.

nonethless i followed this post and all the install went fine.
when i do an ndisrapper -l i get a return saying the bcmwl5 driver is installed, but nothing about the devive being present.

any help greatly appreciated!!

TIA

idanool
May 24th, 2008, 10:22 PM
Hi!

I'm using HP G7000 laptop. exact same wlan card (lspci). Ubuntu Hardy.
I tried to follow the instructions on the guide, and didn't notice any errors.
It seems that now the wireless networks around are discovered, and even it asks me for my authentication (WEP2) key, but it still doesn't connect to my network.
I tried to change to WEP or no authentication and still can't connect.
wired networks works. connect from another computer to my wireless network also works.

$sudo lspci | grep Broadcom
01:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)

$sudo ndiswrapper -i bcmwl5.inf
driver bcmwl5 is already installed

$ ndiswrapper -l
bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: ssb)

$sudo ndiswrapper -m
module configuration already contains alias directive

any ideas ?

I used the link http://www.stosha.net/WLANBroadcom.tar.gz
which I found on http://invaleed.wordpress.com/2007/11/20/install-bcm94311mcg-wlan-mini-pci-ubuntu-710/
which is much faster then the rapidshare link (at least for me:)

-Morgoth-
May 25th, 2008, 04:16 PM
nvm, i got it working. Thanks for the excellent guide :)

Karamiekos
May 25th, 2008, 07:49 PM
This was awesome. As soon as I saw my little blue WLAN light on my HP DV6408nr with a BCM94311MCG Rev 2, I jumped for Joy!!!!

OUTSTANDING! Simply OUTSTANDING. The only thing I also had to look at was here...
http://ubuntuforums.org/showthread.php?t=318539

Some of the settings in the network interfaces were off, but that page fixed my right up.

TWO THUMBS UP!!

syga
May 25th, 2008, 09:00 PM
These instructions worked for me!

I thought I had a problem, the first time I rebooted, the wifi light took more than 1 minute to turn on after logging on.

Now, the wifi light turns on during the boot process.

Also, I'm dual booting with XP. Instead of downloading your files, I just copied bcmwl5 from Windows to my root folder, then made a few minor changes to your instructions.

Thanks.

jocheem67
May 25th, 2008, 10:01 PM
I've got a success too...

Actually it's been a while since I used ndiswrapper, but was forced into it again cause I want to use wpa2.
The b43 doesn't seem to work on this, so I got directed to your howto.
And a nice one it is!!:guitar:

Oh yeah...this is done on a dell 9400...

onetimeposter
May 26th, 2008, 09:41 PM
I registered for this one post, because so many people were saying that they had fixed their problems without stating how. (Very frustrating.)

I followed the instructions perfectly, but I was having the problem listed here:


when i did this, it made my menu when clicking on the two black monitors to

"- Wired Network
_______________Wireless Networks___________
Connect to Other wireless Network...
Create New wireless Network...
-------------------------------------------
Connect to 802.1X Protected Wired Network....
Manual Configuration"



i.e., I was seeing my wired connection and not my wireless. So I tried this:


You are one of the people that needs to have ssb so that your wired ethernet card will work. If you look at your other card, you will see the b44 driver. That driver needs ssb.

Just for now, I would try to remove ssb just to see if you can just get your wireless back up:

sudo modprobe -r b43 b44 ssb ndiswrapper
sudo modprobe ndiswrapper

That didn't work (or so I thought). So, I tried the above plus Ayuthia's next piece of advice (using the terminal to turn on the wireless card; a software on/off switch):




Yours almost looks like your wireless is turned off. Do you have a switch to turn it on? If it is on, what happens when you go to the Terminal and type:

sudo ifconfig wlan0 up
sudo iwlist scan

Worked. Apparently, my hardware switch to turn my wireless card on and off isn't working properly. Then I re-enabled my wired:


You can enable your wired connection again by:

sudo modprobe b44

And they both work now.

I am running a Dell Inspiron E1705.
Broadcom Corporation BCM94311MCG wlan mini-PCI [14e4:4311] (rev 01)

If this helps anyone, please thank Ayuthia and jlandaw.
I am merely a onetimeposter.

WarningXdezzy
May 27th, 2008, 03:09 AM
Thanks a million solved my problem completely

jocheem67
May 27th, 2008, 02:52 PM
Huh??

How can it be that after a kernel-upgrade, I actually don't have to compile ndiswrapper again??

Everything just keeps on working after going from the .16 to the .17 kernel..

doorknob60
May 30th, 2008, 01:55 AM
Huh??

How can it be that after a kernel-upgrade, I actually don't have to compile ndiswrapper again??

Everything just keeps on working after going from the .16 to the .17 kernel..

Probably no incompatabilities that stop it from working or something? Idk. Anyways, thanks for making this guide, I just recommended it to soemone who's brand new to Ubuntu from another site, and I was glad to see my name in the Thanks To list :), let's hope it works OK for him (he has a presario f500).

aemdb
May 30th, 2008, 09:28 PM
Many thanks for this tutorial! I was fighting with b43 drivers but without results. Following your guide I got my Compaq Presario F562LA wifi working! I'm using Ubuntu Hardy 8.04.

telescopic
June 1st, 2008, 01:20 AM
I have hp dv6000 with amd64 and bcm9311. The steps works temporarily for me as i found out the connection is lost some minutes later, although it shows I am still connected. I have to disable and enable the wireless network for it works again.

nizox
June 2nd, 2008, 12:45 AM
This worked perfectly and was very easy to follow.

Thank you very much!

Tuxor
June 2nd, 2008, 08:45 PM
Great! Helped me out on an upgraded (7.10->8.04) HP/Compaq 6720s, which lost the wlan in the upgrade. Worked the first time following your good guide. Perfect.

rabalder
June 3rd, 2008, 07:46 AM
Worked great on my pavilion zv5000 with Hardy
couldn't get the driver file through rapidshare though, I found these mirrrors:

http://www.stosha.net/WLANBroadcom.tar.gz

http://stosha.stylet-software.com/WLANBroadcom.tar.gz

PerceptionX
June 3rd, 2008, 09:35 AM
Feels GREAT!!!

Finally Wireless!!!!!
I am a new Linux user, THANKS A LOT!!!!!!!!!!! REALLY. Linux had been sitting in my laptop useless for many month.

I just have a little final doubt, just as I reboot my computer and finally got wireless conection, the update arrow in the tray sistem appears and marks to new security updates which look very suspecious. One says linux-libc-dev, and the other linux-restricted-modules-common. I didnt install them fearing they could restore the previous configuration, thus killing wireless. Should I ever install them?

Then again, THANK YOU. You should post this in many other pages, there are probably thousands looking for a guide that actually works.

ljungkvist
June 3rd, 2008, 07:13 PM
Hi!

Thanks alot, this solved it nicely for me as well.

Perhaps you should try to compile a list over the computer models/network adapters that have worked so far. I'm using a Compaq Presario V6000 with the BCM94311MCG card and Ubuntu 8.04.

Thanks again!

MrPickle
June 3rd, 2008, 11:15 PM
Here's a download that's not rapidshare. http://www.stosha.net/WLANBroadcom.tar.gz

saveferris7872
June 4th, 2008, 01:03 AM
this guide FTW!!

i have tried so many other guides online that i had just about given up. this was seriously going to be my last attempt at getting wifi working before just using wired permanently.

worked like a charm on my HP dv6636nr. thanks man!

geddyprogshred
June 4th, 2008, 02:35 AM
aaaand you my friend are a SAINT!!!!

you don't even know how long i spent trying to make my wireless work. this little howto finally laid it all out perfectly for me. even taught a newb like me some new linux commands.

btw, my computer is an hp pavillion dv6660se notebook . a list of computers that this worked for would be a great help for anybody looking in the future

rafter109
June 5th, 2008, 03:43 AM
Thanks a bunch. Worked like a charm!

My system is as follows
Ubuntu 8.04 Desktop 2.6.24-18-generic
on HP Pavilion dv9205us
with Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)

Tried fwcutter method before this to no avail.

rootie
June 5th, 2008, 06:10 AM
[SOLVED!]

got a split-second message on shutdown. checked my error logs, which directed me to http://linuxwireless.org/en/users/Drivers/b43. I don't know why I never tried this before, but it worked!

<old help request follows>

Hey there, I'm on a Lenovo 3000 and have the same Broadcom wifi card. I tried the tutorial above but it didn't work. I'll try to outline the problems I had.

I couldn't `make distclean' ndiswrapper
error:

make[1]: Entering directory '~/bcm43xx/ndiswrapper/ndiswrapper-1.53/driver/'
make[1]: No rule to make target `distclean'. Stop.
make[1]: Leaving directory '~/bcm43xx/ndiswrapper/ndiswrapper-1.53/driver/'
make: *** [distclean] Error 2

In an act of desperation, I checked the liveCD to see if it contained an ndiswrapper package and installed that. Entering `ndiswrapper -l' I got the following as output:

bcmwl5: driver installed
device (14E4:4311) present (alternate driver: bcm43xx)

So, I followed the rest of the tutorial.

The next roadblock I hit was on reboot. There was a problem unpacking the driver--unfortunately, I didn't catch the error. The driver is listed under 'Restricted Devices' as 'not in use.' When I click to activate it it tells me to reboot. This occurs ad nauseam.

ifconfig doesn't return the wlan entry. nmapplet doesn't have a Wireless option.

I hope someone can help with this. Thanks :)

Edit: By the way, I was in fact trying to use ndiswrapper 1.53. However, the version I actually installed (via liveCD) was 1.50.

Abhinav Gupta
June 5th, 2008, 09:36 AM
Hi,
I cannot thank you enough!!!! I am completely new to linux, and the posts on other forums for this fix were very confusing for me, especially the bit about adding a blacklist line. I used to add this line in the terminal!
Your instructions were, though, clear as crystal, and such instructions are required to convert newbees like me to linux! Thanks a lot again!
Abhinav.

*shiki
June 7th, 2008, 05:08 AM
This solution worked like a charm. I was about to give up on Ubuntu for my HP. It would have been a shame since I currently use it on my dell and am very happy with it. :D

kj7lo
June 8th, 2008, 07:50 PM
I did a clean install on 8.04 from 7.10 on my HP tx1000 and it blew away my wireless. Your instructions worked perfectly. I wish I understood what I did! Thank you *VERY* much!

Jeff

SteelDragon
June 8th, 2008, 09:26 PM
[SOLVED!]

got a split-second message on shutdown. checked my error logs, which directed me to http://linuxwireless.org/en/users/Drivers/b43. I don't know why I never tried this before, but it worked!


I'm getting the same error as described in your pre-edit post, but I can't figure out what it is you found in that link that solved the problem. Do you mind being more specific about what was in your error log and what you did to fix it?

Thanks

SD

Ayuthia
June 9th, 2008, 02:56 AM
I'm getting the same error as described in your pre-edit post, but I can't figure out what it is you found in that link that solved the problem. Do you mind being more specific about what was in your error log and what you did to fix it?

Thanks

SDI am not the poster of the quote in your post, but the message that the poster is referring is the message for the b43 firmware in dmesg. If you open the Terminal and type dmesg, you will find a message somewhere for the b43 drivers. It will refer you to a site where you can get the firmware. This is the same thing as using b43-fwcutter. You can install it by using this link (http://ubuntuforums.org/showthread.php?t=779754). You can also install the application in that link and it will configure the b43 driver if you have already installed NDISwrapper based on this guide.

Matt Damon
June 9th, 2008, 11:26 AM
Compaq presario C500 running Hardy, just recently upgraded from Gutsy whereupon my wireless quit and sound is shattered. Fortunately everything else (including wired) is OK. I ran these instructions, everything seemed to run OK, but after the reboot at the end I seem to have 'lost' my wireless hardware...


miked@miked-laptop:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:16:d4:e6:f8:ed
inet addr:192.168.2.33 Bcast:255.255.255.255 Mask:255.255.255.0
inet6 addr: fe80::216:d4ff:fee6:f8ed/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3375 errors:0 dropped:0 overruns:0 frame:0
TX packets:3540 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2906580 (2.7 MB) TX bytes:750630 (733.0 KB)
Interrupt:20 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1122 errors:0 dropped:0 overruns:0 frame:0
TX packets:1122 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:56100 (54.7 KB) TX bytes:56100 (54.7 KB)

miked@miked-laptop:~$
miked@miked-laptop:~$ aplay
ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
aplay: main:546: audio open error: Device or resource busy
miked@miked-laptop:~$ aplay
ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
aplay: main:546: audio open error: Device or resource busy
miked@miked-laptop:~$ lspci -v
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
Subsystem: Hewlett-Packard Company Unknown device 30a5
Flags: bus master, fast devsel, latency 0
Capabilities: <access denied>

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
Subsystem: Hewlett-Packard Company Unknown device 30a5
Flags: bus master, fast devsel, latency 0, IRQ 20
Memory at d0200000 (32-bit, non-prefetchable) [size=512K]
I/O ports at 1800 [size=8]
Memory at c0000000 (32-bit, prefetchable) [size=256M]
Memory at d0300000 (32-bit, non-prefetchable) [size=256K]
Capabilities: <access denied>

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
Subsystem: Hewlett-Packard Company Unknown device 30a5
Flags: bus master, fast devsel, latency 0
Memory at d0280000 (32-bit, non-prefetchable) [size=512K]
Capabilities: <access denied>

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
Subsystem: Hewlett-Packard Company Unknown device 30a5
Flags: bus master, fast devsel, latency 0, IRQ 21
Memory at d0340000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>

00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
Capabilities: <access denied>

00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 01) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=06, subordinate=06, sec-latency=0
Memory behind bridge: 30000000-300fffff
Capabilities: <access denied>

00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01) (prog-if 00 [UHCI])
Subsystem: Hewlett-Packard Company Unknown device 30a5
Flags: bus master, medium devsel, latency 0, IRQ 18
I/O ports at 1820 [size=32]

00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01) (prog-if 00 [UHCI])
Subsystem: Hewlett-Packard Company Unknown device 30a5
Flags: bus master, medium devsel, latency 0, IRQ 19
I/O ports at 1840 [size=32]

00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01) (prog-if 00 [UHCI])
Subsystem: Hewlett-Packard Company Unknown device 30a5
Flags: bus master, medium devsel, latency 0, IRQ 17
I/O ports at 1860 [size=32]

00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01) (prog-if 20 [EHCI])
Subsystem: Hewlett-Packard Company Unknown device 30a5
Flags: bus master, medium devsel, latency 0, IRQ 18
Memory at d0544000 (32-bit, non-prefetchable) [size=1K]
Capabilities: <access denied>

00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1) (prog-if 01 [Subtractive decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=08, subordinate=08, sec-latency=32
I/O behind bridge: 00002000-00002fff
Memory behind bridge: d0100000-d01fffff
Capabilities: <access denied>

00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
Subsystem: Hewlett-Packard Company Unknown device 30a5
Flags: bus master, medium devsel, latency 0
Capabilities: <access denied>

00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01) (prog-if 8a [Master SecP PriP])
Subsystem: Hewlett-Packard Company Unknown device 30a5
Flags: bus master, medium devsel, latency 0, IRQ 19
I/O ports at 01f0 [size=8]
I/O ports at 03f4 [size=1]
I/O ports at 0170 [size=8]
I/O ports at 0374 [size=1]
I/O ports at 1810 [size=16]

00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 01) (prog-if 01 [AHCI 1.0])
Subsystem: Hewlett-Packard Company Unknown device 30a5
Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 221
I/O ports at 18b0 [size=8]
I/O ports at 18a4 [size=4]
I/O ports at 18a8 [size=8]
I/O ports at 18a0 [size=4]
I/O ports at 1890 [size=16]
Memory at d0544400 (32-bit, non-prefetchable) [size=1K]
Capabilities: <access denied>

00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
Subsystem: Hewlett-Packard Company Unknown device 30a5
Flags: medium devsel, IRQ 10
I/O ports at 18c0 [size=32]

06:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)
Subsystem: Hewlett-Packard Company Unknown device 1364
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at 30000000 (32-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>

08:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
Subsystem: Hewlett-Packard Company Unknown device 30a5
Flags: bus master, medium devsel, latency 32, IRQ 20
I/O ports at 2000 [size=256]
Memory at d0100000 (32-bit, non-prefetchable) [size=256]
Capabilities: <access denied>

miked@miked-laptop:~$

Ayuthia
June 9th, 2008, 02:21 PM
Compaq presario C500 running Hardy, just recently upgraded from Gutsy whereupon my wireless quit and sound is shattered. Fortunately everything else (including wired) is OK. I ran these instructions, everything seemed to run OK, but after the reboot at the end I seem to have 'lost' my wireless hardware...If you compiled NDISwrapper in Gutsy, you will need to get a new version of NDISwrapper (1.50 or higher) and will most likely need to reinstall the bcmwl5 driver.

ivarkvaal
June 9th, 2008, 05:41 PM
SOLVED!

Hi,

thanks for the guide. I have tried, and re-tried it several times now, without any luck... Maybe someone here can help me figure out what I'm doing wrong.

- Computer: HP Pavilion dv6000.
- I have done all the steps in the guide, from a fresh Ubuntu 8.04 install.
- I have not enabled the restricted wireless driver.
- I get the blue light indicator on my wireless card.
- I can see some networks, but not my own. I cannot connect to any wireless networks.

I suspect the issue is related to ndiswrapper. I got this error when I tried the 'make distclean' command (even though it's from a fresh install).


make -C driver clean
make[1]: Entering directory `/home/magnhild/ndiswrapper-1.53/driver'
rm -f *.o *.ko .*.cmd *.mod.c *.symvers modules.order *~ .\#*
rm -f *_exports.h win2lin_stubs.h
rm -rf .tmp_versions
make[1]: Leaving directory `/home/magnhild/ndiswrapper-1.53/driver'
make -C utils clean
make[1]: Entering directory `/home/magnhild/ndiswrapper-1.53/utils'
rm -f *~ *.o loadndisdriver
make[1]: Leaving directory `/home/magnhild/ndiswrapper-1.53/utils'
rm -f *~
rm -fr ndiswrapper-1.53 ndiswrapper-1.53.tar.gz patch-stamp
make -C driver distclean
make[1]: Entering directory `/home/magnhild/ndiswrapper-1.53/driver'
make[1]: *** No rule to make target `distclean'. Stop.
make[1]: Leaving directory `/home/magnhild/ndiswrapper-1.53/driver'
make: *** [distclean] Error 2


ndiswrapper -l output


bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: ssb)


lshw -C network output

*-network
description: Wireless interface
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan0
version: 01
serial: 00:1a:73:2e:66:8f
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.52+Broadcom,10/12/2006, 4.100. latency=0 module=ndiswrapper multicast=yes wireless=IEEE 802.11g

any ideas? Thanks!

EDIT:

I can actually connect to open networks... but I cant even see my own wep network. I have several other machines connected to it, so I know it the wireless router works...

EDIT2:

I restarted my router, and now everything works... Hehe.. Thanks for the guide, and sorry for not taking the time to restart my router before posting. Have a nice day! Cheers!

IuilAine
June 9th, 2008, 07:20 PM
Hey there. I'm very new to linux and installed (dual boot with vista) Ubuntu by myself last night. Did all the updates and everything. Then got some linux-loving friends to try to help me get my wireless up and running. Gave up and tried again today with your guide and I still get nothing.

I'm running a hp dv6647nr. The only real difference I noticed in the beginning is that I have 02:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02) instead of what you have. My wireless light is still orange and when I check my network connections, the only thing that shows up is my wired and the manual install thing.


Not really sure what to do since I'm entirely new to this, but I hope you might have some idea.

IuilAine
June 10th, 2008, 01:09 AM
Nevermind. Worked for me after a fresh install. =)

phyz
June 10th, 2008, 02:15 AM
Thanks a lot buddy your advice really helped me out, now I have wireless working flawlessly on my laptop.

thanks dude...it works like charmed..

however,network-manager & network-manager-gnome still having wep & wpa encryption problem so i'd replaced them with "wicd".

because of we put some additional modprobe command in /etc/rc.local so i have to trigger 'sudo /etc/init.d/wicd start' to let my wireless connection via wicd works.

did anyone how is there any other way to remove ssb before ndiswrapper module loading on the system boot up?

thanks in advance....

Ayuthia
June 10th, 2008, 03:21 AM
thanks dude...it works like charmed..

however,network-manager & network-manager-gnome still having wep & wpa encryption problem so i'd replaced them with "wicd".

because of we put some additional modprobe command in /etc/rc.local so i have to trigger 'sudo /etc/init.d/wicd start' to let my wireless connection via wicd works.

did anyone how is there any other way to remove ssb before ndiswrapper module loading on the system boot up?

thanks in advance....
You can try this:

echo -e '#Hardy ssb/ndiswrapper workaround, added' `date` '\ninstall ndiswrapper modprobe -r b43 b44 b43legacy ssb; modprobe --ignore-install ndiswrapper $CMDLINE_OPTS; modprobe ssb; modprobe b44;' | sudo tee -a /etc/modprobe.d/ndiswrapper
This will put the loading and unloading at the modprobe command. This is based on the no-fluff method at https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Feisty_No-Fluff#head-6a90c0182f807f29d1a2f55e8654ac07689542bb

Matt Damon
June 10th, 2008, 11:14 AM
If you compiled NDISwrapper in Gutsy, you will need to get a new version of NDISwrapper (1.50 or higher) and will most likely need to reinstall the bcmwl5 driver.

Hi Ayuthia. To clarify what I meant, I carried out Jlandaw's instructions at the start of this thread only after the upgrade from Gutsy to Hardy. Wireless was working with Gutsy, it was only after the upgrade that Wireless stopped working. The NDISwrapper version I installed as part of Jlandaws instructions was 1.53....

Update: I just noticed i'd kept the b43 driver disabled under admin>hardware drivers. Oops. I think I might have got confused with a message after the upgrade. After enabling the B43 driver the hardware is back (surprise), I can view local wireless networks, but I can't connnect. I do not have any security enabled. Any ideas on some other checks I can do?:

Ayuthia
June 10th, 2008, 02:40 PM
Hi Ayuthia. To clarify what I meant, I carried out Jlandaw's instructions at the start of this thread only after the upgrade from Gutsy to Hardy. Wireless was working with Gutsy, it was only after the upgrade that Wireless stopped working. The NDISwrapper version I installed as part of Jlandaws instructions was 1.53....

Update: I just noticed i'd kept the b43 driver disabled under admin>hardware drivers. Oops. I think I might have got confused with a message after the upgrade. After enabling the B43 driver the hardware is back (surprise), I can view local wireless networks, but I can't connnect. I do not have any security enabled. Any ideas on some other checks I can do?:You might try the following:

sudo modprobe -r b43 ssb
sudo modprobe b43
sudo dhclient -r wlan0
sudo ifconfig wlan0 up
sudo iwconfig wlan0 essid <name>
sudo dhclient wlan0

Nike T
June 11th, 2008, 01:28 AM
Help, I've been working on this for like 2 hours today, still can't get it. I was messing around with this stuff, I did this tut before and I got the wireless to work, but my sister, it's her laptop, would always complain about her wireless cutting out. So I looked into other tuts, tried what they told me, didn't work, and then tried this one again, and now I can't get anything. Also when I log out, it shows some script and on that script it tells me that the modules b44 and b43 don't exist in like /proc/mod. Or something like that. Are there any codes that I could use so that you guys can know my problem better?

Ayuthia
June 11th, 2008, 02:44 AM
Help, I've been working on this for like 2 hours today, still can't get it. I was messing around with this stuff, I did this tut before and I got the wireless to work, but my sister, it's her laptop, would always complain about her wireless cutting out. So I looked into other tuts, tried what they told me, didn't work, and then tried this one again, and now I can't get anything. Also when I log out, it shows some script and on that script it tells me that the modules b44 and b43 don't exist in like /proc/mod. Or something like that. Are there any codes that I could use so that you guys can know my problem better?
Just to see if NDISwrapper is installed correctly, check ndiswrapper -v from the terminal. If it does not show any error messages and the version is greater than 1.50, then this is ok.

Next check ndiswrapper -l from the terminal. If it shows that the driver is installed and the device is present then it is also fine.

You then can try and see if the wireless is going to work, you can unload all the modules that work for your Broadcom card and then install ndiswrapper:

sudo modprobe -r bcm43xx b43legacy b43 b44 ssb ndiswrapper wl
sudo modprobe ndiswrapper
ifconfig
If ifconfig does not show your wireless info, then you should check dmesg at the terminal. The error message should show up at the end of the listing since sudo modprobe ndiswrapper is the most recent command entered.
If there are no errors, check:

lshw -C network
It will tell you if ndiswrapper is the driver being used.

If it does show your wireless, you can check

sudo iwlist scanIf it shows you wireless information, then you must have missed something in the blacklisting (/etc/modprobe.d/blacklist), loading your modules (/etc/modules), or your wireless fix script.

Ayuthia
June 11th, 2008, 02:54 AM
Also when I log out, it shows some script and on that script it tells me that the modules b44 and b43 don't exist in like /proc/mod.Usually when it says that b44 and b43 don't exist in /proc/modules, that means that the modules were not loaded when it tried to remove them. If you are using ndiswrapper, that is ok to see. It does sound like the message might be coming from /etc/init.d/rc.local. Can you post this? It could be possible that there is something else in the script that it does not like or else it was the one of the last error messages that showed up while booting.

ljungkvist
June 11th, 2008, 07:31 AM
Hi,

as I wrote in an earlier post I got everything to work after following this guide. It is still working, but two things have been annoying me:

- On shutoff the computer makes some shell output concerning "b43", and "wlan" before it shuts off. Can someone help me catch this output in some way?

- On startup the network manager starts up succesfully, finds the network that I connected to last time and tries to connect. The connection always fail after a short moment or so. The first "green blob" actually lights up almost instantly, but it never makes it to the second. However, if I uncheck the "enable wireless" option, wait a moment and the enable it again, it can connect perfectly well. What's up here?

Actually I would like to learn how to connect manually so to say, without having to use the manager. Can I put some instructions (which?) in a script and the make the system run it at startup?

Any help greatly appreciated!

Matt Damon
June 11th, 2008, 10:45 AM
You might try the following:

sudo modprobe -r b43 ssb
sudo modprobe b43
sudo dhclient -r wlan0
sudo ifconfig wlan0 up
sudo iwconfig wlan0 essid <name>
sudo dhclient wlan0

Hello again. progress... maybe. I'm connecting, but not associating. Also my wlan0 dosn't show up anymore instead I have picked up an extra eth port - eth1 which 'iwconfig' shows is my wireless port which I don't ever recall seeing before... (what have I done I wonder??? Ooo-er). I included some further output which I hope might show some clues. Maybe. Thanks for showing the interest and continuing to help? Ayuthia. People like you rock my Ubuntu!

By the way, sorry for making this message so long.. I guess I should be attaching a file instead?

here's the output;

miked@miked-laptop:~$ lspci | grep Broadcom

06:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)

miked@miked-laptop:~$ ndiswrapper -v

utils version: '1.9', utils version needed by module: '1.9'

module details:

filename: /lib/modules/2.6.24-18-generic/ubuntu/misc/ndiswrapper/ndiswrapper.ko

version: 1.52

vermagic: 2.6.24-18-generic SMP mod_unload 586


miked@miked-laptop:~$ ndiswrapper -l

bcmwl5 : driver installed

device (14E4:4311) present (alternate driver: bcm43xx)


miked@miked-laptop:~$ lshw -C network

WARNING: you should run this program as super-user.

*-network

description: Network controller

product: BCM94311MCG wlan mini-PCI

vendor: Broadcom Corporation

physical id: 0

bus info: pci@0000:06:00.0

version: 01

width: 32 bits

clock: 33MHz

capabilities: bus_master cap_list

configuration: driver=b43-pci-bridge latency=0 module=ssb

*-network

description: Ethernet interface

product: RTL-8139/8139C/8139C+

vendor: Realtek Semiconductor Co., Ltd.

physical id: 8

bus info: pci@0000:08:08.0

logical name: eth0

version: 10

serial: 00:16:d4:e6:f8:ed

width: 32 bits

clock: 33MHz

capabilities: bus_master cap_list ethernet physical

configuration: broadcast=yes driver=8139too driverversion=0.9.28 latency=32 maxlatency=64 mingnt=32 module=8139too multicast=yes

*-network

description: Wireless interface

physical id: 1

logical name: eth1

serial: 00:1a:73:43:fa:fd

capabilities: ethernet physical wireless

configuration: broadcast=yes multicast=yes wireless=IEEE 802.11g


miked@miked-laptop:~$ sudo iwlist scan

lo Interface doesn't support scanning.



eth0 Interface doesn't support scanning.



wmaster0 Interface doesn't support scanning.



eth1 No scan results



miked@miked-laptop:~$ sudo ifconfig

eth0 Link encap:Ethernet HWaddr 00:16:d4:e6:f8:ed

UP BROADCAST MULTICAST MTU:1500 Metric:1

RX packets:46162 errors:0 dropped:0 overruns:0 frame:0

TX packets:40992 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:47429325 (45.2 MB) TX bytes:6988855 (6.6 MB)

Interrupt:20 Base address:0x2000



eth1 Link encap:Ethernet HWaddr 00:1a:73:43:fa:fd

UP BROADCAST MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)



lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:1150 errors:0 dropped:0 overruns:0 frame:0

TX packets:1150 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:57500 (56.1 KB) TX bytes:57500 (56.1 KB)



wmaster0 Link encap:UNSPEC HWaddr 00-1A-73-43-FA-FD-00-00-00-00-00-00-00-00-00-00

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


miked@miked-laptop:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

eth1 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2346 B
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Ayuthia
June 11th, 2008, 02:08 PM
- On shutoff the computer makes some shell output concerning "b43", and "wlan" before it shuts off. Can someone help me catch this output in some way?There are two places that you might be able to find it. You can view /var/log/messages or /var/log/dmesg.0. /var/log/messages will contain information for the last few boots and /var/log/dmesg.0 will contain information only for the previous boot.


- On startup the network manager starts up succesfully, finds the network that I connected to last time and tries to connect. The connection always fail after a short moment or so. The first "green blob" actually lights up almost instantly, but it never makes it to the second. However, if I uncheck the "enable wireless" option, wait a moment and the enable it again, it can connect perfectly well. What's up here?I have encountered this a few times too. It seems to work fine if you do it manually, but when I do it through Wicd it connects for a few seconds then quits. I have not tracked down what is causing this.


Actually I would like to learn how to connect manually so to say, without having to use the manager. Can I put some instructions (which?) in a script and the make the system run it at startup?I would take a look at this sticky by kevdog:
http://ubuntuforums.org/showthread.php?t=684495
He shows you how to do things manually and at the end, there is some information on how to add things to rc.local so that things will start up at boot.

Ayuthia
June 11th, 2008, 02:19 PM
Hello again. progress... maybe. I'm connecting, but not associating. Also my wlan0 dosn't show up anymore instead I have picked up an extra eth port - eth1 which 'iwconfig' shows is my wireless port which I don't ever recall seeing before... (what have I done I wonder??? Ooo-er).This is ok. For some reason it changed the name over but it will work fine. If you don't like it, you can change it by editing /etc/udev/rules.d/70-persistent-net.rules.


miked@miked-laptop:~$ ndiswrapper -v
utils version: '1.9', utils version needed by module: '1.9'
module details:
filename: /lib/modules/2.6.24-18-generic/ubuntu/misc/ndiswrapper/ndiswrapper.ko
version: 1.52
vermagic: 2.6.24-18-generic SMP mod_unload 586

miked@miked-laptop:~$ ndiswrapper -l
bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: bcm43xx)

miked@miked-laptop:~$ lshw -C network
WARNING: you should run this program as super-user.
*-network
description: Network controller
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:06:00.0
version: 01
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: driver=b43-pci-bridge latency=0 module=ssb
*-network
description: Ethernet interface
product: RTL-8139/8139C/8139C+
vendor: Realtek Semiconductor Co., Ltd.
physical id: 8
bus info: pci@0000:08:08.0
logical name: eth0
version: 10
serial: 00:16:d4:e6:f8:ed
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical
configuration: broadcast=yes driver=8139too driverversion=0.9.28 latency=32 maxlatency=64 mingnt=32 module=8139too multicast=yes
*-network
description: Wireless interface
physical id: 1
logical name: eth1
serial: 00:1a:73:43:fa:fd
capabilities: ethernet physical wireless
configuration: broadcast=yes multicast=yes wireless=IEEE 802.11g

You might check and be sure that ndiswrapper and bcm43xx are not loaded also:

cat /etc/modprobe.d/blacklist*|grep -i -e b43 -e ssb -e bcm43xx -e ndiswrapper
We might even see if you can connect without Network Manager running. This command will only stop Network Manager from running for this session:

sudo /etc/dbus-1/event.d/26NetworkManagerDispatcher stop
sudo /etc/dbus-1/event.d/25NetworkManager stop
You can then try loading the modules again:

sudo modprobe -r b43 ssb bcm43xx ndiswrapper
sudo modprobe b43
sudo ifconfig eth1 up
sudo iwconfig eth1 <name>
sudo dhclient eth1

haitechan
June 12th, 2008, 06:13 PM
Reporting a working Compaq v3000 with Hardy here! :p

I had some troubles because I didn't have another way to connect to internet and download the packages, neither do sudo apt-get update :(, so I went to another machine (I was configuring my mom's laptop :)) and downloaded the following packages on my home directory:


build-essential_11.3ubuntu1_i386.deb
dpkg-dev_1.14.16.6ubuntu3_all.deb
g++-4.2_4.2.3-2ubuntu7_i386.deb
g++_4.2.3-1ubuntu3_i386.deb
libc6-dev_2.7-10ubuntu3_i386.deb
libstdc++6-4.2-dev_4.2.3-2ubuntu7_i386.deb
libtimedate-perl_1.1600-9_all.deb
linux-headers-2.6.24-16-generic_2.6.24-16.30_i386.deb
linux-libc-dev_2.6.24-18.32_i386.deb
patch_2.5.9-4_i386.deb


And then did sudo dpkg -i *.deb on a terminal :)

Just thought it might be useful for someone! :)
Thanks a lot for this great tutorial, btw! :D

ljungkvist
June 13th, 2008, 05:40 AM
There are two places that you might be able to find it. You can view /var/log/messages or /var/log/dmesg.0. /var/log/messages will contain information for the last few boots and /var/log/dmesg.0 will contain information only for the previous boot.
ok, checked both of them out. They both contained alot of information from the last boot ups but nothing from the shutoff. Is there a posibility to pause the process, so I can write it off manualy?



I have encountered this a few times too. It seems to work fine if you do it manually, but when I do it through Wicd it connects for a few seconds then quits. I have not tracked down what is causing this.

what i've concluded is that it's not sufficient to just reconnect. I really have to shut the wireless on/off.


I would take a look at this sticky by kevdog:
http://ubuntuforums.org/showthread.php?t=684495
He shows you how to do things manually and at the end, there is some information on how to add things to rc.local so that things will start up at boot.

I tried this, but at this line:


sudo wpa_supplicant -w -D<****see footer below***> -i<interface> -c/etc/wpa_supplicant.conf -dd


it just won't succeed. it just tries and tries... guess i have to post something there.

Ayuthia
June 13th, 2008, 03:01 PM
ok, checked both of them out. They both contained alot of information from the last boot ups but nothing from the shutoff. Is there a posibility to pause the process, so I can write it off manualy?I don't think that there is a way to pause it. You might just dig through /var/log and see if there are any other logs that mihgt have what you are looking for:

cd /var/log
sudo grep -r b43 *
This will go into /var/log and look through all the files and folders to look for anything that contains b43.

ileftrunning
June 14th, 2008, 06:59 AM
God bless you for your post. I was about to set fire to this %$#!@$ machine! Again many thanks.

Sam aka ileftrunning

Chxta
June 14th, 2008, 04:21 PM
This is a very useful thread. I'm cruising on my wifi now...

Momof9Blessings
June 15th, 2008, 05:33 AM
the download file does not seem to be valid anymore....

Ayuthia
June 15th, 2008, 04:04 PM
the download file does not seem to be valid anymore....

I just tested the links and I they seem to be fine now.

SlingerXL
June 16th, 2008, 07:29 PM
03:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)

That's my lspci. I've done everything in this tutorial 2 or 3 times now and I have wicd and it still won't find any wireless networks. HP Pavilion tx 1000.

SlingerXL
June 16th, 2008, 07:30 PM
2x post

Ayuthia
June 16th, 2008, 08:34 PM
03:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)

That's my lspci. I've done everything in this tutorial 2 or 3 times now and I have wicd and it still won't find any wireless networks. HP Pavilion tx 1000.

Please post the results of the following:

lshw -C network
ndiswrapper -v
ndiswrapper -l
lsmod |grep -i -e b43 -e ssb -e ndiswrapper -e bcm43xx

j0sh818
June 16th, 2008, 10:57 PM
You are one of the people that needs to have ssb so that your wired ethernet card will work. If you look at your other card, you will see the b44 driver. That driver needs ssb.

Just for now, I would try to remove ssb just to see if you can just get your wireless back up:

sudo modprobe -r b43 b44 ssb ndiswrapper
sudo modprobe ndiswrapper
If it doesn't work, you can enable your wired connection again by:

sudo modprobe b44. If it does, try connecting your wired again.



thanks a lot for this guide! amazing! I'm currently using an HP dv2415nr notebook with the 64-bit (AMD64) version of Ubuntu 8.04 - Hardy Heron. at first it didnt work but after i followed the additional instruction above, my WLAN is now working flawlessly.

thanks again!
:KS

SlingerXL
June 16th, 2008, 11:46 PM
Please post the results of the following:

lshw -C network
ndiswrapper -v
ndiswrapper -l
lsmod |grep -i -e b43 -e ssb -e ndiswrapper -e bcm43xx

lshw -C network:

WARNING: you should run this program as super-user.
*-network DISABLED
description: Wireless interface
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan0
version: 02
serial: 00:1a:73:a6:9d:b4
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.52+Broadcom,10/12/2006, 4.100. latency=0 module=ndiswrapper multicast=yes wireless=IEEE 802.11g

ndiswrapper -v:

utils version: '1.9', utils version needed by module: '1.9'
module details:
filename: /lib/modules/2.6.24-18-generic/ubuntu/misc/ndiswrapper/ndiswrapper.ko
version: 1.52
vermagic: 2.6.24-18-generic SMP mod_unload 586

ndiswrapper -l:

bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: bcm43xx)

lsmod |grep -i -e b43 -e ssb -e ndiswrapper -e bcm43xx:

bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: bcm43xx)
dan@dan-hp:~$ lsmod |grep -i -e b43 -e ssb -e ndiswrapper -e bcm43xx
ssb 32260 1 b44
ndiswrapper 192920 0
usbcore 146028 10 ndiswrapper,usbtouchscreen,usb_storage,usbhid,uvcv ideo,libusual,hci_usb,ehci_hcd,ohci_hcd

Ayuthia
June 17th, 2008, 01:05 AM
lshw -C network:

WARNING: you should run this program as super-user.
*-network DISABLED
description: Wireless interface
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan0
version: 02
serial: 00:1a:73:a6:9d:b4
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.52+Broadcom,10/12/2006, 4.100. latency=0 module=ndiswrapper multicast=yes wireless=IEEE 802.11g
The disable portion leads me to believe that your wireless card is not flipped on. Can you try the following:

sudo modprobe -r b43 ssb ndiswrapper bcm43xx
sudo depmod -ae
sudo modprobe ndiswrapper
sudo ifconfig wlan0 up
sudo iwlist scan
If you don't see any wireless access points, can you post the results of lshw -C network again along with the following:

dmesg|grep ndiswrapper

EDIT:
Please note that I changed iwconfig to ifconfig if you read this before my edit. That was a mistake.

SlingerXL
June 17th, 2008, 02:12 AM
After doing the first line of code I get this:

FATAL: Module ssb is in use.

What's that mean?

Ayuthia
June 17th, 2008, 02:26 AM
After doing the first line of code I get this:

FATAL: Module ssb is in use.

What's that mean?
It means that there is another module that is using ssb. Most likely it is b44. You can try the following:

sudo modprobe -r b43 b44 ssb ndiswrapper bcm43xx
sudo depmod -ae
sudo modprobe ndiswrapper
sudo modprobe b44
sudo ifconfig wlan0 up
sudo iwlist scan
Can you also post your entire results of lshw -C network? I just want to verify that you really need the b44 module.

EDIT: Please note that the b44 module is removed in the first line and then reloaded after b44. I forgot to remove the b44 module in the original version.

SlingerXL
June 17th, 2008, 02:45 AM
Here's my full lshw:

dan@dan-hp:~$ lshw -C network
WARNING: you should run this program as super-user.
*-network
description: Wireless interface
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan0
version: 02
serial: 00:1a:73:a6:9d:b4
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.52+Broadcom,10/12/2006, 4.100. latency=0 module=ndiswrapper multicast=yes wireless=IEEE 802.11g

I put in all the code you said to and I'm about to reboot. After the last line heres what it said:

lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:17:3F:6A:DD:99
ESSID:"houseoflove"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:42/100 Signal level:-69 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Preauthentication Supported
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
Cell 02 - Address: 00:50:18:45:2A:72
ESSID:"BJ PALACE"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:18/100 Signal level:-84 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0
Cell 03 - Address: 00:1B:63:2D:20:A9
ESSID:"girlfess"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.412 GHz (Channel 1)
Quality:73/100 Signal level:-49 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Cell 04 - Address: 00:1C:10:14:AB:84
ESSID:"Citgo-3"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.437 GHz (Channel 6)
Quality:12/100 Signal level:-88 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:bcn_int=100
Extra:atim=0
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK

Ayuthia
June 17th, 2008, 03:18 AM
Here's my full lshw:

dan@dan-hp:~$ lshw -C network
WARNING: you should run this program as super-user.
*-network
description: Wireless interface
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan0
version: 02
serial: 00:1a:73:a6:9d:b4
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.52+Broadcom,10/12/2006, 4.100. latency=0 module=ndiswrapper multicast=yes wireless=IEEE 802.11g

I put in all the code you said to and I'm about to reboot. After the last line heres what it said:

lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:17:3F:6A:DD:99
ESSID:"houseoflove"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:42/100 Signal level:-69 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Preauthentication Supported
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
Cell 02 - Address: 00:50:18:45:2A:72
ESSID:"BJ PALACE"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:18/100 Signal level:-84 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0
Cell 03 - Address: 00:1B:63:2D:20:A9
ESSID:"girlfess"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.412 GHz (Channel 1)
Quality:73/100 Signal level:-49 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Cell 04 - Address: 00:1C:10:14:AB:84
ESSID:"Citgo-3"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.437 GHz (Channel 6)
Quality:12/100 Signal level:-88 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:bcn_int=100
Extra:atim=0
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK

It looks like you are able to see the wireless sites now. Are you able to connect?

sebastianjanikowsky
June 17th, 2008, 04:16 AM
Hi Ayuthia, I've been reading your instructions specially in SlingerXL's case, I have the same problem but in my case I'm having this results

vinny@vinny-laptop:~$ lshw -C network
WARNING: you should run this program as super-user.
*-network
description: Wireless interface
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan0
version: 02
serial: 00:1a:73:62:7e:a8
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.52+Broadcom,10/12/2006, 4.100. latency=0 module=ndiswrapper multicast=yes wireless=IEEE 802.11g

vinny@vinny-laptop:~$ ndiswrapper -v
utils version: '1.9', utils version needed by module: '1.9'
module details:
filename: /lib/modules/2.6.24-19-generic/ubuntu/misc/ndiswrapper/ndiswrapper.ko
version: 1.52
vermagic: 2.6.24-19-generic SMP mod_unload 586

vinny@vinny-laptop:~$ ndiswrapper -l
bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: bcm43xx)

vinny@vinny-laptop:~$ lsmod |grep -i -e b43 -e ssb -e ndiswrapper -e bcm43xx
ssb 34308 1 b44
ndiswrapper 192920 0
usbcore 146028 6 ndiswrapper,uvcvideo,usbhid,ehci_hcd,ohci_hcd


And no red light, no wireless connection. HP dv6000 AMD Turion 64
Any suggestion?
thanks

Ayuthia
June 17th, 2008, 04:47 AM
Hi Ayuthia, I've been reading your instructions specially in SlingerXL's case, I have the same problem but in my case I'm having this result when I try to scan with sudo iwlist scan


lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 No scan results

any help?

thanks

Let's take a step back and see if everything is configured correctly. Please post the results of:

lshw -C network
ndiswrapper -v
ndiswrapper -l
lsmod |grep -i -e b43 -e ssb -e ndiswrapper -e bcm43xx

sebastianjanikowsky
June 17th, 2008, 07:16 AM
Thanks for your answer, this is the result

vinny@vinny-laptop:~$ lshw -C network
WARNING: you should run this program as super-user.
*-network
description: Wireless interface
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan0
version: 02
serial: 00:1a:73:62:7e:a8
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.52+Broadcom,10/12/2006, 4.100. latency=0 module=ndiswrapper multicast=yes wireless=IEEE 802.11g
vinny@vinny-laptop:~$ ndiswrapper -v
utils version: '1.9', utils version needed by module: '1.9'
module details:
filename: /lib/modules/2.6.24-19-generic/ubuntu/misc/ndiswrapper/ndiswrapper.ko
version: 1.52
vermagic: 2.6.24-19-generic SMP mod_unload 586
vinny@vinny-laptop:~$ ndiswrapper -l
bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: bcm43xx)
vinny@vinny-laptop:~$ lsmod |grep -i -e b43 -e ssb -e ndiswrapper -e bcm43xx
ndiswrapper 192920 0
ssb 34308 1 b44
usbcore 146028 6 usbhid,ndiswrapper,uvcvideo,ehci_hcd,ohci_hcd

SlingerXL
June 17th, 2008, 06:30 PM
It looks like you are able to see the wireless sites now. Are you able to connect?

Sadly, no. No wireless networks show up still. Just so you can eliminate the possibility my wireless switch is on. By the way, I really appreciate all the help you've given me and other community members.

Ayuthia
June 17th, 2008, 08:24 PM
Sadly, no. No wireless networks show up still. Just so you can eliminate the possibility my wireless switch is on. By the way, I really appreciate all the help you've given me and other community members.Well, it looks like a configuration issue. Can you post the results of:

cat /etc/modprobe.d/blacklist*|grep -i -e bcm43xx -e b43 -e b44 -e ssb -e ndiswrapper
cat /etc/modules|grep -i -e bcm43xx -e b43 -e b44 -e ssb -e ndiswrapper

If you can turn off your encryption, can you try the following:

sudo modprobe -r b43 b44 ssb ndiswrapper bcm43xx
sudo depmod -ae
sudo modprobe ndiswrapper
sudo modprobe b44
sudo ifconfig wlan0 up
sudo iwlist scan
sudo dhclient -r wlan0
sudo iwconfig wlan0 essid girlfess
sudo dhclient wlan0
I am just using "girlfess" mainly because it is the closest access point in your scan so I am assuming that it was yours. Just replace girlfess with the name of your access point.

sebastianjanikowsky
June 17th, 2008, 08:31 PM
Hi
This is my result

vinny@vinny-laptop:~$ cat /etc/modprobe.d/blacklist*|grep -i -e bcm43xx -e b43 -e b44 -e ssb -e ndiswrapper
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist b43
sudo apt-get install ndiswrapper-utils-1.9
mkdir ~/bcm43xx; cd ~/bcm43xx
blacklist bcm43xx
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist b43
sudo apt-get install ndiswrapper-utils-1.9
mkdir ~/bcm43xx; cd ~/bcm43xx
vinny@vinny-laptop:~$ cat /etc/modules|grep -i -e bcm43xx -e b43 -e b44 -e ssb -e ndiswrapper
ndiswrapper
ndiswrapper
vinny@vinny-laptop:~$

Ayuthia
June 17th, 2008, 08:37 PM
Thanks for your answer, this is the result

vinny@vinny-laptop:~$ lshw -C network
WARNING: you should run this program as super-user.
*-network
description: Wireless interface
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan0
version: 02
serial: 00:1a:73:62:7e:a8
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.52+Broadcom,10/12/2006, 4.100. latency=0 module=ndiswrapper multicast=yes wireless=IEEE 802.11g
vinny@vinny-laptop:~$ ndiswrapper -v
utils version: '1.9', utils version needed by module: '1.9'
module details:
filename: /lib/modules/2.6.24-19-generic/ubuntu/misc/ndiswrapper/ndiswrapper.ko
version: 1.52
vermagic: 2.6.24-19-generic SMP mod_unload 586
vinny@vinny-laptop:~$ ndiswrapper -l
bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: bcm43xx)
vinny@vinny-laptop:~$ lsmod |grep -i -e b43 -e ssb -e ndiswrapper -e bcm43xx
ndiswrapper 192920 0
ssb 34308 1 b44
usbcore 146028 6 usbhid,ndiswrapper,uvcvideo,ehci_hcd,ohci_hcd
Your results look fine there. Can you post the results of the following:

sudo modprobe -r b43 b44 ssb ndiswrapper bcm43xx
sudo depmod -ae
sudo modprobe ndiswrapper
sudo iwlist scan
ifconfig
iwconfig

Ayuthia
June 17th, 2008, 08:42 PM
Hi
This is my result

vinny@vinny-laptop:~$ cat /etc/modprobe.d/blacklist*|grep -i -e bcm43xx -e b43 -e b44 -e ssb -e ndiswrapper
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist b43
sudo apt-get install ndiswrapper-utils-1.9
mkdir ~/bcm43xx; cd ~/bcm43xx
blacklist bcm43xx
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist b43
sudo apt-get install ndiswrapper-utils-1.9
mkdir ~/bcm43xx; cd ~/bcm43xx
vinny@vinny-laptop:~$ cat /etc/modules|grep -i -e bcm43xx -e b43 -e b44 -e ssb -e ndiswrapper
ndiswrapper
ndiswrapper
vinny@vinny-laptop:~$
You are going to want to clean up these two files. For the first file, you will need to edit it in admin mode:

gksu gedit /etc/modprobe.d/blacklist
You will need to remove the following lines:

sudo apt-get install ndiswrapper-utils-1.9
mkdir ~/bcm43xx; cd ~/bcm43xxand remove any duplicates.

You will also want to edit /etc/modules:

gksu gedit /etc/modules
and remove one of the ndiswrapper lines.

You will receive error messages when you load or unload modules (sudo modprobe/modprobe -r). Other than that, it generally do not cause any harm.

sebastianjanikowsky
June 17th, 2008, 08:52 PM
i didn't receive any error message, thats ok?

Ayuthia
June 17th, 2008, 09:15 PM
i didn't receive any error message, thats ok?
That is ok if you don't.

sebastianjanikowsky
June 17th, 2008, 09:33 PM
sorry about this, noobie here!!! what's next?

SlingerXL
June 17th, 2008, 09:58 PM
Well, it looks like a configuration issue. Can you post the results of:

cat /etc/modprobe.d/blacklist*|grep -i -e bcm43xx -e b43 -e b44 -e ssb -e ndiswrapper
cat /etc/modules|grep -i -e bcm43xx -e b43 -e b44 -e ssb -e ndiswrapper

If you can turn off your encryption, can you try the following:

sudo modprobe -r b43 b44 ssb ndiswrapper bcm43xx
sudo depmod -ae
sudo modprobe ndiswrapper
sudo modprobe b44
sudo ifconfig wlan0 up
sudo iwlist scan
sudo dhclient -r wlan0
sudo iwconfig wlan0 essid girlfess
sudo dhclient wlan0
I am just using "girlfess" mainly because it is the closest access point in your scan so I am assuming that it was yours. Just replace girlfess with the name of your access point.
dan@dan-hp:~$ cat /etc/modprobe.d/blacklist*|grep -i -e bcm43xx -e b43 -e b44 -e ssb -e ndiswrapper
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist b43
blacklist bcm43xx
blacklist b43
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist b43
blacklist bcm43xx
dan@dan-hp:~$

The second line of code just brings up "ndiswrapper"

I don't know how to turn off the encryption since I didn't set up the wireless (I'm subleasing the place for the summer since I'm staying at Indiana University), but this is what the terminal said after I put in all the code:

dan@dan-hp:~$ sudo dhclient -r wlan0
There is already a pid file /var/run/dhclient.pid with pid 4349
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/wlan0/00:1a:73:a6:9d:b4
Sending on LPF/wlan0/00:1a:73:a6:9d:b4
Sending on Socket/fallback
dan@dan-hp:~$ sudo iwconfig wlan0 essid girlfess
dan@dan-hp:~$ sudo dhclient wlan0
There is already a pid file /var/run/dhclient.pid with pid 134519072
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/wlan0/00:1a:73:a6:9d:b4
Sending on LPF/wlan0/00:1a:73:a6:9d:b4
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
No DHCPOFFERS received.
No working leases in persistent database - sleeping.


EDIT: Yes, girlfess is the network name. I moved in to a house with 3 girls and we live on Fess Avenue haha.

rated_emman
June 17th, 2008, 10:40 PM
IT WORKED LIKE MAGIC IN MY HARDY :D:D

thank YOU SO MUCH!!!! yOu GUys!! rocks sooo MUCH! thanks again!

Ayuthia
June 17th, 2008, 11:17 PM
EDIT: Yes, girlfess is the network name. I moved in to a house with 3 girls and we live on Fess Avenue haha.
If you are able to see wireless access points by:

sudo iwlist scan
after loading the modules:

sudo modprobe -r b43 b44 ssb ndiswrapper bcm43xx
sudo depmod -ae
sudo modprobe ndiswrapper
Then your wireless is working. You will then need to try to connect. Since this is WPA, I don't have much experience in it yet. I would join you in this adventure, but my wireless card broke this morning. What I can recommend is to try the following link for configuring manually:
http://ubuntuforums.org/showthread.php?t=684495
There is a section for setting up WPA. You should be able to use WPA supplicant.

Another good link to set up WPA is the following:
http://ubuntuforums.org/showthread.php?t=318539
I have used this before to test out WPA a while back. It works well also.

Ayuthia
June 17th, 2008, 11:22 PM
sorry about this, noobie here!!! what's next?That was my fault. I was waiting for your results from my previous post (#128). Can you show me the results to the following:

sudo modprobe -r b43 b44 ssb ndiswrapper bcm43xx
sudo depmod -ae
sudo modprobe ndiswrapper
sudo iwlist scan
ifconfig
iwconfig
The first three steps removes all the possible Broadcom modules, rebuilds the module dependencies, and then loads ndiswrapper. The next step will look for wireless sites. The fifth command will check your network configuration and the last one is your wireless configuration.

simohell
June 18th, 2008, 12:19 AM
A bit of good news for Hardy, I think...

My WLAN was not working on install today. So I started looking for help. But now it is working with the drivers suggested by Hardy itself, after first installing all the latest updates. It might be, that things will work now for many others as well.

I'm using (since today) HP 6510b, Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)

lcherryholmes
June 18th, 2008, 09:14 PM
If there is a kernel update, does the ndiswrapper need to be recompiled to work with the new version?

I just got a new update the other day and started having issues again. This is frustrating!

Thanks 4 ALL the help!!:KS

Ayuthia
June 19th, 2008, 08:15 AM
If there is a kernel update, does the ndiswrapper need to be recompiled to work with the new version?

I just got a new update the other day and started having issues again. This is frustrating!

Thanks 4 ALL the help!!:KS
If you are not using ndiswrapper from the repositories, yes. The self-compiled versions are compiled with linux-headers-`uname-r` which means that it will only work with that kernel version.

lcherryholmes
June 19th, 2008, 04:09 PM
If you are not using ndiswrapper from the repositories, yes. The self-compiled versions are compiled with linux-headers-`uname-r` which means that it will only work with that kernel version.

So let me get this straight whenever they update the Kernel they will update the ndiswrapper to work with it?

If that's the case I wonder why mine quit working.

Any ideas?

Ayuthia
June 19th, 2008, 04:53 PM
So let me get this straight whenever they update the Kernel they will update the ndiswrapper to work with it?

If that's the case I wonder why mine quit working.

Any ideas?
No, if you compiled ndiswrapper on your own instead of using the ones from the repositories, you will have to compile ndiswrapper every time a kernel update is done or else it will quit working.

lcherryholmes
June 19th, 2008, 05:16 PM
No what I was asking is if I did get ndiswrapper from the repositories when I update the Kernel the ndiwwrapper will update as well.

Same question - asked differently perhaps this will clear up what I am asking. :)

Ayuthia
June 19th, 2008, 05:18 PM
No what I was asking is if I did get ndiswrapper from the repositories when I update the Kernel the ndiwwrapper will update as well.

Same question - asked differently perhaps this will clear up what I am asking. :)Sorry about that. Yes, if you did get it from the repositories then it should update automatically.

lcherryholmes
June 19th, 2008, 05:24 PM
Sorry about that. Yes, if you did get it from the repositories then it should update automatically.

So what should I do now after I did update of kernel the wifi is not working again?

At some point should I see if other drivers are created to work with this card or stick with ndiswrapper for a while longer.

I can be patient just hate having to redo after every kernel update.

Thanks for ALL of the help!!

Ayuthia
June 19th, 2008, 05:29 PM
So what should I do now after I did update of kernel the wifi is not working again?

At some point should I see if other drivers are created to work with this card or stick with ndiswrapper for a while longer.

I can be patient just hate having to redo after every kernel update.

Thanks for ALL of the help!!

Can you post the results of:

lshw -C network
uname -rIt will help see what driver is being used and the second will tell us what kernel version you are running.

lcherryholmes
June 19th, 2008, 05:35 PM
I can't do it now as I am at work but I will tonight. We don't have wireless at work yet.

Thanks

ljungkvist
June 20th, 2008, 06:02 AM
Hi,

Some weeks ago I went through this guide and got it all up and running. As I wrote in an earlier post, my Network Manager was playing a bit with me and didn't want to connect unless I shut it on/off after system startup. Now It's stoped working completely. I see all the networks, but when I try to connect it just doesn't make it. Not even to the "first green blob". What are some good commands to try to determine what's wrong?

I don't really know what the reason for this sudden ****up might be. Like someone else was discussing, I've had a couple of kernel upgrades since my installation of this wireless thing. Yesterday I thought I should just go through the guide from the beginning all over, but the fourth command doesn't uninstall anything. Can this be because I didn't install them (ndiswrapper/bcm43xx-fwcutter) through the apt in the first place? How can I get around this?

aviborse
June 20th, 2008, 07:19 AM
Somehow it is not working out for me .........i tried thrice the same procedure. Doesnt seem to work. Here's what i get

Laptop
Compaq Presario 6608AU
AMD Turion
1GB ram
160 GB hard disk.

avi@avi-laptop:~$ lshw -C network
WARNING: you should run this program as super-user.
*-network
description: Ethernet interface
product: MCP67 Ethernet
vendor: nVidia Corporation
physical id: a
bus info: pci@0000:00:0a.0
logical name: eth0
version: a2
serial: 00:1b:24:86:db:c0
width: 32 bits
clock: 66MHz
capabilities: bus_master cap_list ethernet physical
configuration: broadcast=yes driver=forcedeth driverversion=0.61 ip=192.168.1.5 latency=0 maxlatency=20 mingnt=1 module=forcedeth multicast=yes
*-network DISABLED
description: Wireless interface
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan1
version: 02
serial: 00:1a:73:92:4a:15
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.52+Broadcom,10/12/2006, 4.100. latency=0 module=ndiswrapper multicast=yes wireless=IEEE 802.11g



avi@avi-laptop:~$ lshw -C network
WARNING: you should run this program as super-user.
*-network
description: Ethernet interface
product: MCP67 Ethernet
vendor: nVidia Corporation
physical id: a
bus info: pci@0000:00:0a.0
logical name: eth0
version: a2
serial: 00:1b:24:86:db:c0
width: 32 bits
clock: 66MHz
capabilities: bus_master cap_list ethernet physical
configuration: broadcast=yes driver=forcedeth driverversion=0.61 ip=192.168.1.5 latency=0 maxlatency=20 mingnt=1 module=forcedeth multicast=yes
*-network DISABLED
description: Wireless interface
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan1
version: 02
serial: 00:1a:73:92:4a:15
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.52+Broadcom,10/12/2006, 4.100. latency=0 module=ndiswrapper multicast=yes wireless=IEEE 802.11g

avi@avi-laptop:~$ lspci | grep Broadcom
03:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)

Please guide me!!!!!!!!
Thanks in advance.

durundal
June 20th, 2008, 09:57 AM
Please, can someone tell me why my card worked "out of the box" on a xubuntu 8.04 install but suddenly on updating the kernal the wifi light turned red and it won't turn on again?

I even tried reinstalling ubuntu but still the light only turns blue on random occasions, and if it doesn't turn blue, ubuntu doesn't detect it as hardware.

Ayuthia
June 20th, 2008, 01:07 PM
Hi,

Some weeks ago I went through this guide and got it all up and running. As I wrote in an earlier post, my Network Manager was playing a bit with me and didn't want to connect unless I shut it on/off after system startup. Now It's stoped working completely. I see all the networks, but when I try to connect it just doesn't make it. Not even to the "first green blob". What are some good commands to try to determine what's wrong?

I don't really know what the reason for this sudden [explicit lyrics edited] might be. Like someone else was discussing, I've had a couple of kernel upgrades since my installation of this wireless thing. Yesterday I thought I should just go through the guide from the beginning all over, but the fourth command doesn't uninstall anything. Can this be because I didn't install them (ndiswrapper/bcm43xx-fwcutter) through the apt in the first place? How can I get around this?

Since there was a recent kernel upgrade and you did not install ndiswrapper from the repositories, you will have to recompile ndiswrapper. Step 4 is not needed because you did that the first time around. All you really need to do is theselines in step 9:

cd ~/bcm43xx/ndiswrapper
cd ndiswrapper*
make distclean
make
sudo make installThen verify that all is ok:

ndiswrapper -v
ndiswrapper -l
lshw -C network
the first command should show the current version without any error messages. The second one will show that the driver is installed and device is present. Both must be there or else it will not work. An alternate driver showing is ok. The third command will show that the ndiswrapper driver is installed.

If you still have issues, please come back and post the results of ndiswrapper -v, ndiswrapper -l, and lshw -C network.

Ayuthia
June 20th, 2008, 01:11 PM
Please, can someone tell me why my card worked "out of the box" on a xubuntu 8.04 install but suddenly on updating the kernal the wifi light turned red and it won't turn on again?

I even tried reinstalling ubuntu but still the light only turns blue on random occasions, and if it doesn't turn blue, ubuntu doesn't detect it as hardware.

You will most likely want to post this in another thread because almost all Broadcom cards will not work out of the box. The only one that might work now is the 4310 card (14e4:4315) because it was given a special driver. However, that driver did not come out until the 2.6.24-18 Ubuntu kernel.

Please open a new thread and post your lspci -nn and which kernel you are using (uname -r). Both of those commands are run in the Terminal.

Ayuthia
June 20th, 2008, 01:22 PM
avi@avi-laptop:~$ lshw -C network
multicast=yes
*-network DISABLED
description: Wireless interface
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan1
version: 02
serial: 00:1a:73:92:4a:15
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.52+Broadcom,10/12/2006, 4.100. latency=0 module=ndiswrapper multicast=yes wireless=IEEE 802.11g
The DISABLED label says that either the card is not on for some reason. Can you post the results of:

lsmod|grep -i -e ndiswrapper -e b43 -e bcm43xx -e ssb -e b44

To see if it might work, please remove the cable from your wired connection, verify that the wireless card is on (if it has a switch), and try:

sudo modprobe -r b43 b44 ssb bcm43xx wl ndiswrapper
sudo depmod -ae
sudo modprobe ndiswrapper
lshw -C networkSee if the card is still listed as DISABLED. If so, please do this:

dmesg|grep ndiswrapper > ~/Desktop/dmesgforum.txtGo to your desktop and attach dmesgforum.txt (along with any messages that came with the commands in this post) to your next post.

Vel-Tyno
June 20th, 2008, 02:03 PM
Everything was going great until I hit Step 9. It could not find build essential.

I am using an HP 530


Joe

Ayuthia
June 20th, 2008, 02:16 PM
Everything was going great until I hit Step 9. It could not find build essential.

I am using an HP 530


Joe
If you have the Hardy liveCD, open the Terminal and do the following:

sudo apt-cdrom add
sudo apt-get update
sudo apt-get install build-essential
The first command will ask you for the CD. Insert your Hardy liveCD.

Hope that helps.

lcherryholmes
June 20th, 2008, 02:52 PM
Ayuthia -
Here are the output of the commands you asked for.

I also see something called wlan0:avahi not sure what this is but it seems to get an IP address from somewhere unless it is fake.

Thanks,
lcherryholmes

laptop:~$ lshw -C network
WARNING: you should run this program as super-user.
*-network
description: Ethernet interface
product: MCP67 Ethernet
vendor: nVidia Corporation
physical id: a
bus info: pci@0000:00:0a.0
logical name: eth0
version: a2
serial: 00:1b:24:da:79:21
width: 32 bits
clock: 66MHz
capabilities: bus_master cap_list ethernet physical
configuration: broadcast=yes driver=forcedeth driverversion=0.61 latency=0 maxlatency=20 mingnt=1 module=forcedeth multicast=yes
*-network
description: Wireless interface
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan0
version: 02
serial: 00:1a:73:d0:8d:8a
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.52+Broadcom,10/12/2006, 4.100. latency=0 module=ndiswrapper multicast=yes wireless=IEEE 802.11g


laptop:~$ uname -r
2.6.24-19-generic

laptop:~$ lsmod |grep -i -e b43 -e ssb -e bcm43xx -e ndiswrapper
ssb 34308 1 b44
ndiswrapper 192920 0
usbcore 146028 8 ndiswrapper,uvcvideo,usb_storage,libusual,usbhid,e hci_hcd,ohci_hcd

durundal
June 20th, 2008, 02:56 PM
You will most likely want to post this in another thread because almost all Broadcom cards will not work out of the box. The only one that might work now is the 4310 card (14e4:4315) because it was given a special driver. However, that driver did not come out until the 2.6.24-18 Ubuntu kernel.

Please open a new thread and post your lspci -nn and which kernel you are using (uname -r). Both of those commands are run in the Terminal.

Oh yes, you're right. I had to go through the restricted driver manager to set it up.

jrodri14
June 20th, 2008, 06:05 PM
Hi, i tried your setup, but for some reason, dmesg indicates that windows was unable load the bcm9433. It gives some error C0000001.


I dont know what it could be.

Matt Damon
June 21st, 2008, 02:16 AM
This is ok. For some reason it changed the name over but it will work fine. If you don't like it, you can change it by editing /etc/udev/rules.d/70-persistent-net.rules.


You might check and be sure that ndiswrapper and bcm43xx are not loaded also:

cat /etc/modprobe.d/blacklist*|grep -i -e b43 -e ssb -e bcm43xx -e ndiswrapper
We might even see if you can connect without Network Manager running. This command will only stop Network Manager from running for this session:

sudo /etc/dbus-1/event.d/26NetworkManagerDispatcher stop
sudo /etc/dbus-1/event.d/25NetworkManager stop
You can then try loading the modules again:

sudo modprobe -r b43 ssb bcm43xx ndiswrapper
sudo modprobe b43
sudo ifconfig eth1 up
sudo iwconfig eth1 <name>
sudo dhclient eth1

Hi There Ayuthia,

So I tried the above, and it failed to associate again. I read through later posts and reloaded the drivers, a command I hadn't seen or done before (sudo depmod -ae) and IT WORKS! Yee haaa.

Could you check the output below anyway? It looks to my newbie eyes that I am blacklisting drivers I use, but clearly can't be wrong if wireless is working...right?... all output is listed below... Look ok?

miked@miked-laptop:~$ cat /etc/modprobe.d/blacklist*|grep -i -e b43 -e ssb -e bcm43xx -e ndiswrapper
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist b43
# replaced by b43 and ssb.
blacklist bcm43xx
miked@miked-laptop:~$ ndiswrapper -v
utils version: '1.9', utils version needed by module: '1.9'
module details:
filename: /lib/modules/2.6.24-18-generic/ubuntu/misc/ndiswrapper/ndiswrapper.ko
version: 1.52
vermagic: 2.6.24-18-generic SMP mod_unload 586
miked@miked-laptop:~$ sudo modprobe -r b43 ssb bcm43xx ndiswrapper
miked@miked-laptop:~$ sudo modprobe b43
miked@miked-laptop:~$ sudo ifconfig eth1 up
miked@miked-laptop:~$ sudo iwconfig eth1
eth1 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2346 B
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

miked@miked-laptop:~$ sudo dhclient eth1
There is already a pid file /var/run/dhclient.pid with pid 134519072
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/eth1/00:1a:73:43:fa:fd
Sending on LPF/eth1/00:1a:73:43:fa:fd
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
miked@miked-laptop:~$ sudo ifconfig eth1 up


Then I did this...

miked@miked-laptop:~$ sudo modprobe -r b43 b44 ssb ndiswrapper bcm43xx
miked@miked-laptop:~$ sudo depmod -ae
miked@miked-laptop:~$ sudo modprobe ndiswrapper
miked@miked-laptop:~$ sudo iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

eth1 Scan completed :
Cell 01 - Address: 00:17:3F:81:63:1C
ESSID:"CUO"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.472 GHz (Channel 13)
Quality:65/100 Signal level:-54 dBm Noise level:-96 dBm
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0
Cell 02 - Address: 00:13:10:3B:B2:82
ESSID:"linksys"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:4/100 Signal level:-93 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:bcn_int=50
Extra:atim=0

miked@miked-laptop:~$

And Bingo!.. Ayuthia You Are A RockStar!

Ayuthia
June 21st, 2008, 02:59 AM
Could you check the output below anyway? It looks to my newbie eyes that I am blacklisting drivers I use, but clearly can't be wrong if wireless is working...right?... all output is listed below... Look ok?

miked@miked-laptop:~$ cat /etc/modprobe.d/blacklist*|grep -i -e b43 -e ssb -e bcm43xx -e ndiswrapper
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist b43
# replaced by b43 and ssb.
blacklist bcm43xxThe file has some duplicates, but it looks ok since you are using ndiswrapper.

miked@miked-laptop:~$ ndiswrapper -v
utils version: '1.9', utils version needed by module: '1.9'
module details:
filename: /lib/modules/2.6.24-18-generic/ubuntu/misc/ndiswrapper/ndiswrapper.ko
version: 1.52
vermagic: 2.6.24-18-generic SMP mod_unload 586 You are using a version greater than or equal to 1.50 so that is fine for Hardy.

miked@miked-laptop:~$ sudo modprobe -r b43 ssb bcm43xx ndiswrapper
miked@miked-laptop:~$ sudo modprobe b43
miked@miked-laptop:~$ sudo ifconfig eth1 up
miked@miked-laptop:~$ sudo iwconfig eth1
eth1 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2346 B
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

miked@miked-laptop:~$ sudo dhclient eth1
There is already a pid file /var/run/dhclient.pid with pid 134519072
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/eth1/00:1a:73:43:fa:fd
Sending on LPF/eth1/00:1a:73:43:fa:fd
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
miked@miked-laptop:~$ sudo ifconfig eth1 upThis is you testing the b43 drivers and it looks like it did not receive an IP address from dhclient.

Then I did this...

miked@miked-laptop:~$ sudo modprobe -r b43 b44 ssb ndiswrapper bcm43xx
miked@miked-laptop:~$ sudo depmod -ae
miked@miked-laptop:~$ sudo modprobe ndiswrapper
miked@miked-laptop:~$ sudo iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

eth1 Scan completed :
Cell 01 - Address: 00:17:3F:81:63:1C
ESSID:"CUO"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.472 GHz (Channel 13)
Quality:65/100 Signal level:-54 dBm Noise level:-96 dBm
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0
Cell 02 - Address: 00:13:10:3B:B2:82
ESSID:"linksys"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:4/100 Signal level:-93 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:bcn_int=50
Extra:atim=0

miked@miked-laptop:~$

This portion shows that you are using the ndiswrapper and you are able to wireless signals. So far, ndiswrapper seems to be the most successful driver for your card. It might be possible that ndiswrapper is not in /etc/modules. If you are not sure, please post the results of:

cat /etc/modules|grep -i -e b43 -e ssb -e bcm43xx -e ndiswrapperand we can see what is being loaded.

Another option to try is to add the following:

echo -e '#Hardy ssb/ndiswrapper workaround, added' `date` '\ninstall ndiswrapper modprobe -r b43 b44 b43legacy ssb; modprobe --ignore-install ndiswrapper;' | sudo tee -a /etc/modprobe.d/ndiswrapperThis is a modified version of a script from https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Feisty_No-Fluff#head-6a90c0182f807f29d1a2f55e8654ac07689542bb. I just took out the b44 addition mainly because you don't seem to need it.

Hope that helps.


And Bingo!.. Ayuthia You Are A RockStar!Wait until I go on tour!!! Thanks! I glad that things are working and hopefully this post will help finalize it for you.

Matt Damon
June 21st, 2008, 03:45 AM
Here you go...

miked@miked-laptop:~$ cat /etc/modules|grep -i -e b43 -e ssb -e bcm43xx -e ndiswrapper
ndiswrapper


But also, I am not quite there yet. I think the drivers are not reloading automatically after reload. So when I rebooted even though my wireless indicator was shining brightly there was no wireless option under network connections. So I ran the following...

miked@miked-laptop:~$ sudo modprobe -r b43 b44 ssb ndiswrapper bcm43xx
miked@miked-laptop:~$ sudo depmod -ae
miked@miked-laptop:~$ sudo modprobe ndiswrapper

And I am wireless again.

Do you know the commands to automatically reload the drivers?

Ayuthia
June 21st, 2008, 04:27 AM
Here you go...

miked@miked-laptop:~$ cat /etc/modules|grep -i -e b43 -e ssb -e bcm43xx -e ndiswrapper
ndiswrapper


But also, I am not quite there yet. I think the drivers are not reloading automatically after reload. So when I rebooted even though my wireless indicator was shining brightly there was no wireless option under network connections. So I ran the following...

miked@miked-laptop:~$ sudo modprobe -r b43 b44 ssb ndiswrapper bcm43xx
miked@miked-laptop:~$ sudo depmod -ae
miked@miked-laptop:~$ sudo modprobe ndiswrapper

And I am wireless again.

Do you know the commands to automatically reload the drivers?

I did not proofread my comments in an earlier post. Please try the following and let me know if it works:

echo -e '#Hardy ssb/ndiswrapper workaround, added' `date` '\ninstall ndiswrapper modprobe -r b43 b44 b43legacy ssb; modprobe --ignore-install ndiswrapper;' | sudo tee -a /etc/modprobe.d/ndiswrapperThis command will add the removal and reload commands. The only part it is missing is the depmod -ae, but that might be ok.

aviborse
June 21st, 2008, 07:30 AM
avi@avi-laptop:~$ sudo modprobe -r b43 b44 ssb bcm43xx wl ndiswrapper
avi@avi-laptop:~$ sudo depmod -ae
avi@avi-laptop:~$ sudo modprobe ndiswrapper
avi@avi-laptop:~$ lshw -C network
WARNING: you should run this program as super-user.
*-network
description: Ethernet interface
product: MCP67 Ethernet
vendor: nVidia Corporation
physical id: a
bus info: pci@0000:00:0a.0
logical name: eth0
version: a2
serial: 00:1b:24:86:db:c0
width: 32 bits
clock: 66MHz
capabilities: bus_master cap_list ethernet physical
configuration: broadcast=yes driver=forcedeth driverversion=0.61 latency=0 maxlatency=20 mingnt=1 module=forcedeth multicast=yes
*-network
description: Wireless interface
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan1
version: 02
serial: 00:1a:73:92:4a:15
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.52+Broadcom,10/12/2006, 4.100. latency=0 module=ndiswrapper multicast=yes wireless=IEEE 802.11g
avi@avi-laptop:~$ dmesg|grep ndiswrapper > ~/Desktop/dmesgforum.txt

---------Here's is wat i get . still no wireless.....i have attached tht file

aviborse
June 21st, 2008, 07:43 AM
wow !!!!!!!! its working now, i m replying wireless ly..thx a millon Ayuthia

swoody
June 21st, 2008, 09:26 AM
Thank you very much for this write up! I don't know why, but I had my wireless card working out of the box, and then I had to reinstall Ubuntu on my comp (same install disc as first time) and my wireless wouldn't work?? But thanks to you, I know can have a cigg and surf the web at the same time, haha.

lazyfirecloud
June 22nd, 2008, 07:55 AM
Thanks! I finally got it working on my TX1499. It did take a few hours though =(

For those who are still struggling, here are the commands I took from this thread which helped me debug:


Check that you are using the correct driver

$lshw -C network
and look for:

driver=ndiswrapper+bcmwl5



If you have b43-pci-bridge instead (or just to make sure everything is running properly):

$sudo modprobe -r b43 b44 ssb ndiswrapper
$sudo modprobe ndiswrapper



If this fixes the driver, check that you did the bug fix in step

$sudo gedit /etc/init.d/rc.local
Make sure you have the following lines:

rmmod b43
rmmod b44
rmmod ssb
rmmod ndiswrapper
modprobe ndiswrapper
modprobe ssb
modprobe b44
Also, double-check step 5.



Make sure you have the correct network in /etc/modprobe.d/ndiswrapper

$sudo ifconfig -a
to get the name of the wireless network (mine was wlan1)

$sudo gedit /etc/modprobe.d/ndiswrapper
to edit the file.



To turn the card on/check for networks:

$sudo ifconfig wlan0 up
$sudo iwlist scan
If you don't get any networks, press/slide the switch on the laptop for your wireless card and run those commands again. The card may not turn on until you do the scan.



If the above returns access points but you don't see any wireless in the network manager in the taskbar, right-click on the network manager icon and make sure that the 'Enable wireless' option is checked =)

Matt Damon
June 22nd, 2008, 12:29 PM
I did not proofread my comments in an earlier post. Please try the following and let me know if it works:

echo -e '#Hardy ssb/ndiswrapper workaround, added' `date` '\ninstall ndiswrapper modprobe -r b43 b44 b43legacy ssb; modprobe --ignore-install ndiswrapper;' | sudo tee -a /etc/modprobe.d/ndiswrapperThis command will add the removal and reload commands. The only part it is missing is the depmod -ae, but that might be ok.

Hi there. I did the commands, and like, it works. I will queue all night when you do your world tour.

T H A N K S for your time.

Matt Damon
June 22nd, 2008, 12:31 PM
Hey lazyfirecloud

Nice work. I was going to do the same. You did better than I would have anyway:-)

mags73
June 22nd, 2008, 06:35 PM
This thread is still serving the community quite well. After many threads, this one was the last one that actually worked.

My BCM94311MCG wlan mini-PCI (rev 01) on Hardy 8.04 is working flawlessly. \\:D/

Maybe you could add Dell Latitiude D630 to your list of supported laptops?

Thank you for your time, it is greatly appreciated.

lola23
June 23rd, 2008, 02:31 AM
I am back to trying to fix this issue after using another machine for a while...


No, the new Broadcom drivers are now using ssb which is causing a conflict with NDISwrapper. The new Broadcom drivers are b43 (wireless) and b44 (wired).

The reason why I asked you to do this was to make sure that there was not a conflict. Since NDISwrapper still did not start up even though we removed the b44 and ssb drivers, we know that the wired card is not causing any problems.

Yours almost looks like your wireless is turned off. Do you have a switch to turn it on? If it is on, what happens when you go to the Terminal and type:

sudo ifconfig wlan0 up
sudo iwlist scan

My wireless card does not have an on/off switch; the light is on (was off before I installed the driver) and I see the available networks. However, when I try to set the ESSID or other parameters (password) it doesn't seem to work - it doesn't give me an error message but simply does not connect.

Vel-Tyno
June 23rd, 2008, 02:21 PM
If you have the Hardy liveCD, open the Terminal and do the following:

sudo apt-cdrom add
sudo apt-get update
sudo apt-get install build-essential
The first command will ask you for the CD. Insert your Hardy liveCD.

Hope that helps.

OK, we're still moving forward.

I submitted this command and was told "Permission Denied"

sudo ln -s /usr/src/linux-`uname -r` /lib/modules/`uname -r`/build

Joe

Dusk Eagle
June 24th, 2008, 08:07 AM
Thanks for this tutorial my wireless network finally works!

parabolee
June 24th, 2008, 05:38 PM
THANK YOU!

I had the strangest problem with mine. One day it was working fine, right out of the box by enabling the hardware in the restricted manager (Inspiron 6400). Then it stopped working, the WiFi light was still on and it found networks but when I tried to connect it would fail and then stop finding available networks.

So I do fresh install after many failed attempts to fix it (figuring I messed it up after trying to get networking with a windows workgroup working).

On a new install it NEVER worked (wifi light is on), never found a network at all!

So I go through your guide twice. Didn't work.

Boot into Vista figuring I'll try a fresh install with your guide only to find it no longer works in Vista! Try to enable from Vista, Wifi will not enable, light never comes on!

Try to enable from Function key shortcut (my computer does not have a switch), and BOOM light comes on and is working again! Great so boot back into Linux and works like a charm.:guitar:

I love Ubuntu Linux but crap like this keeps regular users away, took over 6 hours fixing this!

Hopefully 9 or 10 will bring us close to the usability and ease of use needed for regular people.

THANKS!!!!

cutcrank
June 26th, 2008, 06:36 AM
Hi guys, I have followed jlandaw's instructions to the T and i have the wireless card working in my laptop and i can search and see the networks. But there is a weird problem that i am experiencing.


Hardware: Compaq Presario V3611AU, AMD64x2, BCM94311MCG (rev o2)

OS: Kubuntu 8.04

The problem is that i can see the networks in my office but i cannot connect to it. When i try to connect to a network nothing happens. One SSID has WEP protection and another SSID has 802.1x protection and the third one has no protection, security is disabled. Even to the security disabled network i'm not able to connect to.

I use Kwifi manager to search for networks. I have tried configuring the wlan interface manually by providing the SSID and the keys but still it won't connect. What could be the problem. This has got me perplexed. Can anyone help me with a solution.

Here are the outputs of:

lspci | grep Broadcom
04:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)


ndiswrapper -l
bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: bcm43xx)


lshw -C network
*-network
description: Ethernet interface
product: MCP67 Ethernet
vendor: nVidia Corporation
physical id: a
bus info: pci@0000:00:0a.0
logical name: eth0
version: a2
serial: 00:16:d3:af:f6:5f
size: 100MB/s
capacity: 100MB/s
width: 32 bits
clock: 66MHz
capabilities: pm msi ht bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=forcedeth driverversion=0.61 duplex=full ip=192.168.3.26 latency=0 link=yes maxlatency=20 mingnt=1 module=forcedeth multicast=yes port=MII speed=100MB/s
*-network
description: Wireless interface
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:04:00.0
logical name: wlan1
version: 02
serial: 00:1a:73:95:e2:1e
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.52+Broadcom,10/12/2006, 4.100. latency=0 link=no module=ndiswrapper multicast=yes wireless=IEEE 802.11g


wlan1 Scan completed :
Cell 01 - Address: 00:1A:70:B1:E0:D0
ESSID:"iBus-OnBoard WiFi"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.412 GHz (Channel 1)
Quality:54/100 Signal level:-61 dBm Noise level:-96 dBm
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0
Cell 02 - Address: 00:0F:66:BF:CD:F0
ESSID:"Linuxense_ap01"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.437 GHz (Channel 6)
Quality:76/100 Signal level:-47 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:bcn_int=100
Extra:atim=0
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK


Here is a screenshot of the kwifimanager and the scan results.
75366

Hoping somebody would have the solution for this problem. Thanks in advance.

Maputo
July 6th, 2008, 12:36 AM
It worked on mine laptop too!!! I own a Dell Inspiron 1520. I think it too can be added to the list of those laptops :).
Thanks!

However, there seems to be a minor issue. Whenever I (re)boot my computer, before being able to use the wireless, I have to:

sudo modprobe -r bcm43xx b43 b44 ssb ndiswrapper
sudo modprobe ndiswrapper
sudo ifconfig eth1 up

if I don't do this it looks like there is no wireless card on my computer at all. And the wifi led simply seems to be ignorant to switching the wifi on/off (if it's turned off, then it's always turned off, no matter if I switch the wifi on).

Anyone knows what the reason for this might be? It would be cool if I wouldn't have to do all the "modprobing" every time I boot up my laptop.

Thanks a lot!

matthewbpt
July 10th, 2008, 06:40 PM
If you update the kernel, would the previous setup still work do you have to repeat this to make the wireless work again? i ask this because one of the steps involves finding your kernel version

aparrales
July 10th, 2008, 09:03 PM
Just to report that it worked on DELL Inspiron 6400, fresh installation form CD.
Thanks you all.

PharCyDeD
July 10th, 2008, 11:12 PM
Another great, easy, and simple install on a HP dv6000. Many many thanks man! I really appreciate it! This topic should be sticky since it covers so many different computers and is a great tutorial for beginners such as myself. 5 Stars!

:KS:KS:KS:KS:KS

jlandaw
July 11th, 2008, 04:54 AM
I'm not sure how it works, but the kernel updates do not affect the wifi once it is done. I believe the updated kernel takes all the settings from the last kernel and applies them to itself, therefore there should be no need to do anything else once you get your wifi up.

I have updated my kernel consistently since 8.04 was released and have not had to re-do anything. None of my tweaks for any part of my system that did not run "out of box" have been overwritten by updates.

Upgrade with confidence

cyberclops
July 13th, 2008, 05:06 AM
thank you, very, very much. this worked perfectly.

i'm running on a hp6500 on 8.04.

and now my internet works everywhere!!!!

stevejesus
July 13th, 2008, 02:40 PM
I did this a couple of months ago from info that I scratch up from around the web. It worked fine, but upgrading your kernel kills your wireless. I assumed that is what would happen.

How do I get it working again? I really have to get my wife off of my lappy. She has a C700 with 32-bit hardy.

pt6071
July 13th, 2008, 09:19 PM
Wireless works flawlessly on my lappy now w/ Hardy (HP Pavillion dv9000). Thank you!

Vartan
July 17th, 2008, 12:46 PM
Many many many thanks, i had spent the last 2 day doing this and scrubbing that on my D630 laptop with no luck.

but now my wireless works like a charm

thank you.
-Vartan

drgnrave
July 17th, 2008, 11:06 PM
I am a linux n00b, and I am running Hardy Heron on my Compaq Presario C714NR (dual-boot with Vista Home Premium) . Before coming to this forum, I have tried to set up my wireless with ndiswrapper, but without the bug fixes for Hardy. When I start up my Kubuntu install, and go to Kwifimanager, I am connected to wifi, but when I try to switch to a network, I end up in Ad-Hoc mode. I have my WEP Password and everything, a direct network connection through a cable works fine, and my wifi is active, yet I always end up in Ad-Hoc mode when I try to connect. I will try to redo the fix the way said here, but could there be anything else wrong with what I am doing?

--drgnrave

drgnrave
July 18th, 2008, 12:43 AM
Here is a screen shot of my situation,
Please help me with this.
--drgnrave

drgnrave
July 18th, 2008, 01:03 AM
Ok sorry for the triple post but got it to work. If it doesn't work for you, this might help:



If the above returns access points but you don't see any wireless in the network manager in the taskbar, right-click on the network manager icon and make sure that the 'Enable wireless' option is checked =)

Thank you so much. Now I can finally sleep

M8M
July 23rd, 2008, 11:19 PM
I've gone through these steps four times and again we get that the Broadcom B43 wireless driver is enabled but not in use. It also does not show wireless as an option to connect. Since we live 10 mins away from a wired connection, I'm getting tired of going over there everyday to try to figure this out. I have another laptop that still has Windows on it and the wireless works on it. So can someone help me walk through trying to figure out what's wrong? I'll have no internet connection on the Ubuntu laptop (that's what I'm trying to fix), but I do have it on the Windows one. So I can communicate, but can't download to Ubuntu until tomorrow late afternoon. Can someone help me please?

daafisch
July 24th, 2008, 01:02 AM
Worked for me Xubuntu 8.04 on my Dell 600m excellent!

Ayuthia
July 24th, 2008, 04:30 AM
I've gone through these steps four times and again we get that the Broadcom B43 wireless driver is enabled but not in use. It also does not show wireless as an option to connect. Since we live 10 mins away from a wired connection, I'm getting tired of going over there everyday to try to figure this out. I have another laptop that still has Windows on it and the wireless works on it. So can someone help me walk through trying to figure out what's wrong? I'll have no internet connection on the Ubuntu laptop (that's what I'm trying to fix), but I do have it on the Windows one. So I can communicate, but can't download to Ubuntu until tomorrow late afternoon. Can someone help me please?
If you are using ndiswrapper, you will not be able to see the b43 wireless driver in use through Hardware Drivers. This is because there is a native Linux driver that does exist for Broadcom cards.

You should check and see these two things first:

ndiswrapper -l
lshw -C network
The first command will help you see if the driver is working and that the hardware is present. The second command checks to see what driver it is using and that the card is ok. The second command should say that it is using ndiswrapper instead of b43-bridge-pci (or something like that).

You can also check and see if the correct drivers are loaded:

lsmod|grep -i -e b43 -e ssb -e bcm43xx -e ndiswrapper -e wl
This command should only return ndiswrapper and possibly ssb (with b44 attached to it). If you see anything else (b43 or bcm43xx) then that means that the drivers are not getting blacklisted. You can also try the following:

sudo modprobe -r b43 b44 ssb bcm43xx ndiswrapper wl
sudo depmod -ae
sudo modprobe ndiswrapper
If you are able to see wireless connections, then that means that you have some drivers in there that need to be blacklisted. If you are not able to get connected, do the lsmod command again and see if ndiswrapper shows up in the list. If it does not, check:

dmesg|grep ndiswrapper
There is most likely an error message out there for ndiswrapper explaining what is wrong.

Feel free to post back what you have found and we can try to see if we can get things up and running.

M8M
July 24th, 2008, 09:40 AM
You should check and see these two things first:
Code:

ndiswrapper -l
lshw -C network

The first command will help you see if the driver is working and that the hardware is present. The second command checks to see what driver it is using and that the card is ok. The second command should say that it is using ndiswrapper instead of b43-bridge-pci (or something like that).

Thank you, Auythia!

After the first command, this is what came up:
bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: bcm43xx)
I went back to hardware drivers and disabled the broadcom B43 wireless driver, which we manually enabled after following all the steps, b/c my husband insisted that it needed to be enabled.
After the second command it shows that the driver is b43-bridge-pci and not ndiswrapper. So I think that would be the first(hopefully only) problem, but I don't know how to fix it. Do I just follow the rest of the steps you posted?

M8M
July 24th, 2008, 10:01 AM
ok, so I thought it wouldn't hurt to just keep going and I found out that after this command:
lsmod|grep -i -e b43 -e ssb -e bcm43xx -e ndiswrapper -e wl

it says:
grep: ndiswrapper: no such file or directory

so I guess I need to go re-download and install the ndiswrapper file again. But I'm not sure what is not right, since we've downloaded it three times already and we DO HAVE a folder named ndiswrapper-1.53 in the home folder. Any suggestions?

Ayuthia
July 24th, 2008, 02:21 PM
ok, so I thought it wouldn't hurt to just keep going and I found out that after this command:
lsmod|grep -i -e b43 -e ssb -e bcm43xx -e ndiswrapper -e wl

it says:
grep: ndiswrapper: no such file or directory

so I guess I need to go re-download and install the ndiswrapper file again. But I'm not sure what is not right, since we've downloaded it three times already and we DO HAVE a folder named ndiswrapper-1.53 in the home folder. Any suggestions?

Actually, you should not have to reinstall. What that is telling you is that you missed a -e before ndiswrapper. The command thinks that you want to search for b43, bcm43xx, and ssb in the ndiswrapper file.

If you received a response from ndiswrapper -l, the application is there. To verify the version:

ndiswrapper -v

M8M
July 24th, 2008, 03:58 PM
If you received a response from ndiswrapper -l, the application is there. To verify the version:

ndiswrapper -v

when I typed that in this is what I got: (hopefully I'll copy it correctly and not miss any characters)
utils version: '1.9' , utils version needed by module: '1.9"
module details:
filename: /lib/modules/2.6.24-19-generic/ubuntu/misc/ndiswrapper/ndiswrapper.ko
version: 1.52
vermagic: 2.6.24-19-generic SMP mod_unload

Excited to see you might be online at the same time as I am!

Ayuthia
July 24th, 2008, 06:43 PM
You should check and see these two things first:
Code:

ndiswrapper -l
lshw -C network

The first command will help you see if the driver is working and that the hardware is present. The second command checks to see what driver it is using and that the card is ok. The second command should say that it is using ndiswrapper instead of b43-bridge-pci (or something like that).

Thank you, Auythia!

After the first command, this is what came up:
bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: bcm43xx)
I went back to hardware drivers and disabled the broadcom B43 wireless driver, which we manually enabled after following all the steps, b/c my husband insisted that it needed to be enabled.
After the second command it shows that the driver is b43-bridge-pci and not ndiswrapper. So I think that would be the first(hopefully only) problem, but I don't know how to fix it. Do I just follow the rest of the steps you posted?
I would go ahead with this:

sudo modprobe -r b43 b44 ssb bcm43xx ndiswrapper wl
sudo depmod -ae
sudo modprobe ndiswrapper
The b43-bridge-pci most likely means that there is another driver that is conflicting with ndiswrapper. The modprobe commands will remove any conflicting drivers and load ndiswrapper.


I went back to hardware drivers and disabled the broadcom B43 wireless driver, which we manually enabled after following all the steps, b/c my husband insisted that it needed to be enabled.What??? You listened to him? My wife has always told me that the woman is always right. :)

M8M
July 24th, 2008, 06:47 PM
Going to do that right now.

M8M
July 24th, 2008, 06:50 PM
[QUOTE=Ayuthia;5450320]I would go ahead with this:
[code]sudo modprobe -r b43 b44 ssb bcm43xx ndiswrapper wl

This command returned:
FATAL: Module bmc43xx not found

tunafishman
July 24th, 2008, 07:01 PM
What an absolute nightmare.

Thankyou for your wonderful guide and your 20 pages of explanations and special case studies. Page 19 had my answer.

HP tx1120us with Broadcom BCM94311MCG wlan mini-PCI posting on the Ubuntu forums via a wireless connection.

My specific complications:
-64 bit drivers
-previously installed b43 firmware in Hardware Drivers that needed to be disabled.

Thanks again.

Edit:
Spoke too soon. On reboot I am having to do the

sudo modprobe -r b43 b44 ndiswrapper wl
sudo depmod -ae
sudo modprobe ndiswrapper
How do I make it work more betterer?

M8M
July 24th, 2008, 07:17 PM
[QUOTE=Ayuthia;5450320]I would go ahead with this:
[code]sudo modprobe -r b43 b44 ssb bcm43xx ndiswrapper wl

This command returned:
FATAL: Module bmc43xx not found


I reentered the command without the "bcm43xx" part and then followed through and its much better, but still not enough.

I have a connection, but cannot get on to a webpage or on amsn. Both laptops (Windows and Ubuntu) are side by side and the signal strength is not the best but it's still working pretty good on the Windows one. Both laptops are identical, except for the operating systems, as I just installed Edubuntu on the one I'm trying to get internet on.

Ayuthia
July 24th, 2008, 07:29 PM
[QUOTE=M8M;5450367]


I reentered the command without the "bcm43xx" part and then followed through and its much better, but still not enough.

I have a connection, but cannot get on to a webpage or on amsn. Both laptops (Windows and Ubuntu) are side by side and the signal strength is not the best but it's still working pretty good on the Windows one. Both laptops are identical, except for the operating systems, as I just installed Edubuntu on the one I'm trying to get internet on.

You might check:

ifconfigand see if your wireless (should be wlan0 or eth1) is attached to an ip address (something like 219.152.3.6 but the numbers will most likely be different). If there is one attached, see if you can ping to a website:

ping -c1 www.google.comIf this returns something without a packet loss, then you are connected. Since you said that you can't get to a website or even use amsn, then most likely you won't get a successful reply.

How strong is your signal? Can you check:

sudo iwlist scanIf your signal is pretty weak, then it might not be connecting too well. Unfortunately, I have not really seen the wireless cards work as well in Linux in comparison to Windows. You might try getting closer to the router (if it is located in your place).

Ayuthia
July 24th, 2008, 07:35 PM
Edit:
Spoke too soon. On reboot I am having to do the

sudo modprobe -r b43 b44 ndiswrapper wl
sudo depmod -ae
sudo modprobe ndiswrapper
How do I make it work more betterer?

Have you tried the red portion in step 4 of the first post? The command pretty much does those steps when the system starts up unless you have a 4310 card. You can check this by:

lspci -nn|grep 14e4If you see 14e4:4310, then you will need to blacklist the wl driver:

echo blacklist wl|sudo tee -a /etc/modprobe.d/blacklist

M8M
July 24th, 2008, 07:54 PM
[QUOTE=M8M;5450539]

You might check:

ifconfigand see if your wireless (should be wlan0 or eth1) is attached to an ip address (something like 219.152.3.6 but the numbers will most likely be different). If there is one attached, see if you can ping to a website:

ping -c1 www.google.comIf this returns something without a packet loss, then you are connected. Since you said that you can't get to a website or even use amsn, then most likely you won't get a successful reply.

How strong is your signal? Can you check:

sudo iwlist scanIf your signal is pretty weak, then it might not be connecting too well. Unfortunately, I have not really seen the wireless cards work as well in Linux in comparison to Windows. You might try getting closer to the router (if it is located in your place).

I rebooted and seemed to have lost everything, no blue light on the wireless switch, no wireless option on the network manager, etc.

After the "ifconfig" command I got:
eth0 Link encap:Ethernet HWaddr 00:16:36:e0:01:be
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:20 Base address:0xe000

tunafishman
July 24th, 2008, 08:08 PM
I followed all of the steps in the first post thoroughly (and repeatedly).


tunafish@tunafish-ubuntu:~$ lspci -nn|grep 14e4
03:00.0 Network controller [0280]: Broadcom Corporation BCM94311MCG wlan mini-PCI [14e4:4311] (rev 01)


My blacklist currently includes

blacklist bcm43xx
blacklist b43
blacklist wl
blacklist b44

When I restart I still have to

sudo modprobe -r b43 b44 ndiswrapper wl
sudo depmod -ae
sudo modprobe ndiswrapper

The first line seems to need all 4 arguments for the process to work. I tried unloading them one at a time in an attempt to narrow down the possible offender, but it only works if I modprobe -r all the keys at once.

Apologies if I'm thick, I'm not trying to be.

Edit: Found out that

sudo modprobe -r b44 ndiswrapper
sudo modprobe ndiswrapper
seems to do the job. Why would b44 be bothering me if it's in my blacklist file?

Ayuthia
July 24th, 2008, 08:25 PM
[QUOTE=Ayuthia;5450622]

I rebooted and seemed to have lost everything, no blue light on the wireless switch, no wireless option on the network manager, etc.

After the "ifconfig" command I got:
eth0 Link encap:Ethernet HWaddr 00:16:36:e0:01:be
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:20 Base address:0xe000
Sorry about that. I forgot to mention to you that this is going to happen. There is something missing in /etc/modprobe.d/blacklist or /etc/modules that is not being loaded/unloaded. You can get it started again by doing the modprobe commands listed earlier. You will need to check the files:
Blacklist

grep -i -e b43 -e ssb -e bcm43xx -e ndiswrapper -e wl /etc/modprobe.d/blacklist
You will need to make sure that the following are listed:
blacklist b43
blacklist ssb
blacklist bcm43xx
blacklist wl
If they are not, you will need to add them:

echo blacklist <module>|sudo tee -a /etc/modprobe.d/blacklist
Just replace <module> with the module that is missing.

You will also need to make sure that ndiswrapper is loaded. Check:

grep -i -e b43 -e ssb -e bcm43xx -e ndiswrapper -e wl /etc/modulesMake sure that only ndiswrapper shows up. If it is missing:

echo ndiswrapper|sudo tee -a /etc/modules
If b43, ssb, bcm43xx, or wl is listed in there, you will have to edit the file and remove it. To edit he file:

gksu gedit /etc/modules

Ayuthia
July 24th, 2008, 08:42 PM
I followed all of the steps in the first post thoroughly (and repeatedly).


tunafish@tunafish-ubuntu:~$ lspci -nn|grep 14e4
03:00.0 Network controller [0280]: Broadcom Corporation BCM94311MCG wlan mini-PCI [14e4:4311] (rev 01)


My blacklist currently includes

blacklist bcm43xx
blacklist b43
blacklist wl
blacklist b44

When I restart I still have to

sudo modprobe -r b43 b44 ndiswrapper wl
sudo depmod -ae
sudo modprobe ndiswrapper

The first line seems to need all 4 arguments for the process to work. I tried unloading them one at a time in an attempt to narrow down the possible offender, but it only works if I modprobe -r all the keys at once.

Apologies if I'm thick, I'm not trying to be.

Edit: Found out that

sudo modprobe -r b44 ndiswrapper
sudo modprobe ndiswrapper
seems to do the job. Why would b44 be bothering me if it's in my blacklist file?

No need for apologies. The new modules are harder to configure. I am thinking that you have created a script that is loading b44. You might check /etc/rc.local. In step 4, there is a script that loads b44. You only need it if you have the b44 driver for your wired connection. You can check this by doing lshw -C network and check your eth0 card. It will have b44 as the driver. If it does not, then you don't need to load it. If /etc/rc.local has any commands on modprobe (or modprobe -r)b44, b43, ssb, ndiswrapper, you can comment them out by adding # at the beginning of each line. You can edit the file by:

gksu gedit /etc/rc.local
Hope that is what is causing it.

tunafishman
July 24th, 2008, 08:51 PM
/etc/rc.local is clean. There is no mention anywhere that I can find of b44.

I fixed the problem by including a file named b44 in /etc/modprobe.d/ that blacklists b44.
sudo depmod -ae
sudo update-initramfs -u
fixes the initrd script, apparently.

Rebooted, all is well. This make any sense to you?

Ayuthia
July 24th, 2008, 09:18 PM
/etc/rc.local is clean. There is no mention anywhere that I can find of b44.

I fixed the problem by including a file named b44 in /etc/modprobe.d/ that blacklists b44.
sudo depmod -ae
sudo update-initramfs -u
fixes the initrd script, apparently.

Rebooted, all is well. This make any sense to you?
It makes sense, but why that works instead of the other way surprises me. You can create special blacklist files for each module which is what you did. The initramfs is usually dealt with during booting (if I recall correctly). So when you updated the initrd, it added the b44 blacklisting. Apparently, something else must be calling b44 and since you created the special blacklist, it will never load. Glad to see you have it working!

EDIT:
Upon further thinking, the b44 file that you created is most likely being checked every time something calls for that module where /etc/modprobe.d/blacklist most likely is being called only upon booting. I am still thinking that something is calling b44 but I am not for sure what.

M8M
July 24th, 2008, 10:39 PM
[QUOTE=Ayuthia;5451027]
If they are not, you will need to add them:

echo blacklist <module>|sudo tee -a /etc/modprobe.d/blacklist
Just replace <module> with the module that is missing.

After trying to add the ssb module I got the following:
bash: ssb: No such file or directory

I'm a real n00b, so I need step by step help. Thank you for holding my hand...

Ayuthia
July 24th, 2008, 11:52 PM
[QUOTE=Ayuthia;5451027]
If they are not, you will need to add them:

echo blacklist <module>|sudo tee -a /etc/modprobe.d/blacklist
Just replace <module> with the module that is missing.

After trying to add the ssb module I got the following:
bash: ssb: No such file or directory

I'm a real n00b, so I need step by step help. Thank you for holding my hand...

Try the following:

echo blacklist ssb|sudo tee -a /etc/modprobe.d/blacklist

If that does not work, just go and edit the file:

gksu gedit /etc/modprobe.d/blacklistYou can then add whatever you need. Just let us know if you run into problems.

M8M
July 27th, 2008, 11:03 AM
[QUOTE=M8M;5451852]

Try the following:

echo blacklist ssb|sudo tee -a /etc/modprobe.d/blacklist

If that does not work, just go and edit the file:

gksu gedit /etc/modprobe.d/blacklistYou can then add whatever you need. Just let us know if you run into problems.

Thanks, now I see what I did wrong (I included the "<>"). I went through all these steps and it was all working fine, but I couldn't establish a connection. I concluded that that was b/c we were having general internet problems since Windows kept loosing internet too. After that we had no internet at all for a full day. Now its back and strong again, but when I turned my unbuntu on again to try it, I lost everything again (no blue light, no wireless option, etc) How do I make it so the settings stay and I don't have to start the steps all over again every time I shut down?

Ayuthia
July 27th, 2008, 08:28 PM
[QUOTE=Ayuthia;5452311]

Thanks, now I see what I did wrong (I included the "<>"). I went through all these steps and it was all working fine, but I couldn't establish a connection. I concluded that that was b/c we were having general internet problems since Windows kept loosing internet too. After that we had no internet at all for a full day. Now its back and strong again, but when I turned my unbuntu on again to try it, I lost everything again (no blue light, no wireless option, etc) How do I make it so the settings stay and I don't have to start the steps all over again every time I shut down?

It might be easier to have you post the results of the following and then we can see what we need to get it to work on reboot:

grep -i -e b43 -e b44 -e bcm43xx -e ssb -e ndiswrapper /etc/modprobe.d/blacklist
grep -i -e b43 -e b44 -e bcm43xx -e ssb -e ndiswrapper /etc/modules
lshw -C network
In some cases, we just need to make sure that the blacklist and module files are all that is needed to make things work on reboot, but sometimes we need to add another command that will load and unload the modules.

ceolfrith
July 28th, 2008, 12:29 AM
Just wanted to say thanks. I'm new to Linux and the forums arfe a major help.
I'm using an HP dv9000 and I followed the instructions and they worked. Now I can unplug and go get comfortable.

After I rebooted my download automatically installed after asking permission, so I stopped there. It works and I thank you for the help.

ceolfrith
July 28th, 2008, 12:31 AM
Now if I could only spell.

M8M
July 29th, 2008, 01:09 PM
It might be easier to have you post the results of the following and then we can see what we need to get it to work on reboot:

grep -i -e b43 -e b44 -e bcm43xx -e ssb -e ndiswrapper /etc/modprobe.d/blacklist
[/QUOTE]

I didn't fix anything since the last reboot and here are the results:

# replaced by b43 and ssb.
blacklist bcm43xx
blacklist bcm43xx
blacklist b43
blacklist ssb

After the modules one it showed only "ndiswrapper"

After the network one:
*-network
description: Network controller
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
version: 01
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=b43-pci-bridge latency=0 module=ssb

Thank you for your help.

M8M
July 29th, 2008, 01:20 PM
I don't know if this is relevant or not, and if not just ignore. Under system>administration>windows wireless drivers there is currently installed a bcmwl5 driver with hardware present. I don't see bcmwl5 listed on the blacklist. But then I'm a total n00b so, my thinking may not be correct. Should it also be blacklisted? should I remove it? or is this totally irrelevant?

Thanks again.

Ayuthia
July 29th, 2008, 03:16 PM
I don't know if this is relevant or not, and if not just ignore. Under system>administration>windows wireless drivers there is currently installed a bcmwl5 driver with hardware present. I don't see bcmwl5 listed on the blacklist. But then I'm a total n00b so, my thinking may not be correct. Should it also be blacklisted? should I remove it? or is this totally irrelevant?

Thanks again.
The windows wireless drivers is the driver that is used for NDISwrapper. So this driver does not get noticed by the kernel and is not used. The driver here is "wrapped" into ndiswrapper. If it says that the hardware is present, it means that ndiswrapper is happy with that driver.

Ayuthia
July 29th, 2008, 03:28 PM
It might be easier to have you post the results of the following and then we can see what we need to get it to work on reboot:

grep -i -e b43 -e b44 -e bcm43xx -e ssb -e ndiswrapper /etc/modprobe.d/blacklist


I didn't fix anything since the last reboot and here are the results:

# replaced by b43 and ssb.
blacklist bcm43xx
blacklist bcm43xx
blacklist b43
blacklist ssb

After the modules one it showed only "ndiswrapper"

After the network one:
*-network
description: Network controller
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
version: 01
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=b43-pci-bridge latency=0 module=ssb

Thank you for your help.[/QUOTE]

The only driver that I am not for sure about is b44. This is a Broadcom driver for wired ethernet cards. If you have a b44 card, when you type:

lspci -nn|grep 14e4, it will come up with two items. If it only shows your 4311 card, then you most likely don't have the b44 driver.

To try out something different, we are going to create a new file to just blacklist the b43 module:

echo blacklist b43|sudo tee -a /etc/modprobe.d/b43
echo blacklist ssb|sudo tee -a /etc/modprobe.d/b43
In theory, this file will be checked every time the b43 module is being requested for loading. If this file exists, it will read the file and do what it says. Since it says to blacklist it, it should prevent the b43 module from loading.

M8M
July 29th, 2008, 04:27 PM
Everything seems to be working ok (blue light), except that I can't log on. The signal strength is reasonably strong, (about 1/3 of the bar) but I can't log on. I've tried different settings for the wireless, but still can't log on. I'm not sure what's wrong.

iHaVEnOmMrS
August 1st, 2008, 01:14 AM
Everything seems to be working ok (blue light), except that I can't log on. The signal strength is reasonably strong, (about 1/3 of the bar) but I can't log on. I've tried different settings for the wireless, but still can't log on. I'm not sure what's wrong.

I'm getting the same exact thing. Any help?

alexa.pintea
August 1st, 2008, 03:04 PM
Hi!It's working for my HP NX7300!Thanks alot!

ThaRabbit
August 1st, 2008, 07:51 PM
I'm getting the same exact thing. Any help?

I had the same issue, are you using 128 bit wep by any chance?

It seems the network manager fails to correctly configure in case of a 128 bit wep key on some systems:
https://bugs.launchpad.net/ubuntu/+source/gnome-system-tools/+bug/67876

try this:

sudo iwconfig wlan0 mode managed
sudo iwconfig wlan0 essid yourwirelessnetworkname
sudo iwconfig wlan0 channel yourwirelessnetworkchannel
sudo iwconfig wlan0 key yourwepkey

then:

sudo dhclient wlan0

if you get something like this:

Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/wlan1/00:21:00:1e:d6:aa
Sending on LPF/wlan1/00:21:00:1e:d6:aa
Sending on Socket/fallback
DHCPREQUEST of 192.168.1.11 on wlan1 to 255.255.255.255 port 67
DHCPACK of 192.168.1.11 from 192.168.1.1
bound to 192.168.1.11 -- renewal in 35778 seconds.
stefan@lapsteef:~$


you're connected :)

----

Working on HP 6720s

Though I did have to unload ssb.

M8M
August 1st, 2008, 11:43 PM
Working on HP 6720s

Though I did have to unload ssb.[/QUOTE]

I followed these steps (more than once) and got:
There is already a pid file /var/run/dhclient.pid with pid 12348 killed old client process, removed PID file
Internet systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/wlan0/00:1a:73:1d:bf:0a
Sending on LPF/wlan0/00:1a:73:1d:bf:0a
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
No DHCPOFFERS received.
No working leases in persistent database - sleeping

We did manage to connect to a neighbor's unsecure network, but cannot connect to my own network with the Ubuntu 8.04, but can with the windows laptop.

I don't know understand the whole loading and unloading of modules, so I don't know how to unload the ssb.

M8M
August 1st, 2008, 11:48 PM
I had the same issue, are you using 128 bit wep by any chance?

Yes, I am.

M8M
August 1st, 2008, 11:51 PM
Everything seems to be working ok (blue light), except that I can't log on. The signal strength is reasonably strong, (about 1/3 of the bar) but I can't log on. I've tried different settings for the wireless, but still can't log on. I'm not sure what's wrong.

I also lose the settings every time I reboot. So I have a little note pad scribble with the commands I need to punch in to get it working again, but I have to do that every time again.

ThaRabbit
August 2nd, 2008, 09:48 AM
Working on HP 6720s

Though I did have to unload ssb.

I followed these steps (more than once) and got:
There is already a pid file /var/run/dhclient.pid with pid 12348 killed old client process, removed PID file
Internet systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/wlan0/00:1a:73:1d:bf:0a
Sending on LPF/wlan0/00:1a:73:1d:bf:0a
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
No DHCPOFFERS received.
No working leases in persistent database - sleeping

We did manage to connect to a neighbor's unsecure network, but cannot connect to my own network with the Ubuntu 8.04, but can with the windows laptop.

I don't know understand the whole loading and unloading of modules, so I don't know how to unload the ssb.

Ok, first, please post the output of:

sudo ndiswrapper -l (that's an L non capital)
and

sudo iwconfig
and

sudo ifconfig

M8M
August 3rd, 2008, 01:32 AM
Ok, first, please post the output of:

sudo ndiswrapper -l
(that's an L non capital)

bcmwl5: driver installed
device (14E4:4311) present (alternate driver: bcm43xx)


and

sudo iwconfig
lo no wireless extensions.
eth0 no wireless extensions.

and

sudo ifconfig[/QUOTE]
eth0 Link encap:Ethernet HWaddr 00:16:36:e0:01:be
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:20 Base address:0xe000

Thanks

ThaRabbit
August 3rd, 2008, 03:24 PM
You didn't blacklist b43xx / b43 drivers?

Please post your /etc/modprobe.d/blacklist file's contents :)

M8M
August 3rd, 2008, 04:49 PM
I'm not sure how to do this, but looking back at the previous posts I followed this command:
grep -i -e b43 -e ssb -e bcm43xx -e ndiswrapper -e wl /etc/modprobe.d/blacklist

The result was the following (my comment in parentheses):
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist bcm43xx (yes, twice)
blacklist b43
blacklist ssb
blacklist wl

ThaRabbit
August 4th, 2008, 07:20 PM
I'm not sure how to do this, but looking back at the previous posts I followed this command:
grep -i -e b43 -e ssb -e bcm43xx -e ndiswrapper -e wl /etc/modprobe.d/blacklist

The result was the following (my comment in parentheses):
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist bcm43xx (yes, twice)
blacklist b43
blacklist ssb
blacklist wl

Utterly confusing.

please do:

sudo modprobe -r b43
sudo modprobe -r ndiswrapper
duso modprobe ndiswrapper

then please post the output of:

ndiswrapper -l

and

dmesg

and

ifconfig

Please use pastebin for the longer outputs :)
http://pastebin.ubuntu.com/

M8M
August 4th, 2008, 08:56 PM
Ok, I've never done this before, but I think I did it right...
Here's the link to the pastebin: http://pastebin.ubuntu.com/34164/

Thank you for your help!

hackerlife
August 4th, 2008, 09:27 PM
hey I've got an HPdv2000, and I'm trying to install my drivers without an internet connection. I just downloaded the two files onto a memstick and am going to put it on the ubuntu laptop. Is this gonna work? all help is much appreciated. I also have my own thread here:http://ubuntuforums.org/showthread.php?t=878558
thanks all!

ThaRabbit
August 4th, 2008, 10:19 PM
Ok, I've never done this before, but I think I did it right...
Here's the link to the pastebin: http://pastebin.ubuntu.com/34164/

Thank you for your help!

That seems to work, try


iwlist wlan0 scanning

You may have to redo the commands we did before.

if it detects your network using iwlist, then try:


sudo iwconfig wlan0 mode managed
sudo iwconfig wlan0 essid youressid
sudo iwconfig wlan0 channel yourchannel
sudo iwconfig wlan0 key yourwlanwepkey

Now do:

iwconfig

to check if the settings you set have been set correctly (post them again please :) ), if that is the case:

sudo dhclient wlan0

rkolb86
August 8th, 2008, 07:00 AM
worked on my HP CTO dv92000 (dv9000 customized) I had to use the Windows XP (32 bit) drivers from the HP site though. I have a BCM4328.

bookofjoshua
August 9th, 2008, 04:09 AM
thank you very much! I'm a noob mostly because I can't get interested in programing and every time I have installed a version of Linux there was so much to do to make it work right I would just give up.

Thanks to you (and of course everyone who programs on Ubuntu) I now have all the functions I need to get more familiar with Ubuntu (linux in general) and I think it will be more fun this time.

Thanks!!!!!!:KS

ramsuhas
August 9th, 2008, 04:49 PM
Thanks a lot... :D
You Rock! :guitar:

TerryP
August 12th, 2008, 06:10 AM
Outstanding! Wireless is working great! :)

System is a Compaq C714NR with BCM4311MCG Rev 02 on Hardy 8.04.01. Kernel is "2.6.24-19-generic" X86_64. I'm a Linux newbie and spent countless hours over several days to get the wireless card working. I think I tried every other how-to I could find at least once (often multiple times) with no success -- until I found this one!

Since I didn't have an Internet connection, I used another PC to download the files and the Ubuntu CD in the optical drive for the commands in Step 9. I didn't realize it at the time, but later found that I didn't add "generic" to the end of `uname -r` for the following commands in Step 9:

sudo apt-get install linux-headers-`uname -r`

sudo ln -s /usr/src/linux-`uname -r` /lib/modules/`uname -r`/build

In spite of the mistakes, it's working flawlessly, but I'm unsure whether I should repeat all the steps again to be sure (if it ain't broke, don't fix it?).


Thank you for this awesome work!

japelj
August 15th, 2008, 05:18 PM
Hello! I followed the instructions and the result is that my computer can actually detect the network but it can't connect. (actually I managed to get a connection once, but I was unable to access the internet via google...). So, here are some results and I ask you, if you can look at them:

lshw -C network


WARNING: you should run this program as super-user.
*-network
description: Ethernet interface
product: 82562GT 10/100 Network Connection
vendor: Intel Corporation
physical id: 19
bus info: pci@0000:00:19.0
logical name: eth0
version: 03
serial: 00:1f:29:86:42:ae
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical
configuration: broadcast=yes driver=e1000 driverversion=7.3.20-k2-NAPI firmware=1.1-2 latency=0 module=e1000 multicast=yes
*-network
description: Wireless interface
product: BCM94311MCG wlan mini-PCI
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:10:00.0
logical name: wlan1
version: 02
serial: 00:21:00:0f:af:67
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.52+Broadcom,10/12/2006, 4.100. latency=0 module=ndiswrapper multicast=yes wireless=IEEE 802.11g

ndiswrapper -v


utils version: '1.9', utils version needed by module: '1.9'
module details:
filename: /lib/modules/2.6.24-19-generic/ubuntu/misc/ndiswrapper/ndiswrapper.ko
version: 1.52
vermagic: 2.6.24-19-generic SMP mod_unload 586


ndiswrapper -l


bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: bcm43xx)


lsmod | grep -i -e b43 -e ssb -e ndiswrapper -e bcm43xx


ssb 34308 1 b44
ndiswrapper 192920 0
usbcore 146028 5 ndiswrapper,hci_usb,ehci_hcd,uhci_hcd

claudiney
August 15th, 2008, 11:24 PM
thanks for the tutorial, it works perfectly on my hp dv6409 laptop.
I have tried for weeks to have it work, using different tutorial,but none work. your explanation was simple to follow and works.
I really appreciate your time and help posting the tutorial.
God Bless you!
C.Esteves

MisanthropicAnthropoid
August 18th, 2008, 05:03 AM
I started a new thread today trying to figure out how to do this (didn't know what wireless card I had at the time), and it took three hours to enable what I apparently need to disable (generally because I have no idea what I'm doing). Anyways, I don't have an internet connection at all in Ubuntu right now, so I can't go through this until tomorrow or Tuesday, but it appears that the first link is down. Is there another not-rapidshare source from which to download the file?

Ayuthia
August 18th, 2008, 02:53 PM
I started a new thread today trying to figure out how to do this (didn't know what wireless card I had at the time), and it took three hours to enable what I apparently need to disable (generally because I have no idea what I'm doing). Anyways, I don't have an internet connection at all in Ubuntu right now, so I can't go through this until tomorrow or Tuesday, but it appears that the first link is down. Is there another not-rapidshare source from which to download the file?

You might try the following steps:

sudo apt-get install cabextract
wget ftp://ftp.compaq.com/pub/softpaq/sp34001-34500/sp34152.exe
cabextract sp34152.exe

This information comes from https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Feisty_No-Fluff

MisanthropicAnthropoid
August 19th, 2008, 03:38 AM
You might try the following steps:

sudo apt-get install cabextract
wget ftp://ftp.compaq.com/pub/softpaq/sp34001-34500/sp34152.exe
cabextract sp34152.exe

This information comes from https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Feisty_No-Fluff

Thanks for the attempt, but those instructions fail. And I can't do anything with the instructions given in the original post because the first link is broken. Any other ideas?

Ayuthia
August 19th, 2008, 03:53 AM
Thanks for the attempt, but those instructions fail. And I can't do anything with the instructions given in the original post because the first link is broken. Any other ideas?

Can you go into the Terminal and tell me the numbers in the brackets for the Vendor, Device, SVendor, Sdevice, and Rev:

lspci -nnmvd 14e4:*
The information should look something like:

Device: 03:00.0
Class: Network controller [0280]
Vendor: Broadcom Corporation [14e4]
Device: BCM4311 802.11b/g WLAN [4311]
SVendor: Hewlett-Packard Company [103c]
SDevice: BCM4311 802.11b/g Wireless LAN Controller [1363]
Rev: 01

And I would like to see something like:
14e4 4311 103c 1363 01

MisanthropicAnthropoid
August 19th, 2008, 04:05 AM
jay@jay-laptop:~$ lspci -nnmvd 14e4:*
Device: 03:00.0
Class: Network controller [0280]
Vendor: Broadcom Corporation [14e4]
Device: BCM94311MCG wlan mini-PCI [4311]
SVendor: Hewlett-Packard Company [103c]
SDevice: Unknown device [1374]
Rev: 02

jay@jay-laptop:~$


Also, the thread I mentioned previously trying to get help in is here: http://ubuntuforums.org/showthread.php?t=892808

I'm generally making a mess of things, so I don't know if there's any useful information there, but that's what I've got.

Ayuthia
August 19th, 2008, 04:26 AM
jay@jay-laptop:~$ lspci -nnmvd 14e4:*
Device: 03:00.0
Class: Network controller [0280]
Vendor: Broadcom Corporation [14e4]
Device: BCM94311MCG wlan mini-PCI [4311]
SVendor: Hewlett-Packard Company [103c]
SDevice: Unknown device [1374]
Rev: 02

jay@jay-laptop:~$


Also, the thread I mentioned previously trying to get help in is here: http://ubuntuforums.org/showthread.php?t=892808

I'm generally making a mess of things, so I don't know if there's any useful information there, but that's what I've got.

Ok! That did have some useful information. It might be better to see if we can get the bcm43xx driver to work first. By any chance did you get the bcm43xx-fwcutter installed? If so, can you check and see if the following exists:

ls -l /usr/share/bcm43xx-fwcutter/install*
It has been a while since I have tried Gutsy and I can't remember how well the bcm43xx driver worked for your card.

If you want to try the NDISwrapper route, can you let us know if you are still using Windows? If so, is it something else besides Vista? We need to have a Windows driver that is not from Vista to get ndiswrapper to work.

You also mentioned that you could not get the sp34152.exe to work. What did you mean by that? Were you not able to download the file, not able to get cabextract installed, or did the driver not work with NDISwrapper?

There is also a Linux driver that has been created by Broadcom. However, I don't think that it has been tested in any kernels less than 2.6.24 so I am not for sure if it is going to work in Gutsy. Here is the link to it:
http://www.broadcom.com/support/802.11/linux_sta.php

Can you also let us know if you are using 32-bit or 64-bit?

MisanthropicAnthropoid
August 19th, 2008, 04:50 AM
Ok! That did have some useful information. It might be better to see if we can get the bcm43xx driver to work first. By any chance did you get the bcm43xx-fwcutter installed? If so, can you check and see if the following exists:

ls -l /usr/share/bcm43xx-fwcutter/install*
It has been a while since I have tried Gutsy and I can't remember how well the bcm43xx driver worked for your card.

If you want to try the NDISwrapper route, can you let us know if you are still using Windows? If so, is it something else besides Vista? We need to have a Windows driver that is not from Vista to get ndiswrapper to work.

You also mentioned that you could not get the sp34152.exe to work. What did you mean by that? Were you not able to download the file, not able to get cabextract installed, or did the driver not work with NDISwrapper?

There is also a Linux driver that has been created by Broadcom. However, I don't think that it has been tested in any kernels less than 2.6.24 so I am not for sure if it is going to work in Gutsy. Here is the link to it:
http://www.broadcom.com/support/802.11/linux_sta.php

Can you also let us know if you are using 32-bit or 64-bit?

Well, I no longer have Internet access with Ubuntu (I can try to find a connection again tomorrow). I do still have windows, but it is Vista (with which I'm getting a wireless connection). With the instructions you linked, I followed them all, but when step 3 started, and I tried to call the NDISwrapper file, it claimed that the file wasn't found.

Ayuthia
August 19th, 2008, 05:05 AM
Well, I no longer have Internet access with Ubuntu (I can try to find a connection again tomorrow). I do still have windows, but it is Vista (with which I'm getting a wireless connection). With the instructions you linked, I followed them all, but when step 3 started, and I tried to call the NDISwrapper file, it claimed that the file wasn't found.

Ok. We can confirm that bcm43xx works for you. Since you lost your wireless connection, it is because the b43legacy firmware portion is not working for your card. You should be able to get your wireless back by doing the following (it will only work for the current session):

sudo modprobe -r b43 b44 b43legacy ndiswrapper wl ssb bcm43xx
sudo depmod -ae
sudo modprobe bcm43xx
sudo ifconfig wlan0 up

When you have a chance, I would like to see if there is any information in dmesg when you load ndiswrapper. Can you do the following:

sudo modprobe -r b43 b44 b43legacy ndiswrapper wl ssb bcm43xx
sudo depmod -ae
sudo modprobe ndiswrapper
dmesg|grep ndis

MisanthropicAnthropoid
August 19th, 2008, 05:17 AM
Ok. We can confirm that bcm43xx works for you. Since you lost your wireless connection, it is because the b43legacy firmware portion is not working for your card. You should be able to get your wireless back by doing the following (it will only work for the current session)

Not quite accurate. I never had any wireless connection in Ubuntu. I was stealing an ethernet connection from my parents' computer, but their AC is broken and they have no available plugs, so I lasted as long as my battery and then decided to break until tomorrow. Getting the wireless in Ubuntu is the task at hand, and it's still seeming a bit intimidating.

Ayuthia
August 19th, 2008, 05:25 AM
Not quite accurate. I never had any wireless connection in Ubuntu. I was stealing an ethernet connection from my parents' computer, but their AC is broken and they have no available plugs, so I lasted as long as my battery and then decided to break until tomorrow. Getting the wireless in Ubuntu is the task at hand, and it's still seeming a bit intimidating.

Sorry, I meant that we know that bcm43xx does something but the b43 modules do not. I did not mean to say that it works.

If you are willing, you could try out this:
http://ubuntuforums.org/showthread.php?t=880218

It is for 8.04. The only downside to it is that it is a pre-release kernel. It does seem to work for your card.

MisanthropicAnthropoid
August 19th, 2008, 07:15 PM
Sorry, I meant that we know that bcm43xx does something but the b43 modules do not. I did not mean to say that it works.

If you are willing, you could try out this:
http://ubuntuforums.org/showthread.php?t=880218

It is for 8.04. The only downside to it is that it is a pre-release kernel. It does seem to work for your card.

I'm only in 7.10 though. And I don't seem to be able to update. Every time I click on "update," it tells me that certain packages can't be authenticated, and then lists pretty much every package.

MisanthropicAnthropoid
August 19th, 2008, 07:18 PM
sudo modprobe -r b43 b44 b43legacy ndiswrapper wl ssb bcm43xx




FATAL: Module b43 not found

Ayuthia
August 19th, 2008, 08:34 PM
FATAL: Module b43 not found


I am not for sure why it says that it is FATAL. It just means that the module is not loaded. Nothing to worry about. We are trying to remove it.

jackechanprime
August 20th, 2008, 02:34 AM
i donno how else to say this so... erm... help?

I have a Compaq Presario C700 with an Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter. aaaand... it dosnt work. I'm running hardy heron, and have tried a whole bunch of stuff, and nothing has really worked. ndiswrapper makes my computer crash/freeze every 3 minutes, but gets me wireless. where as none of the other drivers even phazed the problem. when i looked at your instructions, and clicked the download link for the driver, i got a 404 error, and i have been finding those allover the net every time i think i finally found the god given 'this one actually works' page. i think theyre all pointing to the same page, and if so, it's been down for at least 3 weeks now. soooo... does anyone have the file i need/ know what's going on/ have the slightest clue how to help me? i've had sooooo little luck elsewhere that i'm getting desperate.

plz, anyone, help.
*begs on hands and knees... trying to not look to totally pathetic...*
jack