PDA

View Full Version : [ubuntu] 8.04 Dell XPS 1530 Wireless and Nvidia not working



antonioev
April 26th, 2008, 08:45 AM
XPS 1530 wireless and Nvidia not working on 8.04 or 7.10.

I have a Dell XPS 1530 but the wireless is not working with 8.04 or 7.10. Even I have tried Suse and Fedora and none of them work.

The computer has an Intel Pro wireless 3945ABG but I am not able to make it work with this computer. The card is not even detected by the network manager. But the Test Hardware Utility is able to detect the card.

When the network card is magically detected it is not able to connect to the access point and it makes the access point to reset, weird isn't it?.

A friend of mine has a another XPS but the 1330 and he has the same problems but he has the Intel Next gen-N card (I donīt remember the model exactly).

The access point is a 2wire DSL router.

Something really weird is that I have a Lenovo 3000 N100 with the same card the 3945ABG and it doesn't have any of these errors.

Another thing that itīs happening using 8.04 is that I am not able to make work the proprietary driver for NVidia...

This is weird I have read many threads saying that the wireless works out of the box but now we have 2 different computers bought in different countries with different card experiencing exactly the same with different versions of linux.

I don't know how to start debugging this problem. If you need additional information I will gladly provide anything needed.

Thanks.

jordan86
April 26th, 2008, 08:51 AM
Hmm.... I also having the same wireless card as you.
My XPS is M1210.
I dun have the problem in 7.10.
But i have a little bit probs in 8.04 kernel 2.6.24-16.
I cant see the wireless icon after i boot into ubuntu.
What i did is just wait for few mins, then it will auto connect to wireless.
And the wireless light no blinking at all one.
Weird.....

Irda_Ranger
April 27th, 2008, 05:08 AM
XPS 1530 wireless ... not working on 8.04

I have a Dell XPS 1530 but the wireless is not working with 8.04

The card is not even detected by the network manager. But the Test Hardware Utility is able to detect the card.

Just chiming in to report the same as above. I did not get as far as testing the nVidia drivers, or test under 7.10, but the wireless was definitely not working under 8.04. I also have the Dell XPS M1530. Test Hardware Utility successfully detected the correct hardware. Neither manual nor automatic setup worked.

I got an error when I added Network Manager to the Taskbar and then clicked on it; sorry I didn't write it down exactly but it was something like "Hardware not detected."

remmosf
April 27th, 2008, 09:35 AM
Hi I have a Dell XPS M1530. Wireless networking works perfectly, but if I enable my NVidia drivers my screen ends up unreadable and I have to reinstall the system. Well the second time I was able to prevent X from starting and repair X by typing sudo init 1. Now I have lost my keyboard settings though

xtracool_protik
May 12th, 2008, 04:30 PM
I've the same problem with nVidia(8400gs in Dell 1530XPS) After whole days work somehow i managed to get it installed however resolution won't go more than gross 800x600.
Please somebody help because without nVidia I won't be able to enable compiz there are really cool effects (I'm not much coding person)

magimum
September 14th, 2008, 10:12 PM
i have the same problem too. i have an xps 1530 with the dell n wireless card by broadcom. i tried using ndiswrapper but it didnt work. ethernet only connects for a second but when i try to update my nvidia driver it doesnt download and ethernet connection stops. im starting to think that something went wrong while installing ubuntu because other xps 1530's didnt seem to have any problems with ndiswrapper.

SephirothLance
September 14th, 2008, 11:02 PM
I'm having the same issue on my m1530 with the broadcom wireless n adapter. Also could not get ndiswrapper to work. It would install the driver but when trying to load it it would fail. I've been trying everything I can find online but none of the options are working for me. There's gotta be someone around here who's figured out how to get this working. :<

jespdj
September 15th, 2008, 12:08 PM
The nVidia driver and wireless (Intel 4965) work fine on my XPS M1530.

To make the nVidia driver work, you most likely need to do:

sudo apt-get update
if your Ubuntu is freshly installed. I noticed that the driver couldn't be enabled with Restricted Drivers Manager before I did this.