PDA

View Full Version : [ubuntu] Hardy upgrade lost UK short date format



Terrycymru
April 25th, 2008, 08:29 AM
After upgrading to Hardy I have lost the UK short date format DDMMYYYY and now have the US format MMDDYYYY across all applications.

I have checked etc/environment and it shows the correct line:
LANG="en_GB.UTF-8"

How can I get the UK format back?

Later: I've also tried making a change in System>Administration>Language Support which is set by default to English (United States). I can select English (United Kingdom) but it will not save the setting. I don't know if this has any relevance to the date format problem.

Terrycymru
April 26th, 2008, 06:14 AM
Bump.

Terrycymru
April 27th, 2008, 07:19 AM
I have reported problem as bug #222570.

bagvian
August 28th, 2008, 04:25 PM
Hello there,
It seems that I have got the same problem than you after installing a 8.04 from scratch.
Did you manage to find a solution?
Cheers, Bagvian

Terrycymru
August 28th, 2008, 04:49 PM
Hello there,
It seems that I have got the same problem than you after installing a 8.04 from scratch.
Did you manage to find a solution?
Cheers, Bagvian

Hi Bagvian, I've had to fix a number of issues relating to locale so I am not sure what fixed what. Try this:

1. Logout
2. On login screen click on Options (on bottom left of screen)
3. Select Language
4. Log back in and hopefully it will be saved

Please post back here if it solves your problem.

seadart
August 28th, 2008, 06:53 PM
I had a similar problem but with an original load of 8.0.4 - This solved it - thanks!

bagvian
September 1st, 2008, 09:49 PM
Hi,
I first re-installed the language-pack-en as well as language-pack-en-base through synaptic.
Nothing changed!
I then tried what was suggested by Terrycymru:
1. Logout
2. On login screen click on Options
3. Select Language (I selected English UK)
4. Log back in
Next, it only asks you whether you want to use this language only for this session.
I then launched Thunderbird and this time dates were displayed properly!
Thanks everybody,
Bagvian

tkking
October 27th, 2008, 05:04 PM
Same problem here on a fresh install of 8.04. Sorted now thanks to this thread.

Benchrest
October 31st, 2008, 03:26 PM
I am in the US and after installing 8.04 I had the wrong date format on the desktop and all applications. I found I had mistakingly chose English America Canada. I probably selected the wrong location on the map. Anyhow I found going to System/Administration/Language Support it showed I was English Canadian. I changed it to English US and rebooted.