PDA

View Full Version : [ubuntu] 7.10 -> 8.04 - Lost Ethernet!



gschoppe
April 25th, 2008, 06:00 AM
I just upgraded from 7.10 to 8.04, and promptly lost all connections to my LAN and the wider internet...

I have two nic cards: an onboard, eth0, and a netgear (GA311, maybe?) gigabit card, eth1. My network/internet comes to eth1. eth0 is currently unused.

manual network configuration displays both as set up with static IPs; however, when I attempt to access network-tools, and I click configure on either interface, I get:


The interface does not exist
check that it is correctly typed, and that it is correctly supported by your system



here are the results of "lshw -C network" and "sudo ifconfig&&iwconfig" :



gschoppe@Hippocampus:~$ sudo ifconfig&&iwconfig
eth0 Link encap:Ethernet HWaddr 00:e0:4d:11:d6:b7
inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:21 Base address:0xa000

eth1 Link encap:Ethernet HWaddr 00:14:6c:cb:5c:7e
inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::214:6cff:fecb:5c7e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4142 errors:0 dropped:0 overruns:0 frame:0
TX packets:770 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:787942 (769.4 KB) TX bytes:62459 (60.9 KB)
Interrupt:18 Base address:0xc000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:7629 errors:0 dropped:0 overruns:0 frame:0
TX packets:7629 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:385680 (376.6 KB) TX bytes:385680 (376.6 KB)

lo no wireless extensions.

eth0 no wireless extensions.

eth1 no wireless extensions.


gschoppe@Hippocampus:~$ lshw -C network
WARNING: you should run this program as super-user.
*-network
description: Ethernet interface
product: RTL-8169 Gigabit Ethernet
vendor: Realtek Semiconductor Co., Ltd.
physical id: 6
bus info: pci@0000:01:06.0
logical name: eth1
version: 10
serial: 00:14:6c:cb:5c:7e
width: 32 bits
clock: 66MHz
capabilities: bus_master cap_list ethernet physical
configuration: broadcast=yes driver=r8169 driverversion=2.2LK ip=192.168.1.100 latency=64 maxlatency=64 mingnt=32 module=r8169 multicast=yes


any ideas?

superprash2003
April 25th, 2008, 11:52 AM
first of all change either eth0 or eth1 to a different ip.. dont set both cards as 192.168.1.100 change one of them

gschoppe
April 25th, 2008, 04:34 PM
I changed the ip address of eth0 to 192.168.1.212, then i ran "ifdown eth0" because I don't really need it. i gave eth1 an ifdown and ifup, but no change

lots of forums have asked for "dmesg | grep eth", so here it is:


gschoppe@Hippocampus:~$ dmesg | grep eth
[ 22.571277] forcedeth: Reverse Engineered nForce ethernet driver. Version 0.61.
[ 23.091103] forcedeth 0000:00:0a.0: ifname eth0, PHY OUI 0x20 @ 1, addr 00:e0:4d:11:d6:b7
[ 23.091112] forcedeth 0000:00:0a.0: highdma csum timirq lnktim desc-v3
[ 23.092087] eth1: RTL8110s at 0xffffc200004ec000, 00:14:6c:cb:5c:7e, XID 04000000 IRQ 18
[ 23.792994] Driver 'sr' needs updating - please use bus_type methods
[ 25.247991] Driver 'sd' needs updating - please use bus_type methods
[ 43.189501] r8169: eth1: link up
[ 54.817352] eth1: no IPv6 routers present
[ 58.926602] eth0: no link during initialization.
[ 58.928282] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1599.561245] eth0: no link during initialization.
[ 1599.563000] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1867.294512] r8169: eth1: link up
[ 1883.577350] eth1: no IPv6 routers present
[ 3331.849425] eth0: no link during initialization.
[ 3331.851052] ADDRCONF(NETDEV_UP): eth0: link is not ready
[42375.958619] eth0: no link during initialization.
[42375.960265] ADDRCONF(NETDEV_UP): eth0: link is not ready
[42977.448275] eth0: no link during initialization.
[42977.449982] ADDRCONF(NETDEV_UP): eth0: link is not ready


still no connection... any other ideas?

gschoppe
April 25th, 2008, 04:47 PM
the other weird thing is that my dd-wrt router (linksys wrt54gl) shows the computer as an "active client" which implies that the issue is not with the setup of the interface, but with the computer's use of said interface.

superprash2003
April 25th, 2008, 05:29 PM
are you able to ping gateway? try ping google.com

gschoppe
April 25th, 2008, 05:34 PM
ping just sits there, and times out... no responses... if i ping www.google.com or http://www.google.com, it tells me that they don't exist (or similar).

superprash2003
April 25th, 2008, 05:42 PM
and are you able to ping your router?

joshrobinson
April 25th, 2008, 05:42 PM
can you post the output of

lspci

gschoppe
April 25th, 2008, 06:00 PM
not able to ping router, am able to ping 127.0.0.1

lspci gives:


gschoppe@Hippocampus:~$ lspci
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a4)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev b1)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a4)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f3)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
05:00.0 VGA compatible controller: nVidia Corporation NV44 [GeForce 6200 LE] (rev a1)

cubeist
April 25th, 2008, 06:19 PM
hmmm, not sure if this will work, but lets take the netgear card out of the equation...focusing on just the onboard should be a bit less confusing.

First backup your /etc/network/interfaces file like this:


sudo cp /etc/network/interfaces /etc/network/interfaces.orig


Now open your /etc/network/interfaces file


sudo gedit /etc/network/interfaces

and comment out all lines except


auto lo
iface lo inet loopback

save, restart, cross fingers, your eth should automatically get an ip...if it doesn't work you can restore original interfaces file with


sudo cp /etc/network/interfaces.orig /etc/network/interfaces

gschoppe
April 25th, 2008, 07:02 PM
i'm not sure you fully understand my set up... the gigabit pci card is the one that I need to have work... I have no cable running to the onboard card, because I need the gigabit speed... I'm serving media to a large network, and can't afford the lag that the onboard gives me...


dhclient does communicate with the router and gets me an address, now that I've set it for dhcp (this is normally static), but I still can't ping anything or connect on any service...


I think ubuntu is trying to force eth0 to be my connection, even when I disable it... is there a way to tell the system that my connection is eth1?

cubeist
April 25th, 2008, 07:54 PM
i'm not sure you fully understand my set up... the gigabit pci card is the one that I need to have work... I have no cable running to the onboard card, because I need the gigabit speed... I'm serving media to a large network, and can't afford the lag that the onboard gives me...


dhclient does communicate with the router and gets me an address, now that I've set it for dhcp (this is normally static), but I still can't ping anything or connect on any service...


I think ubuntu is trying to force eth0 to be my connection, even when I disable it... is there a way to tell the system that my connection is eth1?

maybe just try my suggestion to ensure you actually have a valid connection... this will rule out any question of whether the problem is ubuntu (most likely is) or somewhere else in your network...
If it works, then you should be able to blacklist your onboard network and it may pickup your netgear eth...

gschoppe
April 25th, 2008, 08:41 PM
still no dice...

switched interfaces (now connected to onboard) wiped out interfaces file (except for loopback) and rebooted

same situation, i get an ip, but cannot ping anything local or external other than 127.0.0.1

no connection via any program either.

the settings do show a "broadcast address" set to 192.168.1.255 .... what is that, and is it relevant?

this issue began exactly when i restarted at the end of the update process, so I highly doubt it is a network

gschoppe
April 25th, 2008, 08:43 PM
I think I'll reinstall gutsy temporarily, until there are some more updates out... I cant afford to be down for this long.

jtrindle
April 25th, 2008, 09:26 PM
do a
sudo route

from a terminal window. You should get something which includes
192.168.1.0 * 255.255.255.0 U 0 0 0 eth1
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth1

If you *don't* have these two lines it explains why things aren't working. Look in your /etc/network/interfaces, and there should be a section like:

iface eth1 inet dhcp
address 192.168.1.100
netmask 255.255.255.0
gateway 192.168.1.1


(the address line is not critical with dhcp, I don't think)


The broadcast address is appropriate for the network you are trying to set up, so don't worry about it.

gschoppe
April 26th, 2008, 03:26 AM
results of sudo route:


gschoppe@Hippocampus:~$ sudo route
[sudo] password for gschoppe:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 eth1
link-local * 255.255.0.0 U 1000 0 0 eth1
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth1


any other ideas?

gschoppe
April 26th, 2008, 03:33 AM
also, my interfaces has those exact lines

gschoppe
April 26th, 2008, 04:21 AM
I just realized that after resetting my interfaces, I now can access my router... that's great, but now I still can't get internet... I also noticed that my DNS settings on the computer point to 192.168.1.1 ... I think that's right, but I wanted to double check.


I'm partway there... any more ideas?

gschoppe
April 26th, 2008, 04:29 AM
it's officially a dns issue (at least partly) 216.239.51.99 got me google, but google.com didn't...

where should I be looking...

the manual network config tool lists 192.168.1.1 as my dns server, and that works for all my other (windows) pcs.

YAY, I know what the issue is... maybe!!!

also, as a side note, my server is accessible via 127.0.0.1, but not accessible to other network computers... so it is a two way issue

mocha
April 26th, 2008, 04:32 AM
look at /etc/resolv.conf

the nameserver lines should have the IP of your DNS server(s)

gschoppe
April 26th, 2008, 04:37 AM
resolv.conf has one line:


nameserver 192.168.1.1


should it be different? that seems right by my (limited) understanding.

ROWDY!!!
April 26th, 2008, 04:43 AM
I've got the same problems.
See this post (http://ubuntuforums.org/showthread.php?t=766629) for details.

gschoppe
April 26th, 2008, 04:58 AM
also disabled ipv6 as a test... no change... but for now i'll leave it off.

w00t, 42nd post on this account... does that mean I'll get my answer?

gschoppe
April 26th, 2008, 12:11 PM
should I turn ipv6 back on or not? could it be related? where do I go from here?

cubeist
April 26th, 2008, 07:54 PM
still no dice...

switched interfaces (now connected to onboard) wiped out interfaces file (except for loopback) and rebooted

same situation, i get an ip, but cannot ping anything local or external other than 127.0.0.1

no connection via any program either.

the settings do show a "broadcast address" set to 192.168.1.255 .... what is that, and is it relevant?

this issue began exactly when i restarted at the end of the update process, so I highly doubt it is a network

Well, if you cannot connect even with the systems recognized onboard eth0 connection, then the problem is most likely Not with ubuntu, nor with your recognized realtek card. It is your network failing to assign you an ip...

Can you log into your router and view connection details?

Do you have another OS or computer to test your router with?

Some ISP's require you to register your MAC address of your router before they will assign IP's...

edit
just to clarify... I know it looks like you are getting an ip, but I would guess it is not an external ip from your ISP, rather just a locally assigned ip from your router...
Also, ipv6 is not related...

gschoppe
April 26th, 2008, 08:27 PM
To sum up the issue at this point:

all other computers on my network (same router) have internet connections through the router that work fine
if we're referring to a public IP assigned by my ip, The router states a valid connection (via test) and dhcp renew on router is working fine.
The router states that it is supplying a static IP via dhcp to my gigabit nic in my ubuntu machine
The Ubuntu machine is recieving an IP/Subnet/Gateway from router
The Ubuntu machine can now access the router's web interface via IP and even reach google via IP, but CANNOT resolve DNS listings like http://www.google.com
192.168.1.1 is listed as my nameserver by ubuntu
this address is used by every other system with perfect results
even attempting via ip address, no other computers on my network can access my apache server, webmin, Azureus WebUI, or Samba Shares


This might be an Ubuntu issue relating to my router's settings, but the same setup is working fine for all my windows computers, and was working fine for Ubuntu until the update.

help???

cubeist
April 26th, 2008, 08:58 PM
Thanks for that! Narrows it down to dns issue. Definitely ubuntu issue.

Perhaps try to backup your resolv.conf file, then delete the contents of the file (or just comment out the dns line), restart and see if network manager correctly applies the dns info passed on from router...

this is just a stab in the dark, but I remember doing something vaguely similar when I was having network problems once before...


just for reference, here is what my resolv.conf looks like

### BEGIN INFO
#
# Modified_by: NetworkManager
# Process: /usr/bin/NetworkManager
# Process_id: ----
#
### END INFO

search gateway.2wire.net


nameserver 172.16.0.1

cubeist
April 26th, 2008, 09:16 PM
ok... my previous post probably won't work... I am thinking along a different path now...can you post contents of /etc/iftab and ifconfig again...

gschoppe
April 26th, 2008, 11:16 PM
are you sure about iftab.. it says:


# This file is no longer used and has been automatically replaced.
# See /etc/udev/rules.d/70-persistent-net.rules for more information.
#

# This file assigns persistent names to network interfaces.
# See iftab(5) for syntax.

##eth0 mac 00:e0:4d:11:d6:b7 arp 1



/etc/udev/rules.d/70-persistent-net.rules says:


# This file maintains persistent names for network interfaces.
# See udev(7) for syntax.
#
# Entries are automatically added by the 75-persistent-net-generator.rules
# file; however you are also free to add your own entries.

# Converted from /etc/iftab on upgrade
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:e0:4d:11:d6:b7", ATTRS{type}=="1", NAME="eth0"


# PCI device 0x10ec:0x8169 (r8169)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:14:6c:cb:5c:7e", ATTR{type}=="1", NAME="eth1"


ifconfig yields:


gschoppe@Hippocampus:~$ sudo ifconfig
[sudo] password for gschoppe:
eth0 Link encap:Ethernet HWaddr 00:e0:4d:11:d6:b7
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:21 Base address:0xa000

eth1 Link encap:Ethernet HWaddr 00:14:6c:cb:5c:7e
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:19850 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2033853 (1.9 MB) TX bytes:0 (0.0 B)
Interrupt:18 Base address:0xc000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1439 errors:0 dropped:0 overruns:0 frame:0
TX packets:1439 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:77006 (75.2 KB) TX bytes:77006 (75.2 KB)

gschoppe
April 27th, 2008, 12:07 AM
now I'm really confused... without restart, and without ANY messing with configuration, my box won't even access IP addresses anymore... I am utterly stumped!

i can no longer reach the router from ubuntu, or google by ip.

I tried the forcedeth fix linked to earlier, but that did not change anything.

to recap: I had a partial fix, but it somehow undid itself WITHOUT MY CHANGING ANY SETTINGS!!!

what the hell is with hardy?

cubeist
April 27th, 2008, 12:14 AM
I guess iftab was gutsy and now the rules have changed with hardy, no worries...came across a link where someone was having similar problems to you and his was caused by a MAC mismatch...but yours looks fine.

I think the solution is to blacklist your onboard eth0 module and set your interfaces file for eth1 and loopback.

I can't remember exactly how to do this... but to start comment out everything to do with eth0 in /etc/interfaces

and then try a simple

auto eth1
iface eth1 inet dhcp


there are very few resources on the web with the correct syntax for the interfaces file, but I have a unix textbook in my closet that has some good info...I'll dig that up... in the meantime, try the auto eth1...

ps - don't forget to backup your interfaces file before making changes.

gschoppe
April 27th, 2008, 12:18 AM
ifdown eth1
ifup eth1


that brought me back to the dns issue I've been at, but that was really weird... the ifconfig posted earlier might be a little off... it now reads:



gschoppe@Hippocampus:~$ sudo ifconfig
eth0 Link encap:Ethernet HWaddr 00:e0:4d:11:d6:b7
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:21 Base address:0xa000

eth1 Link encap:Ethernet HWaddr 00:14:6c:cb:5c:7e
inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:25910 errors:0 dropped:0 overruns:0 frame:0
TX packets:4720 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2949144 (2.8 MB) TX bytes:330209 (322.4 KB)
Interrupt:18 Base address:0xc000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1479 errors:0 dropped:0 overruns:0 frame:0
TX packets:1479 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:79386 (77.5 KB) TX bytes:79386 (77.5 KB)

gschoppe
April 27th, 2008, 12:24 AM
interface looks like this now:



auto lo
iface lo inet loopback

auto eth1
iface eth1 inet dhcp
address 192.168.1.100
netmask 255.255.255.0
gateway 192.168.1.1

# auto eth2
# iface eth2 inet dhcp

#auto ath0
#iface ath0 inet dhcp

#auto wlan0
#iface wlan0 inet dhcp




no change from before, only added auto eth1


no change in results... i can go to google or router via ip, but no dns.

gschoppe
April 27th, 2008, 12:28 AM
results of networking restart:



gschoppe@Hippocampus:~$ sudo /etc/init.d/networking restart
* Reconfiguring network interfaces... There is already a pid file /var/run/dhclient.eth1.pid with pid 26893
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:14:6c:cb:5c:7e
Sending on LPF/eth1/00:14:6c:cb:5c:7e
Sending on Socket/fallback
DHCPRELEASE on eth1 to 192.168.1.1 port 67
There is already a pid file /var/run/dhclient.eth1.pid with pid 0
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:14:6c:cb:5c:7e
Sending on LPF/eth1/00:14:6c:cb:5c:7e
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
DHCPOFFER of 192.168.1.100 from 192.168.1.1
DHCPREQUEST of 192.168.1.100 on eth1 to 255.255.255.255 port 67
DHCPACK of 192.168.1.100 from 192.168.1.1
bound to 192.168.1.100 -- renewal in 2147483648 seconds.
[ OK ]

cubeist
April 27th, 2008, 12:31 AM
a bit of progress...your ifconfig now shows the correct eth1 getting the ip...
try commenting out everything but

auto eth1
iface eth1 inet dhcp

do a full restart... not just network restart in terminal.

gschoppe
April 27th, 2008, 12:54 AM
the desktop failed to start gnome, and ran kde (maybe, i think, i've never used kde) as a backup... it hung for a while on a black screen with a white box in the upper corner and my mouse cursor for a while before bringing that up... the only issue I can think of is the attempted modprobe fix listed in the linked forum post on page 2... if must have gone awry.

gschoppe
April 27th, 2008, 12:56 AM
is there a way to reinstall 8.0.4 clean without losing my existing files? i have my home directory on my install partition, and not enough room to resize, partition, and move it.

cubeist
April 27th, 2008, 12:57 AM
the desktop failed to start gnome, and ran kde (maybe, i think, i've never used kde) as a backup... it hung for a while on a black screen with a white box in the upper corner and my mouse cursor for a while before bringing that up... the only issue I can think of is the attempted modprobe fix listed in the linked forum post on page 2... if must have gone awry.

yes...haven't read through that fix...but I can all but guarantee commenting out certain aspects from interfaces file will not prevent gnome from loading...

gschoppe
April 27th, 2008, 12:57 AM
BTW the GNOME Settings Daemon is what refused to start.

cubeist
April 27th, 2008, 01:04 AM
is there a way to reinstall 8.0.4 clean without losing my existing files? i have my home directory on my install partition, and not enough room to resize, partition, and move it.

no, you would have to backup your files first, then do reinstall...very time consuming... save that as a last resort.

what exactly did you do from the other thread link? looking through it seemed the advice was to rmmod the forced eth (forcedeth) and the re-initialize it with modprobe forcedeth msi=0 msix=0... is that what you did?

edit
if thats what you did you can probably reverse it by
rmmod forcedeth
modprobe forcedeth
without the msi and msix parts (I have no idea what those options do)
then restart

EDIT 2
scratch that... I don't think you even need forcedeth... it's for nvidia chipsets...

gschoppe
April 27th, 2008, 01:28 AM
I ran

sudo su
rmmod forcedeth
modprobe forcedeth

and restarted...

no dice, Gnome is still failing.

gschoppe
April 27th, 2008, 01:37 AM
could


sudo echo "blacklist ipv6">/etc/modprobe.d/blacklist-ipv6


have created the issue?

cubeist
April 27th, 2008, 01:38 AM
I ran

sudo su
rmmod forcedeth
modprobe forcedeth

and restarted...

no dice, Gnome is still failing.

did you add forcedeth to /etc/modules ? if so remove it

try this
sudo rmmod forcedeth (no need for su)

restart

cubeist
April 27th, 2008, 01:40 AM
could


sudo echo "blacklist ipv6">/etc/modprobe.d/blacklist-ipv6


have created the issue?

perhaps, but not likely... it is incorrect anyway... blacklisted modules should be in the file /etc/modprobe.d/blacklist ... no need to create a new file for a blacklisted module

gschoppe
April 27th, 2008, 01:50 AM
forcedeth is not in modules; i used sudo rmmod forcedeth and...

no dice it still errors...

could this come from removing lo from the interfaces file?

gschoppe
April 27th, 2008, 02:01 AM
it booted this time... i uncommented all the lines in interfaces I had commented, and that did the trick...

was it a problem that my first line of interfaces after the commented ones was blank?

gschoppe
April 27th, 2008, 02:15 AM
BTW I'm now back where I was befor this whole gnome interlude... where do I go from here?

cubeist
April 27th, 2008, 02:25 AM
hmmm

ok... in interfaces comment out everything but



auto lo
auto eth1
iface eth1 inet dhcp


I don't understand why removing the loopback caused the gnome problems... I can't reproduce that on my system.

Anyway, if that does not work there are only two files on ubuntu that have anything to do with dns. The first id the /etc/resolv.conf file which should have the address of your local router... in my case it is 171.16.0.1 (because I choose to use 172 addressing...no big deal really) but for you it should be 192.168.0.1

the next file is /etc/hosts This file is really only used at boot for dns recognition but is important none the less... It is rare that one has to configure manually either of these files... /etc/hosts should contain just your local information ... ie loopack and machine dns...

anyway, try the interfaces thing first...

gschoppe
April 27th, 2008, 03:44 AM
ok, total confusion level just shot up an order of magnitude...

just to be extra sure, I backed up my interfaces file and created (and triple spell checked) a totally new file from scratch...

the contents of the new file are:


auto lo
auto eth1
iface eth1 inet dhcp


saved and restarted...

Again, GNOME WILL NOT LOAD!!! GHAAAARGH!!

why the hell would what appears to be a logical setup kill GNOME?



btw: i never mentioned, but I am 64bit edition, if that explains some of the insanity.

gschoppe
April 27th, 2008, 03:55 AM
extra info to test the other possible files:

resolv.conf:


### BEGIN INFO
#
# Modified_by: NetworkManager
# Process: /usr/bin/NetworkManager
# Process_id: 4972
#
### END INFO



nameserver 192.168.1.1





hosts:


127.0.0.1 localhost
127.0.1.1 Hippocampus

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

cubeist
April 27th, 2008, 03:59 AM
ok, total confusion level just shot up an order of magnitude...

just to be extra sure, I backed up my interfaces file and created (and triple spell checked) a totally new file from scratch...

the contents of the new file are:


auto lo
auto eth1
iface eth1 inet dhcp


saved and restarted...

Again, GNOME WILL NOT LOAD!!! GHAAAARGH!!

why the hell would what appears to be a logical setup kill GNOME?



btw: i never mentioned, but I am 64bit edition, if that explains some of the insanity.

Darn... this should work...
add this line to interfaces
iface lo inet loopback

you could also try removing the auto eth1 but that will probably just revert to your onboard driver.

if that doesn't work I am not sure what the problem could be...everything else looks ok...

are you sure you need gigabit ethernet? Life would be easier for you if you just used the onboard ethernet driver!

gschoppe
April 27th, 2008, 04:07 AM
I need to stream uncompressed DVD quality and high-def video to my 3 workstations, often simultaneously... I also perform nightly grandfather - father - son backups to the Ubuntu system nightly...

Gigabit is a must.

I'll try adding the line... just gimme a couple minutes.

cubeist
April 27th, 2008, 04:11 AM
I need to stream uncompressed DVD quality and high-def video to my 3 workstations, often simultaneously... I also perform nightly grandfather - father - son backups to the Ubuntu system nightly...

Gigabit is a must.

I'll try adding the line... just gimme a couple minutes.

OK... this should work...just tried it on a second pci ethernet card on my system...

auto lo
auto eth1

thats it thats all... should boot fine, should get you an ip... the only other minor issue I see is in your /etc/resolv.conf file... I think the nameserver should be 192.168.0.1 not 192.168.1.1 ...but this is a fairly minor point.

gschoppe
April 27th, 2008, 04:22 AM
192.168.1.1 is the address of my router... my entire network is based in 192.168.1.xx addressing...


as for the previous interfaces file:


auto lo
iface lo inet loopback
auto eth1
iface eth1 inet dhcp


it loads, but the effects are exactly the same as before... no domain resolution...

is there a built in filter or proxy that could be blocking my dns or limiting my connectivity?

cubeist
April 27th, 2008, 04:28 AM
192.168.1.1 is the address of my router... my entire network is based in 192.168.1.xx addressing...


as for the previous interfaces file:


auto lo
iface lo inet loopback
auto eth1
iface eth1 inet dhcp


it loads, but the effects are exactly the same as before... no domain resolution...

is there a built in filter or proxy that could be blocking my dns or limiting my connectivity?

Not that I can think of.
I am pretty much out of ideas... I thought for sure that the interfaces changes would allow the system to automatically connect with the proper card at boot... I also read through my unix book on networking and dns and it doesn't offer any hints we haven't already tried. I am seriously wondering if something went wrong with the switch to hardy. I cannot duplicate the problems booting into gnome just by changing the interfaces file... which is definitely weird.

I'll post back if I can think of anything new

jtrindle
April 28th, 2008, 05:34 PM
If I understand the problem now, everything works fine except DNS resolution with the eth0 and lo lines in the interfaces file including loopback. You can get out to the internet with numeric IP addresses.

You must have a loopback adapter defined since many Linux/Unix components communicate with each other through socket connections on the loopback address. This allows neat things like running gnome with a remote display. Anyway, it's the way it is and a decent method for interprocess communications.

It sounds as if your router is not providing DNS services, so your setting in resolv.conf of 192.168.1.1 is insufficient. Getting this to work is dependent on your exact router so I won't presume to guess, though if it's a Linksys wireless access point I might be of help. If you tell us your ISP we might be able to find the DNS servers you need to put into resolv.conf in addition to or in place of 192.168.1.1

If you have a Windows machine working with the router via DHCP, you can find out by running ipconfig /all. Use the DNS Servers listed there in your resolv.conf.

Check /etc/dhcp3/dhclient.conf. My 7.10 installation requests domain-name-servers among other information. I don't know if this is what populates my resolv.conf, but I end up with:

search hr.cox.net
nameserver 68.105.28.12
nameserver 68.105.29.12
nameserver 68.105.28.11

*not* my router at 192.168.1.1

cubeist
April 28th, 2008, 06:16 PM
It sounds as if your router is not providing DNS services, so your setting in resolv.conf of 192.168.1.1 is insufficient. Getting this to work is dependent on your exact router so I won't presume to guess, though if it's a Linksys wireless access point I might be of help. If you tell us your ISP we might be able to find the DNS servers you need to put into resolv.conf in addition to or in place of 192.168.1.1



First, yes loopback is required... I managed to duplicate the not booting into gnome problem when removing it from interfaces file...

Second, I wonder if he could test it using opendns and bypass his (potentially) troublesome isp dns servers... (he would probably have to set the dns in his router, but might work)

http://opendns.com/

gschoppe
April 29th, 2008, 06:17 AM
I'm having a couple of (I think) more complex issues than that:


DNS isn't working with the router (the only DNS used by any of my 7 computers, as attested to by ipconfig -all and the settings on my XBMC), I've tested with open DNS and my ISPs DNS, still no dice.
none of my other network devices (SAMBA shares, LAMP install on a Windows box, Brother HL2070N, FreeNAS, XBMC WebUI, FTP Shares) are available by IP or local DNS
none of the network services provided by the Ubuntu box (LAMP, FTP, SSH, SAMBA, Azureus WebUI, Webmin, UPNP Audio, Email, etc... ) are available to any of the other computers on the network
for inexplicable reasons, even the access I have by IP disappears from time to time, and I have to restart networking to get it back
Networking works "out of the box" from the Heron live CD



Something about my upgrade is well and truly Frelled (pardon my Nebari)...

as soon as I've managed to isolate all personal data from my install partition (a multi-step process involving resizing partitions [some of my stuff needs to stay on the SSD and not in RAID]) I'll be performing a clean install.

cubeist
April 29th, 2008, 06:51 PM
I'm having a couple of (I think) more complex issues than that:


DNS isn't working with the router (the only DNS used by any of my 7 computers, as attested to by ipconfig -all and the settings on my XBMC), I've tested with open DNS and my ISPs DNS, still no dice.
none of my other network devices (SAMBA shares, LAMP install on a Windows box, Brother HL2070N, FreeNAS, XBMC WebUI, FTP Shares) are available by IP or local DNS
none of the network services provided by the Ubuntu box (LAMP, FTP, SSH, SAMBA, Azureus WebUI, Webmin, UPNP Audio, Email, etc... ) are available to any of the other computers on the network
for inexplicable reasons, even the access I have by IP disappears from time to time, and I have to restart networking to get it back
Networking works "out of the box" from the Heron live CD



Something about my upgrade is well and truly Frelled (pardon my Nebari)...

as soon as I've managed to isolate all personal data from my install partition (a multi-step process involving resizing partitions [some of my stuff needs to stay on the SSD and not in RAID]) I'll be performing a clean install.


Yes, I think something did not go right with the update.

There is one thing you could try before doing a clean install.

There is a command



sudo dpkg-reconfigure -a


Reading the man page for dpkg-reconfigure it says:
"Reconfigure all installed packages that use debconf. Warning: this may take a long time."

I have never used this command (the -a part anyway) and aside from it taking a long time it will reconfigure everything and all your customized settings will revert to defaults... including graphics.

So while this may fix your networking, it may also cause other headaches.

Edit -
Actually I don't know if I should recommend dpkg-reconfigure -a as I am not sure if it won't erase data... Make sure to backup essential files first!

gschoppe
April 30th, 2008, 10:27 PM
I did my backup and clean install, and while reloading my packages,

I FIGURED OUT MY PROBLEM!!!

--MOBLOCK KILLED MY INTERNET--

i had entirely forgotten that I ran it, apparently, even a newly compiled moblock made on Hardy 64bit will not allow me to access the net... any ideas on how to reconfigure it without losing it entirely?

jre
May 1st, 2008, 12:42 PM
I did my backup and clean install, and while reloading my packages,

I FIGURED OUT MY PROBLEM!!!

--MOBLOCK KILLED MY INTERNET--

i had entirely forgotten that I ran it, apparently, even a newly compiled moblock made on Hardy 64bit will not allow me to access the net... any ideas on how to reconfigure it without losing it entirely?

Set something like this in /etc/moblock/default:
WHITE_TCP_OUT="80 443"
WHITE_IP_IN="192.168.0.0/24"
WHITE_IP_OUT="192.168.0.0/24"

The first line whitelists (= turns off MoBlock's checking) on ports 80 (http) and 443 (https) - so browsing the web will always work.
The next two lines whitelist your LAN and router (in this case the IPs 192.168.0.1-192.168.0.255) - edit it to your needs. You can get your IP with "sudo ifconfig"

Ocean Tramp
July 7th, 2009, 10:26 AM
Hi dear Community
You have saved me from deleting and reinstalling everything.
My Ethernet card works again! ;o)
Thank you heaps!
Ubuntu 9.0.4 is great fun!