PDA

View Full Version : [ubuntu] initramfs + busybox trouble installing



Pages : [1] 2

wconstantine
April 24th, 2008, 06:57 PM
I'm stuck at initramfs after trying to launch the livecd/install ubuntu. I've tried safe graphics mode and several boot parameters such as: noirqdebug irqpoll noapic nolapic nomsi

It loads the linux kernel, then the loading bar shows up. It loads and then it just pops up initramfs.

My system specs are E6600, 8800GT, MSI P965 Neo, 2GB 667MHz.

matl1984
April 24th, 2008, 08:17 PM
i got the same message.

i turned the "sata mode" in bios from "ahci" to "raid" and then it works

my motherboard is asrock 775 twins hdtv r2.0.
my hard disks are seagate Barracuda 7200.10 320GB 16MB
i have 2 sata disks and only dvds are at primary ide master and secondary ide master

my messages - not exactly:


BusyBox 1.1.3...
initramfs
[time..] ata1: COMRESET failed (errno:-16)
[time..] ata1: COMRESET failed (errno:-16)
[time..] ata1: COMRESET failed (errno:-16)
[time..] ata1: COMRESET failed (errno:-16)
[time..] ata1: reset failed. giving up
[time..] ata2: COMRESET failed (errno:-16)
[time..] ata2: COMRESET failed (errno:-16)
[time..] ata2: COMRESET failed (errno:-16)
[time..] ata2: COMRESET failed (errno:-16)
[time..] ata2: reset failed. giving up

Daveoc64
April 24th, 2008, 09:06 PM
Thank you!

That fixed my installation, so I don't need to reinstall!

wconstantine
April 24th, 2008, 09:31 PM
i got the same message.

i turned the "sata mode" in bios from "ahci" to "raid" and then it works

my motherboard is asrock 775 twins hdtv r2.0.
my hard disks are seagate Barracuda 7200.10 320GB 16MB
i have 2 sata disks and only dvds are at primary ide master and secondary ide master

my messages - not exactly:


BusyBox 1.1.3...
initramfs
[time..] ata1: COMRESET failed (errno:-16)
[time..] ata1: COMRESET failed (errno:-16)
[time..] ata1: COMRESET failed (errno:-16)
[time..] ata1: COMRESET failed (errno:-16)
[time..] ata1: reset failed. giving up
[time..] ata2: COMRESET failed (errno:-16)
[time..] ata2: COMRESET failed (errno:-16)
[time..] ata2: COMRESET failed (errno:-16)
[time..] ata2: COMRESET failed (errno:-16)
[time..] ata2: reset failed. giving up

Do you have raid? Because I don't. Dunno why that should do the trick. Will try tho.

Edit: Didn't work.

I've located the problem to be with the wonderful JMicron that my motherboard has. It's a major pain in the ***. Any ideas that could help me?

garyc_onbuntu
April 24th, 2008, 10:24 PM
I had a similar problem on a Dell Vostro 200 - attempts to install or check the CD (8.04 i386 desktop) just resulted in being dumped to the BusyBox screen with (initramfs) showing.

Eventually it would show [111.485885] ata 1.00: revalidation failed.

I went into the BIOS and change the SATA mode from 'IDE' to 'RAID', rebooted and its now installing as I write.

What does this actually do? I have one SATA HDD and a SATA DVD-RW. The machine was a new machine reject due to case damage and the disk had been reformatted with FAT32 if that makes any difference.

Anyway, I'm up and running so thanks alot for the tip.

painaxl
April 25th, 2008, 04:17 AM
I had this same issue and it was resolved by switching from IDE to RAID in the BIOS.

HOWEVER... I was trying to set up a dual boot with Vista using easybcd. I got into Ubuntu fine, but when I tried to reboot into Vista, it wouldn't even get to the splash screen before it rebooted the system. I did the entire rebuild of the bootloader as written on the excellent tutorials on the easybcd site and nothing changed. So I went back into the BIOS and changed the SATA setting back to IDE. That did it and Vista booted fine.

What does that setting do and why does Vista only accept the IDE setting and Ubuntu the RAID setting? I've got a SATA HDD and a SATA DVD-RW, like Gary C, in a Dell Inspiron 530. Any ideas on why this is necessary and what's happening?

azurehi
April 25th, 2008, 06:48 AM
I get the same initramfs + busybox message. I have no idea how to access bios and can't understand why, after using ubuntu successfully since 6.06, I cannot install 8.04. I have downloaded the image X3 and also the alternate install image and get the same error. I am stymied. Help please - thank you.

matl1984
April 25th, 2008, 07:30 AM
my vista ultimate x64 starts normally even if i switch from ahci to raid mode.

vista supports my 2 modes: AHCI / RAID
ubuntu 8.04 can start only successful with the RAID mode.

i have no raid configured yet (previously i had one configured).

the raid mode is also a bit slower as the AHCI mode during system boot (the grub boot loader comes later)

as you can see here AHCI is a published standard from Intel and requires a license from them. so maybe no one from ubuntu/linux has implemented it now???
http://de.wikipedia.org/wiki/Advanced_Host_Controller_Interface

jedimasterk
April 25th, 2008, 07:36 AM
my vista ultimate x64 starts normally even if i switch from ahci to raid mode.

vista supports my 2 modes: AHCI / RAID
ubuntu 8.04 can start only successful with the RAID mode.

i have no raid configured yet (previously i had one configured).

the raid mode is also a bit slower as the AHCI mode during system boot (the grub boot loader comes later)

as you can see here AHCI is an published standard from Intel and requires a license from them. so maybe no one from ubuntu/linux has implemented it now???
http://de.wikipedia.org/wiki/Advanced_Host_Controller_Interface

This is ridiculous!. What if we don't have RAID and use a SATA drive. Never was a problem with 7.10. This version needs to be pulled of the mirrors and fixed, before it is an LTS!!!.

jedimasterk
April 25th, 2008, 07:37 AM
How are "NEWBEES" to Linux going to know how to go into a BIOS!!. Give me a break!!.

logicslayer
April 25th, 2008, 07:43 AM
Enter the CMOS/BIOS by pressing one of the below five keys during the boot. Usually it's one of the first three.

* F1
* F2
* DEL
* ESC
* F10

A user will know when to press this key when they see a message similar to the below example as the computer is booting. Some older computers may also display a flashing block to indicate when to press the F1 or F2 keys.

Press <F2> to enter BIOS setup

Tip: If your computer is a new computer and you are unsure of what key to press when the computer is booting, try pressing and holding one or more keys the keyboard. This will cause a stuck key error, which may allow you to enter the BIOS setup.

matl1984
April 25th, 2008, 07:53 AM
here's a screenshot from the bios setting from my motherboard manual. maybe this helps someone.

jedimasterk
April 25th, 2008, 07:53 AM
I've never had to change anything in the bios to get Ubuntu running except the boot order.

kdnewton
April 25th, 2008, 08:22 AM
I'm in the same boat.

320GB SATA2 hard-drive split 260GB to WinXP and 50+ to Ubuntu 7.10 currently.

I can confirm that both the AMD64 and i386 Live-CD versions dead-end at the busybox / initramfs / ash thinger. I've tried playing with my bios and I can't find a configuration that works. I tried all of "Check CD for Defects", "Try without changing" and "Install" and they *all* lead to the busybox interface.

I did burn the images at 20x write to Sony 700MB CDs. The 8.04 i386 CD installs fine to my old HP Pavilion laptop, but busybox me on my desktop.

I'm now burning the Alternate i386 at the slowest write speed and am going to try that.

Canonical you and I know know you don't owe me anything. I'm just one person. However, I have to say that this sucks that the possible configuration of my computer is going to "busybox" me and the hundreds of other people out there who don't feel the need to post their cares to the forums.

My iso-burn is done. Back in a few.

aliasbind
April 25th, 2008, 08:25 AM
changing from AHCI/IDE to SATA doesn't solve the problem. when the screen with the ubuntu logo and orange bar moving left-right appears, the OS seems to search "desperately" for a disk in the floppy and if i put one in it, it gives an error and then continues loading perfectly.

i have 2 HDs (1x SATA, 1x IDE). ubuntu can't detect the SATA HD, but, amazingly, it detects the IDE as SATA. this is getting creepy!

kdnewton
April 25th, 2008, 08:42 AM
I'd read what jedimasterk wrote in another thread, that to the alternate CD is to loathe and we shouldn't have to resort to it.

I agree, but it seems to be doing the trick for me.

After burning it and booting into it, I started up the install right away. The install hung up for quite a while and didn't seem to be doing anything. I CTRL-C`d it and saw that it appeared to be in an infinite loop, something to do about not finding a database.

A quick search on the f0s here and I find that someone recommended pressing F6 from the alternate boot menu and adding "pci=nomsi" to the boot arguments. That seemed to do the trick.

Now I'm already over 50% done the last stage of the installation process (select and install software).

kdnewton
April 25th, 2008, 08:56 AM
Just a follow up. I'm now swimming happily through the Hardy Heron i386 desktop, thanks to the alternate CD and pci=nomsi argument.

wconstantine
April 25th, 2008, 09:05 AM
Seems like we have unveiled a major problem with 8.04. Although, none of you are experiencing this due to same reason as I. :mad:

ig72
April 25th, 2008, 01:41 PM
I also have this problem on a machine I built myself using an Asus A8-VM CSM motherboard.

It has a single 300Gb sata drive and an IDE DVD writer.

On any option in the install menu, Normal/safe mode check CD etc
as the ubuntu logo appears I see it access the HDD for a second (and I hear the drive seeking) then the CD is accessed for a second, this repeats approx 10 times, after this it then dumps me to the Busybox console with no error messages.

I have tried enabling raid in the BIOS but this makes no difference whatsoever.

I will try the above mentioned "pci=nomsi" in alternate boot options later on today and report if it works.

amosbr
April 25th, 2008, 02:55 PM
I have the same problem. I try to install in any of the different modes and at first i get the ubuntu loading screen for about 2 minutes and then the busybox thingy. The problem i have is i can't seem to find that SATA option in my CMOS. Also, how do I get to "alternate boot options" in order to try the pci=nomsi method?
Thanks.

amosbr
April 25th, 2008, 02:56 PM
sorry admins accidentally posted twice please delete

dishayu
April 25th, 2008, 02:57 PM
same motherbaord, same problem...

BUT
it did run once on mine, i guess the second time i tried, but then i recalled i had to backup some stuff prom my previous 64 bit install (moving to 32 bit now).. and when i backed up the data and tried again...

BAM!!
it just won't work... tried 2 CDs burnt at 16x and both lead to the same screen...

wconstantine
April 25th, 2008, 03:03 PM
I have the same problem. I try to install in any of the different modes and at first i get the ubuntu loading screen for about 2 minutes and then the busybox thingy. The problem i have is i can't seem to find that SATA option in my CMOS. Also, how do I get to "alternate boot options" in order to try the pci=nomsi method?
Thanks.

You press F6 in the menu in order to edit. Just write after the --. :)

azurehi
April 25th, 2008, 04:08 PM
1. changing BIOS from IDE to RAID accomplished Nothing -- still reach initramfs screen and cannot install ubuntu 8.04

2. from F6 adding "pci=nomsi" did nothing -- still reach initramfs screen and cannot install ubuntu 8.04

Would installing 7.10 and then updating to 8.04 seem a viable solution. Any suggestions much appreciated.

amosbr
April 25th, 2008, 04:08 PM
You press F6 in the menu in order to edit. Just write after the --. :)
sorry for noobness, but what menu are you referring to?

dishayu
April 25th, 2008, 04:23 PM
sorry for noobness, but what menu are you referring to?

the menu you are shown when you boot from the cd...

use your eyes, it's written on the bottom of that screen..


PS : so what's the conclusion? does using a msi p965 neo imply that i'm not going to run hardy on my pc??

avenger3000
April 25th, 2008, 04:52 PM
same problem here mates.. i have an asus p5w dh deluxe mobo, two sata hd drives and one ide drive, when i try to boot hardy i get the Busybox message. right now i'm at work but i will give the -- pci-msi parameter a try.. whats more frustrating is the fact that 7.10 starts up normally and i can install it flawlessly.

dishayu
April 25th, 2008, 05:16 PM
okay... everyone on a msi p965 neo IDE cd drive and SATA hard drive... I figured out a solution to work the way around this issue and i shalt give it to you if you all bow down to me... hehe now, jokes apart...

your harddisk most probably is connected to ich8 sata port, plug it into the jmicron sata port (the only one which stands out) and launch the setup, works flawlessly for me... other motherboards with jmicron bios should also
work similarly, although i'm just guessing here...


ENJOY...

PS : drop in an appreciation e-mail to dishayu@gmail.com if this works for you.. i almost never visit the forums..

wconstantine
April 25th, 2008, 05:59 PM
okay... everyone on a msi p965 neo IDE cd drive and SATA hard drive... I figured out a solution to work the way around this issue and i shalt give it to you if you all bow down to me... hehe now, jokes apart...

your harddisk most probably is connected to ich8 sata port, plug it into the jmicron sata port (the only one which stands out) and launch the setup, works flawlessly for me... other motherboards with jmicron bios should also
work similarly, although i'm just guessing here...


ENJOY...

PS : drop in an appreciation e-mail to dishayu@gmail.com if this works for you.. i almost never visit the forums..

My SATA HDD is connected to that very port. Although I have several harddrives.. Could that be the problem?

By the "one that stands out", do you mean sata 1? Here's an image of the mobo sata ports.
http://www.hardwarezone.com.sg/img/data/articles/2006/1987/P965Neo_SATA.jpg

dr_john_doe
April 25th, 2008, 06:04 PM
changing from AHCI/IDE to SATA doesn't solve the problem. when the screen with the ubuntu logo and orange bar moving left-right appears, the OS seems to search "desperately" for a disk in the floppy and if i put one in it, it gives an error and then continues loading perfectly.

i have 2 HDs (1x SATA, 1x IDE). ubuntu can't detect the SATA HD, but, amazingly, it detects the IDE as SATA. this is getting creepy!
Aliasbind's hint was right: I noticed the system trying to get a floppy. I inserted one, then ubuntu read the floppy for some time and finally continued to boot from CD. No error message or anything, just reading the floppy. While I'm writing this posting I still use ubuntu 8.04 in Live-CD mode.

And I have a ASUS P5B-Deluxe mainboard with this f****g JMicron controller stuck on it! This one gave me trouble eversince I bought the board some 18 months ago using Windows or different Linux distributions. Now it's definitly time to buy some SATA DVD-Writer and disable this controller. Perhaps it interferes here as well as some other users mention it as part of their system, too.

dr_john_doe
April 25th, 2008, 06:06 PM
(...) when the screen with the ubuntu logo and orange bar moving left-right appears, the OS seems to search "desperately" for a disk in the floppy and if i put one in it, it gives an error and then continues loading perfectly.

Aliasbind's hint was right: I noticed the system trying to get a floppy. I inserted one, then ubuntu read the floppy for some time and finally continued to boot from CD. No error message or anything, just reading the floppy. While I'm writing this posting I still use ubuntu 8.04 in Live-CD mode.

And I have a ASUS P5B-Deluxe mainboard with this f****g JMicron controller stuck on it! This one gave me trouble eversince I bought the board some 18 months ago using Windows or different Linux distributions. Now it's definitly time to buy some SATA DVD-Writer and disable this controller. Perhaps it interferes here as well as some other users mention it as part of their system, too.

dishayu
April 25th, 2008, 06:11 PM
My SATA HDD is connected to that very port. Although I have several harddrives.. Could that be the problem?

By the "one that stands out", do you mean sata 1? Here's an image of the mobo sata ports.
http://www.hardwarezone.com.sg/img/data/articles/2006/1987/P965Neo_SATA.jpg

and yes, i do mean SATA 1, the one next to the IDE port... the darker coloured one...
try using just 1 harddisk while installation, it worked in one go for me...

azurehi
April 25th, 2008, 06:53 PM
I guess I have to give up on ubuntu 8.04...still reach initramfs no matter what I do. I get this also with kubuntu 8.04.

azurehi
April 25th, 2008, 09:15 PM
I guess I have to give up on ubuntu 8.04...still reach initramfs no matter what I do. I get this also with kubuntu 8.04.

jedimasterk
April 25th, 2008, 09:22 PM
Aliasbind's hint was right: I noticed the system trying to get a floppy. I inserted one, then ubuntu read the floppy for some time and finally continued to boot from CD. No error message or anything, just reading the floppy. While I'm writing this posting I still use ubuntu 8.04 in Live-CD mode.

And I have a ASUS P5B-Deluxe mainboard with this f****g JMicron controller stuck on it! This one gave me trouble eversince I bought the board some 18 months ago using Windows or different Linux distributions. Now it's definitly time to buy some SATA DVD-Writer and disable this controller. Perhaps it interferes here as well as some other users mention it as part of their system, too.

You know I remember my floppy drive constantly turning on and off as well, when booting from 8.04 Live cd than I get the bars than (initramfs)_ prompt. Didn't try inserting a floppy. But oh well, sticking with 7.10. It works!.

jedimasterk
April 25th, 2008, 09:25 PM
I think Caninical should release a new Live CD, that fixes the floppy detection issue. This may be the problem!. 8.04.1 canonical. Before the Shipit cds are sent.

HDave
April 25th, 2008, 10:32 PM
This is not just a floppy detection issue. I have a Dell XPS M1210 laptop with no floppy drive at all and I am getting the same issue: boot into busybox.

I tried the pci=nomsi workaround and it didn't work.

I can't believe that simply upgrading to Hardy has bricked my PC. The only thing that works is the Windows XP side of the dual boot....arrggghhh.

HDave
April 25th, 2008, 11:12 PM
FIXED!

The hard drive UUID in my GRUB menu.lst was wrong. I had swapped out my hard drive when my machine was running Gutsy. I had fixed the UUID in /etc/fstab (you have to or you can't login). However I never changed the UUID in /boot/grub/menu.lst and when I upgraded to Hardy I used the new "merge" capability to get my new menu.lst file.

Apparently Gutsy didn't care the UUID was wrong, but Hardy does. I booted into windows, copied the UUID from fstab and pasted it into menu.lst I now I am swimming in 8.04 goodness.

mat.wojcik
April 25th, 2008, 11:15 PM
I don't have any SATA devices in my PC and I have the same bug! The option pci=nomsi doesn't work. I'm afraid of doing dist-upgrade, cause it might be the same error but on my installed system...

avenger3000
April 26th, 2008, 07:25 AM
the pci=nomsi trick didn't work for me either... i have installed 7.10 on my ide drive and then upgrade it to 8.04. everything went fine. the problem is that when i try to boot windows i get the following error "error 21: selected disk does not exist" if i set as first boot device my windows disk it boots normally but i loose grub since its located on my ide drive.

om1n[A]e
April 26th, 2008, 11:10 AM
i also have the problem with initramfs;

hardware:
MSI P965 Neo-F
250GB SATA HD (connected to ICH8)
DVDRW SATA (connected to Jmicron)

i also noticed that the system tries to read from floppy, so I'll try this recommendation tomorrow. however, i also think that canonical should fix this issue with a new live-cd

Maqz447
April 26th, 2008, 11:39 AM
Hi folks, I updated from 7.10 to 8.04 using the Update Manager, and now I have the same problem. The Ubuntu splash screen hangs for a while trying to mount the root file system, then I'm dumbed into Busy Box and get the initframs error message repeatedly in some kind of infinite loop. The strange thing is that 2 times I did get Hardy up and running without doing anything different, and everything seemed to work fine, but when I restart it just hangs again!

I tried to change the "SATA mode" setting in my BIOS from "IDE" to "RAID" (my HD is a SATA, I have a Dell Inspiron 530), and that did do the trick insofar as I got Hardy to mount the drive, however it was extremely unresponsive to mouse and keyboard input for some reason, so much that it was practically unusable. And, I was then unable to get into Windows (I dual-boot with Vista). So now I've reset it to IDE, and I can't boot Hardy.

8.04 seems to have a major problem with SATA drives... I'll be following this thread to see if any solutions come up, I would deeply appreciate any suggestions anyone might have.

mat.wojcik
April 26th, 2008, 12:03 PM
I do not have SATA drive, I tried to remove 'quiet splash' from boot options in Live CD and I got these errors before Busybox:


Add. Sense: Logical unit communication CRC Error (Ultra-DMA/32)
end request: I/O error, dev sr1, sector 1384512
Sense key: Hardware Error [current]
SQUASHES error: sb-brod failed reading block 0xa8789
SQUASHES error: unable to read uid/gid table

Can you help me with that?

Jong
April 26th, 2008, 12:23 PM
Enabling floppy drive in BIOS even though I don't have one, made the "busybox initramfs" message disappear.

Now I'm stucked with the "buffer i/o error on device fd0" message. As described by other users, it just loops infinite...

I haven't tried changing the interface from "IDE" to "RAID" though.

Hardware:
AMD64 3700+
ASUS A8N-E mb
2 Samsung SP250 SATA-II hd

Edit: Tried installing from the alternate cd, but it can't even detect/mount my cd drive during installation. Very disappointing :(

Aearenda
April 26th, 2008, 12:27 PM
Maqz447, try the all_generic_ide boot option mentioned in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/153702 - this works on my 530 with Hardy, but then so does the RAID setting in the BIOS, for me!

Maqz447
April 26th, 2008, 01:17 PM
Thanks for the link Aerenada, that's very interesting. Now, pardon my noobness, but I'm not entirely sure how to add the boot option "all_generic_ide" to GRUB. Can I do this from GRUB itself, or do I have to edit /boot/grub/menu.lst, or something else?

wconstantine
April 26th, 2008, 02:30 PM
I enabled a floppy in the bios as well, though I don't have one. Now I just loads a really long time and then it drops me a black screen. After a few seconds this message appears with random digits in fron of them. Repeatedly.


Buffer I/O error on device fd0, logical block 0 :popcorn:

Maqz447
April 26th, 2008, 02:35 PM
Ok, so I appended "all_generic_ide" to the "kernel" line in GRUB. That did nothing, however. It still hangs when it's trying to mount the root file system. I changed the SATA setting to RAID in my BIOS again, and edited the same line in /boot/grub/menu.lst (typing s l o w l y because Ubuntu was so unresponsive to keyboard input, just like last time I changed this setting to RAID), but that still doesn't help when I switch the BIOS setting back to IDE.

Using the RAID setting is no option for me, as I sometimes need to use Windows, and Ubuntu becomes more or less unusable even though it does boot.

tofuconfetti
April 26th, 2008, 02:44 PM
Okay after a lot of searching, I found a far simpler fix, and the only one that worked for me. I am running an Intel motherboard with an e6600 quadcore chipset. It has a Marvell 88SE61xx SATA controller. I got the same freeze with the same busybox message. So I did more searching in the bugs list and found this link that explains a possible workaround (https://wiki.ubuntu.com/WubiGuide#head-9fe000fa2e31a632fdcf384438b2aee35076c623). Interestingly, when I booted into the graphical boot menu and hit 'esc' to go into the non-graphical menu and tried to hand edit the boot options, I got a "kernel not found" message. It dawned on me that the drives weren't being recognized by the kernel.

I could NOT use the directions listed in that workaround, so I experimented and found how how I could make it work. Try this:

1] Boot the Live CD and select your language.

2] When you are in the graphical menu, hit <F6> for "other options" and when you do you'll see the actual kernel boot line and at the end you'll see a ' -- ' and the cursor will be placed just after the end of the line just after the ' -- '.

3] At the cursor type: 'irqpoll' (obviously without the quotes).

4] Hit enter to start the boot process.

Worked like a charm and I booted into the Live CD.

Now I haven't tested this with an actual install, BUT if it hangs on a fresh install, boot into the live CD as above, mount the system partition, and edit the /boot/grub/menu.lst file and add 'irqpoll' to the kernel boot line. That is what I am going to try if it hangs on install.

I'm currently typing this from the Live CD, so haven't tried that yet.

Maqz447
April 26th, 2008, 03:35 PM
Thanks for the tip on irqpoll! I added 'irqpoll' to the kernel line in GRUB, and am now typing this at full speed from Hardy Heron! There's only one small problem so far: CPU scaling isn't working, so that my 1.86 GHz Core 2 Duo is always running at 1.86 GHz, whereas it used to idle at 1.60 most of the time. Other than that, seems to be working fine.

tofuconfetti
April 26th, 2008, 03:43 PM
It seems that the kernel that made it into the distribution doesn't have this same problem. Once I installed, it booted right up. The problem seems to be with the differing bios' method of SATA drive assignment. I'll leave it up to the kernel whizkids to figure out exactly why.

So I did not need to modify the /boot/grub/menu.lst kernel boot options. If the problem persists after boot, you may have to do that.

For the record, I have two other AMD 64 AM2 based motherboard computers neither of which had this problem. It only happened with the Intel board using the quad-core chip.

Mazq447, I'll know more about the scaling once I monitor the system for a while. Glad the workaround worked for you.

Caligatio
April 26th, 2008, 03:50 PM
I'm going to bump this as there's a lot of 1 post threads that I think are duplicates of this.

I'm running a ABIT IP-35 board... my boot problem is intermittent. It won't work for like 5 attempts.. I go into Vista to look at posts.. try again and it works.

There's a few launchpad posts about this.. apparently it may be a problem with the kernel version.

sorta90
April 26th, 2008, 05:49 PM
i got the same message.

i turned the "sata mode" in bios from "ahci" to "raid" and then it works

my motherboard is asrock 775 twins hdtv r2.0.
my hard disks are seagate Barracuda 7200.10 320GB 16MB
i have 2 sata disks and only dvds are at primary ide master and secondary ide master

my messages - not exactly:


BusyBox 1.1.3...
initramfs
[time..] ata1: COMRESET failed (errno:-16)
[time..] ata1: COMRESET failed (errno:-16)
[time..] ata1: COMRESET failed (errno:-16)
[time..] ata1: COMRESET failed (errno:-16)
[time..] ata1: reset failed. giving up
[time..] ata2: COMRESET failed (errno:-16)
[time..] ata2: COMRESET failed (errno:-16)
[time..] ata2: COMRESET failed (errno:-16)
[time..] ata2: COMRESET failed (errno:-16)
[time..] ata2: reset failed. giving up
will this bios thing on raid work with my windows xp media center edition ( im relatively new to this)

tofuconfetti
April 26th, 2008, 06:15 PM
Did you try adding 'irqpoll' at the end of the boot string from the graphical boot up menu? Rather than change a working bios with a Windows install, changing your boot options is less intrusive on the system and less apt to mess up your working Windows install.

Also, if you are new, I'd highly recommend putting Ubuntu on a second drive. Careful "moving" or "resizing" partitions unless you know what you're doing.

felipe de la muerte
April 26th, 2008, 06:42 PM
hello,

i have a similar problem with hardy.
after a simple upgrade some things did not work anymore (fglrx....), so i decided to do a clean install, since my home folder is on a different partition anyway.
but after the upgrade i got some problems with my cd writer, the system would freeze every time i wanted to burn the cd. i was getting some strange messages on tty1, like

[ time...] hdb: drive not ready for command
[ time...] hdb: timeout verifying DMA

these come up again and again, and the system freezes, so i had to burn the cd in winxp. never seen things like this before.
the live cd brings up busybox and also some weird messages like

[ time...] ata4.01: cmd a0/01:00:00:80:00/00:00:00:00:00/b0 tag 0 dma 128 in
[ time...] ata4.01: status { DRDY }
[ time...] exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen

again and again every 40-50 units in "time" (seconds? :D).

i'll try the bios thing now.

but seriously: wtf?

UPDATE:
neither the adding irqpoll nor all_generic_ide to the boot string of the live cd helped. my single sata-disk is already managed as raid by the bios, because winxp needed it for some reason.
well, i don't really know what else to try.

strumluff
April 26th, 2008, 10:27 PM
Hi All,

I also got this issue on my laptop (worked fine on my desktop) when trying to boot with the Live CD. I haven't made any changes to my hardware and I dont even have a SATA hard drive in it...seems that this is happening to multiple users but for different reasons.

I couldn't fix it so I tried a dist-upgrade from Gutsy and it worked fine, I guess that will have to do, even though I wanted a clean install...

Aearenda
April 26th, 2008, 11:38 PM
mazq447: Sorry for not supplying the details, it was night time here :-)

I'm glad it is working for you now!

Gentleman83301
April 27th, 2008, 06:47 AM
I am having this exact same problem as well. I was able to install 8.04 clean onto a Dell precision workstation 4300 without any issues. When I try to toss it onto my desktop I reach the same result as everyone else above. Tried the switches, tried the floppy trick, bios etc. Been scouring the forums/google for work-arounds and so far the only one that really works is to not use 8.04 :(

Fury161
April 27th, 2008, 07:38 AM
Same problem here.

Can anybody help me?

2 SATA Hard Drives.
2 IDE DVD-ROM/RW

Bios:

Both (SATA/PATA) => Ubuntu 8.04 Initramfs + Busybox trouble installing and entering

Just SATA => Everything works except DVD-ROM/RW (So I can't either install it through live CD nor use my DVD-ROM devices in my ubuntu updated from feisty)

Thanks a lot everyone

Tarmael
April 27th, 2008, 08:09 AM
I can report that 8.04 is working now after using the pci=nomsi workaround after trying the AHCI to RAID (or any other variant for that matter) and the irqpoll workaround.

Also, I'd like to note that I installed the 8.04 RC Desktop version (as it's the only one I have and I don't have the internet connected to that computer.)

Thank you all. Good luck.

Basil.

Jong
April 27th, 2008, 10:19 AM
OMG, I'm up running with Hardy now :lol:
No IDE to RAID switch, nor enabling the floppy drive (I disabled it again).

Using the desktop live cd, what did the trick for me was adding
all_generic_ide floppy=off irqpoll to the boot options when pressing F6. I can't tell if you really need all three options. I'm just happy to be up running :D

Hope this may help someone - good luck to everyone.

felipe de la muerte
April 27th, 2008, 12:28 PM
ok my hardy heron seems to work now, too!

all the bootoptions did not help. what i did was that i put my cd-writer from primary slave to secondary slave, and everything worked fine. i really don't know why. maybe this can help someone.

no i've got my dvd-rom on primary master and the cd-writer on secondary slave (i have to change the jumpers to get it on master), and my harddisk on the s-ata port. maybe the dvd-rom and cd-writer interfered somehow.

Fenris_rising
April 27th, 2008, 01:22 PM
hi all

ive been trying for days to get HH on my PC. i have an ASUS A8V-VM with a SATA drive as primary with XP pro. i installed HH within windows and rebooted. got the fd0 error and eneded up at initramfs. i went into bios and disabled the floppy which isnt connected anyway. reboot and select ubuntu and hit esc for menu and then 'e' to edit. to the second line of the 3 presented i added pci=nomsi enter then b to boot. HH then did its install yayyyyyyyyyyyy it rebooted...........initramfs boooooooo!!!!
so i reboot and go into the menu again and once more i enter the pci=nomsi. boot and good god!!! its in and on!!!!! now i must stress im a novice and its only reading in this forum thats helped plus a bit of lucky guess work. i didnt really know where to type the pci=nomsi for sure and until i reboot the PC i dont know if ill need to do it again. anyone know?? glad to say the wireless internet access has worked within seconds of HH coming on. BTW last night i cocked it right up and trashed my HDD so i was up till3 oclock this morning reinstalling XP and all the drivers and software. so fingers crossed i have a dual boot system.
all being well ive got a bit of a steep learning curve ahead.
good luck to all dont give up, if a numpty like me can get this far theres hope for us all.........poor bill gates mwahahahaha!

regards

Fenris

Tom_R
April 27th, 2008, 02:38 PM
I had the busybox thing come up on me too. I could switch screens and the boot stuff told me a UUID could not be found. I tried some of the things posted here and nothing helped. I booted a live cd to see what was up and it told me the drive I tried to install to had a bad superblock. I was using 7.10 with that drive no problems, but it's an older IDE 60gb drive.

I solved my problem by installing on a 320gb SATA drive where windows xp used to be. I figured I haven't used it in months and if I need it I'll try to install it on the other disk.

om1n[A]e
April 27th, 2008, 03:44 PM
works for me now, only thing needed was irqpoll...

Neo0351
April 27th, 2008, 04:48 PM
i think it is the something wrong with the kernel. i updated from gutsy and i got the same thing as the live cd, busy box. the alt. cd didnt work either cause it coudnt find my either HDD. i seem to remember this problem with i think it was 7.04 also. anyways, so the 2.6.24 kernel didnt boot right, but i can boot just fine with the old 2.6.22 kernel. go figure.

blindd0t
April 27th, 2008, 05:15 PM
Jong:

Thanks so much! Your suggestion did the trick. I did need all three since I also got the Ultra-DMA I/O error as mat.wojcik on post #43 in this discussion. I did an install using those options to boot the LiveCD, and I did not need to edit my menu.lst file after installation to boot from the hard drive. Also, I am using an Asus A8N-8X Deluxe motherboard with an Athlon 64 (I installed the x64 version of Hardy) with only one SATA drive.

-d0t

Gentleman83301
April 27th, 2008, 05:51 PM
OMG, I'm up running with Hardy now :lol:
No IDE to RAID switch, nor enabling the floppy drive (I disabled it again).

Using the desktop live cd, what did the trick for me was adding
all_generic_ide floppy=off irqpoll to the boot options when pressing F6. I can't tell if you really need all three options. I'm just happy to be up running :D

Hope this may help someone - good luck to everyone.

Thanks Jong, I believe I tried them switchs stand-alone and got no where. However I tried all 3 in the same order you did and am 61% into the install now. Wish me luck, I'll update more after I verify a good reboot or three.

by the way my floppy is enabled in bios, (I did no bios changes) I may go back and see if I can narrow down or shorten it, but im smiling now!

Ubangi
April 27th, 2008, 06:40 PM
Me too, I have written to beginners forum but all I got was advice to reburn the CD for the third time....

Ubangi
April 27th, 2008, 07:53 PM
All hail the powerful wizard Jong for his secret knowledge of the incantation: "F6, all_generic_ide floppy=off irqpoll" to pass through the locked gates of UBUNTU installation!

ScottBla
April 27th, 2008, 08:11 PM
No such luck for me...when I try to boot into the live CD Ubuntu on the 8.04 desktop ISO, I'm ending up with an apparent infinite loop with messages something like this:

SQUASHFS error: unable to read fragment cache block...
SQUASHFS error: unable to read page, block 2224bb3d, size 8404
SQUASHFS error: sb_bread failed reading block 0x8893b

Guess I'll try the re-download & re-burn sequence (again) to see where that gets me...

This is installing on a Dell Vostro 200 that is currently dual booting the original Dell Windows XP (that I shrunk down) and Ubuntu 7.10. I'm attempting to do a fresh install of 8.04 on top of the existing (just recently installed) 7.10 install. No luck so far :(

Any other suggestions would be appreciated!

Tritonio
April 27th, 2008, 11:17 PM
Had the same problem. I used the all_generic_ide boot option and it worked.
My mobo is Gigabyte K8 Triton series, GA-K8NF-9 (nForce4-4x chipset).

This is a really serious problem. In fact it's more than one problem because different users find different workarounds working for them.

louyo
April 27th, 2008, 11:24 PM
Alas, the "fixes" don't work for all. I have a Dell 690 with Quad Core and NVIDIA video. I get the dreaded busybox halt with a: "ata_id [2884 *number varies*] main:HDIO_GET_IDENDITY failed for /dev.tmp-8-32" jumping up about 30 seconds later. Actually 2 such messages. I have tried all the incantations I can find on here, unplugged/disabled everything I can think of in BIOS except for the CDROM and one hard drive (SATA or SCSI). All to no avail. Both Ubuntu and Kubuntu, CD's pass test and both install in a Virtual Machine in VMWare (running on Linux host). System is already running openSUSE 10.3 which installs fine. Guess I will have to stay with it unless another version of the image is released. I have officially given up.
This is a great forum, so I will keep an eye open to see if something else in the way of a work around shows up. Keep up the good work.

--
Lou
I don't know how I got over the hill without ever getting to the top.

Fury161
April 28th, 2008, 12:11 AM
Please help :(

If I use the "all_generic_ide floppy=off irqpoll" option with the live CD it will work and install Hardy but after that the brand new installation won't work, will it?

To make my updated Feisty to Hardy work I have to change in Bios "Both" (SATA/PATA) to "SATA" in the Onboard SATA devices. But the problem is that way I can't use my IDE DVD-ROM devices.

Any idea? Please help :(

jbr6700
April 28th, 2008, 01:59 AM
Have similar issue here, but looks like a network card is jamming things up. I have tried a upgrade from within Gutsy as well as a clean install but the end result is always being dumped to a busybox screen. Message is as follows: (initramfs) [ 139.175210] 8139cp 0000:05:09.0: This (id 10ec:8139 rev 10) is not an 8139C+ compatible chip [ 139.175276] 8139cp 0000:05:09.0: Try the "8139too" driver instead. This setup works pretty well in Gutsy with mimimal tweaking, but Hardy refuses to do anything from a Live CD except Memtest86+. Any other choice results in the error. System specs are Asus A8V-VM / Athlon 64 3500+ / Nvidia 6600GT based GPU / 1GB DDR 400 / Hitachi 80 GB HDD / Lite On DVD ROM CD +/- Burner combo. Any suggestions would be welcomed here.

dvord
April 28th, 2008, 02:03 AM
I had this problem when I installed 7.10. This ugliness appeared again and irqpoll saved the day.

Now can we get 5 button mouse support? PLZ!?

HDave
April 28th, 2008, 02:34 AM
For those of you still having problems -- can you verify that the UUID in the grub /bppt/grub/menu.lst matches your /etc/fstab and is actually the right value for your hard drive?

They were different in my case...and I got dumped into busybox too.

azurehi
April 28th, 2008, 04:02 AM
Thank you Jong! I was able to install HH 8.04 from the Live CD. From Live CD, Install, F6 I entered:

all_generic_ide floppy=off irqpoll

and the image booted from cd-rom to desktop and the installation proceeded without apparent problem. I tried all the other suggestions, without success and this did the job.

matl1984
April 28th, 2008, 09:57 AM
will this bios thing on raid work with my windows xp media center edition ( im relatively new to this)
on my vista ultimate x64 it works with both modes (AHCI, RAID).
maybe you need drivers from your sata controller (on the motherboard cd?)
i don't know - the drivers for my board are integrated into vista or i don't need special one.

additional infos to my config:
my floppy controller is disabled in bios (manually - because i have no floppy)

i think i should also try the options posted her without change sata mode to raid.

all_generic_ide floppy=off irqpoll
if the options are the correct solution this should be autodetected and built in if possible in future iso files.

off topic:
compiz fusion is so cool! The effects are running very fast (ati radeon express 200 onboard with 256mb shared ram). everytime i move a window i have to smile :) these effects are all better than the vista effects. maybe i'll buy a hp all-in-one printer instead of my lexmark all-in-one p4350 and then kill my vista!

wconstantine
April 28th, 2008, 10:25 AM
It seems like all_generic_ide floppy=off irqpoll is the solution for those with an Asus board with JMicron? Not for MSI. I can't get it working.

transisco
April 28th, 2008, 12:28 PM
I can verify that this works on my ASUS AMD X2 4200+ with 8600GT when using all_generic_ide floppy=off irqpoll. After that I don't need to do anything else once Ubuntu is installed.

matthewhunt
April 28th, 2008, 12:54 PM
Well I had the same probems last night trying to install 8.04. Got dumped to the busy box every time. I'll try the command line tags suggested above.

It's a pity there's such a widespread problem with this distriution as it may be enough to put off a less technically savvy person from trying Linux. I'm pissed off with windows sapping my computers resources and I really don't like vista so i'm prepared to put the work in to get linux going.

I do have a copy of 7.10 that i haven't used yet so i could try that and upgrade.

avenger3000
April 28th, 2008, 01:11 PM
After lot of tests i managed to install HH on an 120gb ide hdd and it works flawlessly. the thing is that i can't get into my windows xp installation. if i choose "Windows XP Professional" from the GRUB menu i get a message like "selected disk can not be found". ubuntu starts from sd (0,0) hdd, how can i get grub to load windows as well? the hard disk (sata) where windows are installed is sdc1. what do i have to add on menu.lst. any ideas?

millenium.dare
April 28th, 2008, 03:04 PM
Thanks Jong!

I was able to boot the LiveCD and install Hardy 8.04 on my machine with the help of those kernel parameters. For reference, my specs are:

Asus P5NSLI
Intel E6600
2 Seagate SATA HDD
Nvidia 8800GTS

wconstantine
April 28th, 2008, 03:12 PM
After lot of tests i managed to install HH on an 120gb ide hdd and it works flawlessly. the thing is that i can't get into my windows xp installation. if i choose "Windows XP Professional" from the GRUB menu i get a message like "selected disk can not be found". ubuntu starts from sd (0,0) hdd, how can i get grub to load windows as well? the hard disk (sata) where windows are installed is sdc1. what do i have to add on menu.lst. any ideas?

I suggest you create a new thread for that issue as it's quite off topic here.

vlgligor
April 29th, 2008, 07:19 AM
The "all_generic_ide floppy=off irqpoll" options does not work for me, all the time I end up in the initramfs + busybox.

I tried also changing the IDE/AHCI -> RAID, but it doesn't work.

My configuration:
Intel C2Duo 6300
MB MSI P965 Platinum
HDD SATA
DVD-WR Primary IDE.

matl1984
April 29th, 2008, 08:06 AM
i tried some combinations of
all_generic_ide floppy=off irqpoll but it doesn't work for my system. currently the only solution for me is to switch sata mode in bios/IDE Config from AHCI to RAID.
i tested the following:
with live cd:
all_generic_ide floppy=off irqpoll
floppy=off
all_generic_ide floppy=off
irqpoll

i also removed my dvd burner from the primary ide master and my dvd drive from the secondary ide master and tried to boot the previously installed ubuntu (installed with sata raid mode) with ahci mode with no success.

my system as previously mentioned:
asrock 775 twins hdtv r2.0 with bios 2.10 (floppy disabled),
intel pentium d 805, 2x1GB DDR2 667 RAM, 2 x sata seagate barracuda 7200.10 320 GB 16MB on SATA1 und SATA2.

MinoltaLuvR
April 29th, 2008, 08:14 AM
i havent or cant recall posting on this forum for a long time.
but i gotta chime in now and say, i've been very disappointed in the last two releases of ubuntu. i never had to jump through hoops to get ubuntu installed like i have with 7x and now 8x. its just sad.

that being said.. i just got the live cd to boot finally after using a great many of the start up commands suggested in this and other threads.
what ultimately worked for me was adding:
nolapic acpi=off irqpoll
after hitting F6 i hit the END key, i delete the quiet splash -- and put the above commands in its place.

which iirc was the exact string i had to use to install 7x on my box.

my specs are a Xeon 3220 @3.2ghz on an ip35 pro with 4 gigs of OCZ ram.

hope this helps someone out there.. cheers.

matthewhunt
April 29th, 2008, 12:57 PM
I haven't managed to get Hardy to run on my desktop pc. The live CD however runs on my works laptop and everything works as far as i could see from a quick test this morning.

I have a different issue with 7.10 where the live cd runs ok on my desktop pc, but my keyboard doesn't work but i'll discuss that problem somewhere else.

devliljohn
April 29th, 2008, 05:34 PM
im having this same issue with my asus z96j laptop it has a 32bit core duo processor, radeon x1600 graphics card and 1 gig of ram. i haven't tried any workarounds from this thread yet but i will when i get home tonight and i will post my results

paziek
April 29th, 2008, 06:39 PM
all_generic_ide floppy=off irqpoll
did the trick on MSI KT4AV board.
\thanks.

Sonny Boy
April 29th, 2008, 09:33 PM
all_generic_ide floppy=off irqpoll
worked like a charm on my Acer 5050(after trying all the other with no success)

PhilB
April 29th, 2008, 10:21 PM
Very familiar with this problem as I had it last year with 7.10 on a new machine I built and I have spent the last two days getting very frustrated having encountered it again.
Basically the Hardy upgrade failed for me-no nvidia enabled. Turned out to be booting 7.10 still, and when I edited grub to 8.04 I trashed the machine.
I tried installing 7.10 again and got the initramfs/busybox problem, and all research indicated that the problem lay with Seagate drives, so knowing that I had successfully installed openSuse on a Hitatchi drive tried with this one-same thing.
Only just realized after the last two days why I had for the last six months been using a very old slow Toshiba cd drive instead of my very fast LG dvd burner (which I decided on Sunday I ought to put back in the computer, being a "better" drive).

If you cannot install, and if none of the suggestions for editing the boot script via F6 dont work, I strongly suggest you try a different cd/dvd drive.

silbar
April 30th, 2008, 04:30 AM
I get the same initramfs + busybox message. I have no idea how to access bios and can't understand why, after using ubuntu successfully since 6.06, I cannot install 8.04. I have downloaded the image X3 and also the alternate install image and get the same error. I am stymied. Help please - thank you.
For my BIOS (on a Dell Inspiron 530) I have to hit <F2> to go into the BIOS setup and from there into Integrated Peripherals to eventually find the SATA mode options.

**** Silbar

wib
April 30th, 2008, 05:42 AM
I read the thread...all of it. Could never get a string response. Using older Asus mobo, A7A133 w/ 1.2G RAM and a Deathstar IBM HD.

Nominal installs during HH beta, but when I was installing LTR the Verbatim 52x CD-RW died or stopped being recognized. I replaced it with an LG CED8080B and then could never get past the BusyBox.

As suggested, replacing the IDE device worked instead of using the all_generic_ide command. Since this whole system is built from a pile of pulled parts it was simply a matter of finding the right combination. In this case it was a Sony CRX 140E CD-RW.

I'm all grubbed up and now can hopefully solve Bug #218508. (https://bugs.launchpad.net/ubuntu/+bug/218508) Maybe that's why my network connection and the CD-RW failed: there may be a general problem of Ubuntu not having enough testing on specific drivers for the enormous permutations of installed hardware. I'm on my second HD, third CD-RW, and now headed for a third network card. Keep trying, folks.

louyo
April 30th, 2008, 12:31 PM
:KSDecided to give another go and downloaded the alternate CD image. That one installed. I still see the same messages when booting up the new install but it boots up and runs OK (actually switched over to Kubuntu now). I will try to locate another CDROM drive to see if that makes a difference. Also have to look through the logs. I never did get the liveCD to boot.
Thanks to all the folks who are hanging out here and helping.

kav
April 30th, 2008, 01:12 PM
I don't know if it helps to find the clue or even makes it more complicated, but my story is the following:

Toshiba portege 3505, 512 ram, 60gb IDE, Pentium III, ACPI 1.40, trying to install 8.04

Live CD or installation drops me to Busybox, none of the tricks mentioned in this thread worked for me.
What I did was to remove my HDD and put it in another laptop, where I installed ubuntu without any problems.

I put my disk back to my laptop and... get the busybox thing!
In recovery mode what I get is the following:

http://img230.imageshack.us/img230/7559/ubuntupn4.gif

sda4 is the linux partition so it definitely exists.

In normal mode after removing 'quiet' it stops after


Mounting root file system
Running /scripts/casper-premount -- ok

...and then drops me to busybox.

tofuconfetti
April 30th, 2008, 09:29 PM
After all this, I decided on that particular computer to revert back to 7.10. It did the same thing. I hadn't remembered that, but it finally dawned on me that previously I had disabled the "USB legacy support" in the BIOS of that motherboard. I did that again and had absolutely no problems booting up. Then I remembered that was required of another Intel based ASUS motherboard.

So I closed down the 7.10 Live CD and tried the 8.04 CD with the legacy USB disabled. It worked like a charm with no parameters passed to the kernel line.

The only downside to this is that you can't select the options in the boot menu IF you are using a USB keyboard. You can, of course, solve this with a PS2 connected keyboard just for the setup (I always keep one around).

Add that as another one to try on your list of possible solutions.

The hardware I had success on was:

Intel D975XBX2 motherboard
e6600 quadcore chip
4 Gb of RAM
Nvidia 8800 GTX video
WD 500 Gb SATA drive on SATA1
SATA DVD+/-RW on SATA5
No floppy as registered as such in the BIOS
USB Keyboard/Mouse

Brendt2
May 2nd, 2008, 04:24 AM
I just wanted to thank everyone for there input into this matter.

I have a Vostro Desktop 200 that hit this crazy issue, and irqpoll solved everything for me. I am now functional again!

I love the ubuntu forums!

tofuconfetti
May 2nd, 2008, 01:39 PM
What would be nice to know is exactly where the bug is that's giving everyone these errors. They are obviously widespread. There is something strange in the kernel that's causing drives not to be recognized.

hal8000
May 2nd, 2008, 04:48 PM
What would be nice to know is exactly where the bug is that's giving everyone these errors. They are obviously widespread. There is something strange in the kernel that's causing drives not to be recognized.


I have had the same problems booting Ubuntu since 6.10 (the last Ubuntu that installed from the CD without problems).

My solution was to compile my own kernel, this works, but its not the most elegant solution and outside the scope of a newbies. I have a feeling that its somehow tied in with the libata library as this is when my problems started.

I hope someone can provide an answer.

wconstantine
May 2nd, 2008, 10:17 PM
Would indeed be nice to have some attention over here from the developers of Ubuntu. I've had problems with installing Ubuntu with my JMicron system for as long as I can remember. First time I tried was 6.10 if I remember it correctly. 7.04 (or 7.10) was the first distrobution I succeeded in installing. I think it was due to a kernel fix that existed in the new kernel 7.04 used. Has that fix been stripped away due to this LTS stuff?

I'm going to try to download 7.04 again and try installing it and then doing a dist-upgrade. I've already tried with 7.10 and it didn't work. So I have little hope for 7.04.

This is one of Linux's issues folks. The average joe will need a working OS. Not some shell dropped before their eyes.

hal8000
May 2nd, 2008, 10:18 PM
For those of you still having problems -- can you verify that the UUID in the grub /bppt/grub/menu.lst matches your /etc/fstab and is actually the right value for your hard drive?

They were different in my case...and I got dumped into busybox too.

Hi, can you elaborate on this please? Are you saying that you modified your grub/menu.lst file and can now load Ubuntu 8.04 without problems.

I am multi booting, but using an alternative (PCLinuxOS) grub to control booting, however I still cannot boot Ubuntu without using a non ubuntu kernel. So far changing BIOS settings to non pata, sata, and adding generic_ide_devices irqpoll have all failed for me... however the live CD boots ok, but not the permanent install.

I will load the live CD, copy the kernel and modules into my installed 8.04 system and see if that cures my initramfs problems.

wconstantine
May 2nd, 2008, 10:28 PM
Hi, can you elaborate on this please? Are you saying that you modified your grub/menu.lst file and can now load Ubuntu 8.04 without problems.

I am multi booting, but using an alternative (PCLinuxOS) grub to control booting, however I still cannot boot Ubuntu without using a non ubuntu kernel. So far changing BIOS settings to non pata, sata, and adding generic_ide_devices irqpoll have all failed for me... however the live CD boots ok, but not the permanent install.

I will load the live CD, copy the kernel and modules into my installed 8.04 system and see if that cures my initramfs problems.

The boot parameters you have described there are wrong. :)

"all_generic_ide" is the right one. Anyways, I guess you have added the boot parameters in the /boot/grub/menu.lst file? If not, do it and it'll should work for you.

Adding the boot parameters when launching the live-cd is not enough. It doesn't remember the parameters given when launched so you need to add it yourself in the right line in the meny.lst file.

If you already have done so, sorry. Your reply is not quite so detailed, just wanted to make sure. :)

tofuconfetti
May 3rd, 2008, 03:46 AM
Hi, can you elaborate on this please? Are you saying that you modified your grub/menu.lst file and can now load Ubuntu 8.04 without problems.
When you get booted into the 8.04 installed system (not the Live CD), then you can hand edit the /boot/grub/menu.lst file. It will have a line that passes parameters to the kernel as it boots up. The line will look something like this ...


kernel /vmlinuz-2.6.22-14-generic boot=UUID=349b7b5f-a9af-4f81-abb3-56bb54a72a70 ro quiet splash

At the END of that line add whatever parameters you want to pass at boot up. If you really get stuck and can't pass parameters from the graphical grub menu, you can actually boot into the Live CD, mount the system partition (or the partition with /boot on it, I put it on it's own paritition - an old habit from the Gentoo days) by loading up the terminal and typing ...



sudo mkdir /mnt/system
sudo mount /dev/sda1 /mnt/system
nano /boot/grub/menu.lst


NOTE: you will need to change the /dev/sda1 to whatever partition your /boot/grub/menu.lst is on.

Then add the parameters to that line, and SAVE it before you close it. Then shut down the Live CD, reboot into 8.04 and the parameters will be passed.

For the record, I did NOT have to add "all_generic_ide" to mine. I either had to set the USB Legacy settings to "off" in the BIOS, or had to pass "irqpoll" to the kernel. I don't know WHY this works, it just does. Until we have a firm answer, you may have to try them individually to see which one works for you.


I am multi booting, but using an alternative (PCLinuxOS) grub to control booting, however I still cannot boot Ubuntu without using a non ubuntu kernel.
Then boot into the PCLinuxOS and edit the Ubuntu boot line passing the parameter. That's even easier. Just edit /boot/grub/menu.lst and add it to the UBUNTU line (not the PCLinuxOS line.


So far changing BIOS settings to non pata, sata, and adding generic_ide_devices irqpoll have all failed for me... however the live CD boots ok, but not the permanent install.
Did you say you were using a non-Ubuntu kernel?? That's not good. Install 8.04 fresh using their kernel. That should work IF the Live CD works okay.


I will load the live CD, copy the kernel and modules into my installed 8.04 system and see if that cures my initramfs problems.
I wouldn't do that. Let the installer do it.

Maybe some of that will help you.

hal8000
May 3rd, 2008, 10:34 AM
When you get booted into the 8.04 installed system (not the Live CD), then you can hand edit the /boot/grub/menu.lst file. It will have a line that passes parameters to the kernel as it boots up. The line will look something like this ...


kernel /vmlinuz-2.6.22-14-generic boot=UUID=349b7b5f-a9af-4f81-abb3-56bb54a72a70 ro quiet splash


Maybe some of that will help you.

Hi, thanks for all your help.

Looking back through my own notebook, I have had trouble booting Ubuntu since 6.04, think this is when the Ubuntu kernel used the libata library.

Looks like I may have passed the wrong kernel parameter.
Looking back I to 6.04 a kernel module was missing.
I used the livd CD chroot'ed into my ubuntu system and added piix to /etc/initramfs-tools/modules and created a new initramfs

I have just added piix to the modules in Hardy Heron and updated the initramfs- for a brief second I thought this was going to boot, but after a few lines of text I get a black monitor screen (no text or graphic displayed) then drops to initramfs

One thing I notice between live install and hard drive install is that the boot splash screen changes. The live install gives the familiar Ubuntu logo, after a live install I see what looks like a TV test card, which hangs on waiting for root filesystem then drops to initramfs.



I am still convinced that libata is the problem, in Suse you can disable libata by appending hwprobe=-modules.pata to grub/menu.lst

This only works in Suse as it is parsed by Suse central config file /etc/sysctrl (I think,from memory).
If anyones knows a way to disable libata support from grub/menu.lst I'll give this a try.

I am going to go through your suggestions and all posts in this thread again. My hardware:
Asus P4P800-E motherboard
Intel P4 2.8G
Nvidia 7600GS
1G Ram
Maxtor UDMA100 HD (IDE not sata)

silviutp
May 3rd, 2008, 06:00 PM
OMG, I'm up running with Hardy now :lol:
No IDE to RAID switch, nor enabling the floppy drive (I disabled it again).

Using the desktop live cd, what did the trick for me was adding
all_generic_ide floppy=off irqpoll to the boot options when pressing F6. I can't tell if you really need all three options. I'm just happy to be up running :D

Hope this may help someone - good luck to everyone.

Thanks for help. This did it for me too.

wconstantine
May 3rd, 2008, 10:03 PM
THIS DRIVES ME CRAZY.

Has ANYONE succeeded in even launching the live-cd for 8.04 with MSI P965 Neo?!

I have 2 sata drives and one IDE cd-rom. I've tried with Wubi, A LOT OF BOOT PARAMETERS on the live-cd and I've also tried 7.04/7.10 which I've successfully run before. But none of them works anymore. I'm not dropped into busybox with 7.04/7.10 but the computer locks up and the pc speaker beeps constantly.

In 8.04, you can't even hear the cd is being read. It just loads a little and then drops into busybox. So damn annoying.

Boot parameters I've tried:


irqpoll noirqdebug all_generic_ide noapic nolapic floppy=off pci=nomsi nomsi

LET ME TASTE THAT UBUNTU GOODNES, I CAN'T STAND WINDOWS ANY MORE.

dartdog
May 3rd, 2008, 10:21 PM
FWIW I did a wubi install, went through the entire install and reboot sequence with a Dell opti.. was happily in Ubuntu, went back to win xp for a while... had a thunderstorm shut down power and used the opportunity to go back into Ubuntu after the power came back...
Got the mysterious initramfs + busybox prompt...
rebooted , same thing... went to these forums after getting win XP back...read this thread and others.. was about to figure out how to apply some of the suggestions... but... when rebooting all went well and I'm writing this in Ubuntu... I guess running XP reset some bios? or cleared some hardware states that were not cleared with a powerdown...??? As I said.. Probably won't help anyone else but you never know>>>!

herdivet
May 4th, 2008, 08:01 AM
Add this to the FWIW column. I have a dual boot system I put 8.04 beta on, and applied updates. Eventually I got the busybox, but if I chose an earlier version, it came up fine. I just did that for a while, until another update occurred and suddenly everything was fine.

On my 'working' system, I upgraded from 7.1 to 8.04. Yikes. It looked great immediately after the upgrade, but then I ran the 'updates' and it's been stuck with busybox everytime, unless I pick an older version from the grub menu. It actually has four versions (not counting recovery modes) on the grub menu, with linux-version-2.6.24.17 linux-version-2.6.24.16 linux-version-2.6.22.14 and linux-version2.6.20.16. The 2.2.24.17 ALWAYS busyboxed until I put the recommended all-generic-ide on the loader. That allowed it to boot -thanks for the help.

However - it boots with graphics set to 640x480 and only offers 320x240 as the other option (reminds me of the old PC XT with mode80 and mode40!) The card is an nvidia GeForce 6150LE but the driver, when I get it to load, still only offers 640x480. By booting to the 2.6.22 version, I can get 800x600 w/out the nvidia driver, but I sure miss Ubuntu 7.1 with 1024x768 and booting without having to drop back a few versions.

It appears some of these problems are with the Linux kernel, based on how it gets worse with 2.6.24. I' hoping to hang on with 800x600 for a while and hope an upgrade shows up soon to fix this.

Just FWIW and thanks for all the help. This has been the most informative thread on this topic I've seen. At least it gave a solution that got the system to boot. Thanks again!

jbr6700
May 4th, 2008, 06:33 PM
Well after messing around and trying all else I finally edited grub boot options using what seems to be the Silver Bullet for most people trying to get HH 8.04 running. Here is what my grub list reads now:
title Ubuntu 8.04, kernel 2.6.24-16-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=2a123592-7e9f-4dc2-980c-683f994c2e26 ro quiet splash all_generic_ide floppy=off irqpoll
initrd /boot/initrd.img-2.6.24-16-generic
quiet

I'm not sure which addition solved the issue but at present all looks well here. Running the Nvidia restricted drivers as well as Compiz Fusion went flawlessly, no issues with sound like I had in Gutsy either. Playback of encrypted DVD's took a different approach than what is posted in Community Documentation. AWN runs great as well. I am seeing some issues with Firefox occasionally when I move the mouse it occasionally backs up to the prior window!? That one might require waiting till Firefox is out of Beta to see if it continues. Thanks to Jong for their fix.

Rogerbeep
May 4th, 2008, 09:14 PM
BIOS is a function of any motherboard regardless of the operating system. It is a small set of instuctions that tell the hardware setup how to turn themselves on and at what basic settings. It is accessed in various ways depending on the motherboard. Many require pressing the delete key during the boot process. After you press the power key you should hear a beep from within you case. This is the motherboard's PC Speaker. Directly after you hear this beep you must press the appropriate key to enter BIOS. Try the delete key. If this is not the corrrect key for your motherboard and you cannot find the correct key in your motherboard's documentation then try the insert key or the F8 key. One of these should work. Also, pay attention to your initial boot screen. It goes by fast but you can hit the pause key to stop the progress. It should tell you what key needs to be pressed to get into BIOS.
Once you access BIOS there are many settings that cane be changed but please be careful what you change and I suggest changing one setting at a time unless you are well versed in BIOS settings. This way if you machine will not boot properly you will be able to go back and reverse the change. If you get stuck and have it all completely botched up there is a way to physically reset the BIOS back to it's original default settings. It requires moving a jumper on the motherboard. You must have the proper documentation specific to your motherboard to do this but it is s simple procedure. If all else fails you can shut down your machine. Pull the A/C plug out and then remove the motherboard's battery (a small shiny silver disk like the battery in a car's remote door unlock)for a couple of hours. this will force it to revert to the factory defaults.
Good luck, I hope this helps....

tofuconfetti
May 4th, 2008, 10:09 PM
Boot parameters I've tried:


irqpoll noirqdebug all_generic_ide noapic nolapic floppy=off pci=nomsi nomsi


Wconstantine,

I don't know if you caught that one post I made regarding using a USB keyboard that prevented me from booting on an Intel system. What is your hardware setup? List an inclusive list down to the keyboard. On my Intel motherboard with the quad-core processor I had to disable legacy USB support in the BIOS when using a USB keyboard. I understand your frustration. Try plugging in a PS2 keyboard and see if THAT works. That is one thing that worked for me, hopefully it'll help you.

The problem here is that I see no pattern to why any of this works. I have several MSI motherbords and none of them was a bit of trouble. It's just the Intel motherboards I've tried that give me a hassle.

hal8000
May 4th, 2008, 11:03 PM
I've still not got Ubuntu 8.04 booting on my system Asus P4P800 E motherboard, Intel 865PE chipset and UDMA hard drives.

In my case the Live CD works and boots fine, but an installed system will not boot, taking me to an initramfs shell.


I can boot Ubuntu if I use a Debian 2.6.24 kernel proving that the problem is the configuration of the Ubuntu kernel. I am convinced the answer lies in disabling libATA and just found the following on the libata site:

http://linux-ata.org/faq.html

* Recommended (where BIOS permits): Change BIOS IDE mode from "legacy" or "combined" mode to "AHCI" (recommended), "RAID" or "native".
* Boot with the kernel commandline parameter "combined_mode=libata" or "combined_mode=ide" to allow the specified driver to claim all IDE ports.
* Disable libata (CONFIG_ATA) entirely, and enable CONFIG_BLK_DEV_IDE_SATA.
* (newer choice, with less field testing) Disable CONFIG_IDE, and permit libata to run all your IDE and SATA ports.


Adding the parameters
combined_mode=libata or combined_mode=ide may work as suggested above, but as the Ubuntu kernel config has CONFIG_ATA set to y this may be the only way to disable libATA. This solution isnt quick as it would require
booting from the LiveCD (for those that can) chroot'ing into the installed Ubuntu system, downloading the kernel source and then recompiling the kernel.
This would work (in my case) as my alternative kernels (Debian have ConFIG_ATA disabled).
If an alternative kernel was available from synaptic this may be an alternative solution.

wconstantine
May 5th, 2008, 04:50 PM
Wconstantine,

I don't know if you caught that one post I made regarding using a USB keyboard that prevented me from booting on an Intel system. What is your hardware setup? List an inclusive list down to the keyboard. On my Intel motherboard with the quad-core processor I had to disable legacy USB support in the BIOS when using a USB keyboard. I understand your frustration. Try plugging in a PS2 keyboard and see if THAT works. That is one thing that worked for me, hopefully it'll help you.

The problem here is that I see no pattern to why any of this works. I have several MSI motherbords and none of them was a bit of trouble. It's just the Intel motherboards I've tried that give me a hassle.

I've got both an USB keyboard and mouse. I'll try changing those when installing to give it a try. Thing is, I've just changed my keyboard from PS2 to USB, so you might be right. Gonna eat, then I'll try it out.

Edit: Didn't work. Tried disabling USB controller completly in the bios as well.

revoltism
May 6th, 2008, 11:15 PM
It seems like all_generic_ide floppy=off irqpoll is the solution for those with an Asus board with JMicron? Not for MSI. I can't get it working.

Yes, but in my case i used the alternate cd and installed from my dvd-rw-rom instead of my dvd-rom. to get it to work.. but i still got the slow boot

EDIT: After adding "all_generic_ide floppy=off irqpoll" to menu.lst i booted within 10 seconds...

wconstantine
May 7th, 2008, 11:56 AM
Yes, but in my case i used the alternate cd and installed from my dvd-rw-rom instead of my dvd-rom. to get it to work.. but i still got the slow boot

EDIT: After adding "all_generic_ide floppy=off irqpoll" to menu.lst i booted within 10 seconds...

You got it working with a P965 Neo and the alternate cd?

Edit: I'VE GOT IT WORKING! AT LAST!

Used the alternative 8.04 cd and the boot options as seen: all_generic_ide floppy=off irqpoll

Toddish
May 9th, 2008, 03:38 PM
hey guys

im still stuck :(

I got busybox too (im on an Abit AB9, E6600, 2gb Ram, 1 500Gb SATA, 1 250Gb SATA), and all_generic_ide floppy=off irqpoll actually got ubuntu to load, but now it suddenly freezes.

just locks up, stops loading, and I can't move my mouse (PS2, as is the keyboard). reckon its part of the same problem, or should I make a new thread about it?

ludefork
May 10th, 2008, 03:27 PM
For Dell Ubuntu users: I've had the same problems described here. An Ubuntu tech support person at Dell told me to "flash the BIOS" on my system, i.e. upgrade the BIOS. He gave me a link for instructions on how to flash the BIOS. This is the link:

http://linux.dell.com/wiki/index.php/Repository/firmware

After flashing the BIOS correctly, I still had the same problems booting up - with "intramfs" and "busybox" being displayed on the screen. But changing IDE to RAID in peripherals during bootup fixed my problem completely! I can now run Hardy and it works fine (prior to flashing the BIOS, changing IDE to RAID did not fix the problem). My system is Dell Inspiron 530 Desktop, PCO, E2160 (1.8 GHZ), 4 gig memory.

epidemiks
May 11th, 2008, 07:55 AM
Hi guys,

My problem seems similar.. I have managed to get the update installed, but when i try to boot to the -17 kernels i get:


ata1.01: exception Emask 0x0 SAct 0x0 SErr 0x0 acion 0x2 frozen
ata1.01: cmd C8/00.08.00.../fo tag 0 dma 4096 in
Buffer I/O error on device sdb, logical block 0
and then get the busy box prompt.

but the -14 kernel boots ok, says it's 8.04 and runs well..

would the above errors relate to this sata/bios fix? I don't run any sata drives and i'd imagine XP on the second ide wouldn't like being told it's sata.. or am i wrong?

also, its hard enough for me to understand whats going on in this page, so apologies if I've missed solution in the preceding 11 pages.. :)

hal8000
May 11th, 2008, 10:12 AM
Hi guys,

My problem seems similar.. I have managed to get the update installed, but when i try to boot to the -17 kernels i get:


ata1.01: exception Emask 0x0 SAct 0x0 SErr 0x0 acion 0x2 frozen
ata1.01: cmd C8/00.08.00.../fo tag 0 dma 4096 in
Buffer I/O error on device sdb, logical block 0
and then get the busy box prompt.

but the -14 kernel boots ok, says it's 8.04 and runs well..

would the above errors relate to this sata/bios fix? I don't run any sata drives and i'd imagine XP on the second ide wouldn't like being told it's sata.. or am i wrong?

also, its hard enough for me to understand whats going on in this page, so apologies if I've missed solution in the preceding 11 pages.. :)


Any messages that start ata.. (like the ones you pasted) are from libATA emulation. There are clear and present problems like this for at least 10,000 users so why havent the ubuntu team compiled a different kernel that does not use libATA emulation?
I havent had time to recompile the ubuntu kernel yet, but as a non libATA compiled kernel boots my 8.04 system I'm certain this is the 'root' cause of the problem ~(no pun intended).

The thread is long but some solutions (though they dont work for everyone)
including appending comments to the boot line, or changing settings in BIOS. Hope that helps

mptpro
May 12th, 2008, 07:57 AM
Hi ****,

I have the same computer - Dell 530. Have you gotten it to install 8.04? I have not.

thanks,
Michael

epidemiks
May 12th, 2008, 09:46 AM
I've tried clearing the bios, irqpoll, enabled sata, still getting buffer i/o error on device sdb, logical block 0
still nothing

macr0s
May 14th, 2008, 12:11 PM
Sup

I ran into this problem install 8.04 desktop cd on my old p4 system.

None of those boot paramaters worked for me but this did:

1. Put the hdd and cdrom drive on different ide channels, both master.
2. left a single stick of ram in there (im paranoid about ram errors). Alternatevely run a ram check if you are patient.

good luck

edit: the pc i had this problem on was actually an athlon xp 1400, ASUS mobo - A7A133 with ALI chipset

eleybourn
May 15th, 2008, 11:27 PM
ok my hardy heron seems to work now, too!

all the bootoptions did not help. what i did was that i put my cd-writer from primary slave to secondary slave, and everything worked fine. i really don't know why. maybe this can help someone.

no i've got my dvd-rom on primary master and the cd-writer on secondary slave (i have to change the jumpers to get it on master), and my harddisk on the s-ata port. maybe the dvd-rom and cd-writer interfered somehow.
I don't know why or how, but unplugging my IDE DVD Burner also worked. I have tried everything listed in all the forums, ide_generic_all, pci=nomsi, irqpoll, floppy=off etc.

I will go and buy a new IDE cable so I can plug it into the secondary IDE slot (I have a HDD on the first cable)

52rockwell
May 17th, 2008, 04:05 PM
I had this problem on my Dell 530 Inspiron. The computer I bought because dell was offering Ubuntu preinstalled.
The Bios switch to RAID worked for me.
I just googled busybox+ubuntu. Wow..
This is really a big problem

gmilne
May 19th, 2008, 08:29 PM
How DO I get into BIOS?

Since you guys seem informed can anyone tell me how to install Ubuntu to Drive E:\?
I have XP on bootable F:
C and D are storage disks
I think Ubuntu keeps trying to install itself on C:

Any help much appreciated.

herdivet
May 20th, 2008, 12:24 AM
To get in to the BIOS you press a key, usually <F2> <DEL> <F1> <F10> - the screen may put up a very quick message saying which to press to enter BIOS Setup. You can usually press one after the other until it says it's entering setup.

During the installation process the default is to install Ubuntu on the first HDD. If you're comfortable with it, you can unplug all drives except the one you want Linux on. If not, you can choose Manual and then pick the drive you want to put Linux on. The drive descriptions will be HDA SDA etc. so you will have to look closely to ensure you pick the one you want!

gmilne
May 20th, 2008, 12:56 AM
Problem with that is my two 80G drives - 1 with XP and the other blank have the same number affixed to them. My two 400G also have identical numbers. Is there a workaround?

If I do get to the blank drive and install Ubuntu on it will Ubuntu put a boot manager on the drive so that I can get back to XP if need be.?

I think I can change the boot order with Disk Manager in Windows. But then how do I get back to XP (and boot manager after the Ubuntu install?

herdivet
May 20th, 2008, 03:20 AM
Yes, Linux will add the GRand Universal Boot loader (GRUB) to the first drive so you'll have a menu with XP as an option. If you cancel the install as soon as it starts, then run SYSTEM | ADMINISTRATION | SYSTEM MONITOR and click on the File Systems tab it will show the drives, with designation, file system (NTFS/ext3, etc.) and free space. That should make it easy to pick the empty one. Note which one it is and then double click the Installation folder on the desktop to restart the install.

Hope that helps.

gmilne
May 20th, 2008, 04:39 AM
Thank you so much. Installation seemed to go well, however when I get the boot manager menu and pick Ubuntu I eventually get the initranfs message again. Can you give me an idea of what is wrong here?

I made a
Root partition of 15G
Swap File 10G
Home 55G

I was unable to import Docs and Settings but imagine I can do that later.
Cheers,
/graham

gmilne
May 20th, 2008, 07:16 AM
Install seemed to work fine, but this time get just initranfs.
When I type man intro it returns
/bin/sh: man: not found

Any ideas.

I can boot to XP fine but Ubuntu (7.01) just sits there like my last wife and gives me the silent treatment.

Should I be changing the boot order of disks in the BIOS or anything?
Any help appreciated.

gmilne
May 20th, 2008, 11:47 AM
I found this but because it's for Dell I hesitate to use it. Any idea if it works?

This worked with "Made for Ubuntu" Dell 530N. If your machine is hanging here and not booting then it's worth a shot for you too surely?

Press "Esc" before/during Grub "Countdown". Press "e". Find the line "kernel-blah-blah" (it doesn't really say blah but you are following right?) Go to the end of the line type: irqpoll Press then "b" to boot.

Once Ubuntu/Gnome has booted open a terminal...

sudo gedit /boot/grub/menu.lst

Search for "# defoptions=quiet splash"

Change to "# defoptions=quiet splash irqpoll"

Save and exit your editor. Type:

sudo update-grub

Reboot. This should now boot into Ubuntu/Gnome without hanging at busybox/initramfs

nikolay.dimitrov
May 21st, 2008, 06:23 AM
Hello, I have ASUS A7N8X-VM/400 (nVidia nForce 2) with AMD Sempron, 1 PATA HDD, 2 DVD-ROM and USB wireless Keyboard and mouse. I have the same problem with the installation - with BusyBox initramfs. I solve the problem with 'ide_generic_all irqpoll floppy=off' at the end of the command line (F6 at startup). I write the commands before '--'. After the installation I have no more problems. Thanks all for help.

hannah187
May 21st, 2008, 12:24 PM
I am here with same problem. Please look into this post of mine a week back.
http://ubuntuforums.org/showthread.php?t=791518

I have installed 8.04 with alternate CD however cannot boot and get initramfs + busybox

Disabled USB Legacy support in BIOS
Change BIOS IDE mode from "compatibility" mode to "AHCI"

Have tried following parameters

all_generic_ide floppy=off irqpoll
combined_mode=libata
irqpoll noirqdebug all_generic_ide noapic nolapic floppy=off pci=nomsi nomsi

still no success

My Notebook is
Toshiba Satellite Pro L300 PSLB1A (IN Australia) same as
Toshiba Satellite Pro L300 PSLB1E (In Europe)

You can see some more details and pics of GPARTED in this thread


http://ubuntuforums.org/showthread.php?t=791518

Many thanks for the help

shoeheight
May 21st, 2008, 01:36 PM
I'm having the same problem. I am using Wubi for a dual boot with XP and can't boot Ubuntu anymore. I had been running it fine for the past few weeks but suddenly...I get this (initramfs) screen.

I've been reading this thread but I'm a little worried about changing the bios on my office computer. If I change the boot like <gmilne> has so clearly written, could it affect my XP boot? (I backed up all my info on the Ubuntu boot so I don't mind loosing it)

Sorry, maybe this is more of a beginner question.
:confused:

sprightlyone
May 21st, 2008, 07:59 PM
hi
i was getting same error messages as everyone else ihave 2 burns with different distro`s neither would work
fix for my install was visit bios &turn on sata controller now i can install all my disks
i `m trying to setup on a VIA MM3500 m?board with smll IDEdrive
this may be of use to someone
thanks for this post
the answer may still lie in tweaking BIOS if your board has SATA ports
lyle

hal8000
May 23rd, 2008, 07:31 PM
I've solved my Ubuntu loading problems, but this solution is possibly not going to work for everyone.

In my case I reverted back to Edgy (6.06) which worked without problems. I upgraded to Feisty but needed to append irqpoll to the grub parameters.
Although Feisty worked, checking dmesg revealed many messages relating to my cdrom drive.
I had a DVD drive and a CDROM sharing the same IDE cable and two IDE drives sharing the same IDE cable. IRQ sharing should not be a problem these days, but did affect my install. Only when I removed a device from each cable did the system boot without errors, and using libATA emualtion (IDE hdx drives now seen as sdx drives).

The cost of a 160G SATA drive is now under £30, at this price its a good buy. On my Asus P4P800E motherboard Intel 965 chipset and ICH5 hardware, the performance is excellent:

sudo hdparm -tT /dev/sdb

/dev/sdb:
Timing cached reads: 2038 MB in 2.00 seconds = 1019.29 MB/sec
Timing buffered disk reads: 226 MB in 3.02 seconds = 74.81 MB/sec

The above is a Native Hitachi Deskstar SATA2 drive, my IDE drive is slightly slower:

sudo hdparm -tT /dev/sda

/dev/sda:
Timing cached reads: 1968 MB in 2.00 seconds = 983.49 MB/sec
Timing buffered disk reads: 168 MB in 3.02 seconds = 55.54 MB/sec

The solution may not work for everyone but for my computer, shifting IDE connectors ( a single device on each IDE controller and no shared interrupts has worked for me).

beyboo
May 25th, 2008, 09:06 AM
I'm going to bump this as there's a lot of 1 post threads that I think are duplicates of this.

I'm running a ABIT IP-35 board... my boot problem is intermittent. It won't work for like 5 attempts.. I go into Vista to look at posts.. try again and it works.

There's a few launchpad posts about this.. apparently it may be a problem with the kernel version.

DITTO !

I came in to search for support of my Abit IP35-E mobo. Since Gutsy I've had problems installing the OS. The mobo has 6 SATA ports on the mobo out of which # 1,2,5,6 are enabled. 3 and 4 are disabled as part of the mobo hardware spec. I have Seagate and WD SATA disks installed on ports 2,5 and 6. For some reason whenever I boot from the Hardy live CD, I always get the ATA4 revalidation error when I boot.

In Gutsy I managed to install the OS after removing the disks in ports 1 and 2. AFter that I installed the latest Kernel back then 2.4.26 from kernel.org and it worked. However it boots only 50% of the time. Most other times it just hangs at "Waiting for Root File System" and has to be reset a couple of times. USually entering the bios screen and saving (no changes made) works and the system boots ok. On some occassions I just reboot in to Windows XP and then restart and its sorted out.

I havent been able to boot the Hardy disk as well on this machine. Though I am not in a hurry, I got an ACER 5920 laptop and Hardy works on it like a breeze.

jward3010
May 25th, 2008, 07:36 PM
I'll put in my tuppence happeny worth.

I have a Sony Vaio VGN-A397XP which uses a 100GB S-ATA drive but has a hopelessly optionless BIOS with no options for AHCI and RAID modes and hence I'm having this problem with "initramfs / busybox" etc.

This I have to say is pretty bad for Canonical, I assume that before it's released officially that the installation is tested on hundreds of different configurations in terms of different laptops, PC's, motheboards, drive configurations etc. How this was missed is hard to understand. Anyway I suppose where they should be praised is the fact that this cost me nothing and it's a genuinely good work in progress with this being a bit of a balls-up.

I've included a picture of what exactly comes up. It will be good for reference and I haven't seen one yet that shows the exact error.

hal8000
May 25th, 2008, 08:26 PM
DITTO !

I came in to search for support of my Abit IP35-E mobo. Since Gutsy I've had problems installing the OS. The mobo has 6 SATA ports on the mobo out of which # 1,2,5,6 are enabled. 3 and 4 are disabled as part of the mobo hardware spec. I have Seagate and WD SATA disks installed on ports 2,5 and 6. For some reason whenever I boot from the Hardy live CD, I always get the ATA4 revalidation error when I boot.

In Gutsy I managed to install the OS after removing the disks in ports 1 and 2. AFter that I installed the latest Kernel back then 2.4.26 from kernel.org and it worked. However it boots only 50% of the time. Most other times it just hangs at "Waiting for Root File System" and has to be reset a couple of times. USually entering the bios screen and saving (no changes made) works and the system boots ok. On some occassions I just reboot in to Windows XP and then restart and its sorted out.

I havent been able to boot the Hardy disk as well on this machine. Though I am not in a hurry, I got an ACER 5920 laptop and Hardy works on it like a breeze.

Have you by chance got 2 optical drives on an IDE connector sharing the same interrupt? This was my manin problem and now having a different device on a different connector works a treat. You could try removing the connector and see if that helps.

batmanjohnson
May 27th, 2008, 09:43 PM
e;4811715']works for me now, only thing needed was irqpoll...

worked for me, too. (dual boot via wubi). edited via regular boot sequence, not live cd. selected ubuntu, 'e' to edit, etc...... nice. this problem just started occurring, i had been using 8.04 successfully for days......strange.

wdl71
May 29th, 2008, 10:40 PM
I AM a newbie to Ubuntu and get stuck at busybox with a "try 8139too driver" message and am clueless. Also have an SATA drive. I'll try the AHCI method but beyond that don't know. Hopefully they will come out with a version of Ubuntu for clueless people like myself that will do everything for us called Nuubuntu or Buubuntu.

bgreenaway
May 30th, 2008, 09:00 PM
Just to add my tuppence worth as I have just (hopefully) solved this:

My hardware setup is a HP Media Center m7160n with a single Maxtor 250 GB SATA drive. Did not have the SATA option in BIOS to change to RAID (as suggested in earlier posts).

This problem was resolved for me by adding the all_generic_ide floppy=off irqpoll to the install option. So far, installation of 8.04 running smoothly. Will see what happens upon completion, however.

Li1t
June 1st, 2008, 03:03 PM
This problem was resolved for me by adding the all_generic_ide floppy=off irqpoll to the install option. So far, installation of 8.04 running smoothly. Will see what happens upon completion, however.

I was having a similar problem, except that the CD worked the first time I tried it. I reset as it used an auto-detected resolution which was too high (1600x1200, which worked but wasn't ideal as my old monitor displays part of it off the screen), and teh next time I ran it up it dumped me into busybox. Strangely, it got past that stage the first time for both Ubuntu and Kubuntu KDE4, but I reset from the installer both times opting to instead install from the live CD where I could change the resolution. I had exactly the same problem with both versions, it worked the first time but not subsequent ones.

That exact set of options, "all_generic_ide floppy=off irqpoll" in that order if it matters, worked for me too on my Asus A7N8X-E Deluxe with ATI9700 Pro and IDE HD.

Note, someone a page or so back mistyped ide_generic_all instead of all_generic_ide. The correct option is the one with all at the start, so: all_generic_ide

bgreenaway
June 2nd, 2008, 03:29 PM
Just to add my tuppence worth as I have just (hopefully) solved this:

My hardware setup is a HP Media Center m7160n with a single Maxtor 250 GB SATA drive. Did not have the SATA option in BIOS to change to RAID (as suggested in earlier posts).

This problem was resolved for me by adding the all_generic_ide floppy=off irqpoll to the install option. So far, installation of 8.04 running smoothly. Will see what happens upon completion, however.

Just to conclude that the 8.04 installation completed successfully and everything is running sweet.

robtjr30
June 5th, 2008, 04:24 AM
After I update Ubuntu 8.04 I and install all add-ons I reboot Ubuntu and I get the BusyBox V1.1.1.3(Debien 1:1 1.3-5 Ubuntu 12)Built-in Shell (ash)
Enter 'help' for a list of built in commands.
(initrants)
I do not know how to get back into Ubuntu I tried the Restore option through another Reboot and still the samething
What do I do?
I am running Windows XP Pro along with Ubuntu.

Kujen
June 5th, 2008, 09:13 AM
Posting this from a Dell Inspiron 530. The "all_generic_ide floppy=off irqpoll" fixed the busybox crap for me. Thanks to whoever figured that out.

You would think they would test the Dells that are selling their damn OS before releasing.

hannah187
June 5th, 2008, 11:02 AM
Just to add my tuppence worth as I have just (hopefully) solved this:

My hardware setup is a HP Media Center m7160n with a single Maxtor 250 GB SATA drive. Did not have the SATA option in BIOS to change to RAID (as suggested in earlier posts).

This problem was resolved for me by adding the all_generic_ide floppy=off irqpoll to the install option. So far, installation of 8.04 running smoothly. Will see what happens upon completion, however.

I have reinstalled Hardy Heron from my Alternate CD 8.04 with all_generic_ide floppy=off irqpoll to the install option and it did not solve my initramfs + busybox error. My laptop is Toshiba Satellite Pro L300 (PSLB1A).

Still searching for a solution.

Dave2k6
June 5th, 2008, 11:22 AM
When you get to the GRUB menu, press e, then go down one line and press e again.

Now add this to end of boot line, after the -- ,


all_generic_ide floppy=off irqpoll

If it works, you will need to edit you menu.lst file to include those boot parameters.

At a terminal screen type


gksudo gedit /boot/grub/menu.lst

Enter your password when askede.

Then look for a line similar to below


title Ubuntu 8.04, kernel 2.6.24-17-generic
root (hd1,0)
kernel /boot/vmlinuz-2.6.24-17-generic root=UUID=e61ff7b5-df4b-46c5-b95f-39de2857387a ro quiet splash
initrd /boot/initrd.img-2.6.24-17-generic
quiet

and add a space after the word splash then type


all_generic_ide floppy=off irqpoll (do NOT change the root=UUID bit as yours will be different from above (as it's the drive's id))

then save the file.

hannah187
June 5th, 2008, 11:44 AM
When you get to the GRUB menu, press e, then go down one line and press e again.

Now add this to end of boot line, after the -- ,


all_generic_ide floppy=off irqpoll

.

I am just looking at my Grub Menu..I do not have --

this is what is have:

kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=XXXX ro quiet splash

have added all_generic_ide floppy=off irqpoll at the end of splash and then enter and "b" to boot...
the Ubuntu Splash Screen appears and then after a while drops to busybox + intramfs shell..

still no solution for me..

IS there anyone installed HARDY on this Toshiba Satellite Pro L300 (PSLB1A)

ExemplarUbuntu
June 5th, 2008, 05:34 PM
With a floppy in the drive and muttering the incantaion (extra boot parameters) I have managed to get a Dell PowerEdge 2600 to boot the LiveCD to the Ubuntu desktop.

Next step is to try an install to see if it will recover the wreckage of so many failed installs.

Give me FreeMiNT-XaAES any day.

paul cooke
June 5th, 2008, 07:46 PM
I am really really not happy... I waited a few weeks and then tried to update my laptop from gutsy to the new 8.04LTS...

No dice...

this as far as I'm concerned is a showstopper... a biggy and should never have made it out of the gate...

I have tried some of these boot options no dice... all I get is the logo bar moving back and forth for what seems like ages and then get dumped into the busybox shell...

ALT -F1 gives me the normal terminal screen for the boot process and I see the following in the error message:


starting up ...
Loading, please wait...
Check root= bootarg proc/cmdline
or missing modules, devices:cat /proc/modules ls /dev
ALERT!/dev/disk/by-uuid/ff7922cab-081d-464d-8ee9-9b6341edc685 does not exist. Dr
opping to a shell!

what maroon introduced these uuids for booting???????

basically I have a completely borked laptop... and no obvious way to fix it...

good job it wasn't my primary machine... then I'd really be unhappy...

Mithrandir13
June 6th, 2008, 09:57 AM
Hi folks,

I've got XP and Vista both running together like a charm. But i need to install Kubuntu now as a third os. Tried it with wubi, but got the same problem after rebboting and selecting kubuntu to boot. Now i want to install it from the boot-cd, but as i read about these problems here, i am afraid, that afterwards, my two windows systems wont work anymore.

Is there a final solution?

kroutal
June 7th, 2008, 04:32 PM
Hello
I had the same problem with the Toshiba L300 12k.
I've finally managed to boot with the new kernel that's in the updates.

pascalc
June 8th, 2008, 06:55 PM
>IS there anyone installed HARDY on this Toshiba Satellite Pro L300 (PSLB1A)

Yes, the trick for me was to deactivate the LAN support in the BIOS (F2), this way I no longer have the error on the install CD boot and I could install Hardy. The problem is that I have to leave the LAN deactivated for Ubuntu to accept to boot and the Wifi is not recognized so I can't connect to the internet to get updates.

I read on a forum that some recent updates to the kernel would have fixed it but since I can't connect to the repositories, I can't apply them :(

hannah187
June 9th, 2008, 01:34 AM
>IS there anyone installed HARDY on this Toshiba Satellite Pro L300 (PSLB1A)

Yes, the trick for me was to deactivate the LAN support in the BIOS (F2), this way I no longer have the error on the install CD boot and I could install Hardy. The problem is that I have to leave the LAN deactivated for Ubuntu to accept to boot and the Wifi is not recognized so I can't connect to the internet to get updates.

I read on a forum that some recent updates to the kernel would have fixed it but since I can't connect to the repositories, I can't apply them :(

This is exactly my machine.. ok I will try this way. By the way: which CD have you tried to install. Live or Alternate..

As with ALTERNATE CD (8.04) I can install however after booting I get the error.

What is your experience in regards to get on the internet after installing 8.04. Were you able to?

Cheers

hannah187
June 9th, 2008, 07:23 AM
ok I have changed the bios to disable the LAN and with live CD 8.04 (and not Alternate CD) istalls with out a hitch. Now one can log into Hardy however no internet.

Then I have enabled LAN support in BIOS, and boot my laptop, intramfs+busy box returns. Note that 7.10 works without a problem.

kroutal
June 11th, 2008, 11:08 PM
You have to install this linux image :here (http://security.ubuntu.com/ubuntu/pool/main/l/linux/linux-image-2.6.24-19-generic_2.6.24-19.33_i386.deb) and the message should disapear.

Skerit
June 15th, 2008, 12:37 AM
Is there any progress on getting the WiFi to work on this machine? (Well, on a L350-107 more specifically!)

The kernel updates made the LAN problem go away, but I still don't know how to repair the wifi

Spudgun79
June 18th, 2008, 01:02 AM
Right, after a lot of messing about I've managed to get a Hardy Heron/Vista dual-boot (its a necessity) working.

I too started off with a Busy Box error, mainly preceded by the fd0 error, even though it worked fine with Gutsy. :confused:

My setup consists of a MSI K9A Platinum V1.0 motherboard with 2 Western Digital 320GB SATA II HDs. After reading this thread and seeing all the MSI issues I wasn't holding out much hope. For my mobo at least there are four SATA settings in the BIOS: Native IDE, AHCI, Legacy IDE & RAID. I finally managed to get Hardy to install and be able to use it by changing this setting to 'Legacy IDE' from 'Native IDE'. RAID was a no-go as then Vista would not work.

The problem with 'Legacy IDE' is it made Vista hideously slow so I really wanted to use 'Native IDE'. After trying everything I had found (all_generic_ide, irqpoll, noirqpoll etc..) for the boot options I tried "pci=nomsi" and everything now works like a charm!

Whether that would have worked straight from the live CD and allowed you to install without messing about with the BIOS I don't know, but I suspect it may well do.

I hope my experience will have the chance to help others. Its very frustrating and stuff like this really needs to be sorted out if Linux is going to go mainstream in the Desktop market. I persevered because I like using Ubuntu.

Can anyone tell me what "pci=nomsi" actually does? I did a quick google, but didn't really come up with much.

mmbspa
June 18th, 2008, 02:47 AM
I have the same problem. 100 gig hard ide drive, 64 amd processor and a cd/dvd drive and thats it. I just jet the initramfs and busy box and when typing help get nowhere.
why cannot the distro writers fix this.
Help????

mnec20
June 18th, 2008, 05:23 AM
I tried to install Ubuntu 8.04 LTS around a month ago and had the same problem as everybody else here. I ended up giving up on Ubuntu since nothing described in this topic helped at all, including the commands on start up and bios tweaking.
I tried agian a few minutes ago using the pci=nomsi argument and strangely enough it worked!! Ubuntu is being installed on my desktop as I write this on my laptop. Problem is: this "busybox" stuff is NOT SOLVED. I'm afraid it may happen again sometime soon since I've done nothing different than what I tried the other time. I'm obviously new to Linux so I'd like to ask special attention from the power users and developers about this matter so future releases won't be so troublesome.

paul cooke
June 18th, 2008, 09:55 PM
I'm extremely unhappy with this problem. :mad:

1) I have a borked laptop which won't boot after upgrade from gutsy to hardy. It dumps me in the busybox with the ridiculously long can't find UUID error... ](*,)

2) I have my primary machine still back on Dapper and Firefox 3 doesn't run on it... and there don't appears to be support for it now either... :(

I'm stuck with a dead laptop and I'm too scared to attempt the upgrade from Dapper to Hardy on my other boxes. I've had my fingers burnt too often before on rpm based systems with apparently easy upgrades that fell over completely.

This dumping people into busybox is, as far as I'm concerned, a serious showstopper and will really give a sour taste for both newcomers and experienced hands. :sad:

My laptop isn't anything special... just an old Sony VAIO with a good old fashioned IDE drive, none of this fancy SATA stuff...

herdivet
June 18th, 2008, 10:12 PM
Okay, here's a fix I used that worked for me. I was going to link to it, but I cannot find it on the forums now. it was originally posted by PriceChild.

REPAiRING YOUR BROKEN HARDY INSTALL

If you can, it is preferable to just boot using a backup kernel or into recovery mode and update from there. If you can't:

*Boot up a live cd, or separate Linux install
*Mount your Hardy drive somewhere (replace **** with name of drive, e.g. hda1 or sda2 etc)

code:
sudo mkdir /media/hardy
sudo mount /dev/**** /media/hardy

* chroot into your hardy drive

code:
sudo chroot /media/hardy
su

*Update your system via apt as normal (sudo not required)

code:
apt-get update
apt-get upgrade
apt-get dist-upgrade

*Ctrl+d or type "exit" to exit the chroot, then reboot the computer and you should be able to get back in to Hardy.


That's what was in the post. I have multiple Hardy's, one I have to use the all_generic_ide irqpoll at all times, the other will fall in to busybox on occasion and until I do this process it won't come out.

Hope this helps. Hate to see anyone giving up because of this.

mmbspa
June 19th, 2008, 12:29 AM
Some of us newbees have not done command line work in a while so be a litter nicer. Grow up.

cobraspyguy
June 19th, 2008, 01:25 AM
So does previous versions work? I was hoping to get away from Vista and not go back to XP but this seems like deja vu. Have to use an older version of buntu to get it to work. I guess microsoft isnt so bad after all.

paul cooke
June 19th, 2008, 06:09 PM
Okay, here's a fix I used that worked for me. I was going to link to it, but I cannot find it on the forums now. it was originally posted by PriceChild.

REPAiRING YOUR BROKEN HARDY INSTALL

If you can, it is preferable to just boot using a backup kernel or into recovery mode and update from there. [...]

Hope this helps. Hate to see anyone giving up because of this.

thanks, I managed to get in via an old kernel that was in the grub menu...

busy installing some 305 mb of updates right now... will get back with yey or ney when it's all finished.

paul cooke
June 19th, 2008, 07:50 PM
thanks, I managed to get in via an old kernel that was in the grub menu...

busy installing some 305 mb of updates right now... will get back with yey or ney when it's all finished.


it's a yey...

laptop rebooted fine

joele
June 20th, 2008, 01:00 PM
Tried all the suggestions in this thread, wasted most of the night.. got nowhere.. Back to Vista (it installs fine)..

If I wanted to screw around this much I would use Gentoo again...

Ubangi
June 22nd, 2008, 12:37 PM
Like many other people, I eventually managed to install with:
all_generic_ide floppy=off

However, I find now that some benchmarks run at only half their expected speed on my amd64.

I wonder if anyone else noticed this problem and if it might be connected with the screwed up installation?

hadley
June 22nd, 2008, 01:54 PM
Hi everyone,

I finally succeeded in installing 8.04 after experiencing the same initramfs+busybox issue. Jong's (http://ohioloco.ubuntuforums.org/showpost.php?p=4809508&postcount=61) solution worked in my case (using the live CD). Many thanks!

If it helps, or anyone's interested I'm running an Asus A8N-E, with one SATA and ATA drive (master and slave respectively).

As a bit of an aside, from 6.06 to 7.10 I've had no problems what so ever on any of my machines. A bit annoying, but great 8.04 is running!

hannah187
June 23rd, 2008, 05:52 AM
I have a Toshiba Satellite Pro L300 (PSLB1A) on which normal 8.04installation will stall at initramfs + busybox.

One needs to disable LAN in BIOS and then install 8.04 from Live CD (Not Alternate CD).

Then have this kernel update (suggested by Kroutal) offline ready in your Flash Drive or in any other form. Apply this update and when you then restart the comp, under Ubuntu 8.04 grub menu, one should see another option for 2.6.24-19 Kernel.

Now enable LAN in BIOS.

Restart the computer with 2.6.24-19 Kernel option. You should be able to access Internet.

However my sound card now stopped working. Should be a small problem to fix.


Mega thanks to Kroutal for his advice.


You have to install this linux image :here (http://security.ubuntu.com/ubuntu/pool/main/l/linux/linux-image-2.6.24-19-generic_2.6.24-19.33_i386.deb) and the message should disapear.

Gafard
June 24th, 2008, 11:10 PM
OMG, I tried this and that and it still doesn't work for me. I tried all the mentioned options in menu.lst and it didn't work.

I have no live cd. Could anyone tell me PLEASE what I could do to get rid of this annoying bug? I'm quite new to Linux and I'm obviously overstrained...

What kind of data do you need to help me?

hannah187
June 25th, 2008, 01:52 AM
OMG, I tried this and that and it still doesn't work for me. I tried all the mentioned options in menu.lst and it didn't work.

I have no live cd. Could anyone tell me PLEASE what I could do to get rid of this annoying bug? I'm quite new to Linux and I'm obviously overstrained...

What kind of data do you need to help me?


Tell us make and model of your computer and which Cd you use to install. Alternate CD does not work at least in my machine. I had to use the Live CD to install Hardy.

I'd_rather_be_____'ing.
June 26th, 2008, 05:14 AM
Read through almost all of this thread and finally came to a solution for me, although I haven't actually installed yet.

I tried all the bootloader commands and all combinations - no good.

In the BIOS I: disabled legacy USB support, changed the SATA mode from 'AHCI' to 'compatibility' (only options), and finally, disabled internal LAN. That's what did it. I went back and undid everything else, leaving only the LAN disabled, and the LiveCD still loads and appears willing to install. It's too late/early for me to try now...

The hardware is a Toshiba Equium L-300 laptop, and the culprit LAN is a Realtek RTL8102E. At least it's the one that disappears from Vista's device manager when it's disabled.

Now I have but two questions:
Should I leave the SATA mode as 'AHCI'? Is this generally a better choice?
Will my LAN work in the future? The link posted by hannah187 is 404.

Thanks to everyone who slugged this out before my arrival here a few days ago! I'll sign in under Ubuntu next time.

A.

tofuconfetti
June 26th, 2008, 07:36 PM
For me it's always been the legacy USB setting. Get things installed, then change the other settings back AFTER you install and I'll bet you'll be fine.

confused57
June 26th, 2008, 08:05 PM
Found this on the Phoronix website which may help some with LAN problems:

Onto the Linux and Solaris compatibility for the Gigabyte 965P-DS3. This board's predecessor had a few issues with the JMicron controller that was integrated to the board, but luckily we did not have any major issues with the P35! However, we did have one issue with the Realtek RTL8111/8168B Gigabit Ethernet controller. Ubuntu was unable to turn on the controller after Windows set it to disabled state instead of Wake on LAN state (don't worry; we just used Windows for the BIOS flashing). The fix is to unplug your computer, press the power button to drain the power, and then boot it back. Then enable Wake on LAN in the Windows Device Manager and it should boot fine. Enabling LAN boot ROM in the BIOS might also help for some people. Those of you who will be planning to use this board (or any board with this controller) on a dual boot Windows machine will most likely have this issue; but those who simply plan to run Linux will not have an issue.

dennisn
June 29th, 2008, 03:54 PM
I'm a little short on details, but basically, I'm pretty this is caused by the installation kernel not having the sata module required to use the hard drive (in my Acer 3680 cheap laptop). After much frustration, I ended up downloading the newer "intrepid" (8.10) iso image, and installing it via the hd-media installation images (as opposed to cdrom or netboot, hd-media's initrd automatically searches for iso images on your USB stick, etc, to install from). Intrepid's kernel/initrd is able to find my sata drive. (There is nice information on USB installation here: https://help.ubuntu.com/community/Installation/FromUSBStick )

So yeah -- the default 8.04 is a horrible release -- I'm pretty sure previous releases of ubuntu didn't have this problem (7.10, etc).

In particular, the Acer 3680 is poorly supported. Aside from not even being able to install AT ALL using 8.04 (dropped to busybox), sound doesn't work out of the box (a small configuration change has to be made), nor does wifi. ( http://ubuntuforums.org/showthread.php?t=429182 ). Maybe these things could be fixed in upcoming releases? (I'm not exactly sure if/how ubuntu deals with quirky hardware, but this seems to me what the distro is primarily meant to do. The "beauty" of ubuntu was NOT to force the user to tinker with "ugly" internals. In fairness, my first install of ubuntu on a friend's (older) computer was absolutely effortless and flawless, so I know this great potential is there.)

Gafard
June 30th, 2008, 11:46 AM
Tell us make and model of your computer and which Cd you use to install. Alternate CD does not work at least in my machine. I had to use the Live CD to install Hardy.

I do not use a live CD, I use a synaptec for upgrade.

My system:
-Computer-
Processor : 2x AMD Processor model unknown
Memory : 2063MB (776MB used)
Operating System : Ubuntu 8.04
Date/Time : Mo 30 Jun 2008 12:44:25 CEST
-Display-
Resolution : 1680x1050 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : HDA-Intel - HDA ATI SB
-Input Devices-
Macintosh mouse button emulation
AT Translated Set 2 keyboard
Logitech Logitech Dual Action
PC Speaker
PS/2 Logitech Mouse
Power Button (FF)
Power Button (CM)
-Printers (CUPS)-
PDF
-IDE Disks-
TSSTcorpCD/DVDW SH-S182M
-SCSI Disks-
ATA MAXTOR STM325031

What can I do to get a new kernel to work?

kewlito
June 30th, 2008, 05:44 PM
Thanks Jong

Neo0351
July 1st, 2008, 03:44 AM
so today i finally put my theory to the test that this was indeed caused buy a missing module. following this thread, http://ubuntuforums.org/showthread.php?t=311158&highlight=ahci
i spent all day trying different things. finally i found this
http://www.ussg.iu.edu/hypermail/linux/kernel/0707.3/3840.html
it said to disable the CONFIG_PCI_MSI module and sure enough now my computer boots properly without having to enter boot parameters. im using an abit an52 motherboard (nvidia 520 chipset). here's my ispic output for anyone interested

neo@neo-desktop:~$ lspci
00:00.0 RAM memory: nVidia Corporation MCP65 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP65 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP65 SMBus (rev a1)
00:01.2 RAM memory: nVidia Corporation MCP65 Memory Controller (rev a1)
00:02.0 USB Controller: nVidia Corporation MCP65 USB Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation MCP65 USB Controller (rev a1)
00:07.0 Audio device: nVidia Corporation MCP65 High Definition Audio (rev a1)
00:08.0 PCI bridge: nVidia Corporation MCP65 PCI bridge (rev a1)
00:09.0 IDE interface: nVidia Corporation MCP65 IDE (rev a1)
00:0a.0 IDE interface: nVidia Corporation MCP65 SATA Controller (rev a1)
00:0b.0 PCI bridge: nVidia Corporation Unknown device 045b (rev a1)
00:0c.0 PCI bridge: nVidia Corporation MCP65 PCI Express bridge (rev a1)
00:0d.0 PCI bridge: nVidia Corporation MCP65 PCI Express bridge (rev a1)
00:0e.0 PCI bridge: nVidia Corporation MCP65 PCI Express bridge (rev a1)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller (rev 13)
04:00.0 VGA compatible controller: nVidia Corporation Geforce 9600 GT 512mb (rev a1)

hannah187
July 1st, 2008, 04:58 AM
In the BIOS I: disabled legacy USB support, changed the SATA mode from 'AHCI' to 'compatibility' (only options), and finally, disabled internal LAN. That's what did it. I went back and undid everything else, leaving only the LAN disabled, and the LiveCD still loads and appears willing to install. It's too late/early for me to try now...

Now I have but two questions:
Should I leave the SATA mode as 'AHCI'? Is this generally a better choice?
Will my LAN work in the future? The link posted by hannah187 is 404.

A.


Right..I also run XP in my laptop hence I need to leave it on Compatibility mode otherwise my XP won't boot. If AHCI works for Vista, then try it and see what happens.

You will find that if you enable the LAN in BIOS, Ubuntu will not boot and drops to busybox. Hence you need to upgrade the kernel as suggested in the previous post. Since you cannot connect to internet, you need to download the latest kernel offline and then load it offline as well. After that you can enable LAN in BIOS and it should work.

You may find that the sound driver will not work. The solution is to load the latest kernel again through Synaptic (now that you can go online).

Cheers

hannah187
July 1st, 2008, 05:02 AM
I do not use a live CD, I use a synaptec for upgrade.


Can you please tell us the kernel version?

Gafard
July 2nd, 2008, 07:45 PM
Can you please tell us the kernel version?

Currently the last one that works is 2.6.22.14. Everything with 2.6.24 doesn't work.

Did you mean this?

hannah187
July 3rd, 2008, 12:51 AM
Currently the last one that works is 2.6.22.14. Everything with 2.6.24 doesn't work.

Did you mean this?

ok I understand.

Try one of these: You need copy this in your flashdrive and load in your laptop off-line.

http://security.ubuntu.com/ubuntu/pool/main/l/linux/linux-image-2.6.24-19-generic_2.6.24-19.34_i386.deb


or even later:

http://security.ubuntu.com/ubuntu/pool/main/l/linux/linux-image-2.6.26-2-generic_2.6.26-2.6_i386.deb

I am assuming that you have got an Intel 32bit machine.

kvmapr
July 8th, 2008, 02:42 PM
"i turned the "sata mode" in bios from "ahci" to "raid" and then it works"

Same problem here, and the same solution worked for me as well. In my bios (Dell 530n) the SATA line item has two modes, IDE and RAID. It was defaulting to IDE. After setting it to RAID and saving my settings, it booted wonderfully.

Now I just have to get my wireless working with the new 2.6.18 kernel.

kvmapr

onelife151
July 10th, 2008, 05:13 AM
I do seriously apologize if this has already been answered. I am going to try the achi to raid bios option when i reboot. I just wanted to see if you guys could help me out with this. I have a compaq sr1630nx. good will tell you my system specs. the only addons i have added is more memory and an extra harddrive. I downloaded the ubuntu 8.04.1 iso via torrent and then verified the iso image via the md5sums. when i boot using the pci=nomsi option or any options it freezes trying to load my external which i inturn had to unplugg and then freeze a bit on my card reader finally stalls at the initramfs prompt but through out the loading process i get this error over and over again.

hdc: status error: error 0x00 {}
ide: failed opcode was: unknown
hdc: drive not ready for command
hdc: status error: status=0x59 { DriveReady SeekComplete DataReset error }

if you need me to post for information about my specs or what i am doing please let me know. I really want to get ubuntu on this computer.

Gafard
July 14th, 2008, 08:35 AM
ok I understand.

Try one of these: You need copy this in your flashdrive and load in your laptop off-line.

http://security.ubuntu.com/ubuntu/pool/main/l/linux/linux-image-2.6.24-19-generic_2.6.24-19.34_i386.deb


or even later:

http://security.ubuntu.com/ubuntu/pool/main/l/linux/linux-image-2.6.26-2-generic_2.6.26-2.6_i386.deb

I am assuming that you have got an Intel 32bit machine.

I have 64bit, but I already installed these versions. And they all do not work. :confused:

Isn't there any single option or file that is responsible for this mess?

Tom55
July 14th, 2008, 09:20 AM
I have discovered a solution that worked for me. My setup is

ASUS MN2 MX SE-Plus motherboard
AMD Sempron LE-1200
2GB RAM
500GB SATA HDD
Pioneer DVD D/L burner
AMIBIOS V 0503 build date 26 Mar 08

When I attempted to use the Ubuntu Hardy Heron live CD I received the Busybox message.
After googling for ideas I selected the F6 option at the boot screen and added the parameters noapci nolapic acpi=off pci=noapci
I was able to avoid the Busybox screen but the system then froze at the Initramfs screen.
Thinking that there was a problem with the live CD I burned 3 more HH live CDís from different sources but had the same problem with each disk.
I then burned a Gutsy Gibbon live CD but still couldnít get the disk to work.
Next I went into the MB bios to the power option and disabled the ACPI Version Features and the ACPI APCI support option.

This resulted in the Gutsy Gibbon live CD successfully booting. However the HH CD (all of them) would not boot.
I then noticed when HH was attempting to load the monitor was showing some lines of text with SR0 and CDROM block error messages. Iím a newbie with Linux and have the Thomas Edison approach to problem solving (just keep trying anything until you find a solution). So I disconnected the Pioneer DVD player and replaced it with a Liteon CD player.

The HH live CD (all 3 of them) then worked.

So was the problem the Pioneer DVD drive. I then removed the CD driver and replaced it with an LG DVD player. The HH live CD would boot from the LG DVD drive.

In summary
To get Hardy Heron to boot from the live CD Iíve deactivated ACPI support in the bios and replaced the Pioneer DVD burner.

The Pioneer model is DVD-RW DVR-106D

raydude
July 20th, 2008, 05:00 AM
For 8.04.1 Boot CD (either 32 or 64 bit) I had to use all_generic_ide at the boot menu, and then (and this is the important bit) it took a full minute to start booting after the kernel good message came up.

Why the delay? I do not know. I'm just glad I came back to the forum to read some more before I rebooted. It started up while I was reading more posts.

Raydude

raydude
July 20th, 2008, 05:05 AM
Well, I can't log in to edit the post but I can log in to post so: its an Acer ASPIRE 5050 that I had this problem with, its not even SATA and its a laptop without a floppy.

Raydude

n7cee
July 20th, 2008, 09:26 PM
I had the same problem after upgrading Kubuntu 8.04 to 8.04-1. The old kernel, 2.6.24-16-generic, would boot OK, but not the new 2.6.24-16-generic. In checking that the UUID in the /boot/grub/menu.lst kernel line was correct for the new kernel, I discovered that a newline had been inserted in the middle of the UUID. Deleting the newline so the UUID was all on one line fixed thr problem.

irlandes
July 22nd, 2008, 05:40 AM
I am really really not happy... I waited a few weeks and then tried to update my laptop from gutsy to the new 8.04LTS...

No dice...

this as far as I'm concerned is a showstopper... a biggy and should never have made it out of the gate...

I have tried some of these boot options no dice... all I get is the logo bar moving back and forth for what seems like ages and then get dumped into the busybox shell...

ALT -F1 gives me the normal terminal screen for the boot process and I see the following in the error message:


starting up ...
Loading, please wait...
Check root= bootarg proc/cmdline
or missing modules, devices:cat /proc/modules ls /dev
ALERT!/dev/disk/by-uuid/ff7922cab-081d-464d-8ee9-9b6341edc685 does not exist. Dr
opping to a shell!

what maroon introduced these uuids for booting???????

basically I have a completely borked laptop... and no obvious way to fix it...

good job it wasn't my primary machine... then I'd really be unhappy...

Don't know if you got this fixed or not, much time has passed.

However, the whole thing,

/dev/disk/by-uuid/ff7922cab-081d-464d-8ee9-9b6341edc685

Should not be appearing in a boot error message.

The UUID that goes into grub menu.lst should only say:

ff7922cab-081d-464d-8ee9-9b6341edc685

For example:

root=UUID=ff7922cab-081d-464d-8ee9-9b6341edc685

I have no idea why you put the whole /dev/disk/by-uuid/ path in front. But, I can tell you that is why it didn't work based on your error message.

paul cooke
July 24th, 2008, 11:21 AM
my laptop booting issue is fixed. I used an earlier kernel in the boot list and gained acces and was then able to finish the upgrade properly...

epidemiks
August 13th, 2008, 02:26 PM
Oh wow.. After sitting on my hands since May, I figured I'd give this another go.. And IT WORKS!!

My troubles seem to stem from the Hard Disk I had Gutsy on..

Samsung SV1022D Rev A 2000.02

With that out of the system, and all_generic_ide floppy=off irqpoll in the boot options, the damn thing just worked!


If you will excuse me, I got some bandwidth to burn..:guitar:

melodis
August 16th, 2008, 08:32 PM
I've been working for months now trying to get Linux installed on my main machine. The only way I've been successful is to install an old ATA133 hard drive. Ubuntu, and more than likely, the GRUB manager seems to have a serious flaw, or compatibility issue with SATA connections.

I have both the SB600 SATA Controller and a JMicron JMB363 controller and the 8.04 live disc can't find any of my hard drives including a RAID 0 on the JMB363 or two seperate hard drives on the SB600 controller running in IDE Mode.

Strangely enough, I found this on the Wikipedia entry for JMicron:


JMicron SATA/IDE controllers are often incompatible with some boot loaders. In particular, those using GRUB, such as Ubuntu, cannot boot in some conditions[5]. The most recent Linux kernel and the most recent JMicron controller BIOS [6] solve these incompatibilities but may not be present in existing products, requiring a flash of the motherboard BIOS if the newer version contains the JMicron BIOS update. Other bootloaders such as EXTLINUX and the Windows boot loader work fine.

I've tried almost every recommendation in this thread, including:

all_generic_ide
irqpoll
nolapic
noapic
deleted quiet splash
floppy=off

Nothing seems to work or improve the situation. Granted, some of these commands change the errors I receive, or the point at which my machine locks up on boot, but in general, I still can't install 8.04.

My motherboard is nearly 3 years old (ECS KA3 MVP) so I would think at this point the Linux community would have addressed an issue with GRUB that has these types of issues with SATA controllers.

Does anyone know what kind of attention this issue is getting?

paul cooke
August 17th, 2008, 07:56 PM
My motherboard is nearly 3 years old (ECS KA3 MVP) so I would think at this point the Linux community would have addressed an issue with GRUB that has these types of issues with SATA controllers.

Does anyone know what kind of attention this issue is getting?

Well, the subset of ECS mobo users of that particular motherboard who actually use Linux is probably very small, so you are quite likely in a very small number of Linux users who are having problem... The issue here is that the problem is really yours to manage, not that of the community. You can't expect somebody else who isn't having a problem to know about the problem until they are actually made aware of the problem...

so has it actually been reported to the GRUB developers? If not, you'll have to do it yourself. If it already exists as a GRUB bug, then add extra details to the bug report.

Be prepared to help testing any patch as they are extremely unlikely to have the hardware you have.

euthymos
August 18th, 2008, 07:08 PM
Got the same problem on my system (mobo: ASUS P5K-E with JMicron controller, video card: nvidia 8800gt).
Tried all the workarounds but none worked.

I'm reverting back to windows: I've not so much time to waste.

azurehi
August 18th, 2008, 08:49 PM
The work around all_generic_ide has worked for me with all of the 8.04 "buntus" and must also be used in my case with all other 8.04 based distributions,e.g., linux Mint. As Intrepid approaches, I wonder whether this or similar issues will exist, whether, once again, workarounds will be necessary. I had no difficulty with any of the unbuntu distros prior to Hardy. I do not have the expertise to understand why 8.04 has been so difficult and exasperating to install and and I certainly cannot upgrade ot purchase a new computer.

If ubuntu is ever to become mainstream, i.e., easy to install with everything working, the developers are going to have to pay more attention to the user with older equipment, I would think. I have never heard on Any official ubuntu acknowledgment that the problem discussed in this topic since Hardy's release exists. Perhaps, I should not expect to. I can well understand the frustration of poster euthymos. I use ubuntu extensively but still use xp if I want to share pictures/cam in yahoo messenger, for example. When, if ever, can I do that with pidgin in ubuntu.

Sorry if my frustration is showing.

melodis
August 19th, 2008, 04:08 AM
Well, the subset of ECS mobo users of that particular motherboard who actually use Linux is probably very small, so you are quite likely in a very small number of Linux users who are having problem... The issue here is that the problem is really yours to manage, not that of the community. You can't expect somebody else who isn't having a problem to know about the problem until they are actually made aware of the problem...

so has it actually been reported to the GRUB developers? If not, you'll have to do it yourself. If it already exists as a GRUB bug, then add extra details to the bug report.

Be prepared to help testing any patch as they are extremely unlikely to have the hardware you have.

From the number of posts in this thread alone it's a very poor conclusion of yours to assume it's my ECS board. This isn't an ECS issue, but more like a GRUB/Linux issue with SATA controllers in general. Many people in this thread have a different manufactured mainboard with a JMicron controller on it that's having the same problem.

I don't know if this is a GRUB issue, or a Linux Kernal issue, or something else. I'm not a coder, programmer, debugger, or a driver designer. I'm just a Linux user.

As another user said later in this thread, if Linux is to become more mainstream, bugs like this have got to be resolved quicker than 2 years. After I've googled this problem, it dates back at least 2 years that I've found.

Enki0611
August 19th, 2008, 01:30 PM
Like many other people, I have a JMicron controller for my SATA drives. For me, the solution was to set the JMicron Controller Mode to RAID in the BIOS. Windows XP still launches with this setting.

I installed Ubuntu by installing the network installer on an USB stick through UNetBootIn (get it at: http://unetbootin.sourceforge.net/). I installed it without the RAID mode, but then that worked only once from the 10ish times I tried.

For the statistics, I have an Asus P5W DH Deluxe with a Intel quadcore Q6600. I am installing to a 300gb samsung sata disk. I have an Ami Bios version 2503 from 12/26/07.

If your computer uses JMicron and you can not set this option in your BIOS, perhaps you need to update your BIOS. According to JMicron, JMB bios 1.06.53 and above supports linux & grub as can be read here (http://www.jmicron.com/Support_FAQ.html). I have a different bios, but I think I might update my bios anyway to see if I can get it working without setting the controller mode to RAID

Oortism
August 19th, 2008, 09:28 PM
Ok Guys,
For the past week I have been unable to get Mythbuntu to install on my new made up system that I put together. I have read alot of this threads and have had to same problems as a lot of you. It was always, no matter what I tried,:

Busybox v1.1.3 (Debian 1:1.1.3-5ubuntu12) Built-in Sheull (ash)
Enter 'help' for a list of built-in commands.

(initramfs)

So finally, success!!!

These are my specs:

Xpci- ATI HD 2600 Pro Super
PCI - Broadlogic 2030 card
PCI - Vision Plus 1020a Digital Satellite TV card
PCI - Firewire / USB card and
USB - Genpix board

Motherboard: Asus A8V-XE

Memory: Rosewill DDR400 512mb model: RW 400/512 (4 x 512 = 2 gigs)

Hard Drive:

80 gig-7200rpm Western Digital #WDC WD800JD-(This drive has got Windows xp and want to erase and install fresh'Mythbuntu' system)

500 gig-7200rpm Western Digital #WDC WD5000KS (New)

Video Card: Palit Radeon HD 2600 Pro Super

DVD/CD: Samsung DVD Writer (BG68-01353A Rev. 02)
Artec DVD Writer (Vom-12E48X)Motherboard: Asus A8V-XE
Memory: 2 gigs
Hard Drive:

This is what I had to do:

Installed Ubuntu 7.10 as it saw everything with no problem. Next, I rebooted and inserted the, Ubuntu 8.04.1 (AMD 64) and whe it goes to the graphical menu, hit <F6> for "other options" and you'll see the kernel boot line and at the end you'll see a ' -- ' and the cursor will be placed just after the end of the line just after the ' -- ', just add 'all_generic_ide', without the quotes, and press the 'Enter' button on the keyboard.

It went to install Ubuntu 8.04.1 and after installation, reboot and insert the Mythbuntu 8.04.1 and it will install that.

I know it is a very long rout to get to install Mythbuntu but it worked for me. I am very happy after going 1 week on a daily basis trying and trying that to install this.

I give credit to whomever posted about the 'all_generic_ide'. That did for me.

Hope it works for someone else---Oortism

AlanPo
August 23rd, 2008, 04:59 PM
thanks to gmilne post #133

I needed only irqpoll option. and no more initramfs!!
just needed time to realize that after editing a line need to press b not ESC:)

I have Intel dual core system , 8.041 hardy, and this unfortunate SATA.

Miroku
August 24th, 2008, 02:28 AM
very discouraged when i learned of this issue, how am i suppose to brag about this LTS when the first thing that pops up to those who i recommend ubuntu to is an error. i guess i am sticking with 7.10 for now. and i was so excited as well.

well its time to start plowing thru these posts to get the livecd to 'just work'. i appreciate all the hard work and yes this was a completely useless post. i just felt a strong need to say something.

manthony121
August 24th, 2008, 09:24 PM
Adding my experience:

My current seup: Intel D975XBX2 Mobo, (has a Marvell SATA controller), 2 SATA HDDs, 1 SATA DVD-R/W drive. Dual-booting XP / Ubuntu 7.04 64 bit (though I can't remember the last time I booted XP). Put in the 8.04 i386 CD to begin upgrade....BusyBox/initramfs comes up. Added "irqpoll" to the boot options --> boots OK.

I'm not sure what "irqpoll" is telling it to do; it sounds like an oxymoron: irqs are a way of getting the CPU's attention *without* polling.

It's little things like this that make Linux so lovable. You expect something to go a certain way. When it doesn't, you dig around the Internet and the forums, learn a bunch of stuff that you never knew before, try things you didn't even know were there to be tried, and when it works, you feel a wave of relief wash over you.

cmat
August 24th, 2008, 10:08 PM
This seems to be a problem with BusyBox when it cannot find a floppy drive on certain systems. Getting the latest Ubuntu LiveCD ISO solved this problem for many people.

mkoonstra
August 25th, 2008, 01:28 PM
Did not see that this topic was active at the time I posted mine, maybe somebody can help me here.

You can view my topic here: http://ubuntuforums.org/showthread.php?t=899341

Does somebody have an idea what to do?

ferral-cat
August 25th, 2008, 06:48 PM
I was finally able to install Xubuntu 8.04 (Hardy Heron) on my Dell Vostro 200 tower PC. These instructions should also work on Kubuntu 8.04 and Ubuntu 8.04

I did NOT go into the BIOS to change the Sata to RAID. The best thing is "restore default settings" in the BIOS.

Then when you get to the screen to install Xubuntu press F6 key so you can edit the special arguments boot line.

add the following to the end of the line after the --

all_generic_ide floppy=off

This worked for me and after the install I did not have to edit menu.lst at all

Good Luck. And this distro rocks!

After sucessful install then install the package "ubuntu restricted" and you will have flash, java, mp3 and so on working.

sn0rlaxx
August 26th, 2008, 08:53 AM
Just thought I'd contribute my success story, using the all_generic_ide floppy=off irqpoll command my install worked on a rig with Asus A8N-E mobo, SATA hdd.
Great job ubuntuforums, you guys are my heroes :)

mkoonstra
August 26th, 2008, 09:47 AM
My succes was with "floppy=off pci=nomsi".

Kipposaurus
August 27th, 2008, 05:52 PM
I'm trying to install Ubuntu so I can dual boot it alongside XP.

Getting the Initramfs error, putting me into the console but unable to type at all.

A lot of conflicting information in this thread, I know that my Windows won't boot in RAID mode though, so that fix isn't an option.

How can I do this "pci=nomsi" thing. Where is the option for the setting?

Michel347
August 29th, 2008, 03:24 PM
I'm a newbie at this since it is my first experience to load a Linux distro (past experience of re-installing Windows 98, Windows 2000 and XP because the kids would mess up the PCs and change some hardware as well).

I have a 2004 Gateway 500:
Processor: Intel Pentium 4 Processor 2.6GHz with hyper-threading technology and 800MHz FSB
Memory: 768MB 333MHz DDR SDRAM
Hard Drive: 120GB 7200 RPM Ultra ATA 100
Network Adapter: Integrated 10/100 Ethernet adapter
Controller: Integrated Ultra ATA Controller
Graphics: Integrated Intelģ Extreme Graphics 2 with dynamic video memory
Audio: Integrated Intel
Chipset: Intelģ 865G, Intelģ BIOS
USB Ports: 8 Version 2.0 USB ports (2 in front, 6 in back).
DVD+RW/CD-RW combination drive

Ubuntu 8.04.1 -desktop-i386, with Wubi installation would not install after the first boot, I was getting that busybox (initramfs) each time after seeing it attempting to do something with the DVD+RW/CD-RW combination drive.

I tried everything found in that long post, nothing worked, untill when trying it again and again I decided to play with the open door of the DVD when it was doing something with it, it did the trick !!! So I was able to complete the installation, and my Ubuntu HH is now working perfectly with the exception that I have now to figure out why there is no sound.

RealG187
September 1st, 2008, 01:44 AM
My friend has a Toshiba Satellite notebook and this happened, so he is staying with Vista...

UPDATE: Looks like the new Ubuntu 8.04 ISO works:

http://www.ubuntu.com/getubuntu/download

JYoungest1
September 1st, 2008, 04:19 PM
I am fairly new at this whole linux game, but I think I might know part of the issue with the busybox start.

I was having the same problem and continued to reset it over and over. The only way I got it working again was to start into Vista, and when I did there were updates to be installed, and I had also shut down windows a little messy the time before. When I let the updates install and shut down correctly it worked.

GaryLog
September 2nd, 2008, 01:03 PM
I have been reading alot about this initramfs + busybox trouble installing.
I wanted to thank this forum in helping me resolve this issue.
I wanted to give you my results to solve the installation of Ubuntu:

in reguards to AHCI to Raid, below is how I have to load Vista and Ubuntu in the bios:
IDE = Vista but not Ubuntu
ACHI = Ubuntu but not Vista
Raid = neither no boot to Vista or Ubuntu

This is a real pain in the ***, but it works, if anybody has a betterway to boot this please let me know.
My system has my two harddrives in the raid on the motherboard and not IDE but the only way it will but is in the IDE mode.

cmat
September 2nd, 2008, 05:16 PM
My friend has a Toshiba Satellite notebook and this happened, so he is staying with Vista...

UPDATE: Looks like the new Ubuntu 8.04 ISO works:

http://www.ubuntu.com/getubuntu/download

Getting the new ISO worked for me. Also has this bug been reported to launchpad? Or are we just running in circles with our arms in the air?

RealG187
September 3rd, 2008, 01:23 AM
I wonder does this happen if you boot the old Kubuntu (or Xubuntu) CD?

molochi
September 3rd, 2008, 07:35 PM
I was running into this sort of problem a week ago installing Ubuntu 8.04.1. SATA is running as IDE on a P43 motherboard (GA-EP43-DS3L). I'm downloading intrepid-desktop-amd64 (Alpha4)now for a clean install, but it'll be a few hours before the dl finishes. Lots of newer hardware and chips on this system, should be interesting to see what works. I'll update later.

50words
September 4th, 2008, 09:57 PM
I tried switching from IDE to RAID on my new Inspiron 530, but now I cannot get into the setup menu. Pressing F12 gets me the boot menu, but pressing F2 doesn't get me anything but the regular boot process.

50words
September 4th, 2008, 10:38 PM
I just pulled the cord and battery and reset the BIOS. Now, of course, I can't boot into Ubuntu. If I change the SATA from IDE to RAID, I can't access the BIOS. It's a no-win, it seems.

RealG187
September 5th, 2008, 01:33 AM
I tried switching from IDE to RAID on my new Inspiron 530, but now I cannot get into the setup menu. Pressing F12 gets me the boot menu, but pressing F2 doesn't get me anything but the regular boot process.

My friend and I have similar BIOSES, ours are F12 for boot menu and F2 for setup, and when I press F2 it looks the same, the only difference is when you first turn it on, the splash for mine says acer and his says Toshiba.

I recall that if you get to the boot menu (F12) you can access setup from there, I think it's the last option.

molochi
September 5th, 2008, 02:41 AM
Ubuntu 8.10A4-amd64 up and running, no busybox, no change in bios, so windows works too. Of course 8.10A5 is supposed to drop today, but I didn't know that when I DLed. I just did a regular clean install

Got a blank white screen after login (ATi4850) but I fixed that (get rid of Compiz). Now I just need to get wireless, azailea hd sound, and access to the NTFS partition going.

GaryLog
September 7th, 2008, 03:12 AM
[QUOTE=GaryLog;5711814]I have been reading alot about this initramfs + busybox trouble installing.
I wanted to thank this forum in helping me resolve this issue.
I wanted to give you my results to solve the installation of Ubuntu:

in reguards to AHCI to Raid, below is how I have to load Vista and Ubuntu in the bios:
IDE = Vista but not Ubuntu
ACHI = Ubuntu but not Vista
Raid = neither no boot to Vista or Ubuntu

This is a real pain in the ***, but it works, if anybody has a betterway to boot this please let me know.
My system has my two harddrives in the raid on the motherboard and not IDE but the only way it will but is in the IDE mode.

[I forgot to say that I used the Wubi download for the installation of Ubuntu.)
http://wubi-installer.org/

grashdur
September 17th, 2008, 03:13 AM
My patience is at an end with this thing! I was using Ubuntu HH with Wubi and it seemed mostly fine. I just wanted to make things a bit more secure by switching to a normal ubuntu partition. I wanted to use LVPM to make the transfer, but needed partitions, and the Partition Manager refused to run on my hdd. I tried all kinds of things, and decided to just do a fresh reinstall. I ran into this initramfs problem and finally concluded unintelligently that it must be caused by the boot menu situation for Wubi, so I uninstalled Wubi. But I still had the same problem. Now it looks like I have no choice but to return to Wubi, and do a whole round of installing and configuring for nothing!!

Maybe Itchy Ibex will solve this problem???

jm1508
September 17th, 2008, 03:34 AM
I was having the same problem, i have windows and ubuntu installed side by side. I know this isn't a permanent fix but it got me in. when the screen comes up to select OS i clicked ubuntu then a screen comes up saying press "esc (or something else) to go to menu" or something like that with a timer, i went to it and some options pop up
ubutu 8.07
ubuntu 8.07 recovery mode
something else

and windows

i clicked on the recovery mode and let it load then clicked on start ubuntu normally, and the login window popped up. I wouldn't suggest using this every time but it'll get you in to change the files the other user metioned.

hope this was helpful.

bsprecher
September 20th, 2008, 10:41 PM
I have been trying to completely replace the OS on my old Dell Dimension 4600 with Ubuntu. I also encountered the issue described here and tried everything mentioned (such as adding 'all_generic_ide floppy=off irqpoll' after hitting F6 on the boot menu, changing boot order in the BIOS; trying to turn on RAID - which wasn't even an option; etc.), all to no avail.

In desperation, I was sitting here, staring at the forum on my other computer as the machine went through yet another reboot, and I guess I let the system wait long enough that it automatically selected the English language and continued to boot into the Live mode! From within the Live mode, I ran the installer (on the Hardy Heron desktop), and that seems to be running now (knock on wood).

So, if you can't get the installer to load, try running the Live mode. In case it matters to anyone, here is some info about my machine:

Dell Dimension 4600
2.4GHz Pentium 4
1.5 GB RAM
2 ATA hard disks - 80 GB and 160 GB
2 CD/DVD drives (also ATA)
No Floppy

I suspect all the pain has something to do with the 2 hard drives I have set up, but I have no idea.

Good luck everyone!

earlyjazz
September 25th, 2008, 10:41 PM
For everyone's info, I am having the same problems trying to install mandriva (one) 2008.1 from a live disk on a brand new Dell 530n which is also loaded with winXP. Don't shoot me, I need Quicken and TaxCut. I'm about to try some of the suggestions from this forum and will report back. Might help to isolate problem ie. kernel, computer, distro.
BTW, I tried to reinstall Ubuntu from disk Dell sent w/computer and it also had same problem!

odeley
September 29th, 2008, 12:52 AM
I have the same problem. I've installed Ubutu with Wubi, then I rebooted the computer and that initramfs thing appeared. I have Windows XP as my primry os, so I don't want to make any changes on the bios and also I don't want to make a partition. Soo what can I do?:confused:

spoier
September 30th, 2008, 06:07 PM
I had the same problem, turned out to be the Seagate FreeAgent USB hard drive, it was trying to mount it on /dev/hdc or something. Just disconnected all non-essential USB devices and then it booted fine. I have IDE drives, a 3ware PCI RAID controller, and disabled the onboard SATA since I wasn't using it.

Skye

warnec
September 30th, 2008, 07:03 PM
I've experienced similar issues to yours guys. I think I might have found a possible solution.

(look here: http://ubuntuforums.org/showthread.php?t=934302)


PS My mobo is Foxconn MARS, also with Jmicron SATA controller. I have one SATA HDD and one SATA DVD burner, that's all.

cspizz
October 1st, 2008, 01:43 AM
There are many different issues and errors that have been discussed (and resolved) in this thread. Mine was (thankfully [-o<) more stereotypical. What's below isn't anything new--I may have found all my answers in this thread--but it pulls together a few of the most common errors and their common solutions in one spot. Doubt anyone will even find this post on page 24(?) of this ~6 month-old thread, but I spent hours figuring it out so thought I'd share. :popcorn:

I couldn't install HH 8.04.1, boot to the live desktop, or get through a disk check. They all resulted in the same thing: an endless loop of "[##.####] Buffer I/O error on device fd0, logical block 0." (and some other errors I'll get back to). I quickly found that fd0 was reference to the floppy disk drive (FDD). The kernel was looking for a FDD for some reason, and I don't have one. (Why it didn't just move on, I can't say. :confused:) This was an easy fix for me (as it appears to have been for many others): I disabled the floppy drive in my BIOS and removed it from the boot order.

That stopped the 'fd0 error' loop, but now brought me to the BusyBox and initramfs deadend. Again, this was an easy fix for me (as it appears to have been for many others): I hit F6 at the install menu, removed the last two parameters from the boot line ("silent" and "quiet" I think) and added "irqpoll".

Once I did that, I was able to boot to the live CD. After booting live, I could see everything was generally working fine, so I installed to a new partition and set up a dual boot with EasyBCD. Here's my cautionary tale: I logged out before changing the boot line parameters inside the newly installed OS, so HH wouldn't boot after I logged out. #-o I had to reboot into the live CD to edit the boot line. SO, before you log out after having gone through all you've gone through, DON'T FORGET TO EDIT THE BOOT LINE TO ADD WHATEVER PARAMETERS GOT YOU IN IN THE FIRST PLACE!!! To do that inside the newly installed OS, open up a terminal window and type:


gksudo gedit /boot/grub/menu.lst

That will open up a document. Scroll down to the bottom (about 3/4 down) to find the boot command line (I identified the right line by finding the 2 parameters I needed to replace--"silent" and "quiet" I think--and make your changes.

If you're a dunce like me #-oand logged out before making the changes, you'll probably need to add a few more directories to your command:


gksudo gedit /disk/folder/boot/grub/menu.lst

These errors have apparently been common since this thread started in April 2008 when HH 8.04 was the latest. Since then, 8.04.1 was released (the version I installed), but these issues haven't been fixed. :-k

That's it, I think. If anyone finds this and has any question, feel free to PM me. Keep in mind what I just wrote is the sum of my linux knowledge to date.

iamah
October 11th, 2008, 04:12 PM
I'm in awe and shock in front of the revelation I had this morning: my computer world is collapsing.

I had an old computer, very supported by all distros. Couldn't run new games, though...

Now I have a new computer, but couldn't run Ubuntu cause of busybox, and windows xp new games keeps crashing with Nvidia infinite loop problem.

It's hell! :guitar:

Whats in the future for us? :confused:

I'll try Vista for Nvidia driver support, but since Vista has problems of its own, I'll end up with a triple boot Vista + XP + Ubuntu...

bobwyajnr
October 14th, 2008, 10:05 AM
OMG, I'm up running with Hardy now :lol:
No IDE to RAID switch, nor enabling the floppy drive (I disabled it again).

Using the desktop live cd, what did the trick for me was adding
all_generic_ide floppy=off irqpoll to the boot options when pressing F6. ...

Hope this may help someone - good luck to everyone.


Thanks Jong!! I have been tearing my hair out trying to get Ubuntu to install on my system!! Those switches did the trick!! The question this begs then is why haven't these installer woes been sorted out in the 8.04.1 release!! :confused:

I have a system build around a Tyan K8SE board (Nvidia nForce 4 professional 2200 chipset), dual AMD Opterons, lots of SCSI and SATA controllers (I actually boot from a U320 15K SCSI drive), no floppy drive present (floppy controller disabled)!! But I have been using an IDE DVD rewriter drive to boot Ubuntu from (secondary channel, master)!! However the boot process drops out prematurely to the Busybox command prompt. This happens with Ubuntu and Kubuntu discs versions 8.04 and 8.04.1 (x86 and AMD64 variants).

The Linux kernel is still booting when the Ubuntu CD drops out to the Busybox prompt (without Jong's magic solution). There is a race condition happening where Ubuntu is looking for the install CD before the kernel has even located the IDE DVD drive!! So the Caspter log file shows that Ubuntu has quickly whipped through all the possible drive devices and decided it can't find the install CD - dropping out to the Busybox prompt very early on. However with "priority=low" switch set, the non-graphical installer, I can see that the kernel does not finish detecting hardware till much later on in the boot process!! BTW there are no errors in the dmesg log (so it is simply a timing issue - unlike some other folks experience).

This is a very poor show as the actual OS itself runs very well... If you can get the bugger to install itself!! :lolflag:

Bob

iamah
October 14th, 2008, 01:17 PM
OMG, I'm up running with Hardy now :lol:
No IDE to RAID switch, nor enabling the floppy drive (I disabled it again).

Using the desktop live cd, what did the trick for me was adding
all_generic_ide floppy=off irqpoll to the boot options when pressing F6. I can't tell if you really need all three options. I'm just happy to be up running :D

Hope this may help someone - good luck to everyone.

Thanks, I could run the cd and install, but when running from hd i got busybox again...

any suggestions are appreciated

cspizz
October 15th, 2008, 02:49 AM
Thanks, I could run the cd and install, but when running from hd i got busybox again...

any suggestions are appreciated


[...]I was able to boot to the live CD. After booting live, I could see everything was generally working fine, so I installed to a new partition and set up a dual boot with EasyBCD. Here's my cautionary tale: I logged out before changing the boot line parameters inside the newly installed OS, so HH wouldn't boot after I logged out. #-o I had to reboot into the live CD to edit the boot line. SO, before you log out after having gone through all you've gone through, DON'T FORGET TO EDIT THE BOOT LINE TO ADD WHATEVER PARAMETERS GOT YOU IN IN THE FIRST PLACE!!! To do that inside the newly installed OS, open up a terminal window and type:


gksudo gedit /boot/grub/menu.lst

That will open up a document. Scroll down to the bottom (about 3/4 down) to find the boot command line (I identified the right line by finding the 2 parameters I needed to replace--"silent" and "quiet" I think) and make your changes.

If you're a dunce like me #-oand logged out before making the changes, you'll probably need to add a few more directories to your command:


gksudo gedit /disk/folder/boot/grub/menu.lst


iamah - Because booting from the HD doesn't bring up the boot menu, you have no opportunity to change the boot parameters as you did when successfully booting from the live CD. Your install is stuck trying to boot from the same bad parameters. You need to boot into the live CD then edit the boot parameters for your install. Open a terminal window and type:


gksudo gedit /*disk*/*folder*/boot/grub/menu.lst

NOTE: You must replace *disk* and *folder* in the code above according to your configuration. You need these to find the boot parameters of your HD install.

PM me if you need clarification or more help on this.

craigcrawford114
October 17th, 2008, 06:26 AM
Hi,

I am experiencing the same problem. I am trying to install Ubuntu 8.04 (I've also tried 8.10) on a RocketRaid 2320 controller in a RAID 5 array.

I've tried all the suggestions in this thread with no luck. It gets up to the Ubuntu loading screen and then throws me back into the "initramfs + busybox" screen.

I know I probably wont get any responses to this message (I haven't in any other thread I've created here), especially due to the fact that not many people would be trying to install on a RAID 5 array.

But are there ANY parameters I can try?

Pxtl
October 18th, 2008, 03:25 AM
Hey, installing on a brand-new Dell box, had the same problem... irqpoll dodged that one problem and it seems to get further, but instead, it freezes up after ath_pci, on
"ACPI: PCI Interrupt 0000:02:01[A] -> GSI 16 (level, low) IRQ 16"

dunno where to go from there.

iamah
October 18th, 2008, 05:03 AM
i followed cspizz suggestion, but my menu.lst already had the options i used at live-cd boot... nice, but it didn't work when booting from hd, it hangs at some USB HiD stuff... man I'm missing my Ubuntu:confused:

snake_in_a_box
October 22nd, 2008, 01:38 AM
I've been having quite a problem with this installation. Tried to install Hardy Heron but I got busybox'd. Tried many of the solutions here but none worked. So, out of desperation, I popped in a Gutsy Gibbon disk. Lo and behold, it works. I then install Gutsy on my comp and upgrade to Hardy. I restart my computer and Busybox rears its ugly head. I need to get Hardy on this computer for school. Specs are below. I'm trying to install on the SATA HD.

AMD Athlon 64 X2 5200+
Nvidia Geforce 8800GT
ASUS M2R32-MVP Mobo
one 320 Gb SATA HD
one 80 Gb IDE hd

Matthew Good
October 23rd, 2008, 04:39 PM
I've been having quite a problem with this installation. Tried to install Hardy Heron but I got busybox'd. Tried many of the solutions here but none worked. So, out of desperation, I popped in a Gutsy Gibbon disk. Lo and behold, it works. I then install Gutsy on my comp and upgrade to Hardy. I restart my computer and Busybox rears its ugly head. I need to get Hardy on this computer for school. Specs are below. I'm trying to install on the SATA HD.

AMD Athlon 64 X2 5200+
Nvidia Geforce 8800GT
ASUS M2R32-MVP Mobo
one 320 Gb SATA HD
one 80 Gb IDE hd

Your setup is very similar to mine. To get hardy to install when your at the options menu press F6 and add pci=nomsi. That should get you thru or at least it did for me. To bad it doesn't work on the new Intrepid which I am still trying to figure out how to get that one installed.

iamah
October 27th, 2008, 04:47 AM
will try the 8.10 or other distro someday, for now I'm using windows

matis_keynell
October 27th, 2008, 11:38 AM
i had the same issue with wubi 8.04 & 8.10 live cd
'all_generic_ide irqpoll' fixed it the initramfs issue, but now installation stucks at
'usb hid core driver'
some mentioned adding a line: /sbin/udevsettle --timeout 10
to udev (in /scripts/init-premount) but i don't know how to do that since no command listed with 'help' can edit text files, and i can't do this under another os since it's a wubi installation
how to pass around that, any idea?

bep
October 27th, 2008, 12:04 PM
I updated from 7.04 -> 7.10 -> 8.04, then got the busybox.

Could only boot from a fairly old kernel. Here is what fixed my problem:

First I removed splash/quiet from the boot options in /boot/grub/menu.lst. Then it was clear that Ubuntu for some reason now identifies my IDE disk as a SCSI device or something.

So I changed the menu.lst-item to this (/dev/hdc3 -> /dev/sda3 (my Ubuntu is on the fourth partition)):


kernel /boot/vmlinuz-2.6.24-21-386 root=/dev/sda3 ro

I also edited /boot/grub/device.map:



(hd0) /dev/hdc
(hd0) /dev/sda


(Do not know if the last step is necessary.

And viola!

the_darkside_986
November 1st, 2008, 07:35 PM
I am still getting BusyBox on 8.10 on a cheap Compaq Presario that has been able to run Windows XP, Windows Vista, and even older versions of Ubuntu without any issues. This happens before AND after replacing the IDE drive with an extra SATA I had. The BIOS doesn't support changing many options and Windows XP SP3 installed on the same machine without any issues, so the BIOS clearly isn't at fault. I should probably just give up and format the whole drive for NTFS anyway if it is a kernel problem until someone makes a distro containing an old stable kernel that Just Works (TM) suitable for desktop usage while running all of the latest free software.

Cha-cha
November 2nd, 2008, 08:37 AM
Here is how I fixed my initramfs and busybox problem.
First I noticed from my bios that my hard-drive was being detected as a secondary hard-drive (not primary). Many of the info here suggested that the initramfs issue has to do with the drives (hard, floppy, CD). I opened my computer, checked out the hard-drive and CD connection to the IDE. It turned out, just as the bios indicated, the hard-drive is connected as secondary IDE device. The cable I have has 3 connector--black (top) , grey (middle), blue (end). The label on my hard-drive says the grey connector is for secondary IDE devices. The original setup has the hard-drive connected to the the grey connector, while the CD-ROM is connected to the black connector and the black connector is connected to the IDE slot on the mother board.

I reconnected my devices as follows: black connector was connected to the hard-drive, the grey connector was connected to the CD-ROM and the blue connector was connected to the mother board.

The installation went very smoothly after the reconfiguration.

Note: my box had XP and I was able to boot with it, so initially, I didn't suspect I have a hardware issue.

the_darkside_986
November 3rd, 2008, 01:49 AM
I've already tried two different SATA slots but I'll try the remaining later. But still, if Ubuntu 8.04 and earlier can find the drive, there is no reason the newest shouldn't be able to. They should quit introducing fatal bugs into the OS for no good reason.

bibloks
November 6th, 2008, 01:54 AM
Ok Guys,
For the past week I have been unable to get Mythbuntu to install on my new made up system that I put together. I have read alot of this threads and have had to same problems as a lot of you. It was always, no matter what I tried,:

Busybox v1.1.3 (Debian 1:1.1.3-5ubuntu12) Built-in Sheull (ash)
Enter 'help' for a list of built-in commands.

(initramfs)

So finally, success!!!

These are my specs:

Xpci- ATI HD 2600 Pro Super
PCI - Broadlogic 2030 card
PCI - Vision Plus 1020a Digital Satellite TV card
PCI - Firewire / USB card and
USB - Genpix board

Motherboard: Asus A8V-XE

Memory: Rosewill DDR400 512mb model: RW 400/512 (4 x 512 = 2 gigs)

Hard Drive:

80 gig-7200rpm Western Digital #WDC WD800JD-(This drive has got Windows xp and want to erase and install fresh'Mythbuntu' system)

500 gig-7200rpm Western Digital #WDC WD5000KS (New)

Video Card: Palit Radeon HD 2600 Pro Super

DVD/CD: Samsung DVD Writer (BG68-01353A Rev. 02)
Artec DVD Writer (Vom-12E48X)Motherboard: Asus A8V-XE
Memory: 2 gigs
Hard Drive:

This is what I had to do:

Installed Ubuntu 7.10 as it saw everything with no problem. Next, I rebooted and inserted the, Ubuntu 8.04.1 (AMD 64) and whe it goes to the graphical menu, hit <F6> for "other options" and you'll see the kernel boot line and at the end you'll see a ' -- ' and the cursor will be placed just after the end of the line just after the ' -- ', just add 'all_generic_ide', without the quotes, and press the 'Enter' button on the keyboard.

It went to install Ubuntu 8.04.1 and after installation, reboot and insert the Mythbuntu 8.04.1 and it will install that.

I know it is a very long rout to get to install Mythbuntu but it worked for me. I am very happy after going 1 week on a daily basis trying and trying that to install this.

I give credit to whomever posted about the 'all_generic_ide'. That did for me.

Hope it works for someone else---Oortism

Please mate how did you manage to instal PCI - Broadlogic 2030 card?
I am trying to get this card to install and read in the net bunch of articles but I cannot find driver anywhere, the one I found are old and are for redhat!

I have installed mythbuntu 8.10, still did not configured anything in mythtv as I want to have DVB initially installed.

PCI - Broadlogic 2030 card is visible by the system as netowrk card when i lounch hardware testing but its not dvb.

Can you guys help me on this, need to know is this old card still can be runned with mythbuntu 8.10

Thanks

Gralgrathor
November 6th, 2008, 10:21 AM
I have a similar problem with installing the 8.10 32-bit livecd.

I have a simple machine, 32 bit architecture mainboard, dual core Intel cpu, 4 sata channels, 2 IDE, to which I added an additional 4 IDE channels using a PCI IDE controller. The machine came with a Samsung 500G SATA drive (ch. 1/4), and I added 2 WD 1T SATA drives (ch. 2 and 4/4), and 2 older WD 500G IDE drives (those last two I plugged into the PCI controller, both as master).

The base install works like a charm. I just enter through the program, sacrifice my entire (hd0) 500G SATA drive to the "guided partitioning" process, remove the CD, hit enter - and -

End of story. The thing won't boot no matter what I do. The machine just stopped dead right after the POST check.

So here's what I did: I re-installed Debian, my previous installation, using the same harddrive, and told the installation program to tweak the MBR and /boot partition (why doesn't the ubuntu install livecd have nifty options like that? sure, the installer is easy to use - unless it doesn't work!). Then I re-installed ubuntu, again using (hd0).

Now, at boot, at least I got the grub menu. But keying enter got me in the BusyBox. The UUID its trying to boot from is wrong. So I rebooted and got myself into a grub commandline, to try some stuff. I couldn't get it to boot no matter what "root (hd#,#); setup (hd#)" or what UUID I entered.

I did discover one thing though:

Debian assigns a completely different range of drive numbers to my drives than ubuntu.

My machine has 3 SATA drives, and 2 IDE drives on a plugged in PCI IDE card. It also has a combination card reader internally on USB. It's starting to look like with ubuntu, the cardreader or USB devices are numbered as the first 4 SCSI devices, while the SATA and IDE drives are given drive designations higher than those. I want to install ubuntu to the same disk Debian was first on: the first sata drive - but apparently my BIOS, Debian and Ubuntu *all* have different ideas as to which drive is which.

Haven't tried switching BIOS to RAID yet - and I don't see why an off-the-shelf install CD should require somebody to radically alter their system hardware config anyway. Besides, I would like to make try and the machine a dual-boot, so I cannot willy nilly change system parameters, or something else will not boot.

I will try to add the "noapic" option to the kernel parameters at my next install attempt. I have tried the "all_generic_ide" option, but that just got me loads of "Input/output-errors."

I'll add another post if my attempts at installing this thing succeed. The machine's been offline for 3 days now. If I don't get the server to run within another day or so, I'll probably revert to Debian permanently, and to hell with the TV-card.

Yo!

G.

Addendum I:

Users have reported slower than normal detection of SATA hard drives on systems with Intel D945 motherboards in Ubuntu 8.10. This may cause the system to drop to a busybox initramfs shell on boot with a "Gave up waiting for root device." error. Wait a minute or two and then exit the initramfs shell by typing 'exit'. Booting should proceed normally. If it doesn't, wait a bit longer and try again. Once the system boots, edit /boot/grub/menu.lst and add rootdelay=90 to the kernel stanza for your current kernel. (Bug 290153: https://launchpad.net/bugs/290153).

I'll try this as well: might be that the UUID is not wrong, but that my mainboard has an unsupported chipset, even though it is an MSI mainboard. At some installation attempts I got the message "... doesn't exist" and in some just timeouts, so it's worth a shot.

G.

iamah
November 6th, 2008, 11:42 AM
I believe I'm getting this wrong UUID error because my sata disk is at a secondary slot, due to my VGA being too big I can't use Sata primary slot.