PDA

View Full Version : [ubuntu] Anydata CDMA modem



pedrosal
April 23rd, 2008, 12:20 AM
Hi to all,
I have an Anydata CDMA 3G modem model ADU-BAT-100. I have a new Vaio SZ laptop.

In Angola we use these modems commonly as they provide the most reliable internet access.

But I cannot manage to configure this. Anydata sent me a Linux driver, but I cannot get this to work. I can post it if need be.

The Windows utility has an interface on which you press a dial button and in a few seconds the connection is running.

Is it possible to have a similar setup under Ubuntu? Without having to put in passwords, dialling numbers etc? Just a simple interface which can take me direct to my network?

I understand little about software, and have become determined to run Ubuntu to replace the Windows OS in my company. But this is one fnction I need to get to work easily.

In placing answers, I would like to request that you understand that I am really in the dark here.

Thank you, Pedro

alexandremrj
May 29th, 2008, 01:18 PM
Hello,

I'm running hardy and my installation had a few problems and only worked with sudo. The instructions here are for the normal user (in the bottom of the post i will place the commands i used with my installation). I use the modem ADU-BAT-100 from AnyData and the Internet provider is Zapp from Portugal.

1. The first thing i did was install the package gnome-ppp (you can search for it in synaptic or do: sudo apt-get install gnome-ppp ).

2. In the network manager on the notification area choose manual configuration and choose point to point connection and in the "General" tab uncheck the option "Enable this connection" (so that option will be blank). - In my configuration not disabling this point gave that the modem didn't work.

3. Connect your modem to the PC

4. In the terminal run: gnome-ppp

5. A window will appear so press Setup and in the "Modem" tab press Detect. It will detect your modem in the USB port, probaly with the type Analog Modem, so in the Type choose USB Modem. Speed you can leave the detected one. In the dial prefix place #
In the "networking" tab see that "Dynamic IP adress" and "Automatic DNS" are the options selected.
In the "options" tab choose "Dock in notification area" if you want.
Close the window

6. Place your username in the box and the password. If you want choose "Remember password" so that it will stay in memory for further sessions. In "Phone number" place 777 (if this is the option of your service provider, and it usually is).

7. Press connect. It will give you a small window. If that doesn't disappear then you can press "log" and see what is the problem. If you can't see the problem copy and paste in the foruns the error message.

8. Create a shortcut in your panel with "Add to panel" --> "Custom application launcher". Choose Type "Application" and in command place: gnome-ppp Press "Close"

9. When pressing this shortcut you will enter a window with everything from your connection and all you have to do is press connect.

P.S: If you can't connect to the internet because the log gives permission errors then you can:
In point 4 run the command: sudo gnome-ppp
Then in point 8 the command becomes gksu gnome-ppp

pedrosal
June 2nd, 2008, 05:12 PM
Alô Alexandre.

It works but not fully.

It works, and I'm ecstatic, in that I am able, finally, to connect to my service provider after having to guess the password and with no support from them. But...it only connects to the service provider, and I cannot, thereafter, use the internet.

I had to use the command sudo gnome-ppp.
It connects perfectly.
But the connection manager isn't coming right. Even after connection I cannot use the connection to connect to the internet. I have disabled as per instructions in the 'general' tab of the point to point connection. And I also tried the alternative of enabling it and using the relevant information regarding such as account name, service provider etc.

In short, I am ALMOST there. It is working but I'm still unable to access the internet through the connection.

Below is the terminal info:

luanda@luanda-laptop:~$ sudo gnome-ppp
WVCONF: /root/.wvdial.conf
GNOME PPP: Connecting...
GNOME PPP: STDERR: --> Ignoring malformed input line: ";Do NOT edit this file by hand!"
GNOME PPP: STDERR: --> WvDial: Internet dialer version 1.60
GNOME PPP: STDERR: --> Cannot get information for serial port.
GNOME PPP: STDERR: --> Initializing modem.
GNOME PPP: STDERR: --> Sending: ATZ
GNOME PPP: STDERR: ATZ
GNOME PPP: STDERR: OK
GNOME PPP: STDERR: --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
GNOME PPP: STDERR: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
GNOME PPP: STDERR: OK
GNOME PPP: STDERR: --> Modem initialized.
GNOME PPP: STDERR: --> Sending: ATM1L3DT#777
GNOME PPP: STDERR: --> Waiting for carrier.
GNOME PPP: STDERR: ATM1L3DT#777
GNOME PPP: STDERR: CONNECT
GNOME PPP: STDERR: --> Carrier detected. Waiting for prompt.
GNOME PPP: STDERR: ~[7f]}#@!}!}!} }9}"}&} } } } }#}%B#}%}%}&_r$(}'}"}(}"[15][14]~
GNOME PPP: STDERR: --> PPP negotiation detected.
GNOME PPP: STDERR: --> Starting pppd at Mon Jun 2 17:23:30 2008
GNOME PPP: STDERR: --> Pid of pppd: 23095
GNOME PPP: STDERR: --> Using interface ppp0
GNOME PPP: STDERR: --> local IP address 41.210.199.172
GNOME PPP: STDERR: --> remote IP address 10.0.255.30
GNOME PPP: STDERR: --> primary DNS address 217.168.127.15
GNOME PPP: STDERR: --> secondary DNS address 217.168.127.14
GNOME PPP: STDERR: Caught signal 2: Attempting to exit gracefully...
GNOME PPP: STDERR: --> Terminating on signal 15
GNOME PPP: STDERR: --> Connect time 1.1 minutes.
GNOME PPP: STDERR: --> Disconnecting at Mon Jun 2 17:24:38 2008

pedrosal
June 2nd, 2008, 05:38 PM
Sorry!!!! It works!

This is fantastic. Sorry, I had been looking at the network manager icon for an indication that there was a connection. There is no indication. And because the internet is sloooooooow I though I had no connection.

But it works.

Some more info...I have been given a linux driver by AnyDATA. Are you interested in me sending it? I have been unable to make it work. But maybe it could be used for Ubuntu by someone who understands better.

Thanks,

Pedro

lswb
June 2nd, 2008, 09:01 PM
Hi,

I have some issues with NetworkManager and ppp also and thought you'd be interested. NetworkManager does NOT recognize when a ppp session is active and this can cause firefox and evolution to start in "offline mode." If you set up evolution to automatically send/receive your email, it won't work without manually setting it to "online" mode. Likewise with firefox, before you can load any web sites, you must manually set it to online also. There are other applications that are also affected, most of them are the ones that are integrated into gnome to some degree. I've heard that these shortcoming will be addressed in a newer version of NM, but I don't know when that will be or if it will be part of a Hardy update

If you uninstall NetworkManager and use wicd or some other solution instead you will not have this problem.

pedrosal
June 2nd, 2008, 10:17 PM
Thanks for the advice. I'll uninstall NM and use another solution. Yes, this had caused me some confusion, but I'd just realised it caused things to start in 'offline' mode.

alexandremrj
June 5th, 2008, 11:43 AM
Sorry for only now replying to the thread.

I don't have the problem you guys refer to.

My network manager (in the notification area - i don't have the applet in the panel) is always on so my connection always starts with the applications online.

When you use gnome-ppp you have a new notification that says if you are online or not, just like in windows (the small pc screens blink when data is passing).

bluemarble
June 24th, 2008, 09:10 AM
I tried all the above but unfortunatly Gnome-ppp 'can not open modem'

I have tried 777 and *99# for the number but neither work.....

i am going crazy!!!!!

alexandremrj
June 24th, 2008, 11:32 AM
Hello,

i would recommend you use this step so we can help you.

7. Press connect. It will give you a small window. If that doesn't disappear then you can press "log" and see what is the problem. If you can't see the problem copy and paste in the foruns the error message.


Also the can't open modem is usually an error for modem not connect or in use by another program, it doesn't reach the number part.

bluemarble
June 24th, 2008, 02:46 PM
hi, thia is the out-put when i try and connect...

bluemarble@bumble:~/Desktop$ gnome-ppp
WVCONF: /home/bluemarble/.wvdial.conf
GNOME PPP: Connecting...
GNOME PPP: STDERR: --> Ignoring malformed input line: ";Do NOT edit this file by hand!"
GNOME PPP: STDERR: --> WvDial: Internet dialer version 1.60
GNOME PPP: STDERR: --> Cannot get information for serial port.
GNOME PPP: STDERR: --> Initializing modem.
GNOME PPP: STDERR: --> Sending: ATX3
GNOME PPP: STDERR: ATX3
GNOME PPP: STDERR: OK
GNOME PPP: STDERR: --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
GNOME PPP: STDERR: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
GNOME PPP: STDERR: OK
GNOME PPP: STDERR: --> Modem initialized.
GNOME PPP: STDERR: --> Sending: ATM1L3DT#,*99#
GNOME PPP: STDERR: --> Waiting for carrier.
GNOME PPP: STDERR: ATM1L3DT#,*99#
GNOME PPP: STDERR: ^BOOT:40989822,0,0,0,6
GNOME PPP: STDERR: ^BOOT:40989822,0,0,0,6

pedrosal
June 24th, 2008, 02:54 PM
Hi Bluemarble,
I'm not very sure, but from your log data it appears you have managed to set up your modem.
Try going to your internet programme and checking if it is working online or offline. In my case the network manager does not recognise the connection, but it is actually connected. The result is that e-mail programme and firefox start in 'offline' mode. Maybe this is the problem.

Otherwise, are you sure about the dialled number and pasdsword for you network?

In my Anydata modem interface (MS Windows), I enter setup only when the modem is not yet connected and therein I can determine some of the data such as dialled number #777. The password was tricky and I had to get some free programme to unhide some letters.

I hope this may be useful.

bluemarble
June 25th, 2008, 02:46 AM
Hey,

I have double checked and *99# is the right number for me, as for the password = password and username = username. I did have a pin number on the sim card but I disabled that, as many forums suggest.

I managed to connect last night for the first time but I could not access the net, firefox does load in offline mode but i had changed that.

But since then I have not connected again... i am so close but i just dont know what else to do :(

this is the output of my last attepmt :´(´´

any more suggestion??


WVCONF: /home/bluemarble/.wvdial.conf
GNOME PPP: Connecting...
GNOME PPP: STDERR: --> Ignoring malformed input line: ";Do NOT edit this file by hand!"
GNOME PPP: STDERR: --> WvDial: Internet dialer version 1.60
GNOME PPP: STDERR: --> Cannot get information for serial port.
GNOME PPP: STDERR: --> Initializing modem.
GNOME PPP: STDERR: --> Sending: ATX3
GNOME PPP: STDERR: ATX3
GNOME PPP: STDERR: OK
GNOME PPP: STDERR: --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
GNOME PPP: STDERR: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
GNOME PPP: STDERR: OK
GNOME PPP: STDERR: --> Modem initialized.
GNOME PPP: STDERR: --> Sending: ATM1L3DT#,*99#
GNOME PPP: STDERR: --> Waiting for carrier.
GNOME PPP: STDERR: ATM1L3DT#,*99#
GNOME PPP: STDERR: Caught signal 2: Attempting to exit gracefully...
GNOME PPP: STDERR: --> Disconnecting at Wed Jun 25 11:35:56 2008

pelle.k
July 15th, 2008, 06:38 PM
Disable all forms of "carrier detect" as this is not a regular phone line!
I use "stupid mode" (don't know if that helps anyone though).
You have to use a username+password (even if there is no need from your ISP) or else the conecction attempt will fail.

Also, just a tip, but if i fail to connect i have to replug my phone (e.g. usb modem), and that will create a new dev node (e.g. /dev/ttyACM1, /dev/ttyACM2 etc), so watch out for that when experimenting.

eotakos
July 16th, 2008, 01:52 PM
hello, i have a similar problem connecting with my modem - i get the

"Cannot get information for serial port" message. The thing is that mine is not a serial modem - it's an internal modem in my laptop. For that modem the system has detected and prompted me to install a proprietary driver "software modem" which i see under system->administration->hardware drivers.

my modem appears under "lspci -v" like a pci modem. the messages i get when i try to connect with gnome ppp is the following:

GNOME PPP: STDERR: --> Ignoring malformed input line: ";Do NOT edit this file by hand!"
GNOME PPP: STDERR: --> WvDial: Internet dialer version 1.60
GNOME PPP: STDERR: --> Cannot get information for serial port.
GNOME PPP: STDERR: --> Initializing modem.
GNOME PPP: STDERR: --> Sending: ATX3
GNOME PPP: STDERR: ATX3
GNOME PPP: STDERR: OK
GNOME PPP: STDERR: --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
GNOME PPP: STDERR: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
GNOME PPP: STDERR: OK
GNOME PPP: STDERR: --> Modem initialized.
GNOME PPP: STDERR: --> Please enter password (or empty password to stop):

any suggestions? thanks in advance!