PDA

View Full Version : [SOLVED] movie files show only a black/blank screen, but audio is okay



hanzj
April 22nd, 2008, 06:23 AM
I've tried playing movie (m4v) files with mplayer, mplayer-gui, and totem (gstreamer).

The sound comes out fine, but all i see is a black/blank screen.

Help.

i'm on xubuntu 8.04 beta.

subzero316
April 22nd, 2008, 06:26 AM
Try with VLC player.:KS

hanzj
April 22nd, 2008, 06:27 AM
could you tell me why my setup currently doesn't work? I'd like to figure that out first, before i install more programs?

hanzj
April 22nd, 2008, 06:29 AM
anyway, i've installed VLC, and it's the same problem.

subzero316
April 22nd, 2008, 07:00 AM
Does this happen with other video formats?

hanzj
April 22nd, 2008, 07:08 AM
yes, it happens with avi and mov formats, too.

russo.mic
April 22nd, 2008, 07:10 AM
Are you running Compiz? If so, do you have the Video Plugin enabled?

Russo

subzero316
April 22nd, 2008, 07:21 AM
I guess the problem is not with the player or codecs cause VLC has everything in built. You have the new beta ubuntu maybe some problem with that..try reinstalling the related libraries

nicedude
April 22nd, 2008, 07:22 AM
Hans you need to add the Medibuntu restricted repositories so you can download codecs that for legal reasons they can't include in Ubuntu. Copyright reasons I believe. hold on a sec and Ill find the guide here and post the link to it here

nicedude
April 22nd, 2008, 07:23 AM
uh maybe not sorry just saw you are using hardy so maybe go into your synaptic package manager and search to see if you have w32codecs

Saint Angeles
April 22nd, 2008, 07:25 AM
+1 for medibuntu and ubuntu-restricted extras!!

hurrah!

nicedude
April 22nd, 2008, 07:32 AM
If you haven't added the medibuntu repositories to your sources list yet then you should. below are the commands

Just copy the 2 command lines 1 at a time when you copy each one paste in terminal window and execute first the sources then the key.

Ubuntu 8.04 "Hardy Heron":

sudo wget http://www.medibuntu.org/sources.list.d/hardy.list -O /etc/apt/sources.list.d/medibuntu.list

Then, add the GPG Key:

wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O - | sudo apt-key add - && sudo apt-get update


now you will have more multimedia playback related and other software in your synaptic

Ace_Of_Days
August 22nd, 2008, 11:09 PM
anyway, i've installed VLC, and it's the same problem.

go into vlc in program and click quick settings and video then click on Ęset video mode to openGlĘ
that workt for me i gott the same problem before:d

specialk1st
May 29th, 2010, 01:28 AM
go into vlc in program and click quick settings and video then click on Ęset video mode to openGlĘ
that workt for me i gott the same problem before:d

THANK YOU SO MUCH FOR THIS TIP!!!! I've tried all the other method listed on here and on Google, but this is the one that actually works! :P

hanzj
May 29th, 2010, 01:33 AM
I've marked this thread as solved, even though I recall my reaching a solution on Xubuntu 8.XX (I'm now on Ubuntu 10.04).