PDA

View Full Version : firefox flash and no other sound



medivh
April 22nd, 2008, 03:59 AM
When i open a website with flash content it sucks the cpu so much(~%40 of Intel C2D 2.0Ghz) and no other program can play sounds. But rhythmbox and moviplayer can work and sound at the same time.

Incredulous Moose
April 22nd, 2008, 04:05 AM
http://ubuntuforums.org/showthread.php?t=279990

medivh
April 22nd, 2008, 04:30 AM
where should i exactly look at in this post you send?
i already have flash 9.0.124 and that posts describes how to install flash 9 beta. do i miss something?

tango_ninja
April 22nd, 2008, 04:34 AM
what version of firefox are you running? I've heard those with 3 experience problems with flash

medivh
April 22nd, 2008, 04:42 AM
i am using a clean install of hardy which means ff 3.0b5
i would prefer ff2 but when i try to install 2 and remove 3 then everything gets worse.a few updates before flash could sound simultaneously with other apps but i was experiencing too many firefox crashes because of flash. Now crashes are gone but here is the sound problem.only 2 days left before release and there are many problems i think.

Incredulous Moose
April 22nd, 2008, 04:47 AM
where should i exactly look at in this post you send?
i already have flash 9.0.124 and that posts describes how to install flash 9 beta. do i miss something?

My apologies.

medivh
April 22nd, 2008, 04:51 AM
My apologies.

No problem. It was a 16 pages post and i thought maybe you were talking about some information deep inside there.

medivh
April 22nd, 2008, 02:06 PM
still waiting for a solution

Nevyn
April 22nd, 2008, 02:35 PM
Are you using the 32 or 64 bit version of FF?
(Look in the Help -> About Mozilla Firefox. Mine says "Mozilla/5.0 (X11; U; Linux x86_64;" = I use the 64 bit version).

I solved my flash problem by installing the 32 bit version of FF. If you also have the 64 bit version I'll find the how-to for doing that.

livingtarget
April 22nd, 2008, 03:08 PM
Make sure you are running the latest flash plugin even though you say you do, checking the url: about:plugins in firefox will tell you more.

Another thing to try is killing pulseaudio, close firefox and try again.

Basically a "sudo killall pulseaudio" should do the trick or disable the sound daemon somewhere in preferences -> sound settings. Basically that's what restored flash sound for me, probably not the problem you have.

The high CPU is unfortunate but does happen quite a bit with flash on linux I think.

Greg T.
April 22nd, 2008, 05:43 PM
The changeover to Pulseaudio in Hardy has resulted in a bug with Flash. In particular, using the libflashsupport package can result in a lot of crashes, so it has been made into an optional package when the flashplugin-nonfree is installed.

Unfortuantely, a side effect of making libflashsupport an optional package is the problem you're describing; Flash can commandeer the sound card and not let other apps use it.

A fix for this being worked on. The gory details are in bug #192888 (https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/192888).