View Full Version : cod4 no cd patch error

April 16th, 2008, 12:25 PM
hi, my first post here, I am new to ubuntu and linux altogether, and i´m not sure if I am meant to be posting here or in the wine forum, please move it if I have posted in the wrong section.

Well, I bought cod4 today, confident it would work on wine because of this tutorial: http://www.fsckin.com/2008/02/21/how-to-run-call-of-duty-4-cod4-modern-combat-in-linux/

after some trouble, I do most of it, start the game in singleplayer and it says something like
¨please insert proper dvd¨ so then I tried lots of other things (uninstallign wine etc) none of them worked, and I ended up deleting my wine install which was running counter strike, hl2dm etc on steam just fine.

but,back when I got the please insert cd error, I tried downloading the no cd patch listed on that tutorial, I download it open it with archive manager or package manager (can´t remember sorry) and it says ¨wrong architecture¨ or ¨architecture not supported¨

so if anyone has either,

another easy to follow tutorial for installing call of duty 4 through wine on ubuntu 8.04,

a solution for how to fix the wrong architecture error,
or a
a new no cd patch for call of duty 4

it would be greatly appreciated.
thanks, and sorry that my post is long. :)

EDIT: I am using 64 bit hardy heron, and my computer specs are fine (amd phenom 9500, nvidia 8800gts with driver, more than enough hard drive space)

April 18th, 2008, 04:33 AM
You could always copy CD onto the hard drive. I believe there is a way to tell WINE to look at any file folder as a CD drive or any other kind of drive for that matter.

April 18th, 2008, 04:38 AM
Hi, thanks, but I got a new no cd patch and it is working fine, except I cant run the game because I am having some trouble compiling wine with 3dmark patch, check my other thread if you have any ideas.