PDA

View Full Version : Problema con webcam



sartrejp
April 16th, 2008, 02:23 AM
Hola, como les va? Escribo por lo siguiente.
Tengo una webcam minicam GE H98657 que no logro hacer andar.

Bus 003 Device 001: ID 0000:0000
Bus 002 Device 004: ID 0c45:6011 Microdia
Bus 002 Device 005: ID 0458:0035 KYE Systems Corp. (Mouse Systems)
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

Se que tiene un chipset microdia (aunque no se que signifique eso) y probé con todos los drivers que encontré por la web, con todos los que eran para microdia, con los de easy cam, etc. y llegué acá, donde vengo a solicitar su ayuda.
Para colmo la cámara es un regalo, sino a esta altura ya la hubiese hecho volar por la ventana.

Bueno, si alguno sabe o tiene una idea, les estaré eternamente agradecido.
Nos vemos

sajnox
April 16th, 2008, 03:14 AM
http://ubuntuforums.org/showthread.php?t=749943

Probablemente esto te ayude a desistir con la webcam, pero es lo que hay

sartrejp
April 16th, 2008, 06:35 PM
Efectivamente, ya lo había visto, lo instalé (por las dudas), pero no hubo caso.
Bue... ya veré como hago para hacerla andar, o entraré en el club del trueque (lástima que ya no esté más jejje)

Gracias, un abrazo.

sartrejp
May 10th, 2008, 12:22 AM
Acá encontré la solución http://ubuntuforums.org/showthread.php?p=4831129
(por si a alguien le sirve)

User21
May 10th, 2008, 01:52 AM
No sabes a cuanta gente ayudas con eso! :D Podes editar el nombre del hilo como "Problema con webcam Microdia" ?
Me tomo el tiempo de traducirlo al español! :D

Una vez conectada la webcam al puerto usb, tipeen en terminal el comando lsusb. Entre los dispositivos enlistados, debe aparecer:

Bus 001 Device 006: ID 0c45:6011 Microdia (sin importar el numero de Bus o Device)
El dato que nos interesa es 0c45:6011. 0c45 -cada fabricante tiene su propio ID en hexadecimal. 0c45 es para Microdia.
6011 - es el ID del producto. Hay muchos productos que contienen el chip Microdia.

Para hacer funcionar la camara, es necesario compilar un modulo con un parche para gspca (gspca v1-2007 12 24). En terminal:


sudo apt-get install kernel-package linux-source build-essentialUna vez instalado, descarga y extrae el parche, luego ingresa a la carpeta donde fue descargado:

wget http://www.cspath.com/gspcav1-20071224-0c45:6011.tar.gz
tar -zxvf gspcav1-20071224-0c45:6011.tar.gz
cd gspcav1-20071224/y compila el mismo:

makeluego, antes de probar el modulo, haz lo siguiente:


sudo modprobe fuse
sudo modprobe videodev
sudo modprobe compat-ioctl32 Luego, prueba el modulo con:


sudo insmod ./gspca.ko Enchufa tu webcam y testeala. Mi webcam funcionó perfecto con Skype. Tambien puedes probarla con Cheese.
Si funciona bien, pues instala el modulo con:


sudo make install Si te preguntas que hay dentro de tu cam:
Bridge: SN9C101
Image sensor: OV6650

Espero sea util y les funcione! Saludos!
Gracias a Skretch (http://ubuntuforums.org/member.php?u=493861) y a sartrejp ! :D

marcunix
January 23rd, 2009, 08:29 PM
Pues con la camara NGS spincam he probado varias cosas y nada, ahora estoyintentanto hacer este tutorial, pero no encuentro ya el archivo en http://www.cspath.com/gspcav1-20071224-0c45:6011.tar.gz

He buscado en google si puedo descargarlo de otro sitio, pero no encuentro nada, si alguien aun lo guarda podria postearlo en algun sitio?

Gracias

sartrejp
January 23rd, 2009, 09:52 PM
Está acá http://mxhaard.free.fr/download.html
Igual a partir de intrepid ibex no hace falta, viene el módulo en el kernel (creo) y reconoce la webcam directamente.
Suerte

marcunix
January 24th, 2009, 12:06 AM
Gracias, yo uso Intrepid y mi camara no la reconoce, por eso busco como solucionarlo. Probare haber que pasa.

Gracias

Editado----------------

Pues lo he intentado y me tira estos errores.....

marcos@marcos-ubuntu:~/Escritorio$ ls
configuracion angel gspcav1-20071224 gspcav1-20071224.tar.gz Ubuntu
marcos@marcos-ubuntu:~/Escritorio$ cd gspcav1-20071224
marcos@marcos-ubuntu:~/Escritorio/gspcav1-20071224$ make
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/marcos/Escritorio/gspcav1-20071224 CC=cc modules
make[1]: se ingresa al directorio `/usr/src/linux-headers-2.6.27-9-generic'
CC [M] /home/marcos/Escritorio/gspcav1-20071224/gspca_core.o
/home/marcos/Escritorio/gspcav1-20071224/gspca_core.c:54:27: error: asm/semaphore.h: No existe el fichero ó directorio
/home/marcos/Escritorio/gspcav1-20071224/gspca_core.c: En la función ‘spca5xx_ioctl’:
/home/marcos/Escritorio/gspcav1-20071224/gspca_core.c:2463: error: declaración implícita de la función ‘video_usercopy’
/home/marcos/Escritorio/gspcav1-20071224/gspca_core.c: En el nivel principal:
/home/marcos/Escritorio/gspcav1-20071224/gspca_core.c:2609: error: se especificó el campo desconocido ‘owner’ en el inicializador
/home/marcos/Escritorio/gspcav1-20071224/gspca_core.c:2609: aviso: inicialización desde un tipo de puntero incompatible
/home/marcos/Escritorio/gspcav1-20071224/gspca_core.c:2611: error: se especificó el campo desconocido ‘type’ en el inicializador
/home/marcos/Escritorio/gspcav1-20071224/gspca_core.c: En la función ‘spca50x_create_sysfs’:
/home/marcos/Escritorio/gspcav1-20071224/gspca_core.c:2769: error: declaración implícita de la función ‘video_device_create_file’
/home/marcos/Escritorio/gspcav1-20071224/gspca_core.c:2780: error: declaración implícita de la función ‘video_device_remove_file’
/home/marcos/Escritorio/gspcav1-20071224/gspca_core.c: En la función ‘spca5xx_probe’:
/home/marcos/Escritorio/gspcav1-20071224/gspca_core.c:4301: error: tipos incompatibles en la asignación
make[2]: *** [/home/marcos/Escritorio/gspcav1-20071224/gspca_core.o] Error 1
make[1]: *** [_module_/home/marcos/Escritorio/gspcav1-20071224] Error 2
make[1]: se sale del directorio `/usr/src/linux-headers-2.6.27-9-generic'
make: *** [default] Error 2


---------------------------------------


Yo ya no se x donde tirar para instalar la maldita cam....

sartrejp
January 24th, 2009, 12:31 AM
Claro, pero si el módulo está en el kernell, no te va a servir ese.
¿Con que programa probaste la webcam? A mi me anda con cheese y con amsn (con los demás no). ¿El chipset es microdia? ¿que sale del comando lsusb?

marcunix
January 24th, 2009, 03:26 AM
Hola.... esto es lo que me tira el lsusb

---------------

marcos@marcos-ubuntu:~$ lsusb
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0c45:62b0 Microdia Audio (Microphone)
Bus 001 Device 002: ID 06b9:0120 Alcatel Telecom
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

---------------

Yo uso Ubuntu Intrepid y Amsn, pero el cheese tampoco me la reconoce... La cam es una Ngs spincam y ya me tiene desesperadito....

sartrejp
January 24th, 2009, 03:35 AM
Probaste este paquete? http://debian-multimedia.org/pool/main/v/v4l2ucp/v4l2ucp_1.2-0.1_amd64.deb Es para debian pero por ahí anda, sino descargando el tar.gz de http://downloads.sourceforge.net/v4l2ucp/v4l2ucp-1.2.tar.gz?modtime=1142094286&big_mirror=0 y compilándolo
Leí por ahí que les funcionó con una webcam similar

marcunix
January 24th, 2009, 04:07 PM
Ese en concreto me daba error porque era la version 64 bits, me he bajado del mismo sitio la i386 y la he instalado sin problemas, pero sigue sin funcionar la camara, no se si igual tengo que hacer algo mas...

sartrejp
January 24th, 2009, 05:16 PM
fiajte en la wiki de v4l a ver si aparece la solución, o si tiene lista de correo, porque la verdad me supera el asunto, la web http://linuxtv.org/v4lwiki/index.php/Main_Page

Exitos

marcunix
January 24th, 2009, 06:10 PM
Echare un vistazo haber que tal......... Gracias

inma
June 13th, 2009, 05:50 PM
hola yo soy nueva en ubuntu, una novata vamos y tengo un asus a6000 series y tiene la camara integrada, tengo el disco partido entre windows y ubuntu y cuando instale los drivers lo hice en windows, la camara funciona pero la calidad de la imagen es mucho peor que cuando la uso en windows, alguien podria decirme por que puede ser?
gracias.