PDA

View Full Version : emacs help



jamescowie
March 20th, 2008, 11:24 PM
Hi all,

ive got emacs installed on my ubuntu box, but when i type emacs or try to open any file with emacs it opens the gnu version. i can open the bash version using emacs -nw but this is just a pain.

is there a conf file anywhere to change this to the default?

thanks

j.

CptPicard
March 20th, 2008, 11:32 PM
I suppose you mean you want the non-X11 text mode version? :) They're both "GNU" software... put



alias emacs='emacs -nw'


in your .bashrc

jamescowie
March 20th, 2008, 11:39 PM
still no joy, i added the line you said into the /home/james/.bash file and emacs still loads the gui version?

thanks for the help.

ha1f
March 20th, 2008, 11:42 PM
still no joy, i added the line you said into the /home/james/.bash file and emacs still loads the gui version?

thanks for the help.

$HOME/.bashrc ...?

jamescowie
March 20th, 2008, 11:45 PM
hi sorry type home/james/.bashrc

any sugestions.

ha1f
March 20th, 2008, 11:47 PM
have you source'd it?

CptPicard
March 20th, 2008, 11:47 PM
Well.. it should work... open up a new window to make sure you run a new shell that has loaded its settings from the edited file?

ha1f
March 20th, 2008, 11:49 PM
Also, if you're trying to open files from nautilus, you'll need to make sure that nautilus knows to use emacs -nw

Lux Perpetua
March 21st, 2008, 07:05 AM
Hi all,

ive got emacs installed on my ubuntu box, but when i type emacs or try to open any file with emacs it opens the gnu version. i can open the bash version using emacs -nw but this is just a pain.

is there a conf file anywhere to change this to the default?

thanks

j.If you don't ever use the X11 version of Emacs, you can uninstall it. The curses version of Emacs is in the package emacs-nox, which is all you would need (+ emacsen-common and other dependencies).