PDA

View Full Version : Error in compiling clanLib in CDT



drgreborn
October 5th, 2005, 08:05 PM
I'm trying to compile a file in eclipse using CDT and came up with this error.
Severity Description Resource In Folder Location Creation Time Id
1 C/C++ Indexer Problem: Preprocessor Inclusion not found: ClanLib/gl.h in file: /home/drgreborn/workspace/test/MyApp.cpp on line: 2. MyApp.cpp test line 2 October 6, 2005 3:02:50 AM 81


Any idea what this means? Thank you.

drgreborn
October 5th, 2005, 08:14 PM
Ok I found out the error, its due to my using teh wrong binaries parser. My question is how do you know which binary parse to use? Thank you.

drgreborn
October 6th, 2005, 07:36 AM
Right. I got this error again. Could someone tell what is wrong? How do i set the preprocessor for using clanlib? Could someone help me please thank you.

drgreborn
October 6th, 2005, 08:38 AM
Erm anyone? :confused: Thanks.

drgreborn
October 6th, 2005, 11:25 AM
I am seriously at my wits end. Could someone PLEASE tell me hwo is it actually am I suppose to run ClanLib files in eclips eusing CDT. How do I set the PREPROCESSORS link and such? Thank you.
I'm begging anyone please. Its been more than 1 week and i'm not able to compile a single piece of work from school. Googling this error doesn't seem to throw up any solutions. Please anyone?

Jave27
October 6th, 2005, 06:28 PM
I can't help you directly, but I'd suggest signing on via IRC to irc.freenode.net, and joining the #clanlib channel. There's almost always someone there, but it may take them 20-30 minutes to answer the question, so just be patient. They're pretty friendly.

Also, try posting a message to their development mailing list which you can find at http://clanlib.org. Good luck!