PDA

View Full Version : USN-580-1: libcdio vulnerability



rss-bot
February 21st, 2008, 05:00 PM
Referenced CVEs:
CVE-2007-6613


Description:
================================================== ========= Ubuntu Security Notice USN-580-1 February 20, 2008 libcdio vulnerability CVE-2007-6613 ================================================== ========= A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 6.10 Ubuntu 7.04 Ubuntu 7.10 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 6.06 LTS: libcdio6 0.76-1ubuntu1.6.06.1 Ubuntu 6.10: libcdio6 0.76-1ubuntu1.6.10.1 Ubuntu 7.04: libcdio6 0.76-1ubuntu2.7.04.1 Ubuntu 7.10: libcdio6 0.76-1ubuntu2.7.10.1 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: Devon Miller discovered that the iso-info and cd-info tools did not properly perform bounds checking. If a user were tricked into using these tools with a crafted iso image, an attacker could cause a denial of service via a core dump, and possibly execute arbitrary code.





More... (http://www.ubuntu.com/usn/usn-580-1)