PDA

View Full Version : mouse offset in games :( Help plz



carnivore1
February 18th, 2008, 05:04 AM
Hey All,

I finally got Lineage II to work under wine but im having some strange display issues.

my mouse seems to be offset and i have to click about 1/4 of an inch above anything i want to click on when im in game.

also, when my game comes up in full screen the top and bottom panel of my desktop cover up part of the game (menu buttons) and makes it very difficult to navigate the menus.

does anyone know a workaround for this??

Toffeeapple
February 18th, 2008, 10:27 AM
Try changing the wine settings under the 'Graphics' Tab,

Allow the window manager to control the windows & Emulate a virtual desktop.

Try running the game windowed.

Toffeeapple
February 18th, 2008, 10:29 AM
Try this (http://www.playonlinux.com/en/) as well, it's really rather handy.

siikah
May 25th, 2009, 03:39 PM
OK!

I have the same problem here. With an Acer Travelmate 2300.

The game in question is Warcraft III - Frozen Throne. Irregardless of which mouse I use (tried two USB and the touchpad) the problem is always the same. No settings in winecfg helps and windowed mode isn't an option.

The offset varies depending on where on the screen I click. The closer I get to the middle of the screen the larger the offset. The offset is vertical and always upwards - I must click above the unit in question.

In the middle of the screen the offset is approx. 2cm, around the borders about one centimeter.

Different resolution in gnome or Warcraft doesn't have any effect on the problem.

Please help! I'm loosing my mind here!

killabee44
July 11th, 2011, 06:20 AM
Guys, I am also having this issue in Starcraft2. If anyone has a fix, plz post.

It is a known issue with Wine:

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/755406?comments=all

xavi787
July 11th, 2011, 01:19 PM
I had this problem too with Live For Speed Demo.
What I did as a temporal fix was changing the screen resolution inside the game (so that it matches with my real screen resolution, even if the setting is correct) e.g. 1280x720 (16:9).:)

I also have a problem with LFS demo:
When playing the game it doesn't draw the textures, all is in gray except for the trees and the tires. Anyways and will make a post about this anytime soon.:neutral:

killabee44
July 11th, 2011, 06:55 PM
Found a workaround here, in the forums:


Right click on the desktop and select:
Change Desktop Background, then select the Visual Effects tab, then
select None.

That turns off visual effects (like Compiz) and makes the mouse pointer
offset disappear. I hope this helps.