PDA

View Full Version : Free Portal Demo on Steam Problem



jorwex
February 17th, 2008, 08:56 PM
Hey All,

So I'm sure some of you have seen this page before:

http://www.steampowered.com/nvidia/

Where Steam's got a Portal demo (among others) and I wanted to try it. So I followed this page:

http://ubuntuforums.org/showthread.php?t=433548

so Firefox would understand links with the "steam://" protocol. Lo and behold, it actually launches Steam and I get to a screen like this:

http://glue.umd.edu/~jwexler/steam1.png

then there's the EULA:
http://glue.umd.edu/~jwexler/steam2.png

then finally I get this:
http://glue.umd.edu/~jwexler/steam3.png

and a recommendation to go to this page:
http://support.steampowered.com/kb_article.php?p_faqid=11

I'm not behind a firewall and don't have a router or anything tricky. just a dumb hub/switch between me and the modem.

the weird thing is that I can log onto steam regularly no problem. I haven't used steam much, so maybe if i tried to connect to an actual game, i'd run into the same error message, but somehow i'm skeptical.

I am using wine 0.9.50 cuz a friend of mine said it worked better for these halflife2 based steam games than the newest one. i found a thread in UbuntuForums that said someone fixed their connection problem by updating to the newest version of wine, but i think the thread was kinda old.

any suggestions as to how to either
a) get the connection problem working, OR
b) somehow extract whatever promo code that page gives me so i can maybe enter it into steam manually?

kinkdxm
March 30th, 2008, 06:00 AM
I have the exact same problem.
:(
Were you able to get it to work?

jorwex
March 30th, 2008, 06:07 PM
I have two steam accounts. For one I just logged in on a Windows machine and did everything, then logged back into my account on Ubuntu and it was there.

For the second, I tried it 3 times at different times of the day, and it finally worked once. So I'd say it's a random problem. Maybe with one of the newer versions of Wine it works better.

Sorry I can't give any concrete answers.

kinkdxm
March 31st, 2008, 04:23 AM
Sorry I can't give any concrete answers.
np thanks for the reply!


Maybe with one of the newer versions of Wine it works better.
I'm using the latest version.

haha even installing firefox.exe in wine and tried that no luck either :(

I'm just gonna have a friend sign into my steam account on there windows machine for me.

jorwex
March 31st, 2008, 01:08 PM
be careful with your friend and the other pc. I dont know how they qualify your account being "hijacked" but I let my friend use my account, so the account was used on my old windows machine and his pc. i stopped using the account for a year, and then I tried logging on, and my account was disabled. had to jump thru lots of hoops to get it working again.

good luck