PDA

View Full Version : PHP-GTK2 problem



frankos44
February 1st, 2008, 03:18 PM
The following php code snippet was fired up by typing:

$ php -f test.phpw

<?php
if (!class_exists('gtk')) {
die("Please load the php-gtk2 module in your php.ini\r\n");
}
?>

I have 3 php.ini files on my system:

/etc/php5/cli/php.ini
/etc/pdp5/cgi/php.ini
/etc/php5/apache2/php.ini

I assume the /etc/php2/cli is the file I need to change. What exactly to I need to add to this file please?

tosk
February 8th, 2008, 10:03 AM
extension=php_gtk2.so

http://gtk.php.net/manual/en/tutorials.installation.linux.php

See near the bottom where it says 'Testing Your Installation.'

frankos44
February 8th, 2008, 11:12 AM
Thanks for that, it worked a treat. Now i can write my php snippet instead of firing up a web page every time.