PDA

View Full Version : USN-569-1: libxml2 vulnerability



rss-bot
January 15th, 2008, 04:30 AM
Referenced CVEs:
CVE-2007-6284


Description:
================================================== ========= Ubuntu Security Notice USN-569-1 January 14, 2008 libxml2 vulnerability CVE-2007-6284 ================================================== ========= A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 6.10 Ubuntu 7.04 Ubuntu 7.10 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 6.06 LTS: libxml2 2.6.24.dfsg-1ubuntu1.1 Ubuntu 6.10: libxml2 2.6.26.dfsg-2ubuntu4.1 Ubuntu 7.04: libxml2 2.6.27.dfsg-1ubuntu3.1 Ubuntu 7.10: libxml2 2.6.30.dfsg-2ubuntu1.1 After a standard system upgrade you need to restart your session to effect the necessary changes. Details follow: Brad Fitzpatrick discovered that libxml2 did not correctly handle certain UTF-8 sequences. If a remote attacker were able to trick a user or automated system into processing a specially crafted XML document, the application linked against libxml2 could enter an infinite loop, leading to a denial of service via CPU resource consumption.





More... (http://www.ubuntu.com/usn/usn-569-1)