PDA

View Full Version : USN-555-1: e2fsprogs vulnerability



rss-bot
December 8th, 2007, 09:50 AM
Referenced CVEs:
CVE-2007-5497


Description:
================================================== ========= Ubuntu Security Notice USN-555-1 December 08, 2007 e2fsprogs vulnerability CVE-2007-5497 ================================================== ========= A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 6.10 Ubuntu 7.04 Ubuntu 7.10 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 6.06 LTS: e2fslibs 1.38-2ubuntu2.1 Ubuntu 6.10: e2fslibs 1.39-1ubuntu0.1 Ubuntu 7.04: e2fslibs 1.39+1.40-WIP-2006.11.14+dfsg-2ubuntu1.1 Ubuntu 7.10: e2fslibs 1.40.2-1ubuntu1.1 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: Rafal Wojtczuk discovered multiple integer overflows in e2fsprogs. If a user or automated system were tricked into fscking a malicious ext2/ext3 filesystem, a remote attacker could execute arbitrary code with the user's privileges.





More... (http://www.ubuntu.com/usn/usn-555-1)