PDA

View Full Version : Mathematica 6.0 and Compiz



Gagle
October 25th, 2007, 02:39 AM
I've bought and installed successfully the new version of mathematica 6 on a fresh install of Gutsy Gibbon running Compiz-Fusion with a Nvidia graphics card.

When I start mathematica, a couple of extra blank windows that cannot be dealt with pop-up . I've searched this forum, wolfram's and googled for a fix, but no one found a work-around.

Other issues were mentionned and fixed, for example the splashscreen or the keyboard problems.

My question is this :
Is what is happening to me a known bug that remains un-fixed or did I forget a crucial install step that deals specifically with Ubuntu ?

regards,

Gagle

ravenon
October 25th, 2007, 03:17 AM
I experience the same thing when running compiz and Mathematica 6. Don't know a solution except to turn off compiz.

I have had similar problems with other apps and fixes eventually make it in.

parktownprawn
October 30th, 2007, 04:39 PM
Also have this problem with an ATI card and compiz.

It seems be a known bug with no known fix other than turning off compiz:

http://forums.wolfram.com/mathgroup/archive/2007/May/msg01501.html

PoorLeno
November 4th, 2007, 12:54 PM
I have the same problem. Is there a way to disable compiz temporarily with a script, that launches mathematica and restores compiz when it's done? I'm rather fond of both apps, I don't want to switch constantly...

IgnatiusReilly
November 4th, 2007, 03:25 PM
I have exactly the same problem and the suggested script would be the right solution for me.
Moreover, I am really a newbie and I don' even know which is the command to disable Compiz.
Can anyone help us?

Thanks a lot

Loreleye
November 5th, 2007, 02:49 PM
Hello!
I'm about to install Mathematica 6 at home (my school gave us a free student version). I'm hesitating between installing it on Kubuntu or on Windows (XP).
Is it easy to install on Kubuntu? Does it work well? Is there a lot to fix before use?
Thank you for your help! I'm not very good with computers! (my father will install the software)

Bye!

IgnatiusReilly
November 5th, 2007, 07:47 PM
I'm about to install Mathematica 6 at home (my school gave us a free student version). I'm hesitating between installing it on Kubuntu or on Windows (XP).
Is it easy to install on Kubuntu? Does it work well? Is there a lot to fix before use?
Thank you for your help! I'm not very good with computers! (my father will install the software)


It is really simple and, apart from the problem with Compiz (but I think you don't have Compiz if you use Kubuntu), it seems to work well.

To install it you must copy the whole CD in a directory, move to the directory where the file MathInstaller is now located, write in the terminal:


sudo ./MathInstaller

and answer the questions the program asks you. That's all.

Bye

Loreleye
November 5th, 2007, 08:24 PM
Thank you very much ! I'm going to try it and we'll see. I hope I'll be happy with it!

tielie
November 5th, 2007, 10:57 PM
The problem is probadly related to the old crapy Motif Toolkit.

Someone should patch the shity Motif to fix this issues. (Infact Motif sucks alot the fonts looks like hell)

IMHO Wolfram should KILL motif and start write an GUI mathfrontend based on QT or GTK+

argie
November 7th, 2007, 09:26 AM
I have the same problem. Is there a way to disable compiz temporarily with a script, that launches mathematica and restores compiz when it's done? I'm rather fond of both apps, I don't want to switch constantly...

That should be rather easy to manage. Try this:


#!/bin/bash

metacity --replace &
(pi 400000;
compiz --replace)

Replace that thing in bold with the command to start Mathematica (currently it switches back after pi is calculated to 400,000 places). That seems to pull all your windows to the current workspace though, unfortunately.

IgnatiusReilly
November 7th, 2007, 05:05 PM
It works. Thanks a lot.

Another issue. Using the default StandardForm for the output cells when 3 and g are index they are displayed by Mathematica 6 as 9.

So, for instance, x^3 looks like x^9. I fixed the problem changing the format type of output cells from StandardForm to TraditionalForm.

Have you experienced the same problem?

marius311
December 3rd, 2007, 09:14 AM
Yeah I've definitley noticed this problem too, along with the fact that the back/forward buttons and search bar do not work under Help.

Anyway, a quick fix is this: When Mathematica boots, X out of both the ghost windows (this has no immediate effect). Now type the first few letters of some command (e.g. "Int") and hit Ctrl+K to autocomplete. The popup menu with options should appear, and the ghost windows should be gone.

mannheim
December 4th, 2007, 05:25 PM
Anyway, a quick fix is this: When Mathematica boots, X out of both the ghost windows (this has no immediate effect). Now type the first few letters of some command (e.g. "Int") and hit Ctrl+K to autocomplete. The popup menu with options should appear, and the ghost windows should be gone.

An alternative way to get rid of the two "extra" windows is to exploit the fact that both these windows have a menu-bar: the menu items are not drawn, but it does respond to mouse-clicks. So click on each of these windows where the "File" menu should be. The File menu appears. Select "Close" from the File menu, and the window does indeed close.

I wish this could be fixed.

mannheim
January 15th, 2008, 05:33 PM
A much better fix is described in the launchpad bug (https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/153045) on this. In Mathematica, got to Edit->Preferences->Advanced and click on "Open Option Inspector". Under "Notebook Options", select "Window Properties" and change "WindowFrame" to "Generic".

This works for me, and I haven't noticed any side effects.

dmonkey
January 16th, 2008, 05:33 PM
A much better fix is described in the launchpad bug (https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/153045) on this. In Mathematica, got to Edit->Preferences->Advanced and click on "Open Option Inspector". Under "Notebook Options", select "Window Properties" and change "WindowFrame" to "Generic".

This works for me, and I haven't noticed any side effects.

Yep, works for me too. An absolute life saver!!

jdeslip
January 27th, 2008, 09:18 AM
Thanks for this solution. It is fantastic!

BryanFRitt
February 9th, 2008, 01:03 AM
A much better fix is described in the launchpad bug (https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/153045) on this. In Mathematica, got to Edit->Preferences->Advanced and click on "Open Option Inspector". Under "Notebook Options", select "Window Properties" and change "WindowFrame" to "Generic".

This works for me, and I haven't noticed any side effects.

This work for me, Thanks...
The windows still pop up briefly though, but no biggie.
However; some of the palettes don't seam to work properly.
The Algebraic will type in what it's supposed to then it will delete what it just put down.
(don't know if this problem existed before this fix)

mannheim
February 15th, 2008, 04:05 PM
.
The Algebraic will type in what it's supposed to then it will delete what it just put down.

I hadn't come across this bug before; but yes, it happens to me too, now that I try it. On the other hand, it seems to occur whether or not I apply the "fix" for the two extra windows. So it doesn't seem to be related.

pip_134
February 15th, 2008, 10:57 PM
Hey guys,
I'm trying to installer Mathematica on Gusty but I've run into a problem:

I've copied the files across from the CD and gone to the /Unix/Installer folder but when I run

sudo ./MathInstaller
I get the reply
sudo: ./MathInstaller: command not found
But a quick dir shows the file is there.

Any ideas would be greatly appreciated!

pip_134
February 15th, 2008, 11:15 PM
Solved my earlier problem:
In the GUI File Browser I clicked on the properties of the MathInstaller. Under Permissions there's an option "Execute: Allow executing file as program" select that then follow the normal instructions and the install will go through fine.

ndb82
March 26th, 2008, 03:45 AM
The problem is probadly related to the old crapy Motif Toolkit.

Someone should patch the shity Motif to fix this issues. (Infact Motif sucks alot the fonts looks like hell)

IMHO Wolfram should KILL motif and start write an GUI mathfrontend based on QT or GTK+

They got rid of Motif for version 6. The use QT now.



The documentation "search" bug can be worked-around by turning on/off numlock (forgot which). I just updated to 6.0.2 and this bug seems to be gone anyway.

binnaeus
April 11th, 2008, 03:05 PM
A much better fix is described in the launchpad bug (https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/153045) on this. In Mathematica, got to Edit->Preferences->Advanced and click on "Open Option Inspector". Under "Notebook Options", select "Window Properties" and change "WindowFrame" to "Generic".

This works for me, and I haven't noticed any side effects.

That worked for me too! Thank you very much :)