PDA

View Full Version : Can't set 1280x720 on Front projector with Mythbuntu.



am_pcguy
October 25th, 2007, 01:54 AM
SOLVED: I needed:
HorizSync
VertRefresh

in the monitor section, that corrected the problem


I've been working on this for days.

I use the correct modelines for my projector given on the MythTV wiki.
I've used "UseEDID" "FALSE", I've set the modes to 1280x720.

/var/logs/Xorg.0.log always says no valid modes found setting 640x480.

If I plug in a Monitor, doesn't matter if it's widescreen or not, then restart X, the resolution is set to 1280x720. I can then plug in my projector and I have 1280x720 until I reboot.

I've even tried removing "allow fail-safe" from /etc/X11/Xsession.options.

Any idea's how to set this up?

XORG.CONF


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder26) Wed Sep 12 14:29:17 PDT 2007

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
Load "vnc"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "AE-700"
VendorName "Pansonic"
Option "DPMS"
UseModes "Modes[0]"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "AE-700"
Option "SecurityTypes" "VncAuth"
Option "UserPasswdVerifier" "VncAuth"
Option "PasswordFile" "/root/.vnc/passwd"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x720_60" "720x480_60"
EndSubSection
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1280x720_60" 74.160 1280 1352 1392 1648 720 725 730 750 -hsync -vsync
EndSection

tgm4883
October 25th, 2007, 01:59 AM
When you reboot what resolution does it come up as? "720x480"?

Try removing "720x480" from your xorg.conf

am_pcguy
October 25th, 2007, 03:29 AM
640x480 - the log says those are not vaild modes and defaults to vga 640x480.

Lem
October 25th, 2007, 08:14 AM
Wiith some vga cables, especially long ones, X cannot auto-detect the mode of your screen.
However, I corrected this problem simply by adding the modeline manually as you have, so I'm not sure why it's defaulting to 640x480.

mungewell
October 25th, 2007, 04:09 PM
Any idea's how to set this up?


Did you check the Xlog to ensure that your projector is advertising the correct sizes, maybe it is not telling the truth.

For my display I see the following block
---
(II) LoadModule: "i2c"(II) Module already built-in
(II) RADEON(0): PLL parameters: rf=2700 rd=60 min=12000 max=35000; xclk=16600
(II) RADEON(0): Bios Connector table:
(II) RADEON(0): Port0: DDCType-3, DACType-0, TMDSType-0, ConnectorType-2
(II) RADEON(0): Port4: DDCType-0, DACType-2, TMDSType-2, ConnectorType-1
(II) RADEON(0): Output VGA-0 using monitor section Generic Monitor
(II) RADEON(0): I2C bus "VGA_DDC" initialized.
(II) RADEON(0): Output LVDS has no monitor section
(II) RADEON(0): Panel ID string: 1024x768
(II) RADEON(0): Panel Size from BIOS: 1024x768
(II) RADEON(0): BIOS provided dividers will be used.
(II) RADEON(0): Port0:
---

The 'smart' comms is done via I2C, it is possible that this does not work over a long cable, or that the cable does not have the correct wiring to support this. Try a short cable first.

Simon.

am_pcguy
October 25th, 2007, 06:10 PM
This is a front projector, so I do have a very long vga cable(20'). I don't really have an option to use a shorter cable.
Reason for long cable. (http://www.flickr.com/photos/amesenbrink/718509311/in/set-72157600007175405/) that also might be a key to why I like Ubuntu. :)

I thought that "UseEDID" "FALSE" told the xserver just to use the settings I gave. Last night I tried a few changes
that just made it worse. I can, as I said above, trick it by plugging in a monitor and now the gamma is way to high,
I was able to do some correction with "nvidia-settings".

This is what /var/log/Xorg.0.log has to say:


(II) NVIDIA(0): NVIDIA GPU GeForce 6150 (C51) at PCI:0:5:0 (GPU-0)
(--) NVIDIA(0): Memory: 524288 kBytes
(--) NVIDIA(0): VideoBIOS: 05.51.22.33.07
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 6150 at PCI:0:5:0:
(--) NVIDIA(0): CRT-0
(--) NVIDIA(0): CRT-0: 350.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(WW) NVIDIA(0): No valid modes for "1280x720_60"; removing.
(WW) NVIDIA(0): No valid modes for "720x480_60"; removing.
(WW) NVIDIA(0):
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0): "nvidia-auto-select".
(WW) NVIDIA(0):
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 640 x 480
(++) NVIDIA(0): DPI set to (100, 100); computed from -dpi X commandline option
(==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp

tgm4883
October 25th, 2007, 08:21 PM
Well testing a shorter cable would be to see if it's the cable in itself that is causing the problem

am_pcguy
October 26th, 2007, 12:37 AM
Shorter cable changes nothing.

DVI to HDMI cable works perfectly at 6" when I connect the longer HDMI cable, I need because
the projector is mounted on the ceiling, it reverts back to 640x480. I don't know if that's the DVI to
HDMI adapter I use on the longer cable or just a function of the lenght.

I really, really want to get this working over VGA. Any Suggestions?

Nabu
October 26th, 2007, 06:41 PM
Hi am_pcguy

You may need to add a HorizSync and VertRefresh to your Monitor section (especially for Analog VGA?) like so:

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 15.0 - 110.0
VertRefresh 38.0 - 150.0
Option "DPMS"
modeline etc..
EndSection

You'll have to get the specs for your particular monitor.

Anyhow, here is the longer version for those interested:
This is the process I went through to get my Sony G70 projector up and running, I've always found getting X to play the 'fun' part..
Just to be clear my goal was to get 1280 x 768 @ 75Hz

Firstly the nVidia web site knowledge base:
http://nvidia.custhelp.com/cgi-bin/nvidia.cfg/php/enduser/std_adp.php?p_faqid=178&p_created=1101837956&p_sid=8nQj73Pi&p_accessibility=0&p_redirect=&p_lva=&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX 3Jvd19jbnQ9NSZwX3Byb2RzPTImcF9jYXRzPTAmcF9wdj0xLjI mcF9jdj0mcF9zZWFyY2hfdHlwZT1hbnN3ZXJzLnNlYXJjaF9ub CZwX3BhZ2U9MSZwX3NlYXJjaF90ZXh0PWN1c3RvbSByZXNvbHV 0aW9u&p_li=&p_topview=1

Basically it gives you a run down on the steps that take place when X starts, etc..
The main section for me was about disabling EDID so that it doesn't override your custom resolution, even when EDID can't obtain monitor details.
I found my Xorg.log file didn't like: "IgnoreEDID" "True", rather it seems the newer way is to specify "UseEDID" "False" instead.
Also to wards the end of the KB, it mentions how to specify modeline, etc.

Secondly I found this to be helpful in the process: http://www.linuxsolutions.co.nz/sager9860wiki/index.php/X.org_setup
Nice step by step xorg.conf sections to look at, it gave me the clue I needed for adding the Horizontal Sync and Vertical Refresh settings. My projector refused to work and kept defaulting to 640x480 until I added this.

Thirdly, this site to just round out things again: http://www.nvnews.net/vbulletin/showthread.php?t=88154
Used cvt to generate my modeline items for me it was (from memory): cvt -v 1280 768 75
There is also the gtf command, I'm not sure what the difference is, but is gives a slightly different modeline result when running: gtf 1280 768 75 -v

I guess the upshot is my xorg.conf:


Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 15.0 - 110.0
VertRefresh 38.0 - 150.0
Option "DPMS"
# 1280x768_75
modeline "1280x768_75" 102.25 1280 1360 1488 1696 768 771 781 805 -hsync +vsync
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "nvidia"
Option "DPI" "100x100"
Option "UseEvents" "1"
Option "AddARGBVisuals" "1"
Option "ADDARGBGLXVisuals" "1"
Option "NoLogo" "1"
Option "UseEDID" "False"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 24
Option "MetaModes" "1280x768_75"
EndSubSection
EndSection

Hope it helps...

Rgs,

N.

am_pcguy
October 27th, 2007, 11:35 PM
horizrefresh
vertsync

That was it I needed those 2 lines in the monitor section and the data from the manual of the projector. With that info I was able to get my projector working.

Thank you.

Nabu
October 29th, 2007, 02:18 AM
Woohoo!

Glad it worked for you. :)

N.