View Full Version : Texlipse - High CPU-Usage, slow editor

October 23rd, 2007, 04:27 PM
Hey there.

Iam working with Texlipse, a LateX-Editor for Eclipse, to write my Diploma.
I encounter the problem that it is really CPU-consuming. I work on an CoreDuo 1.66Ghz with 1.5GB Ram. When writing a new paragraph its ok, but when it starts getting longer the cursor starts to fall behind my typingspeed.
Then things go fast an i sometimes have to wait over 30 seconds for the editor to catch up. Its like he parses the document with every new letter i type.
The document isn't even long, maybe 3 pages. =(

Now i tried the following:
Under Window -> Preferences -> Texlipse -> Editor i disabled Automatic Parsing and Content Assist

But this totally made no impact on the performance. The compilation on the other hand is really fast ... it doesn't take longer than a second.

Maybe you have some idea. I really want to hold on to this editing platform, since it integrates the CVS-Client so well!

thx David

October 24th, 2007, 09:58 AM
OH cmon ...

It cannot be that iam allways a singular person having such problems!

October 25th, 2007, 12:13 PM
After wasting three days of experimental time i figured it out.
As it seems eclipse didn't like the used JavaRuntime-Environment.
Switching to sun-java1.6 saved the day.

March 18th, 2008, 08:25 PM

you aren't the only one. I am facing this problem currently, too. Almost half a year after you. I'll try your solution, thank you for posting it!


March 18th, 2008, 10:03 PM
Solution was replacing iced tea jre with sun java jre, which is faster! However it wasn't really faster, which I consider the soft wrapping as responsible. I switched to KILE, damn.