PDA

View Full Version : USN-534-1: OpenSSL vulnerability



rss-bot
October 22nd, 2007, 09:40 PM
Referenced CVEs:
CVE-2007-4995


Description:
================================================== ========= Ubuntu Security Notice USN-534-1 October 22, 2007 openssl vulnerability CVE-2007-4995 ================================================== ========= A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 6.10 Ubuntu 7.04 Ubuntu 7.10 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 6.06 LTS: libssl0.9.8 0.9.8a-7ubuntu0.5 Ubuntu 6.10: libssl0.9.8 0.9.8b-2ubuntu2.2 Ubuntu 7.04: libssl0.9.8 0.9.8c-4ubuntu0.2 Ubuntu 7.10: libssl0.9.8 0.9.8e-5ubuntu3.1 After a standard system upgrade you need to reboot your computer to affect the necessary changes. Details follow: Andy Polyakov discovered that the DTLS implementation in OpenSSL was vulnerable. A remote attacker could send a specially crafted connection request to services using DTLS and execute arbitrary code with the service's privileges. There are no known Ubuntu applications that are currently using DTLS.





More... (http://www.ubuntu.com/usn/usn-534-1)