PDA

View Full Version : [SOLVED] unable to remove seamonkey



mandrill
October 1st, 2007, 01:50 AM
Don't know why, (probably wrong directory) but here is the text from uninstall attempt(s):

rm: cannot remove `/usr/bin/seamonkey': No such file or directory
sudo rm /usr/bin/seamonkey
Previous command has failed to complete successfully. Exiting.
Process returned code 1
Traceback (most recent call last):
File "/usr/local/bin/ubuntuzilla.py", line 1045, in <module>
bs.start()
File "/usr/local/bin/ubuntuzilla.py", line 210, in start
si.start()
File "/usr/local/bin/ubuntuzilla.py", line 233, in start
self.remove()
File "/usr/local/bin/ubuntuzilla.py", line 527, in remove
self.removeLaunchLink()
File "/usr/local/bin/ubuntuzilla.py", line 925, in removeLaunchLink
self.util.execSystemCommand(executionstring="sudo rm /usr/bin/seamonkey")
File "/usr/local/bin/ubuntuzilla.py", line 140, in execSystemCommand
raise SystemCommandExecutionError, "Command has not completed successfully. If this problem persists, please seek help at our website, " + self.version.url
__main__.SystemCommandExecutionError: Command has not completed successfully. If this problem persists, please seek help at our website, http://ubuntuzilla.sourceforge.net/

The executable still fires up, and is located at /usr/local/seamonkey...cannot remove manually, as trash option greyed out.

removal because of 1) inability to launch mail separately, 2) themes revert to default on every start of application. Have visited website, sent here, hoping it is as simple as changing the command to point to the actual location...

Thank you in advance for your help!

Oh, and does this help?

jim@monkey:~$ cd
jim@monkey:~$ /usr/local/
bash: /usr/local/: is a directory
jim@monkey:~$ cd /usr/local
jim@monkey:/usr/local$ rm seamonkey
rm: cannot remove directory `seamonkey': Is a directory
jim@monkey:/usr/local$

aysiu
October 1st, 2007, 03:18 AM
Try pasting this command into the terminal:
sudo rm -r /usr/local/seamonkey Make sure you copy and paste the command instead of retyping it. Retyping it can be dangerous!

nanotube
October 1st, 2007, 03:42 AM
since your seamonkey is located in /usr/local, and since ubuntuzilla installs in /opt by default, am i correct in guessing that you did /not/ use ubuntuzilla to /install/ seamonkey?

if that is the case, then... it's not surprising that your uninstall isn't working - ubuntuzilla uninstall is built to undo what the install has done. if you installed by some other means, then you get to uninstall by some other means, as well.

that may also explain why you are having problems with your seamonkey install in the first place - if you have not properly set some permissions or symlinks somewhere in the process of install.

if i'm wrong in my guess, then let me know, and we'll go from there. the command that aysiu posted will work to remove your seamonkey directory - but before uninstalling, i think it's a good idea to figure out what procedure you followed during your install.

mandrill
October 1st, 2007, 05:18 AM
First of all - thank you both for your replies.

I was going to mention that I obviously had screwed up the installation - Ubuntuzilla was my third attempt - I realized it, but did not know exactly how to safely fix it. My first attempts were with the native installer. Another learning experience! This is my 4th install of Ubuntu, and, at this point, really do not feel like doing it all again - too much time invested!

Gotta throw out the old thinking - most of it, anyway! I will post results of un-install - I think I knew what to do, but not quite how....

mandrill
October 1st, 2007, 05:25 AM
Perfect.

Ran this, its gone...you can see that I did it the second time, because there was no dialogue, or any elepsed time, and the second result (plus manually looking) convinced me....

jim@monkey:~$ sudo rm -r /usr/local/seamonkey
Password:
jim@monkey:~$ sudo rm -r /usr/local/seamonkey
rm: cannot remove `/usr/local/seamonkey': No such file or directory
jim@monkey:~$

Thanks again.

ps Funny, but after 4 installs I am able to answer a lot of the questions in "Absolute Beginners" ! :)

nanotube
October 1st, 2007, 12:38 PM
congrats! :)

MSchenker
December 19th, 2007, 03:46 PM
I was about to post about the same problem, and noticed there is a discussion on this already!

I installed SeaMonkey using Ubuntuzilla, but I can't seem to uninstall it with the command given above by aysiu.

Here's the session:

matthew@Main:~$ sudo rm -r /usr/local/seamonkey
rm: cannot remove `/usr/local/seamonkey': No such file or directory
matthew@Main:~$
Can anyone help me figure out what's going on here?

Thanks!

MSchenker
December 19th, 2007, 11:28 PM
I just found SeaMonkey listed in the following two places:
/opt/seamonkey
/usr/bin/seamonkey

Question: If I want to uninstall SeaMonkey, would I do this...


sudo rm -r /opt/seamonkeyWould this work, or am I misunderstanding how to use the remove command?

Thanks!

mandrill
December 20th, 2007, 03:11 AM
sudo rm -r /opt/seamonkey should work if installed with ubuntuzilla install

MSchenker
December 20th, 2007, 05:14 AM
mandrill,
Thanks, it worked!
Is it safe to manually delete the "/usr/bin/seamonkey" file. now that SeaMonkey is uninstalled?

mandrill
December 20th, 2007, 08:35 AM
Yes, it is. I prefer to use "wipe" when deleting files/directories, but that is just a personal preference and not at all necessary. You may also do 'sudo apt-get autoremove' to rid yourself of unnecessary or uninstalled packages. For wipe, use 'sudo apt-get install wipe'. Once installed, do 'sudo wipe -r' for directories, or 'sudo wipe' for regular files. It will let you know.
To avoid more typing, just drag the offending item into the terminal after typing either command, hit enter, and confirm by typing "yes"

nanotube
December 21st, 2007, 12:52 AM
actually... while the "manual" method of seamonkey uninstall works just fine, ubuntuzilla comes with a built-in uninstaller that automatically does all that rm -rf stuff.
just do

ubuntuzilla.py -p seamonkey -a remove
and it will take care of all the bits and pieces automatically.

for future reference. :)