PDA

View Full Version : HOW TO: Install Ubuntu on a HP TC1100 tablet pc



Pages : [1] 2 3

phenest
September 30th, 2007, 04:20 PM
I just bought a 2nd hand HP TC1100 tablet pc, and have to say, I'm impressed. It came with a docking station (although I don't have much use for it), with a DVD/CDRW drive which can be removed and placed in an external USB caddy. I'd say this is one of the better designed tablets around (I also have a Fujitsu ST4110).

Ok. Down to business. This is what I have so far, and will keep this guide updated as more information arrives.

Ubuntu 7.04

After installing, everything pretty much works out of the box.

nVidia
Enable the NVIDIA driver from the Restricted Drivers Manager.

xorg.conf
Then you need to update the xorg.conf file:

sudo nano /etc/X11/xorg.conf
Edit the Device section and add:

Option "RandRRotation" "on"
Option "NvAGP" "1"
This enables rotation capabilities. The 2nd line is to help suspend work properly.
Then edit the InputDevice section- Driver wacom - Identifier stylus add:

Option "Button2" "3"
This enables right-clicking with the pen button.

Rotation
You will need to install wacom-tools:

sudo apt-get install wacom-tools
You will need a script and map it to a key. The script:

#!/bin/sh

# Change System Input orientation for Tablet Mode
# Depends on wacom-tools from repo

orientation=`/usr/bin/xrandr --query | /bin/grep "Current rotation" | /usr/bin/awk '{print $4}'`
if [ "$orientation" = "normal" ]; then
/usr/bin/xrandr -o left
/usr/bin/xsetwacom set stylus Rotate CCW
else
/usr/bin/xrandr -o normal
/usr/bin/xsetwacom set stylus Rotate none
fi

Save it as rotate.sh and put into the /usr/bin/ directory. The TC1100 has a 'Q' key on its edge. In Windows, this activates a popup menu, but the menu doesn't exist in Ubuntu. So we will use it for screen rotation. To map the key, open the Configuration Editor and browse to /apps/metacity/keybindings_commands. Edit command_1 (or the 1st available command) enter: sh /usr/bin/rotate.sh . Then browse to /apps/metacity/global_keybindings and edit the run_command_1 with 0x9f (or press the 'Q' button.

OSK: On Screen Keyboard
Cellwriter (http://risujin.org/cellwriter/) version 1.2.5 is the choice here for both OSK and hand-writing recognition. Under System>Preferences>Accessibility>Assistive Technology Preferences, you need to check the following:
Enable assistive technologies
Password dialogues as floating windows (the on-screen keyboard can be used for root access)
Start on-screen keyboard at log in

I did find a problem with the pen operating erratically during login where the cursor would not follow the pen and kept jumping to the lower-right of the screen. To stop this behaviour, uncheck 'Enable accessible login' in System>Administration>Login Window - Accessibility tab. This is probably a bug in the wacom driver.

To enable Cellwriter at login:

sudo nano /etc/X11/gdm/Init/Default
At the bottom of the script, add:

cellwriter --keyboard-only --window-y=600 &
... so it reads ...

fi
cellwriter --keyboard-only --window-y=600 &
exit 0

If you wish to use xvkbd at login instead:

sudo apt-get install xvkbd
... then enter ...

xvkbd -geometry -300-100 -no-keypad &
...or onboard:

sudo apt-get install onboard
...then enter...

onboard &
... into the /etc/X11/gdm/Init/Default file instead of cellwriter.
Kubuntu users: Put either onboard or xvkbd into the /etc/kde3/kdm/Xsetup file.
Also note: Login style must be changed from Themed to Plain in System>Administration>Login Window - Local tab
Another note: If you enable automatic login, do NOT amend this file as you will end up with 2 instances of the OSK!

Sleep & Suspend
To make sleep and suspend work, follow the instructions here (https://help.ubuntu.com/community/NvidiaLaptopBinaryDriverSuspend)

Miscellaneous
To make the 3 pen activated 'soft keys' work, look here (http://ubuntuforums.org/showthread.php?p=3672701#post3672701)

Since Cellwriter 1.3.1, it is possible to use it when the screen is locked. Open Configuration Editor and browse to apps/gnome-screensaver and check embedded_keyboard_enabled and enter:

cellwriter --xid
under embedded_keyboard_command

Brigtness can also be adjusted. Look here (http://ubuntuforums.org/showthread.php?t=571696&highlight=tc1100+brightness)
----------------------------------------------------------------
That's about it.


What doesn't work?
The SD card reader -
However, the PCMCIA slot DOES work, so I bought a Jessops branded '6 in 1' card reader for it and now I can use my SD card with this tablet. But I would prefer it if the built-in card reader worked.

Everything else works or can be made to work in some fashion.


Any other useful software?
Xournal is an equivalent to Windows Journal.

Ubuntu 7.10

For those wanting to try Ubuntu 7.10 (Gutsy), I will say it works very well, but you won't get any better results than with 7.04 (Feisty). That is to say, what doesn't work with Feisty, still doesn't work with Gutsy. After installation, follow the above procedure.

Suspend, hibernate, and sleep
Although suspend and hibernate work fine, sleep only works once, and afterwards it may give this error:

Your computer failed to suspend.
...even though it did it perfectly. It then (without any warning), goes into hibernation. When it wakes from that, another error message:

Your computer failed to hibernate.
...even though it did it perfectly! If anyone knows the answer, please let me know.
EDIT: After this error, you may lose your wireless connection and have to set it manually (related?).

Rotation
The console shows different output in Gutsy for xrandr, so the above script won't work correctly. Please use the following:

#!/bin/sh
if [ -n "$(xrandr | grep 768x1024)" ]; then
xrandr -o normal
xsetwacom set "stylus" Rotate NONE
else
xrandr -o left
xsetwacom set "stylus" Rotate CCW
fi
...from post #16 by ronnystandtke. Thanks for that.

Stylus not working? While you are editing /etc/X11/xorg.conf, you will need to uncomment one line at the bottom to make the Stylus work. You do not need to uncomment Eraser or Cursor.

Compiz
Compiz works quite well on this tablet considering the low-end video card and limited video RAM. Edit this file:

sudo nano /usr/bin/compiz
...and comment out the line that reads:

NVIDIA_MEMORY="65536" # 64MB
...to read:

# NVIDIA_MEMORY="65536" # 64MB
This will allow you to start the desktop effects without it checking for a minimum of 64Mb of video RAM.
You may notice the 3 stylus activated 'buttons' stop working with Compiz running. It's because it's tampered with the key mappings. You need to add the key mappings in the CompizConfig Settings Manager under General Options and add the commands in the Commands tab, and the key mappings in the Actions tab>Commands.
Compiz is installed by default in Gutsy, so you just need the Settings Manager:

sudo apt-get install compizconfig-settings-manager

Bluetooth
If you have the model with bluetooth like mine, I can tell you it works fine. I'm using a HP Deskjet 460wbt printer using the bluetooth module.

Ubuntu 8.04

I'm skipping Hardy Heron because it shouldn't be much different from Gutsy. There are posts here concerning Hardy if you do a search.

Ubuntu 8.10

For anyone using Ubuntu version 8.10 (Intrepid Ibis), refer to post 116 (http://ubuntuforums.org/showpost.php?p=6123218&postcount=116) by Aearenda.

francisco_athens
October 3rd, 2007, 04:34 AM
Nice tute,
there is some more useful info here:

http://wiki.linuxquestions.org/wiki/Tc1100#Onscreen_Keyboard_at_Login

including how to get the onscreen keyboard at login
the two things that confound me are getting sleep to function properly with the atheros wifi (known bug in madwifi) and getting the Onboard working when the screensaver has locked the screen.

there are also some general tablet apps here:

http://wiki.linuxquestions.org/wiki/Tablet_PC

but the list is missing Xournal, the very good app you mentioned.

francisco_athens
October 3rd, 2007, 05:00 AM
BTW there is an AMAZING replacement for onboard/GOK called cellwriter:

http://www.gnomefiles.org/app.php?soft_id=2127

this really needs to be a part of (X,K,*)Ubuntu!!

sorry for all the enthusiasm but it really is very good!

Francisco

phenest
October 3rd, 2007, 10:51 AM
BTW there is an AMAZING replacement for onboard/GOK called cellwriter:

http://www.gnomefiles.org/app.php?soft_id=2127

This looks very interesting. I'm gonna check it out.

The trouble I have with OnBoard during login, is the cursor behaves erratically with the pen although works fine with a mouse or the trackstick. When I use the pen, the cursor keeps jumping to the bottom-right of the screen. No idea why. Pen works fine after login.

phenest
October 4th, 2007, 10:52 AM
BTW there is an AMAZING replacement for onboard/GOK called cellwriter:

http://www.gnomefiles.org/app.php?soft_id=2127

As a follow up to this app, I have emailed the author with some suggestions and also some bugs. He is very willing to implement my suggestions and to hopefully fix the bugs.

I have asked to add a couple of features so it's completely usable during login.

I would like to see this added to Ubuntu too, perhaps as default to replace OnBoard.

robnz
October 4th, 2007, 07:26 PM
I use xvkbd on my TC1100 under kubuntu. To make it available during login simply add the following line to the end of /etc/kd3/kdm/Xsetup

xvkbd -geometry -300-100 -no-keypad &
It would probably work the same under gdm just find where Xsetup is located.

$ locate Xsetup
/etc/kde3/kdm/Xsetup

robnz
October 4th, 2007, 09:25 PM
BTW I agree cellwriter shows great promise. For use at login it would need a dropdown to select the right user so that the appropriate strokes database can be accessed.

robnz
October 4th, 2007, 11:01 PM
The xmodmap calls in the script from Linuturk are unnecessary on the TC1100. The script I use is as follows

#!/bin/sh
# Script created to toggle screen orientation on a Compaq TC1100 tablet
# Adapted by Rob Stockley from code found at
# http://www.koders.com/noncode/fidF6152D1225924664BF30DC6977DCD1E697FACD61.aspx
if [ -n "$(xrandr | grep rotation | grep left)" ]
then
xrandr -o normal
xsetwacom set "stylus" Rotate 0
else
xrandr -o left
xsetwacom set "stylus" Rotate 2
fi
To get the side keys working my .Xmodmap file looks like this

rob@rob-laptop:~$ cat .Xmodmap
! keysyms for buttons on edge of Compaq TC1100 Tablet
! mapped for use in Kubuntu 7.04
!
! Jog shuttle
! Left = 99
! Right = 105
! Press = 36
! Escape = 9
! Reset = 37
! Tab = 23
! Q = 159
! Screen = 151
!
keycode 99 = Page_Up
keycode 105 = Page_Down
keycode 36 = Return
keycode 23 = Tab
keycode 9 = Escape
!
! The Q and screen buttons are mapped to XF86 launch
! events so they can be linked to scripts from within
! system settings
keycode 159 = XF86Launch0
keycode 151 = XF86Launch1

I have the screen button mapped to my rotate script and the Q button mapped to xournal which I use often.
HTH

phenest
October 5th, 2007, 12:50 PM
BTW I agree cellwriter shows great promise. For use at login it would need a dropdown to select the right user so that the appropriate strokes database can be accessed.

I have asked that you only have a keyboard at login.

phenest
October 5th, 2007, 12:55 PM
I use xvkbd on my TC1100 under kubuntu. To make it available during login simply add the following line to the end of /etc/kd3/kdm/Xsetup

xvkbd -geometry -300-100 -no-keypad &
It would probably work the same under gdm just find where Xsetup is located.

$ locate Xsetup
/etc/kde3/kdm/Xsetup

There doesn't seem to be an Xsetup file in gdm. Perhaps to put that line into the /etc/X11/gdm/Init/Default file instead of onboard. I will test this and modify my guide to include the different on-screen keyboards.

phenest
October 5th, 2007, 01:18 PM
The xmodmap calls in the script from Linuturk are unnecessary on the TC1100. The script I use is as follows

#!/bin/sh
# Script created to toggle screen orientation on a Compaq TC1100 tablet
# Adapted by Rob Stockley from code found at
# http://www.koders.com/noncode/fidF6152D1225924664BF30DC6977DCD1E697FACD61.aspx
if [ -n "$(xrandr | grep rotation | grep left)" ]
then
xrandr -o normal
xsetwacom set "stylus" Rotate 0
else
xrandr -o left
xsetwacom set "stylus" Rotate 2
fi
To get the side keys working my .Xmodmap file looks like this

rob@rob-laptop:~$ cat .Xmodmap
! keysyms for buttons on edge of Compaq TC1100 Tablet
! mapped for use in Kubuntu 7.04
!
! Jog shuttle
! Left = 99
! Right = 105
! Press = 36
! Escape = 9
! Reset = 37
! Tab = 23
! Q = 159
! Screen = 151
!
keycode 99 = Page_Up
keycode 105 = Page_Down
keycode 36 = Return
keycode 23 = Tab
keycode 9 = Escape
!
! The Q and screen buttons are mapped to XF86 launch
! events so they can be linked to scripts from within
! system settings
keycode 159 = XF86Launch0
keycode 151 = XF86Launch1

I have the screen button mapped to my rotate script and the Q button mapped to xournal which I use often.
HTH

That is a better script. Thanks for that. The one I used was simply the first one I found.

The side keys work 'Out-Of-The-Box' with Ubuntu. Did you not find this with Kubuntu?

robnz
October 5th, 2007, 07:59 PM
The side keys work 'Out-Of-The-Box' with Ubuntu. Did you not find this with Kubuntu?

Actually they probably did work out of the box except for perhaps the Q and screen buttons. I've spent a long time trying to get the pen buttons working and some of my key mappings got a little broken along the journey. Chances are I could comment out the tab, esc, and jog shuttle mappings now and they would function normally.

robnz
October 5th, 2007, 08:18 PM
Option "Button1" "1"
Also the above line in xorg.conf is unnecessary as that is already the default button mapping.

phenest
October 7th, 2007, 01:21 PM
... things that confound me are getting sleep to function properly with the atheros wifi (known bug in madwifi) ...

If by 'sleep' you mean 'suspend', then it does work with some tweaking.

EDIT: I have edited the guide to show how.
Also, Suspend and Hibernate now work in Gutsy with the 2.6.22-14-generic kernel using the same method.

robnz
October 11th, 2007, 01:45 AM
FYI. I've submitted a script to adjust LCD brightness on the TC1100 in this thread. (http://ubuntuforums.org/showpost.php?p=3511736&postcount=4)

ronnystandtke
October 15th, 2007, 10:38 PM
I noticed that the script does not work with Ubuntu 7.10 because the console output of xrandr changed. Here comes my version of the rotate script:


#!/bin/sh
if [ -n "$(xrandr | grep 768x1024)" ]; then
xrandr -o normal
xsetwacom set "stylus" Rotate NONE
xsetwacom set "cursor" Rotate NONE
xsetwacom set "eraser" Rotate NONE
else
xrandr -o left
xsetwacom set "stylus" Rotate CCW
xsetwacom set "cursor" Rotate CCW
xsetwacom set "eraser" Rotate CCW
fi

phenest
October 16th, 2007, 08:32 AM
...the script does not work with Ubuntu 7.10 because the console output of xrandr changed...

I also found this. I will update the guide as soon as 7.10 is released officially.

robnz
October 16th, 2007, 08:57 AM
I noticed that the script does not work with Ubuntu 7.10 because the console output of xrandr changed.
What has it changed to?
UPDATE: Disregard. I took a look at the xrandr source for Gutsy and saw the extensive changes.

robnz
October 22nd, 2007, 09:29 PM
The attached script below should work with both Feisty and Gutsy. There is an issue with screen dimensions that I have yet to address but this is half the solution.

#!/bin/sh
# Script created to toggle screen orientation on a Compaq TC1100 tablet
# Adapted by Rob Stockley from code found at
# http://www.koders.com/noncode/fidF6152D1225924664BF30DC6977DCD1E697FACD61.aspx
# Updated 23 October 2007 to work with xrandr version 1.2 as
# installed on Gutsy Gibbon.

if [ -n "$(xrandr --version | grep 'version 1.2' )" ]
then
if [ -n "$(xrandr | grep 'left (')" ]
then ORIENTATION="left"
else ORIENTATION="normal"
fi
else
if [ -n "$(xrandr | grep rotation | grep left)" ]
then ORIENTATION="left"
else ORIENTATION="normal"
fi
fi

if [ $ORIENTATION = "left" ]
then
xrandr -o normal
xsetwacom set "stylus" Rotate 0
else
xrandr -o left
xsetwacom set "stylus" Rotate 2
fi

popch
November 6th, 2007, 11:06 PM
Thanks for this nice HowTo.

I am just now trying to set up my TC1100.

First problem: enabling the restricted nvidia drivers will fail in Switzerland.

Solution: open Systems/administration/software sources. Change download from Server for Switzerlandto main server (Hauptserver) before trying to enable the restricted drivers.

popch
November 6th, 2007, 11:29 PM
Since Gutsy (7.10) three important lines in /etc/X11/xorg.conf have been commented out. The HowTo (first post) should mention that at least one of them (stylus and cursor?) need to be uncommented. Otherwise, the pen will not work:

# Uncomment if you have a wacom tablet
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"

(Near the end of the file, in
Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"

Since the TC1100's pen does not have an eraser, the third line can remain commented out.

The OSK (on-screen keyboard) seems to be working. Still no luck in the login screen. The login screen hides the virtual keyboard. Perhaps I have not understood all the settings properly. Will look again later.

Later (under 'Rotation' for Gutsy), the new script mentions xsetwacom. Does the HowTo mention that wacom-tools must be installed?

I am terribly pleased so far. Rotation works on first trial. The TC1100 is much more useful when rotated.

OK, time for bed. More tomorrow or some days after.

phenest
November 7th, 2007, 12:34 AM
Good point. In fact, I only have Stylus uncommented. I left Cursor and Eraser commented out.

popch
November 7th, 2007, 12:43 AM
Good point. In fact, I only have Stylus uncommented. I left Cursor and Eraser commented out.

I just edited the post you replied to. Thanks for the useful information.

phenest
November 7th, 2007, 10:20 AM
The OSK (on-screen keyboard) seems to be working. Still no luck in the login screen. The login screen hides the virtual keyboard. Perhaps I have not understood all the settings properly. Will look again later.

Later (under 'Rotation' for Gutsy), the new script mentions xsetwacom. Does the HowTo mention that wacom-tools must be installed?

Yep, I forgot a couple of things there:

To see the OSK during login, set the login style to Plain instead of Themed.

And yes, wacom-tools needs to be installed.

popch
November 7th, 2007, 10:07 PM
Practically everything now works.


/etc/X11/gdm/Init/Default
appears to have been moved to
/etc/gdm/Init/Default

btw, the pcmcia slot works for me in gutsy.
sd slot does not work, but then, in XP it does detect my SD card but says it is not formatted.

phenest
November 7th, 2007, 11:02 PM
/etc/X11/gdm/Init/Default
appears to have been moved to
/etc/gdm/Init/Default
I'm glad you verified that. I thought I'd made a mistake.


btw, the pcmcia slot works for me in gutsy.
I never had anything to test it with.

sd slot does not work, but then, in XP it does detect my SD card but says it is not formatted.

Mine works perfectly in Windows, as it does on my Dell laptop with Ubuntu. I think it's always worth spending a bit extra on memory cards to get reliability.

Now I know the PCMCIA slot works, I'm going to try and get a memory card reader for it.

popch
November 7th, 2007, 11:34 PM
Now I know the PCMCIA slot works, I'm going to try and get a memory card reader for it.

I use mine with a SanDisk CompactFlash PC Card adapter. I do not have any other PCMCIA cards to test it with.

timnicholson
November 9th, 2007, 08:05 PM
Thanks for all the great info!



Then edit the InputDevice section- Driver wacom - Identifier stylus add:

Option "Button2" "3"This enables right-clicking with the pen button.


I have a Fujitsu Stylistic Tablet PC and have xubuntu v7.10 installed, have the screen settings all set and have a script for screen rotation that works. However, I've added the above line for the "right click" and it doesn't seem to work. My pen has a rocker button on it where if you press the bottom I think its supposed to right click and if you press the top its supposed to erase. I don't care as much about the erase function, but I need to be able to right click since unlike in Windows you can't press-and-hold to pull up the context menu.

Is there documentation anywhere on this? Is this related to the wacom drivers or something else?



Rotation
You will need a script and map it to a key.
<SNIP>
Save it as rotate.sh and put into the /usr/bin/ directory.


BTW, I needed to modify the one posted here to grep for "current 768 x 1024". The word current is needed because the 1024 x 768 string also exists in the output. Notice the space in front of and behind the x as well.



The TC1100 has a 'Q' key on its edge. In Windows, this activates a popup menu, but the menu doesn't exist in Ubuntu. So we will use it for screen rotation. To map the key, open the Configuration Editor and browse to /apps/metacity/keybindings_commands. Edit command_1 (or the 1st available command) enter: sh /usr/bin/rotate.sh . Then browse to /apps/metacity/global_keybindings and edit the run_command_1 with 0x9f (or press the 'Q' button.


I have researched this and found that what you are referring to is probably the gconf-editor. I've installed that successfully by typing

sudo apt-get install gconf-editor

However, I don't see a menu option for it. I thought this was a program that let me changes things with a graphical UI, similar to Windows regedit function.

I obviously want to be able to assign the screen rotation to a button and also would like to get the up/down/left/right arrows working and assign things the web browser to a button.



OSK: On Screen Keyboard

I haven't installed an onscreen keyboard yet. It looks like there is cellwriter and xvkbd. What's the consensus on which one is the best for me to try?



Suspend, hibernate, and sleep

Did anyone ever figure out how to get suspend and hibernation working properly in Gutsy 7.10? I'll want to get that working next as the whole reason I'm doing all this is to get this tablet where its quick enough that the kids can hop on quickly and not bellyache about how slow Windows is. So I'd like it to remain in suspend or hibernation mode all the time.

popch
November 9th, 2007, 08:12 PM
Configuration Editor :
I have researched this and found that what you are referring to is probably the gconf-editor. I've installed that successfully by typing

sudo apt-get install gconf-editor

That had me stumped, at first, too. I later found out about it and forget to mention it in my feedback.

In Ubuntu 7.10, the Configuration Editor apparently is installed by default. In order to make it visible, use System/Settings/Main Menu (or equivalent; I do not know what terms they use in the English language menues).

In the Menu editor, scroll to the System tools group. On the right hand side you should find an entry called Configuration Editor. Activate that.

Lo and behold! you can access it in the applications menu.

phenest
November 9th, 2007, 11:18 PM
I would like to say you are wandering off-topic here. This thread is for a Hewlett Packard/Compaq TC1100 tablet pc. I also have a Fujitsu Stylistic ST4110 tablet pc, and all the things you mention can be made to work. There are other threads already in discussion about those.

Also, please note that this thread is for installing Ubuntu. Although it will work for Xubuntu and Kubuntu, you may have to make adjustments. Again, there is already information on this forum for you. But please stay on-topic here.

Many thanks.

P.S. I will make amendments to my tutorial for Kubuntu and Xubuntu users but only for Compaq TC1100 owners. I will be starting a tutorial for Fujitsu Stylistic ST4110 owners (unless someone beats me to it).

phenest
November 15th, 2007, 12:02 AM
This is a breakdown of the Q Menu in Windows XP Tablet Edition. If anyone would like to help me program a Linux equivalent, please PM me to discuss it (programmers of C++ only).

The default popup menu consists of:

Mute On/Off
Brightness
Wireless Off
Internal Only
Internal and External
Volume
Presentation Mode On
Portrait-Primary
Landscape-Primary
Tablet PC Settings
Q Menu Settings

Brightness brings up a dialog box which says: Please use the Jog dial to adjust the brightness. Click OK button when you are done.
Wireless Off toggles wireless on and off.
Volume brings up the Volume Control (found in the Control Panel).
Presentation Mode sets Extended Desktop and sets Presentation power settings (something to do with NView Desktop Manager).
Tablet PC Settings opens a Control Panel applet.
Q menu Settings brings up an applet allowing you to choose which items to display on the Q Menu:

Q Menu Settings
Items to display on Q Menu

Mute On/Off
Brightness
Internal Only
External Only
Internal and External
Extended Desktop
Volume
Capture Screen
Capture Window
Power Control
Presentation Mode
Docked Profile
Undocked Profile
Write Profile
Portrait-Primary
Landscape-Primary
Standby
Hibernate
Shut down
Tablet PC Settings
Q Menu Settings

Most of the items are self explanatory.

Down the right of the list is 7 buttons:

Add
Modify
Remove
Move Up
Move Down
Execute
About

Add and Modify opens a dialog box:
Add New Menu Entry
Please enter Diplay name ane File name. Display name is limited to 25 characters.
Display Name (text box)
File Name (text box)
Buttons: Browse, OK, and Cancel.

Under the list is a text window showing a description for the highlighted list item. Under that is a checkbox: Display Q Menu Icon on system tray. Under that are the usual buttons: OK, Cancel, and Apply.

Tablet and Pen Settings
4 tabs: Setting, Display, Tablet Buttons, and Pen Buttons

Settings
Handedness - to do with hand-writing recognition (Won't need this)
Menu location - You can select a menu position so that menus don't appear under your hand. (Useful and possible I think)
Calibration - Need Special Wacom tools installed from their site
Display
Screen orientation - A bit pointless?
Screen brightness - Need this
Tablet Buttons
Allows programming of the 3 screen buttons as well as the edge buttons
Pen Options
Pen actions - such as Right-click etc.
Pen buttons - (checkbox) Use pen button to right-click - Use top of the pen to erase (where available)


A linux equivalent doesn't have to be exactly the same, but this gives an idea.

I only program in C++ but have never written for Linux. So if you're up to the challenge, PM me and we'll put our heads together. If not, I'll have a bash myself.

Zolty
December 4th, 2007, 07:32 PM
I have followed your guide, well written and easy to understand for even a noobie like me, I am having one problem binding my Q key to the rotate command. It works fine With Compiz disabled, but as soon as I activate Compiz it stops working.

I noticed in your guide that I should expect this as Compiz will take over keybindings, so I go into the ccsm and check to make sure the command is bound to command 0, it is, then I check the actions tab to be sure the key is bound properly. The Run Command 0 has a key value of DISABLED. I can set it to a keyboard command like ctrl+alt+D, but it will not let me bind it to 0x9f as your guide suggests (it simply goes back to "disabled" when I hit OK). I have also tried hitting the key when prompted for "New accelerator" and nothing happens when I hit any of the proprietary keys on the TC1100.

Based on some advice from the #compiz-fusion irc channel on freenode I tried the Xen Command to see what is being returned from those key presses:


KeyPress event, serial 31, synthetic NO, window 0x6800001,
root 0xc1, subw 0x0, time 2792056699, (276,-95), root:(283,464),
state 0x0, keycode 159 (keysym 0x0, NoSymbol), same_screen YES,
XLookupString gives 0 bytes:
XmbLookupString gives 0 bytes:
XFilterEvent returns: False

KeyRelease event, serial 31, synthetic NO, window 0x6800001,
root 0xc1, subw 0x0, time 2792056699, (276,-95), root:(283,464),
state 0x0, keycode 159 (keysym 0x0, NoSymbol), same_screen YES,
XLookupString gives 0 bytes:
XFilterEvent returns: False

Any help is greatly appreciated.

phenest
December 5th, 2007, 12:51 AM
...but it will not let me bind it to 0x9f as your guide suggests (it simply goes back to "disabled" when I hit OK)...

CCSM does not like you entering some key combinations. I also had this problem. Try entering them via the Configuration Editor instead.

cathectic
December 8th, 2007, 02:46 PM
Would someone be able to post the DSDT from this machine?

Using sudo:

cat /proc/acpi/dsdt > dsdt

And then attach the dsdt file?

(I don't have the machine, but am planning to work on the tc1100-wmi driver, so it plays nice with some other upstream patches I'm working on).

Edit:You can safely disregard this - I've managed to get my hands on the DSDT for this machine.

timere969
December 27th, 2007, 04:47 AM
There is a program called Tabatha. Just do a Google search for tabatha and groundstate and it will pull up the page. It replicates must of the Q menu functions.

mgk
December 29th, 2007, 12:16 PM
Hello
i ve got some problems with my xorg.conf
my screen rotate but not the cursor
this is my xorg.conf
i am on linux mint darina (gusti)
thanks a lot for help

xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "oss"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Button2" "3"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
Option "Mode" "Absolute"
Option "KeepShape" "on"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Button2" "3"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
Option "Mode" "Absolute"
Option "KeepShape" "on"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Button2" "3"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
Option "Mode" "Absolute"
Option "KeepShape" "on"
EndSection

Section "Device"
Identifier "nVidia Corporation NV17 [GeForce4 420 Go 32M]"
Boardname "nv"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 0
Option "RandRRotation" "on"
Option "NvAGP" "1"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Modelname "Custom 1"
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV17 [GeForce4 420 Go 32M]"
Monitor "Generic Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1024 768
Modes "1024x768@60" "800x600@60" "800x600@56" "640x480@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"

# Uncomment if you have a wacom tablet
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
Inputdevice "Synaptics Touchpad"
EndSection
Section "Module"
Load "wacom"
Load "glx"
Load "v4l"
EndSection
Section "device" #
Identifier "device1"
Boardname "nv"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 1
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
EndSection
Section "monitor" #
Identifier "monitor1"
Gamma 1.0
EndSection
Section "ServerFlags"
EndSection

phenest
December 29th, 2007, 09:25 PM
It has nothing to do with the xorg.conf file. When you rotate the screen, it only rotates the video and not the wacom device. You need a script like the one I provided in the 'How To'.

mgk
December 30th, 2007, 11:55 AM
hello
thanks for help
I use your script and i map the "Q"
when i press "Q" the screen don't rotate
i use Grandr 0.2 to turn left the screen rotate but not the cursor, if i use "Q" the screen come back right
from landscape to portrait don't work for me????

I use the script on first page, do i use the script on page 2?

phenest
December 30th, 2007, 12:28 PM
Have you installed wacom-tools?


sudo apt-get install wacom-tools

mgk
December 30th, 2007, 12:37 PM
yes wacom tools are install
i ve got : wacom kernel source, wacom tools and xserver xorg input wacom
thanks

mgk
December 30th, 2007, 05:42 PM
All works fine
i am sorry i haven't use the good script
thanks again for help
happy new year for all
Marc

galileon
January 26th, 2008, 09:42 PM
Hi, thanks for the nice tutorial!

Has anyone got Nvidia Propritary driver AND suspend and/or hibernate to work at the same time? I can do each separately, but not both.

I installed the NVIDIA driver through Restricted Manager and added the option mentionned in the tutorial. The computer hibernates or suspends, but on wake up, the screen remains blank.

Any ideas?

Cheers

galileon

Markopolo123
February 4th, 2008, 04:24 PM
Heya guys, after seeing this guide I decided to take the plunge and install ubuntu 7.10 on my tc1100.

Installation went fine, and it connects to my wifi network. I can ping websites from the terminal, but wget doesn't do anything. At first firefox wouldn't load up any pages, but after much talking with a friend we got firefox to come alive, I had to go into the about:config and change

"network.dns.disableIPv6"

to true.

Rather annoyingly, apt-get doesn't work and neither does synaptic, whatever it tries to download fails.
Other computers on the network (windows &mac) can access the net fine, and the DNS is the same on both the tc1100 and this machine.
I have no idea whats wrong (I am a linux n00b).

Any ideas or help would be appreciated
Thanks
Mark.

galileon
February 4th, 2008, 06:57 PM
http://www.ubuntugeek.com/how-to-disable-ipv6-in-ubuntu.html

Markopolo123
February 4th, 2008, 08:25 PM
http://www.ubuntugeek.com/how-to-disable-ipv6-in-ubuntu.html

Many thanks, just before reading your reply I had tried this guide from

http://ubuntuforums.org/showthread.php?t=161742

which didn't help. I gather the two methods achieve the same end?

I will reset the file and try the method you linked to.

Neither method has resolved this, I am quite tempted to reinstall the OS.

Mark

Markopolo123
February 11th, 2008, 03:56 PM
I have managed to resolve the problem with apt-get ="http://ubuntuforums.org/showthread.php?t=206692&page=3"
Other than that I am very happy with it, thanks for the guide!
Mark
:popcorn:

phenest
March 14th, 2008, 10:27 PM
Has anyone tried the latest Hardy on this tablet to see if the memory card reader works. Apparently, there has been some fixes in this area.

If your able to reply, there is a bug report: 163345 (https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/163345)

An answer is needed for this bug as to whether the memory card reader now works.

popch
March 15th, 2008, 06:20 PM
Has anyone tried the latest Hardy on this tablet to see if the memory card reader works. Apparently, there has been some fixes in this area.

If your able to reply, there is a bug report: 163345 (https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/163345)

An answer is needed for this bug as to whether the memory card reader now works.

I did a few perfunctory tests with Hardy Heron Alpha 6 (downloaded March 15, 2008 ) on my TC1100. There have been no changes with regards to the SD card reader. No card will be detected. The same card is detected, read and written when used in the other HP laptop both with Gibbon and Heron.

On the other hand, on the TC1100 not even Windows XP handles the card. It detects it and assigns it a drive letter (E: ). However, it can not read the card, offers to format it, fails to format if asked to. This is the XP wich was installed when I bought the PC. It is conceivable that the XP installation is somewhat flawed because the PC appeared to be refurbished when I bought it.

The SD slot does not appear to work on this PC. Period. I bought a 5$ SD to USB adapter which works at once without thinking about it.

phenest
March 15th, 2008, 06:59 PM
Personally, my TC1100 worked fine with XP Tablet Edition including the card reader. But using Ubuntu Gutsy, I had to resort to a PCMCIA card reader which did the job.

I hope someone can give a Yes/No to the bug report so the devs can mark it as Fixed or whatever.

kpfade
March 22nd, 2008, 05:05 PM
use this for rotate and use pen:
Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/ttyS4"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"
Option "Mode" "Absolute"
Option "Button2" "3"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/ttyS4"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"
Option "Mode" "Absolute"
Option "Button2" "3"
EndSection

And add the following lines to the Server Layout section.

InputDevice "cursor" "SendCoreEvents"
InputDevice "stylus" "SendCoreEvents"

wsilk
April 20th, 2008, 12:04 AM
I'd just like to say thanks for the great writeup. I'm new to linux and managed to get Ubuntu 7.10 up and running on my tc1100 with all the features I need with relative ease. I even managed to do it off a usb flash drive. So far, I've seen a large increase in performance over XP tablet edition.

The last tasks are to get the side button working for the OSK (using onboard) and figure out the "keyring" password prompt on boot.

sethtriggs
May 14th, 2008, 05:21 PM
For some reason I can't get my pen to work correctly - this is a mothballed Tablet PC for work, and I'm trying to get the pen to work~! I'd hate to have to carry a keyboard everywhere with me!

I am hoping for the best here, heh heh...if any of you can tell me what could cause the attached stylus pen to do absolutely nothing in Ubuntu (yet the original pen calibration works just after POST), I'd be most grateful!

Thanks,


Seth

On edit: A restart fixed it after I changed the device to /dev/input/wacom and then restarted. It works beautifully! Just have to get the onboard keyboard to move out of my way, hehehe...

galileon
May 14th, 2008, 08:58 PM
i get the feeling wacom users are being persecuted. Once upon a time, the required lines to make wacom work were there by default in xorg.conf.

this seemed to break something on some systems, so the devs, in their infinite wisdom, decided to comment the required lines out.

that was not enough. so they removed the lines completely.

without ANY mention of the deliberate regression in the release notes!

Thankfully, you can still copy-n-paste them into your zorg.conf if have an old copy lying around...

so here goes:

$sudo nano /etc/X11/xorg.conf

add the following somwehere after your "mouse" bits:

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection



and also add the necessary lines in your server layout:

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
EndSection


hopefully this should help, it did in Gutsy. I havent tried Hardy yet, so they may have done something that would stop even that from working, I can't tell yet.


For some reason I can't get my pen to work correctly - this is a mothballed Tablet PC for work, and I'm trying to get the pen to work~! I'd hate to have to carry a keyboard everywhere with me!

I am hoping for the best here, heh heh...if any of you can tell me what could cause the attached stylus pen to do absolutely nothing in Ubuntu (yet the original pen calibration works just after POST), I'd be most grateful!

Thanks,


Seth

On edit: A restart fixed it after I changed the device to /dev/input/wacom and then restarted. It works beautifully! Just have to get the onboard keyboard to move out of my way, hehehe...

phenest
May 18th, 2008, 09:06 AM
...
Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection
...

I would like to point out here, that there is no need to a add the 'eraser' and the 'cursor' devices. You only need the 'stylus' device. Seeing as the TC1100's stylus' has no eraser (although there may be a rare one around), and I think the 'cursor' device is for external tablets (the type you may attach to the serial or USB port).

romana
May 29th, 2008, 07:56 AM
Hardy has stylus working - Cellwriter and Xournal rock.

Tabatha, as suggested for mapping Q menu functionality, has errors and falls over, but am hoping a Q menu gets posted soon:)

Rotate script is fine,but having trouble mapping it to a key in KDE4. Suggestions?
I have tried in SystemSettings->Advanced->InputActions
But no matter what combo, nada. Zip.

ChaOConnor
June 6th, 2008, 09:23 PM
I'm trying to install Hardy, but I can't because the linux-image-2.6.25-1-generic is gone. any suggestions? I can get Hardy installed, but no wacom, hence what the linux-image-2.6.25-1-generic was for. Appreciate any thoughts you have!

Aearenda
June 7th, 2008, 12:55 AM
2.6.25 is the Intrepid Ibex kernel! I have had wacom working on all the Hardy kernels in the 2.6.24 series, the latest being -18.

romana
June 20th, 2008, 04:55 AM
Having got it all pulled together on Kubuntu Hardy running KDE4, I decided to howto MY setup, given all I learnt here and in other places. Naturally, duly credited:)

Could not have done it without all the info in this forum, thanks guys:)

Kubuntu TC1100 Tablet Functions Howto (http://timelady.com/blog/howtos-technical-guidestips/kubuntu-804-hp-tc1100-tablet-functions-howto/)

jdn-za
July 4th, 2008, 11:01 PM
Ola,

I managed to get kubuntu 8.04 working well enough on my tc1100 with this guide, thanks for that :D

though managed to mangle it badly when forcing a change from kde to gnome and then back with various changes to nvidia drivers etc =\

going to be doing a clean install of ubuntu tomorrow.

One iss I havent managed to get past so far is after installing the nvidia drivers, via envyng or via the nvidia run file (legacy or new) my glxgears runs very slowly (500 fps+-) this is after having corrected the xorg.conf...

Is there any thing obvious I am missing? I noticed that load/cpu is high due to the glx thread.

Wont bother posting my xorg.conf until i have installed the clean ubuntu, nvidia drivers with enyng and compiz as per the guide above.


thanks again for the kewl guide :D

Aearenda
July 5th, 2008, 02:05 AM
I think turning off 'sync to vblank' might fix this - in nvidia-settings, OpenGL settings (NOT the Xserver Xvideo settings). I get 1000+ fps with it off and <100fps with it on, but I'm using an external display atm so it might differ internally.

jdn-za
July 5th, 2008, 10:43 AM
thanks will try that, just installed ubuntu and envyng is finishing up. default display drivers I get 200 - 300 fps

jdn-za
July 5th, 2008, 11:03 AM
k after having installed the nvidia driver via envyng and having disabled the "sync to vblank" option I am getting 850 odd fps +- =\ should still be higher than that though?

currently am on a default ubuntu 8.04 install with nvidia driver ver: 96.43.05

xorg.conf below:



# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Option "AddARGBGLXVisuals" "True"
Option "UseDisplayDevice" "DFP"
Defaultdepth 24
EndSection

Section "Module"
Load "glx"
Load "v4l"
EndSection


Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Screen 0
Option "NvAGP" "1"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Inputdevice "Synaptics Touchpad"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

b

Aearenda
July 5th, 2008, 11:56 AM
Do you have a Celeron processor or a Pentium M? Some TC1100s have Celerons. Mine is a 1Ghz Pentium M.

For comparison, the TC1100-relevant bits of xorg.conf on mine are:

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "Button2" "3" # This is the line you need for the stylus button to right click
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
Option "RandRRotation" "on"
Option "NvAGP" "1"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
InputDevice "stylus" "SendCoreEvents"
Inputdevice "Synaptics Touchpad"
EndSection
Section "Module"
Load "glx"
EndSection

This includes the settings to get the pen working. I'm not saying this is perfect - just that it works for me.

BTW, I don't think you need the touchpad entry, even though it's there in mine too.

jdn-za
July 5th, 2008, 12:26 PM
The xorg.conf below is working fiarly well right now, have compiz effects on (still need to tweak them)

What I was thinking of doing is once I have the full setup sorted out maybe I should make a live CD to help other folks in setting up a TC1100, any one interested in helping out with this?


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Option "AddARGBGLXVisuals" "True"
Option "UseDisplayDevice" "DFP"
Defaultdepth 24
EndSection

Section "Module"
Load "glx"
Load "v4l"
EndSection


Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
BoardName "vesa"
BusID "PCI:1:0:0"
Screen 0
Option "RandRRotation" "on"
Option "NvAGP" "1"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "Button2" "3"
Option "ForceDevice" "ISDV4"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Default Screen" 0 0
InputDevice "Generic Keyboard" "CoreKeyboard"
InputDevice "Configured Mouse" "CorePointer"
InputDevice "Synaptics Touchpad"
InputDevice "stylus" "SendCoreEvents"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
VendorName "Generic LCD Display"
ModelName "LCD Panel 1024x768"
HorizSync 31.5 - 48.0
VertRefresh 56.0 - 65.0
Gamma 1
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
ModeLine "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
ModeLine "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
ModeLine "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

jdn-za
July 5th, 2008, 01:01 PM
kewl have got compiz with all the nice effects working perfectly now :D

Aearenda
July 5th, 2008, 11:56 PM
That's great - I find that Compiz tends to give black windows after a while - esepcially with Firefox. There just isn't enough video RAM in the TC1100.

Enabling compositing in Metacity will be more suitable for the TC1100 once it works reliably - I keep getting brightness problems after screen savers kick in, and display corruption during animations, when I turn this on.

romana
August 11th, 2008, 05:38 AM
Now runing Interpid Ibex Alpha 3 - and of course, much is broken. Not as much as you think:)

Rotate not working, nor is button mapping. So, xrandr/xbindkeys are an issue.

Stylus and related applications just fine.

Will post/update my howto when solutions worked out, which may NOT be until at least beta/prerelease stage:)

phenest
August 11th, 2008, 05:48 PM
As I've mentioned before, I don't have my TC1100 any more. But I am interested if anyone knows a solution to this problem:

The stylus only allows left or right click. How does one achieve a middle click?

okrichie
August 16th, 2008, 01:34 PM
K am starting to get really upset about this.. I've installed Ubuntu on my tc1100, it worked fine apart from the usual; stylus, extra buttons etc..

I started messing with this tutorial and a couple of others such as for the 'soft buttons' and the hardware buttons like Q.

This is the second time now, after hours of compiling stupid wacom drivers and messing in the xorg.conf, I have reached the same problem I got after a few hours of messing the first time; and I was honestly, really careful this time.

What's going on? Well the stylus still doesn't work. Now the graphics are set to only 800x600max and I can't change it. I tried restoring an original xorg.conf backup; it did NOT help at all..

Why is this such a demanding problem? Why are all the solutions to these issues so cryptic? Why do these solutions not seem to work and at the same time cause MORE trouble?

Has anyone encountered this? I'm obviously being a complete moron and doing it wrong. So take pity and help please?

I got the stylus to work once, using an xorg.conf file I downloaded that someone else made (I think for a slightly different distro of linux), but that seemed to cause the same graphics problem; so I formatted and tried over, being more careful to self-build my own xorg.conf rather than slap my name on someone else's but it hasn't worked!

olaoni
August 21st, 2008, 02:26 AM
I have managed to get the pen stylus to work using the following url as reference http://ubuntuforums.org/showthread.php?p=3672701#post3672701 both as a mouse and for invoking the three soft buttons to the left hand side of the screen.
Starting from the top the buttons are mapped as "rotate screen" "xournal" and "cellwriter".

The problem I have is that when the screen is rotated the stylus pointer is all over the place when I move the pen to the screen.

I am currently using an xorg.conf file which I picked up from one of these forums on the subject. I have attached it below just in case any of you smart guys may see something wrong that I am doing many thanks in advance.

olaoni
August 21st, 2008, 02:37 AM
I don't know what happened in my last post I attached my xorg.conf file but it has not shown up so I am doing a cut and paste job here.

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Option "AddARGBGLXVisuals" "True"
Option "UseDisplayDevice" "DFP"
Defaultdepth 24
EndSection

Section "Module"
Load "glx"
Load "v4l"
EndSection


Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
BoardName "vesa"
BusID "PCI:1:0:0"
Screen 0
Option "RandRRotation" "on"
Option "NvAGP" "1"
Option "NoLogo" "True"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "Button2" "3"
Option "ForceDevice" "ISDV4"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Default Screen" 0 0
InputDevice "Generic Keyboard" "CoreKeyboard"
InputDevice "Configured Mouse" "CorePointer"
InputDevice "Synaptics Touchpad"
InputDevice "stylus" "SendCoreEvents"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
VendorName "Generic LCD Display"
ModelName "LCD Panel 1024x768"
HorizSync 31.5 - 48.0
VertRefresh 56.0 - 65.0
Gamma 1
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
ModeLine "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
ModeLine "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
ModeLine "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

phenest
August 21st, 2008, 06:49 PM
Are you using the rotation script in post #1? If not, then that's your problem. If so, check you have the necessary packages installed:


sudo apt-get install wacom-tools

olaoni
August 21st, 2008, 07:08 PM
Thanks for your response phenest In answer to my stylus problems

Are you using the rotation script in post #1
the script in post #1 did not seem to work for me, I however found one that on as shown below



!/bin/sh
if [ -n "$(xrandr | grep 768x1024)" ]; then
xrandr -o normal
xsetwacom set "stylus" Rotate NONE
else
xrandr -o left
xsetwacom set "stylus" Rotate CW
fi


I can either use F1 to rotate the screen or use the pen stylus.

check you have the necessary packages installed:
Yes I have the wacom tools installed

olaoni
August 21st, 2008, 07:12 PM
A minor typo error the line in the else block is meant to read


xsetwacom set stylus Rotate CCW

phenest
August 21st, 2008, 07:42 PM
That script is in post #1 too.

Does that mean it works now?

olaoni
August 21st, 2008, 09:08 PM
Sorry for the late response, I was away from my pc.

No still not working.
I can confirm that the script works by running the commands in shell and in addition to this. When I click the rotate pen button or when I press F1 on my laptop.

The problem is when the screen is rotated I can't use the stylus to point to anything on the screen. Every time I try to point to icon or something on the screen the cursor moves far away from the tip of the stylus.

Just for the record I am using ubuntu Hardy and linuxwacom-0.8.1-3.

phenest
August 22nd, 2008, 06:46 PM
The problem is when the screen is rotated I can't use the stylus to point to anything on the screen. Every time I try to point to icon or something on the screen the cursor moves far away from the tip of the stylus.

What does "...moves far away..." mean? Does the cursor move to a screen edge? Or moves as if the wacom has not rotated? Does it move correctly, but just not in the right place?

Could you please try and describe the cursors action in as much detail as possible, please?

olaoni
August 22nd, 2008, 09:23 PM
When the laptop is in the normal position if I place the tip of the sytlus to the screen the cursor follows the direction of the pen.

When I rotate the screen and holding the pc as a slate if I point the sytlus to the top middle of the screen the cursor appear to the left middle of the screen and if I run the pen from top to bottom the cusor goes from left to right.

Likewise if I run the pen from right to left of the screen the cusor goes from bottom to top of the screen.

Regards
Ola oni

olaoni
August 22nd, 2008, 09:26 PM
When the laptop is in the normal position if I place the tip of the sytlus to the screen the cursor follows the direction of the pen from top to bottom and left to right etc.

When I rotate the screen and holding the pc as a slate if I point the sytlus to the top middle of the screen the cursor appear to the left middle of the screen and if I run the pen from top to bottom the cursor goes from left to right.

Likewise if I run the pen from right to left of the screen the cusor goes from bottom to top of the screen.

Regards
Ola oni

phenest
August 23rd, 2008, 04:34 PM
Then the wacom has not rotated. What happens if you type:

xsetwacom set stylus Rotate CCW
from a terminal? Any error messages? If not, test the pen again. Any difference?

Report back with the results.

olaoni
August 23rd, 2008, 06:33 PM
Then the wacom has not rotated. What happens if you type:

xsetwacom set stylus Rotate CCW
from a terminal? Any error messages? If not, test the pen again. Any difference?

Report back with the results.
Running the above code through the terminal window did not make any difference. I can confirm that the pen works because it works under windows.

May I ask what version of wacom project and ubuntu are you using on your tablet?

phenest
August 23rd, 2008, 08:52 PM
May I ask what version of wacom project and ubuntu are you using on your tablet?

I'm not. I sold my tablet a while ago, but someone here has reported the tablet works fine with Hardy and the rotate script works. I'm at a loss as to why yours does not.

olaoni
August 23rd, 2008, 09:06 PM
The problem seems to be that the following line of code


xsetwacom set stylus Rotate CCW

I don't think it is working correctly, do you know of any other command that can set the stylus pen.

Aearenda
August 23rd, 2008, 11:51 PM
Here is the script I use to toggle my TC1100 screen rotation on Ubuntu Hardy, both screen and tablet. I have it set to trigger when I click on a panel launcher.


#!/bin/sh
# Based on work from Patrick Coke & Tim Pope
# Modified for TC1100 by Francisco Athens
# Rewritten for current xsetwacom and xrandr vesrions by Krzysztof Kosiński
# Adapted for me to work as a toggle - SCJ 1/3/08

# Rotate all detected wacom devices to the given direction,
# and the screen!

ROTATION=`xrandr --verbose --query | \
grep 'default connected' | \
sed -e 's/^.*(.*) \(.*\) (.*).*$/\1/'`

case $ROTATION in
normal) xsetwacom set stylus rotate ccw
xrandr -o left ;;
left) xsetwacom set stylus rotate none
xrandr -o normal ;;
esac


I use the stock wacom-tools 1.0.7.9.8-0ubuntu3 installed from the standard repositories. I don't have anything called linuxwacom installed. My /etc/X11/xorg.conf contains the following, in addition to the entries required for the keyboard, screen and mouse :


Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "Button2" "3" # This is the line you need for the stylus button to right click
EndSection

Section "ServerLayout"
<other stuff goes here too - just add the following "stylus" line,
the Section/EndSection lines are shown here so you know where it belongs>
InputDevice "stylus" "SendCoreEvents"
EndSection

olaoni
August 24th, 2008, 01:00 AM
Hi Aearenda I just tried the script you proivded and things are still the same. I don't know if it is possible for you to try the copy of xorg.conf I posted in post #71 on you tc1100.
I was just wondering if the ordering of the entries in the xorg file play any role to this behaviour.
I am very new to linux so can you elaborate a bit more on the statement stock wacom-tools 1.0.7.9.8-0ubuntu3 installed from the standard repositories

I built the wacom_drv.so I am using from the wacom project website and it is labeled
linuxwacom-0.8.1-3

phenest
August 24th, 2008, 08:52 AM
Hi Aearenda I just tried the script you proivded and things are still the same. I don't know if it is possible for you to try the copy of xorg.conf I posted in post #71 on you tc1100.
I was just wondering if the ordering of the entries in the xorg file play any role to this behaviour.
I am very new to linux so can you elaborate a bit more on the statement stock wacom-tools 1.0.7.9.8-0ubuntu3 installed from the standard repositories

I built the wacom_drv.so I am using from the wacom project website and it is labeled
linuxwacom-0.8.1-3

The xorg.conf has nothing to do with rotation except to tell the X server to use the stylus. But seeing as you've mentioned that you're using a custom built driver, then that is your problem. This How To was not designed to be used with custom drivers. If you're using a driver obtained from the Wacom Project, then you need to discuss it with them, as it is outside the scope of this tutorial.

For someone who is new to Linux, I'm amazed you managed to custom build a Wacom driver, but you can't follow this How To.

If I were you, I would re-install Hardy fresh, and read post #1 again taking note of sections for Gutsy. It does work provided you don't try and add stuff that isn't there.

Aearenda
August 25th, 2008, 04:26 AM
Olaoni, I agree with Phenest, your problem is most likely to do with the custom drivers you have installed. That's what I meant in my post - I haven't taken anything from Wacom's site, all I did was

sudo apt-get install wacom-tools and this installed the required drivers for me with no further fuss.

EDIT: By 'no further fuss' I meant no need to compile anything - I stll had to modify xorg.conf as described earlier.

olaoni
August 25th, 2008, 09:44 PM
Thanks for your support phenest and Aearenda. I will re-install ubuntu at the earliest opportunity I get and let you know how it went.

Just for the record when I installed wacom-tools I used is the above command. The reason for the custom build was to get get the pen buttons to work.

The tutorial I followed was from:-http://ubuntuforums.org/showthread.php?p=3672701#post3672701
And like I mentioned in my first mail I got the pen buttons working satisfactorily.

Moreover the tutorial used linuxwacom-0.7.8-3.tar.bz2. Which when I built did not work under ubuntu Hardy. So I had to build with linuxwacom-0.8.1-3.tar.bz2 which does work (Pen button functionality at least).

Aearenda
August 26th, 2008, 03:14 AM
Good luck! Just for the record, I have never bothered with trying to get the extra buttons to work as described in that thread.

phenest
August 26th, 2008, 08:18 AM
olaoni: The thread you refer to is something I and another member were working on, and indeed, did get it working. We did both submit our findings to the Wacom Project, but heard nothing back. Of course, our fix was only a workaround and not a true fix. If I still had the tablet, I would have worked on it further. It's a shame those buttons still don't work 'out of the box'.

WebBuddha
September 12th, 2008, 04:30 PM
Hello,

I've tried it also with
sudo apt-get install wacom-tools but it was'nt workling for me.
Did I have to run the How-To also? I thought that it should work with the wacom-tools only?

Regards
WebBuddha

phenest
September 12th, 2008, 05:06 PM
Hello,

I've tried it also with but it was'nt workling for me.
Did I have to run the How-To also? I thought that it should work with the wacom-tools only?

Regards
WebBuddha

If you read the 'How To', you will see you need to amend the xorg.conf file.

trksh22
September 23rd, 2008, 01:34 AM
Can someone help me? None of the changes are remaining in terminal. I cannot get the pen to work at all.

phenest
September 23rd, 2008, 01:35 PM
...None of the changes are remaining in terminal...

Not sure what you mean by that. But if you follow the guide exactly as shown in the first post of this 'How To', it will work. Please persevere as the majority of people having problems have simply missed a step.

trksh22
September 23rd, 2008, 01:56 PM
Thanks for replying. That's the thing, I don't know what I am doing wrong. I open up terminal, type in the nec things, close out. No changes saved. I reopened terminal, retyped everything, waited for it to "automatically save" closed out, then nothing. I tried looking at other tuts but nothing says what I should do after I am done editing something in terminal. There is no way to save my changes.

After that the nest step is to type in some code and save it as (I forget what) but where would I do that?

Thanks in advance. I am a total newbie. I am reading, I promise I am.... just not getting anywhere. I just need it "dumbed down" LOL.

Thanks in advance...

phenest
September 23rd, 2008, 09:44 PM
Ok. I think I know what you're getting at. Are you trying to edit files in a terminal? If you're using nano, Ctrl-X will prompt you to save. Press 'Y' and 'Enter', and it will be saved. If that confuses you, then use gedit, e.g.:

gksudo gedit /etc/X11/xorg.conf
Remember to use gxsudo for graphical apps and sudo for terminal apps.

Aearenda
September 24th, 2008, 12:45 AM
Phenest means 'use gksudo for graphical apps', gxsudo is a typo. Gksudo is a way of gaining admin privilege while running a graphical application. Sudo is a way of gaining admin privilege when running a command-line application.

trksh22
September 24th, 2008, 12:53 AM
Yes! That is what I need. I promise I did read, tutorials and manuals but nothing I read (yet) had explained that. If you know of a basic tut that expounds upon what you just said then I would be happy to look at it (but no pressure, I am happy enough just knowing this!)


Remember to use gxsudo for graphical apps and sudo for terminal apps.

Yet another silly question, what would be considered a "graphical app"? Thanks!!

trksh22
September 24th, 2008, 01:19 AM
.....

trksh22
September 24th, 2008, 03:44 AM
The same thing has happened to me! It's so hard to get any consistant help. I am about ready to give up. I don't want to, but it looks like I don't have a choice now! I can't get the screen to change back, no matter what I do. I couldn't (and still can't) get the pen to work. This is depressing. I am at a lost. Help is very hard to come by, even on this site... I guess Ubuntu isn't for everyone...... :(



K am starting to get really upset about this.. I've installed Ubuntu on my tc1100, it worked fine apart from the usual; stylus, extra buttons etc..

I started messing with this tutorial and a couple of others such as for the 'soft buttons' and the hardware buttons like Q.

This is the second time now, after hours of compiling stupid wacom drivers and messing in the xorg.conf, I have reached the same problem I got after a few hours of messing the first time; and I was honestly, really careful this time.

What's going on? Well the stylus still doesn't work. Now the graphics are set to only 800x600max and I can't change it. I tried restoring an original xorg.conf backup; it did NOT help at all..

Why is this such a demanding problem? Why are all the solutions to these issues so cryptic? Why do these solutions not seem to work and at the same time cause MORE trouble?

Has anyone encountered this? I'm obviously being a complete moron and doing it wrong. So take pity and help please?

I got the stylus to work once, using an xorg.conf file I downloaded that someone else made (I think for a slightly different distro of linux), but that seemed to cause the same graphics problem; so I formatted and tried over, being more careful to self-build my own xorg.conf rather than slap my name on someone else's but it hasn't worked!

Aearenda
September 24th, 2008, 08:06 AM
A graphical application is something that creates its own window on the desktop, and can lay out that window with buttons and pictures and other stuff anywhere it likes - a classic "Windows Program" - in contrast to applications which run in a terminal (or 'command-line') session, which are constrained only to use letters, not pictures - as if they were still running on an old-fashioned teletype terminal, or on MS-DOS before the days of Windows.

Gedit is a graphical text editor. You start it by using the mouse to find 'Text Editor' in the Accessories menu. Then you have to click on 'File->Open' and select a file to get started.

Nano is a command-line text editor that runs in a terminal session. You start it by typing 'nano <filename>' in a command line session, which might have been started by using the mouse to fine 'Terminal' in the Accessories menu, for example. Nano runs inside the Terminal window. You can also use it from a text logon session, if the windowing system fails to start.

Giving instructions using terminal commands is usually much more succinct and exact than telling people to click on menus and buttons, which is why they come up so often in the forums.

Consistent help is hard to find simply because everyone is a volunteer here, and everyone has different experiences. We can only advise based on what we have encountered ourselves. Sometimes it takes a while to get an answer because we have to go out and earn money, or because we live in different time zones. Whether you find this good or bad depends on the level of your expectations. I recommend this as a way to get the best responses: http://www.psychocats.net/ubuntucat/getting-the-best-help-on-linux-forums/
Also see: http://ubuntuforums.org/showthread.php?t=232059

Here's some help on using the terminal: http://www.psychocats.net/ubuntu/terminal

And here's some more general help on Ubuntu:
http://book.opensourceproject.org.cn/distrib/ubuntu/official/ especially Chapter 4 on the Terminal.


Having said all that, it is true that Ubuntu isn't for everyone. Being an Ubuntu user can be downright frustrating at times. I have used it for about 3 years now, yet last week I contemplated switching back to Windows XP - because I can't get my scanner to work on Ubuntu. But then I plugged my XP drive back into my TC1100, and started it up, and it reminded me of all the things I was trying to escape - and I fell in love with Ubuntu all over again. It's never going to be a completely smooth ride, simply because the hardware manufacturers don't all want to play. But then, neither is Vista, or XP, or OS/X.

Anyway, I hope this helps you to make up your mind to be persistent! People WILL help, given time, if you are clear about what you need, what has happened, follow instructions carefully, and stay patient.

trksh22 said:
I can't get the screen to change back, no matter what I do. I couldn't (and still can't) get the pen to work.

I'd like to help you, but I don't know what you mean by "I can't get the screen to change back". What has it changed to?

Also, you say you can't get the pen to work - can you summarise what you have done to try to make it work?

trksh22
September 24th, 2008, 01:22 PM
Thanks, I wrote my last email out of desperate frustration, lol. Thank you for taking the time to explain things and even provide other links. This is all so new, I knew that there was a learning curve, but I have become so accustomed to windows that I am only slightly overwhelmed by all that I need to know. But, I have to start somewhere, huh? ;)

As for the screen, I was able to just reinstall Ubuntu and now it works.

trksh22
September 24th, 2008, 01:25 PM
fixed with reinstall. Please ignore, I don't think I have the privileges yet to delete my own post.

trksh22
September 24th, 2008, 07:29 PM
Can anyone comfirm that Ubuntu tablet functions (use of the pen) will work with a replacement/non stock pen. Maybe that is why it won't work for me? This is the pen that I have (which worked fine in Xp):

Pen with Eraser (http://direct.wacom.com/stores/5/Penabled_Tablet_PC_Eraser_Pen_P1047C72.cfm)

Aearenda
September 25th, 2008, 12:46 AM
I'm glad to hear you are making progress! That's good news.

I'm using the standard pen that came with the TC1100. I see no reason why your pen should not work, but since it has an eraser you will need extra stuff in your /etc/X11/xorg.conf. I suggest you do this:

1. Press ALT and F2 (this brings up the 'run' box, like Windows and R or Start->Run on XP).

2. Start the text editor and open the appropriate configuration file by pasting the text in this box:
gksudo gedit /etc/X11/xorg.confand then press <enter>. Fill in your password if you are asked for it.

3. In the text editor, do File->Save As and make a copy of the file somewhere where you can find it in an emergency!

4. Now close the Text Editor, and then re-open the original file exactly as in step 2.

5. Add the following to the file by copy and paste - in mine, it comes straight after the keyboard and mouse sections. It must follow an 'EndSection' line, unless it is at the very start of the file.


Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "Button2" "3" # This is the line you need for the stylus button to right click
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "Button2" "3"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "Button2" "3"
EndSection


I'm not sure you need the third section here (the 'cursor' one), but it won't hurt. I used to run my TC1100 with all three sections enabled until somebody pointed out that the TC1100 pen doesn't have an eraser. You may already have the first section ('stylus') - if so, don't duplicate it.

6. Still in the text editor, make sure the section that links all the devices together looks something like this:
Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection
It's the three 'InputDevice' lines that matter here - just add them if they are not there - don't change anything else!

7. Now save the file and close the text editor.

8. Start the package manager from the menu using System->Administration->Synaptics Package Manager.

9. In the list of packages, find 'wacom-tools'. You can do this by clicking once in the package list area, then typing 'wacom' - without the quotes - which make Synaptic do a stem match on the name. Click in the package list area again to dismiss the little stem-match box.

10. If the square box next to the wacom-tools package is empty, right-click on that line and choose 'install', accept any dependencies it might need, then click on 'Apply' in the tool bar, then click on 'Apply' in the confirmation box; wait for the installation to complete.

11. Close Synaptic Package Manager.
[Aside: steps 8 to 11 could have been done in a command-line terminal simply by pasting in the following command: 'sudo apt-get install wacom-tools' and then pressing Y to confirm - much easier!!]

12. Now log out, and when the login screen appears, press <CTRL> and <ALT> and <BACKSPACE>. This causes X-Windows to restart. X-Windows is the graphical subsystem we use on most Linux systems - without it, all we have are character-mode sessions. Doing this makes the changes we just made take effect, without doing a complete restart.

13. Log in again, and see if the stylus and eraser work, using gimp or another stylus-aware app. The stylus should work anywhere - the eraser may only work where it makes sense. If they work, you're done; otherwise, continue.

14. Diagnostic only: start a command-line session from Accessories->Terminal and type:

xsetwacom list devThe output from this should be something like

stylus stylus
eraser eraser

15. Recovery: If after step 12 all you get is a black text-mode screen, rather than the normal Ubuntu graphical login screen, you will need to log in in text mode with your normal username and password.
15.1 If you see no writing on the black screen at all, try pressing <CTRL> and <ALT> and <F1> - this should switch to the first text-mode console, and you should be able to log on there.
15.2 Type

sudo cp <the-name-of-the-copy-you-made-in-step-3> /etc/X11/xorg.conf<ENTER>
15.3 Type
reboot<ENTER>

Please let us know how you get on! Good luck!

trksh22
September 25th, 2008, 03:10 PM
Aearenda, firstly, thanks for breaking everything down for me. I needed it to be dumbed down :)

I did follow your directions exactly and got the same results as before. When I did Step 12 thing, I got the same error message as before "Ubuntu is running in low graphics mode. Your screen and graphics card could not be detected. ... you need have to configure the display yourself."


After I logged in, I ran the "Xsetwacom" thing and it did not return anything, just repeated the input line (name@blank etc)

I feel like I am so close :)


ETA: (I have since restored my back up file so my graphics card and everything is recognized and back to the default settings.)

Aearenda
September 25th, 2008, 11:54 PM
Interesting - I guess the next step is for you to post the /etc/X11/xorg.conf file that you had as a result of step 7. Mine is below for comparison. Note that the cursor and eraser are commented out in mine, since I have a stock pen.

I wouldn't expect xsetwacom to return anything without the changes in that file being present.

Hmmm, I wonder - do you have the Nvidia driver installed (I do)?



# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "vmmouse"
EndSection

#Section "InputDevice"
# Identifier "Synaptics Touchpad"
# Driver "synaptics"
# Option "SendCoreEvents" "true"
# Option "Device" "/dev/psaux"
# Option "Protocol" "auto-dev"
# Option "HorizEdgeScroll" "0"
#EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "Button2" "3" # This is the line you need for the stylus button to right click
EndSection

#Section "InputDevice"
# Driver "wacom"
# Identifier "eraser"
# Option "Device" "/dev/input/wacom" # Change to
# /dev/input/event
# for USB
# Option "Type" "eraser"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
# Option "Button2" "3"
#EndSection

#Section "InputDevice"
# Driver "wacom"
# Identifier "cursor"
# Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
# Option "Type" "cursor"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
# Option "Button2" "3"
#EndSection


Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
# Option "ConnectedMonitor" "DFP"
Option "RandRRotation" "on"
Option "NvAGP" "1"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
# Inputdevice "Synaptics Touchpad"
EndSection
Section "Module"
Load "glx"
EndSection

trksh22
September 26th, 2008, 12:14 AM
Ok, I will redo everything and post what I get. I really did learn a lot from your tutorial so if this doesn't work out I didn't walk away empty handed. (I also have Ubuntu stored on my desktop.) I will post the results as soon as I finish....

trksh22
September 26th, 2008, 06:47 PM
6. Still in the text editor, make sure the section that links all the devices together looks something like this:
Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection
It's the three 'InputDevice' lines that matter here - just add them if they are not there - don't change anything else!


Ok, wow. I got it to work. THANK YOU :) I know what I did wrong, too. You see what you put in bold up there, the "don't change anything else" part?

That's what I didn't do!

I thought I was following the directions line by line but I wasn't! In the part of code you mentioned earlier, I had an extra line "InputDevice "touchpad" "Synaptics touchpad" (or something like that). I was removing that line, and then putting in the the three so that it looked like the one above. I think my reasoning was that it wasn't a regular laptop so it didn't have a touchpad so it was ok to remove it. Last night I took a break and decided to try again in the morning. It's weird because you made it clear several times throughout this topic that things should be "followed exactly". Anywho, this morning I retried without editing anything and it worked.

In case you were wondering, I AM very embarrased but happy it works and always has worked and lastly, very, very thankful to you and the others that tried helping me.

Aearenda
September 27th, 2008, 01:05 AM
That's excellent news, and I'm glad to have been able to help! Don't be embarrassed, we are all learners here, and if you never get anything wrong, you never learn anything new.

The touchpad part isn't needed for the TC1100, but the 'screen' line most certainly is - and that's probably what led to your problem with the screen :-)

Anyway, I hope you enjoy using Ubuntu on your TC1100 - and don't hesitate to ask if you need more help! The difficult thing with the forums is having new messages seen by the right people - there are so many flowing by all the time, I'm sure I only see a very small portion of them. But I'll leave this thread subscribed, so if you need help with the TC1100, I'll definitely see that.

phenest
September 28th, 2008, 05:22 PM
Ok, wow. I got it to work. THANK YOU :) I know what I did wrong, too. You see what you put in bold up there, the "don't change anything else" part?

That's what I didn't do!

Information for all:

Please remember, that if you're going to follow any guide in the Ubuntu forums, you must do what the instructions tell you to do, and nothing else. It will save you a lot of time and bother of asking the same questions over, and over again, and getting nothing but headaches. ](*,)

As an example: some here seem to think that because the pen won't work, that maybe they need to install the drivers. If the guide doesn't tell you to install them, then that is because you don't need to. If you decide to install non-standard drivers, and things break, then that becomes outside of the scope of this guide. If you wish to use non-standard stuff, then do it (at the very least), after you have it working first. :-k

The guide is all you need to make this work. A lot of stuff (particularly drivers), already ships with a basic Ubuntu installation, so this guide is no more than a few 'tweaks'. So don't make it harder for yourself by adding stuff that isn't there.

Have fun. \\:D/

trksh22
September 28th, 2008, 07:50 PM
Yes, thanks!! I was definitely making everything MUCH harder than it needed to be. Had I just read what was there, then I wouldn't have had to go through days of feeling like I couldn't do it.

Hopefully someone new will come along, read what I went through, and make sure that they follow the directions and know what NOT to do :)

g0ldenchild562
November 7th, 2008, 06:47 AM
Hi I'm new, how do I edit the xorg.conf? I keep getting an error saying I dont have permission.

zoomy942
November 7th, 2008, 06:52 AM
Hi I'm new, how do I edit the xorg.conf? I keep getting an error saying I dont have permission.

open a terminal window and type

suod gedit

Aearenda
November 7th, 2008, 12:00 PM
That's a mis-type - it should be
sudo gedit /etc/X11/xorg.confor better
gksudo gedit /etc/X11/xorg.confwhich will ask for the password using a dialog box instead of the terminal.

You can also press ALT and F2 to bring up the 'Run application' box, and do the 'gksudo' version in there - this is the equivalent of start->run on Windows.

Aearenda
November 7th, 2008, 12:18 PM
I have my TC1100 running Ubuntu 8.10 (Intrepid Ibex) reasonably well now. For the record, I had to...

1. Install the nvidia beta drivers from intrepid-proposed (now in intrepid-updates) to enable rotation (see earlier in this thread) and my external monitor. See http://albertomilone.com/wordpress/?cat=2 for comments and instructions. Alberto does a great job. This driver presently has a bug with KDE 3 (only affects me if I have compositing turned on) and Wine fonts but if you don't use these it's fine on the TC1100 (http://www.nvnews.net/vbulletin/showthread.php?t=122350, and now there's a workaround at http://nancib.wordpress.com/2008/11/02/does-anyone-know-what-borked-wine-this-week/). I tried nouveau but it was too slow. The nv driver works fine if you don't need to use external screens or projectors. The nvidia driver works fine with metacity compositing and even allows compiz to be turned on, but compiz wasn't stable.
UPDATE: The nv driver supports rotation too. If you don't need to use an external screen or projector, and you don't need 3D acceleration, the nv driver will be enough and it lets you use hibernate and standby properly. Post 126 (http://ubuntuforums.org/showpost.php?p=6273546&postcount=126) tells how.

2. UPDATED - 21 November 2008: Install Ndiswrapper and the Windows XP driver for the wireless network, taken from HP's SP30102A update. This seems to be more reliable than ath5k and to associate quicker than ath_pci, for me. It doesn't introduce any of the mouse jerkiness I saw with the backported drivers installed, and doesn't need a newer Network Manager.

So, don't do this: OLD STEP 2: Install the latest network-manager from PPA to overcome a wireless association timeout with ath_pci, and it is still much slower to associate than Hardy was. See https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/292054.
UPDATE - 19 November 2008: I have installed linux-backports-modules-intrepid to see if the ath5k driver improves the association times. The process is described in many forum threads - the important bit is to blacklist ath_hal and ath_pci in /etc/modprobe.d/blacklist. This improves association time considerably, and ath5k performs much better than it did during the Intrepid alpha builds. However, there is collateral damage: a new version of ssb is installed as well, but no matching b44 driver, so we lose wired networking! Also, mouse responsiveness suffers for some reason I have yet to fathom. I have kludged a working system by overwriting the updated ssb driver with the stock ssb driver for the same kernel version and then doing 'update-initramfs -u -k `uname -r`' but I'm not recommending this change to anyone else.
LATER THE SAME DAY: There's an update to linux-backports-modules-intrepid in intrepid-proposed that fixes the b44 issue properly. It still leaves the mouse jerky every so often when wireless is enabled, and it seems that this coincides with when Network Manager is re-associating, which it does every two minutes!

3. Install uswsusp to make hibernate worth the effort - otherwise it was slower to wake from hibernate than to do a cold boot. This prevents going to standby, but I've never been able to get it to resume from standby reliably with the nvidia driver anyway. See https://bugs.launchpad.net/ubuntu/+source/pm-utils/+bug/246053/comments/18. I installed uswsusp in Synaptic and then modified /etc/pm/config.d/00sleep_module to contain
SLEEP_MODULE="uswsusp" # was "kernel"
SUSPEND_MODULES="ath_pci ath_rate_sample ath_hal"

UPDATE - 29 Nov 2008: Hibernate still fails randomly with the nvidia driver. I suppose it IS still a beta <sigh>. This overrides my comment on 16th about it not having failed.
UPDATE - 16 Nov 2008: It seems the unreliability was associated with running the netbook-launcher - that is, it hasn't failed since I stopped running that. Also, to get wireless to resume after hibernation, I find I have to use tc1100-wmi to turn it back on (see below). I made a copy of /usr/lib/pm-utils/sleep.d/10NetworkManager in /etc/pm/sleep.d and added 'echo 1 > /sys/devices/platform/tc1100-wmi/wireless' before the 'thaw' dbus command to wake Network manager. Actually this probably ought to have gone in a separate entry, say '15TurnWirelessOn' with just the echo bit in it. The SUSPEND_MODULES list only needs ath_pci in it. I have blacklisted agpgart in /etc/modprobe.d/blacklist and set agp=off in /boot/grub/menu.lst (see the line starting '# defoptions', on mine it is '# defoptions=quiet splash resume=/dev/sda5 vga=791 agp=off' - note that the leading '#' is important here) and nvAGP="1" in /etc/X11/xorg.conf. Hibernate works for me, but standby won't work reliably with the nvidia driver, and if it does come back, the wireless hardware is clobbered until next reboot.

UPDATED - 15 December 2008: I have found that putting 'Option "NvAGP" "0"' in the xorg.conf file allows standby to work reliably with the nvidia driver, and it doesn't clobber the wireless! I have to turn the wireless on though, using tc1100-wmi.

4. Turn off keypad control for the mouse, when using an external keyboard, from the keyboard preferences (http://nancib.wordpress.com/2008/03/17/fixing-the-borked-numeric-keypad-in-ubuntu-hardy/ has simple intructions, bug is https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-keyboard/+bug/197589).

5. Fix my external CD drive so it didn't close the drawer as soon as it was opened (https://bugs.launchpad.net/ubuntu/+source/udev/+bug/283316/comments/34).
UPDATE: This is now fixed automatically.

6. Load the tc1100-wmi module to gain control of screen brightness and the wireless kill switch (see earlier in this thread). This now works without the use of sudo. To turn wireless off do
echo 0 > /sys/devices/platform/tc1100-wmi/wireless and to turn it back on
echo 1 > /sys/devices/platform/tc1100-wmi/wirelessto enable jogdial brightness do
echo 0 > /sys/devices/platform/tc1100-wmi/jogdial and to return to normal (page up/down) do
echo 1 > /sys/devices/platform/tc1100-wmi/jogdial
UPDATE - 19 November 2008: Brightness isn't working every time, neither is the jogdial doing its normal pageup/pagedown function reliably. Probably associated with the xmodmap experiment I have done (but not yet written up) to try to get the side button to control the internal/external screen as in Windows.
UPDATED - 15 December 2008: I have found that it is necessary to use tc1100-wmi to set the normal jogdial mode after waking from standby.

7. Installed wacom-tools and copied the pen details from my Hardy xorg.conf (see earlier in this thread). I believe there is a better way to do this using hal fdi files in Intrepid, but I haven't looked at that yet.

8. Enabled laptop-mode - see Intrepid comments in https://wiki.ubuntu.com/PowerManagement#How%20to%20get%20disks%20idleing%2 0correctly%20(without%20excessive%20load%20cycling ) and then monitor the Load_Cycle_Count in smartctl to see if you need to do anything about your drive.

UPDATE: I have a non-standard 7200 rpm Hitachi drive in my TC1100. I have set /etc/laptop-mode/laptop-mode.conf to use 254 for HDD power management on both battery and AC power, and to do idle spindown after 60 seconds on battery. I don't subscribe to the theory that battery power = increased likelihood of physical shock. YMMV.


9. [ADDED 25 November] Disabled input device hotplugging using evdev. This was crashing X whenever I plugged my keyboard in. I found this the hard way after taking a morning's handwritten notes on a course using Xournal, which does not have a timed-save feature. My notes were lost when I plugged the keyboard in during the lunch break. I reverted to Hardy again for the rest of the course (luckily I have a dual-boot setup). I later found that the X crash would occur if I put the tablet in the dock, or if I plugged in the normal keyboard. I don't know if this is related to my attempts to modify the side key map (which I have successfully done on Hardy, so that I can switch monitors using the same side key as the Windows XP driver uses), or whether it has had the potential to crash this way from day 1.
I added the following to xorg.conf:

Section "ServerFlags"
Option "AutoAddDevices" "false"
EndSection
And I set the keyboard layout to 105-key international.



Other stuff not specific to the TC1100:
I also upgraded to OpenOffice 3 (but see below) from the PPA (http://www.theopensourcerer.com/2008/10/14/how-to-install-openofficeorg-30-on-ubuntu-intrepid-ibex/ has a simple how-to), Sunbird 0.9 from Mozilla (just follow their instructions - install in /opt/sunbird), and Thunderbird, xournal, vym, k3b and amarok from the standard repos.

UPDATE: I find amarok stutters a bit - now trying banshee (It turned out not to be Amarok's fault - it works fine). I have also installed vym 1.12.0 by compilation from source to fix a bug on opening saved files when saved with embedded notes. This also allows landscape printing to work properly, which it didn't in Hardy. Xournal doesn't work properly with the pen unless the zoom factor is set to page width.

UPDATE - 21 Nov 2008: I have downgraded OpenOffice again, owing to slowness and some apparent corruption in saved writer documents.

25 Nov - I am beginning to think I need to re-install from scratch, as I have had to muck with so much to get Intrepid working that I no longer trust the installation. There have been too many failed attempts to fix things on my part, and I am not good at cleaning up after failed fixes; so now it keeps biting me, like with the keyboard X crash losing my course notes. Intrepid has been by far the hardest release to install on the TC1100 (note that I don't do upgrades - I do a fresh installation into a separate partition each time, so this isn't due to a long series of upgrades; and I've done every release since Breezy) and it's the first one I have seriously contemplated skipping (which also means Hardy set a high standard that is hard to match in a non-LTS release).

Jan 2009 - In the end, though, Intrepid has ended up being my best-performing release so far! This is because of getting suspend to work properly.

g0ldenchild562
November 7th, 2008, 09:36 PM
How do I enable the visaul effect? When I do try to enable it, it keeps telling me that the desktop can't enable.

Aearenda
November 7th, 2008, 11:18 PM
g0ldenchild562: If you are running Hardy, it won't work because the code checks for 64Mb Video RAM and the TC1100 only has 32Mb. You can hack it, but it gives black screens all over the place and isn't worth the effort. In Intrepid, it will turn on, but it doesn't stay on for me.

You can try Metacity compositing - see http://ubuntuforums.org/showthread.php?t=924124 but see https://bugs.launchpad.net/ubuntu/+source/metacity/+bug/218322

g0ldenchild562
November 8th, 2008, 12:38 AM
Hey thanks for the response, I actually have the original Ubuntu 8.10. I don't understand the difference between the hardy or the other versions out there. Anyways I manage to get it working by installing the Envyng driver. The effects are so cool!!!!

g0ldenchild562
November 8th, 2008, 04:04 AM
I'm still having problems getting the stylus to work. I did everything that was posted on the first page.

Aearenda
November 8th, 2008, 04:27 AM
Please post (e.g. by copy and paste from a terminal session) the output from
cat /etc/X11/xorg.confand the version number output from
xsetwacom -V Mine look like this for 8.10:


$ cat /etc/X11/xorg.conf
Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "Button2" "3" # This is the line you need for the stylus button to right click
EndSection

Section "Device"
Identifier "Configured Video Device"
# Driver "nv"
Driver "nvidia"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
Option "RandRRotation" "on"
Option "NvAGP" "1"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
InputDevice "stylus" "SendCoreEvents"
EndSection

$ xsetwacom -V
0.1.7
Ignore the nvidia stuff - concentrate on the stylus bits.

g0ldenchild562
November 8th, 2008, 10:53 PM
Hey thanks I got it working! Now i need to fix the hibernation error.

Aearenda
November 16th, 2008, 12:36 PM
I've just added an update to post 116 concerning hibernation with Intrepid.

phenest
November 17th, 2008, 10:35 PM
I've just added an update to post 116 concerning hibernation with Intrepid.

I've added a link to post #1 referring users to post #116. Perhaps you could keep that post up to date with new fixes, etc as they occur.

Aearenda
November 18th, 2008, 08:06 AM
Perhaps you could keep that post up to date with new fixes, etc as they occur.I will - but for now I have retreated to Hardy again as I am on a course where there is occasional access to the internet via wireless, and the slow association problem in Intrepid is unbearable!

EDIT: This was resolved using ndiswrapper and the XP wireless driver - so I'm now back on Intrepid again!
And then later back again to Hardy, because of keyboard hotplugging crashing X...

Aearenda
November 29th, 2008, 11:03 AM
I have just discovered that in *Hardy* the default "nv" driver will support rotation, and that the striping it shows in colour gradients at times can be prevented. I have the following entries in the "Device" section of /etc/X11/xorg.conf:


Section "Device"
Identifier "Configured Video Device"
Driver "nv"
Option "Rotate" "RandR"
Option "FlatPanel" "True" # may not be needed
Option "FPDither" "True"
EndSection

With this, I can at last rotate the screen for use as a tablet AND use standby successfully! I found it in 'man nv' - too obvious!

I haven't tried it with Intrepid yet.

Now if only I could get it to switch to the external screen using the nv driver...

UPDATE: It does work with Intrepid too, so long as metacity compositing is turned off (and generates an X crash if it's on).

gdville
December 15th, 2008, 05:19 AM
Help! I cannot get the pen working after installing nVidia and wacom-tools and updating xorg.conf:


Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "Button2" "3" # This is the line you need for the stylus button to right click
EndSection

#Section "InputDevice"
# Driver "wacom"
# Identifier "eraser"
# Option "Device" "/dev/input/wacom" # Change to
# /dev/input/event
# for USB
# Option "Type" "eraser"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
# Option "Button2" "3"
#EndSection

#Section "InputDevice"
# Driver "wacom"
# Identifier "cursor"
# Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
# Option "Type" "cursor"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
# Option "Button2" "3"
#EndSection


Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
Option "RandRRotation" "on"
Option "NvAGP" "1"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
# Inputdevice "Synaptics Touchpad"
EndSection

Section "Module"
Load "glx"
EndSection


When I query the device with xsetwacom, I get only a prompt back.

I've tried uninstalling nVidia and wacom-tools and reinstalling in various combinations to no avail.

I'll confess to being a newbie, but I had this working on this machine a month ago with a different hard drive. I am nearing wit's end so any new ideas would be very much appreciated.

Aearenda
December 15th, 2008, 05:46 AM
Xorg.conf looks right. Please post your /var/log/Xorg.0.log. To do that, start a command line, then paste in the following command:


zip xlog.zip /var/log/Xorg.0.log

Then go into advanced mode on your forum reply, click the paperclip icon, click the top 'browse' button and find the xlog.zip file just created.

gdville
December 18th, 2008, 12:55 AM
Wow, I can't believe you fixed it! I'm not sure what happened, but the pen has magically begun working again. I swear, I didn't do anything since posting, other than shutting down and running windows for a couple days.

I have attached the log file (after stripping out all my passwords and bank account info:eek:). If you are able to tell what the problem was, it would be gratifying to know what the problem was. I'm sure I won't be the only one to find it useful.

Thanks, it's folks like you that make me love linux!

Aearenda
December 18th, 2008, 02:46 AM
That log file gets overwritten on each login, so now it shows the successful startup, as far as I can see. Oh well, if it's working then let's leave it working and enjoy Christmas!

rubbafishe
December 21st, 2008, 02:12 AM
ok so i may sound like a moron here but im fresh to linux and have had too many problems just getting it running.

im trying to get ubuntu 8.10 intrepid ibex to run on my Compaq tc1100. unfortunately the install deleted my xp partition by accident and now i've lost all the functions i got the laptop for!

problems i'm having are as follows

no wireless (no internet at all)
no pen functions
no tablet buttons functions
can't read from my regular usb drive (i had to dedicate one to the linux install)


i've been searching forums and websites for days now with no luck. just lots of jargon and patches etc that i cant understand or get to work in the way they seem to for everyone else.

i really love this laptop and need it to work properly as soon as possible. please help. im going insane with this.

Aearenda
December 21st, 2008, 03:48 AM
Everyone feels that way when they first start - up the creek without a paddle, and with the water running fast! Patience is needed :-) I'm writing this from a docked TC1100 running Ubuntu 8.10 with the pen, side buttons, external monitor, screen rotation and wireless working, and with which USB drives work normally, so I assure you it can be made to work. The only thing I have difficulty with at present is hibernation, but I rarely want to use that since Linux hibernation is no faster for me than a full startup on the TC1100 - I just leave it in standby when I want to save power.

By the way, to reinstall Windows XP, you would need the recovery CDs and a USB CD drive.

First, can you confirm my understanding of how things stand with Ubuntu.

1. You're definitely using a TC1100 (made by HP really, since they took Compaq over after the TC1000 and before the TC1100), and not a TC1000. I have a TC1000 as well, and it is much slower than the TC1100 and significantly different inside.

2. There are variants of the TC1100 - from your recall of running Windows XP, does yours have a Celeron or Pentium-M CPU, and does it have an Atheros or an Intel Wireless card? Don't worry about this now if you don't know.

3. It sounds to me as though you have used a USB-drive installation method instead of the standard CD, probably because you don't have a USB CD drive. I think this because you say 'I had to dedicate one (USB drive) to the linux install'; but alternatively, you could be saying that you have actually installed Ubuntu on the USB drive. Which is it?

4. Somehow in the process the Windows partition has been deleted or become unbootable. Is this because the partition was really deleted, or perhaps because the boot sector on the hard drive was erased? You can explore this by pressing 'ESC' when the system says 'Press Esc to enter menu' as it starts up (if it does), and then selecting the Windows XP entry on the menu, if it exists. Ubuntu will always add such an entry if it finds an existing Windows partition.

5. Does the wired network interface work? It should just work without any fiddling, once you have logged on to Ubuntu, giving you Internet access using Firefox, assuming the network it is plugged in to will offer it an IP address using DHCP, just like with Windows. If you had to configure Windows specially to make it work when wired, then the same settings will be needed for Ubuntu.

I'll leave it there for now, since the next set of instructions depend greatly on how things stand, and I don't want to make it worse.

rubbafishe
December 22nd, 2008, 03:13 AM
Thanks for helping me out here Aearenda. unfortunately i bought the tc1100 second hand, so i didn't get the recovery disk or any of the authentic windows software. this was one of the reasons i want to switch to ubuntu. i hope its not a problem where i'll have to go and buy XP tablet pc windows to make this work.

let me clear this up a little.





1. You're definitely using a TC1100 (made by HP really, since they took Compaq over after the TC1000 and before the TC1100), and not a TC1000. I have a TC1000 as well, and it is much slower than the TC1100 and significantly different inside.

2. There are variants of the TC1100 - from your recall of running Windows XP, does yours have a Celeron or Pentium-M CPU, and does it have an Atheros or an Intel Wireless card? Don't worry about this now if you don't know.

3. It sounds to me as though you have used a USB-drive installation method instead of the standard CD, probably because you don't have a USB CD drive. I think this because you say 'I had to dedicate one (USB drive) to the linux install'; but alternatively, you could be saying that you have actually installed Ubuntu on the USB drive. Which is it?

4. Somehow in the process the Windows partition has been deleted or become unbootable. Is this because the partition was really deleted, or perhaps because the boot sector on the hard drive was erased? You can explore this by pressing 'ESC' when the system says 'Press Esc to enter menu' as it starts up (if it does), and then selecting the Windows XP entry on the menu, if it exists. Ubuntu will always add such an entry if it finds an existing Windows partition.

5. Does the wired network interface work? It should just work without any fiddling, once you have logged on to Ubuntu, giving you Internet access using Firefox, assuming the network it is plugged in to will offer it an IP address using DHCP, just like with Windows. If you had to configure Windows specially to make it work when wired, then the same settings will be needed for Ubuntu.


1.I'm definitely using a tc1100, with the cd dock and a usb keyboard and mouse.

2.i think it runs on a Celeron cpu. i managed to get the wireless card working. the problem was i had to turn it on in the bios. now i can connect online but still have no pen features.

3.For the install of Ubuntu, i downloaded ubuntu .iso image and burned it to a cd for install. that works fine when i need it to. the usb drive is just for shuffling all the patches around. its just 2gigs so it gets frustrating.

4.When installing Ubuntu Intrebid Ibex, where it asks to select or make a partition, i had the 'clear hard drive for fresh install' option selected. i didnt realise it until after the install. There is no XP or windows option anywhere in the boot menu.

5. now that the wireless works, i'm not too concerned about the wired connection.

so far i have tried various patches, edits to some files like xorg.conf (i have backups of the original file)but the pen and side buttons get no response.

i'm shattered having this machine on my desk with no pen features as thats the main reaon i bought the thing.

Aearenda
December 22nd, 2008, 03:50 AM
Ok, well done in getting the wireless working - that makes the rest much easier!

Let's get the pen working then!

1. Go to system->administration->synaptic package manager

2. When it has finished getting ready, find the package 'wacom-tools'. You can do this by clicking once anywhere in the top-right pane, and then typing 'wacom' (I'd suggest quick search but the index may not be ready yet). When you see 'wacom-tools' appear in the top-right pane, click once on it to clear the little stem-match window that will have appeared.

3. If the package is already installed, the little square on the left of its name will be green; you can skip to step 4 in this case.

3.1 If it isn't green, double-click on wacom-tools, to get it marked for installation, and if a 'Mark additional changes?' dialogue pops up, click on the 'Mark' button to accept them.

3.2 Now click the 'Apply' button on the main toolbar. A confirmation window will appear; click the 'Apply' button, and wait for the changes to be made.

4. Close Synaptic Package Manager.

5. Now press ALT and F2 to bring up the 'run' dialogue.

6. Type (or paste) in the following command:
gedit /etc/X11/xorg.conf

7. Press CTRL and A to select the whole file, and the CTRL and C to copy it to the clipboard.

8. Start Firefox and use it to start a 'quick reply' to this message. Begin by telling me whether you had to install wacom-tools or not.

9. Then press CTRL and V to paste the contents of /etc/X11/xorg.conf into the reply, so that I can see what we should do next.

10. Post the reply.

11. Close the text editor.

rubbafishe
December 22nd, 2008, 09:02 PM
Wacom-tools was already installed in the package manager.

here is my xorg.conf file:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder57) Mon Oct 27 14:37:20 PST 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "cursor" "SendCoreEvents"
InputDevice "stulus" "SendCoreEvents"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/ttyS4"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"
Option "Mode" "Absolute"
Option "Button2" "3"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/ttyS4"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"
Option "Mode" "Absolute"
Option "Button2" "3"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Aearenda
December 23rd, 2008, 01:35 AM
Thanks, I think the pen device should be /dev/input/wacom not /dev/ttyS4. That xorg.conf looks 'old'.

To prepare the way for getting the other TC1100 features working, I think it's probably a good idea for you to move your existing xorg.conf out of the way, and use a copy of mine. There are several differences, which should be clear from the comments.

To move the existing file, I suggest you do ALT and F2 and start gedit as before, then use 'Save As' to save the file in your own folder somewhere. Then close gedit.

Next, do ALT and F2 and this time add 'gksudo' to the front of the command, like so:
gksudo gedit /etc/X11/xorg.confSelect All and remove the existing contents, then paste in the details below, and save the file.


Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "Button2" "3" # This is the line you need for the stylus button to right click
EndSection

# Don't need cursor or eraser devices on TC1100

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
# Next two lines are recommended for nvidia beta on Intrepid
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
# Suppresses the nvidia logo at startup
Option "NoLogo" "True"
# Enable screen rotation
Option "RandRRotation" "on"
# NvAGP set to 0 makes standby work on TC1100
Option "NvAGP" "0"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
InputDevice "stylus" "SendCoreEvents"
EndSection

Section "ServerFlags"
# This option allows us to use the TC1100 side keys
Option "AutoAddDevices" "false"
EndSection

This contains settings that remove blockers for standby, rotation and the side keys to work, but other things are needed as well for these - they won't all work for you yet. The important thing at this stage is to test the pen after putting this xorg.conf into place, and then rebooting (or doing 'sudo service gdm restart' from a console after logging out from the main session).

By the way, which version of Nvidia driver have you installed, and how? Mine is 96.43.09-0ubuntu1 which is now in the intrepid-updates repository.

rubbafishe
December 23rd, 2008, 02:26 AM
I replaced my xorg.conf files contents with yours. this has given me access to a 'rotate screen' option in my nvidia x settings menu. my driver version is the same version 96.43.09, from the repository.

unfortunately i'm still getting no response at all from the pen. ive been working with a usb keyboard and mouse, and i wonder if i should be disconnecting them while testing the pen or updating. maybe they're getting in the way of some sort automatic detection?
i don't know if this is the case thogh, just a thought.

Aearenda
December 23rd, 2008, 02:36 AM
No need to detach USB devices, it should work regardless.

Yes, rotate screen will work, but we need extra stuff to make the pen rotate, once we've got it working! You'll probably find you can go into standby as well, but the wireless may not work afterwards yet.

Now we need to know what the wacom driver is seeing. Please start a terminal session and enter the following command:
grep [Ww]acom /var/log/Xorg.0.logPlease post the output from this command here.

rubbafishe
December 23rd, 2008, 02:42 AM
here is the result from the terminal.

professor@Mandy:~$ grep [Ww]acom /var/log/Xorg.0.log
(II) LoadModule: "wacom"
(II) Loading /usr/lib/xorg/modules/input//wacom_drv.so
(II) Module wacom: vendor="X.Org Foundation"
(II) Wacom driver level: 47-0.7.9-11 $
(**) stylus device is /dev/input/wacom
(II) XINPUT: Adding extended input device "stylus" (type: Wacom Stylus)
(**) Option "Device" "/dev/input/wacom"
Wacom unable to read ISDV4 control data after 3 tries
Wacom unable to read ISDV4 control data after 3 tries

Aearenda
December 23rd, 2008, 03:14 AM
Your wacom driver level is old - mine is 47-0.8.1-4.

The Ubuntu xserver-xorg-input-wacom package showing in Synaptic for me is 1:0.8.1.4-0ubuntu3 and it comes from the standard Intrepid repository. I'm wondering how yours comes to be an older version - have you tried to install this from source?

This may not be the problem, but we'd better fix it. First, please post the output from the following terminal commands:

uname -a
apt-cache showpkg xserver-xorg-input-wacom
apt-cache showpkg wacom-tools

rubbafishe
December 23rd, 2008, 03:26 AM
i ran the commands and here are the results.


professor@Mandy:~$ uname -a
Linux Mandy 2.6.27-11-generic #1 SMP Fri Dec 19 16:29:52 UTC 2008 i686 GNU/Linux
professor@Mandy:~$ apt-cache showpkg xserver-xorg-input-wacom
Package: xserver-xorg-input-wacom
Versions:
1:0.8.1.6-1ubuntu2 (/var/lib/dpkg/status)
Description Language:
File: /var/lib/dpkg/status
MD5: 2bd3c8ee2eda769c94b546d751232b99

1:0.8.1.4-0ubuntu3 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_intrepid_main_bina ry-i386_Packages)
Description Language:
File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_intrepid_main_bina ry-i386_Packages
MD5: 2bd3c8ee2eda769c94b546d751232b99


Reverse Depends:
wacom-tools,xserver-xorg-input-wacom
xserver-xorg-input-all,xserver-xorg-input-wacom
xserver-xorg-core,xserver-xorg-input-wacom 0.7.8
wacom-tools,xserver-xorg-input-wacom
Dependencies:
1:0.8.1.6-1ubuntu2 - xserver-xorg-core (2 2:1.5.1-1ubuntu3) wacom-tools (0 (null)) wacom-tools (3 1:0.7.9.3-2) wacom-tools (3 1:0.7.9.3-2)
1:0.8.1.4-0ubuntu3 - xserver-xorg-core (2 2:1.5.1-1ubuntu3) wacom-tools (0 (null)) wacom-tools (3 1:0.7.9.3-2) wacom-tools (3 1:0.7.9.3-2)
Provides:
1:0.8.1.6-1ubuntu2 - xserver-xorg-input-2.1
1:0.8.1.4-0ubuntu3 - xserver-xorg-input-2.1
Reverse Provides:
professor@Mandy:~$ apt-cache showpkg wacom-tools
Package: wacom-tools
Versions:
1:0.8.1.6-1ubuntu2 (/var/lib/dpkg/status)
Description Language:
File: /var/lib/dpkg/status
MD5: b5617785fb45ae13c791e945f0a78a65

1:0.8.1.4-0ubuntu3 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_intrepid_main_bina ry-i386_Packages)
Description Language:
File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_intrepid_main_bina ry-i386_Packages
MD5: b5617785fb45ae13c791e945f0a78a65


Reverse Depends:
xserver-xorg-input-wacom,wacom-tools 1:0.7.9.3-2
xserver-xorg-input-wacom,wacom-tools 1:0.7.9.3-2
xserver-xorg-input-wacom,wacom-tools
ubuntustudio-graphics,wacom-tools
ubuntustudio-graphics,wacom-tools
xserver-xorg-input-wacom,wacom-tools 1:0.7.9.3-2
xserver-xorg-input-wacom,wacom-tools 1:0.7.9.3-2
xserver-xorg-input-wacom,wacom-tools
Dependencies:
1:0.8.1.6-1ubuntu2 - libc6 (2 2.4) libncurses5 (2 5.6+20071006-3) libx11-6 (0 (null)) libxi6 (2 2:1.1.3-1ubuntu3) tcl (0 (null)) tk (0 (null)) xserver-xorg-input-wacom (0 (null))
1:0.8.1.4-0ubuntu3 - libc6 (2 2.4) libncurses5 (2 5.6+20071006-3) libx11-6 (0 (null)) libxi6 (2 2:1.1.3-1ubuntu3) tcl (0 (null)) tk (0 (null)) xserver-xorg-input-wacom (0 (null))
Provides:
1:0.8.1.6-1ubuntu2 -
1:0.8.1.4-0ubuntu3 -
Reverse Provides:


i had downloaded and tried to install 2 wacom related patches from a help tutorial online, but i wasnt able to install them properly or at all to my knowledge.

Aearenda
December 23rd, 2008, 03:52 AM
You must be living on the edge with the intrepid-proposed repository enabled, since the 2.6.27-11 kernel hasn't gone to most users yet. I'm still using 2.6.27-9. However, that doesn't account for your wacom driver being *older* than mine! Can you tell me which help tutorial it was that you followed?

In the mean time, I think you should go into Synaptic, right-click on xserver-xorg-input-wacom and choose 'reinstall', and apply the change; then reboot, and see if the driver reported by 'grep [Ww]acom /var/log/Xorg.0.log' is now a later one than 47-0.7.9-11. If it isn't, then we may have to reinstall the kernel as well, since the underlying driver is part of that package.

I've come across material that suggests your tablet my have its pen interface appearing on a different serial port than is standard - I'm researching that at the moment.

UPDATE: it would be useful to see what output the following command gives:

ls /dev/ttyS*
After that, if you run the following command and move the pen over the screen, does anything appear on the screen? You should see a stream of characters when it is working, and you will need to press CTRL and C to quit. Try this for each device listed by the previous command until one works, or you get to the end of the list (on mine it lists /dev/ttyS0 /dev/ttyS1 /dev/ttyS2 and /dev/ttyS3, and produces output on ttyS0).

xxd /dev/ttyS0When run for devices that do not function, xxd immediately exits, so just move on to the next one in that case.

Did your pen work with Windows before it was nuked?

rubbafishe
December 23rd, 2008, 04:54 AM
so i uninstalled the xserver-xorg-input-wacom package and reinstalled it. now the pen is working! seems like that older patch was the thing getting in the way.
thanks a million.

i don't really care about the 3 buttons on the tablet screen but the pressure sensitivity and eraser for my stylus are still inactive

Aearenda
December 23rd, 2008, 05:36 AM
Well done!

Pressure sensitivity is usually controlled by the application - so in Xournal, for example, you have to turn it on in the options menu. In GIMP, you have to enable the stylus in preferences, otherwise it thinks its a mouse.

The TC1100 pen doesn't have an eraser, so you're out of luck there.

Other things I can steer you through if you want:
1. Make the Q and screen output selection buttons on the side of the TC1100, near the power switch, work
2. Make the table rotate with the screen - otherwise the pen is useless in portrait mode!
3. Test standby and fix wireless if it doesn't recover
4. Set up Cellwriter for on-screen keyboard and letter recognition.

I don't bother with the three pen-operated buttons near the USB sockets.

rubbafishe
December 23rd, 2008, 07:10 AM
well the 'esc' and 'tab' buttons on the side seem to work alright. even with XP i never really used the Q button or screen output buttons, or the screen rotation. i use it for image editing so keeping landscape is fine.
standby and wireless seem ok.

i understand the tc1100 doesn't necesarrily ship with a 2 ended stylus. since i bought mine second hand, the stylus i got with the thing had a working eraser. i can live without that though.

what would be useful is setting up cellwriter (i have it but cant really figure how it works yet)and change the q button to a shortcut.

thanks for all your help, you've really saved my life here.

Aearenda
December 23rd, 2008, 07:50 AM
That's cool - Cellwriter is good once you get used to it.

To get the eraser to work I think you need to add the following into xorg.conf, after the stylus section, using gksudo gedit as before:


Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "Button2" "3"
EndSection
Then restart GDM as before. However, I can't test this!

Below is how to get both side buttons working. You should write and test the scripts you want the buttons to trigger using a terminal, before doing this - I've called them '/full/path/to/your/script1' and '...2'. An example script to start Xournal might be:
#!/bin/bash
xournal &
exit 0

The '&' makes the command start in a separate process, so that the button handler doesn't have to wait for it. Save the file and use the following command to make it executable:
chmod u+x /full/path/to/your/script

Here's how to do the button mapping:
1. Create a text file in your home directory called '.Xmodmap' (the dot makes it hidden) containing these two lines:
keycode 159 = XF86Launch2
keycode 151 = XF86Launch1This does both the Q and the screen button. Next time you log on, it will ask whether to include these settings, but you can make it not ask after that. 151 is the screen button and 159 is the Q button.

2. Use ALT and F2 to start gconf-editor, and then use CTRL and F to find 'metacity' (this is the name of the window manager component)

3. Left-click on the arrow or double-click on 'metacity' in the left pane if it needs to be opened out (it probably does unless you've been here before).

4. Click on 'global_keybindings' in the left pane.

5. Double-click on 'run_command_1' in the right pane; enter the text 'XF86Launch1' (omit quotes) and save it.

6. Double-click on 'run_command_2' in the right pane; enter the text 'XF86Launch2' and save it.

7. Now click on 'keybinding commands' in the left pane.

8. Double-click on 'command_1', enter the text 'sh /full/path/to/your/script1' and save it; here, I enter 'sh /home/me/nvidia-toggle' which is my script to switch to the external screen. I don't know whether the 'sh' is really necessary here, but I do know that it works like this!

9. Double-click on 'command_2', enter the text 'sh /full/path/to/your/script2' and save it; here, I enter 'sh /home/me/rotate-screen' which is my script to rotate the screen and pen together.

10. For previous versions of Ubuntu, that was it. For Intrepid, I had to add the 'Option "AutoAddDevices" "false"' part to xorg.conf, which you have already done, and I had to do this kludge:
sudo mv /etc/rc2.d/S20hotkey-setup /etc/rc2.d/S99hotkey-setupThis prevents the hotkey setup from happening too soon.

rubbafishe
December 23rd, 2008, 11:01 PM
well thanks again for all the help. this stuff worked and now my tc1100 went from almost unusable to perfectly new in just 3 days! i can't thank you enough for your help.

Aearenda
December 23rd, 2008, 11:41 PM
I'm glad it's all turned out well in the end!

JHavok
December 28th, 2008, 09:25 AM
This has been a very informative thread. Thanks to all the instructions here, I've been able to get my TC1100 99% working. I have 1 problem, my wireless does not work at all. I have the Pentium M 1100 with the Intel Pro 2100 wireless card. I already downloaded and installed NDISWRAPPER and the windows xp driver for that wireless card.

I did not get any errors while installing the driver and I can see it as eth1 when I run ifconfig and iwconfig. The problem is that I can't seem to connect to a network and I can't find a way to do it other than via the terminal. The status light on the TC1100 is on for the wireless card but I can't figure out how to access it. When click on the network icon on the top menu bar, i see "wireless is disabled" under Wireless Networks. Also, dhclient fails to get an IP. I have configured eth1 with the essid, key, key type, mode, and rate.

I am not sure if I am missing something here. Any help would be appreciated.

Aearenda
December 28th, 2008, 10:49 AM
I'm glad everything else is working ok. It's worth knowing that wireless with Ubuntu can be done in several different ways, depending on your needs.

The basic architecture has a set of drivers for the different hardware - you have an Intel card, mine is Atheros. These manage the hardware and do basic tasks. Sometimes we use native Linux drivers, sometimes we use ndiswrapper with the relevant Windows driver.

When you use WPA security on the wireless network, a different bit of code called 'wpa supplicant' is used to manage the encryption keys.

The lowest level at which we can control thing is by using ifconfig and iwconfig, but that's hard work, as you have probably found. The next level involves settings in /etc/network/interfaces, which allows us to use ifup and ifdown to trigger wpa supplicant and the hardware driver to do the right things, get a DHCP address, and set routing and DNS so that it all works. This is good for diagnostics and for servers, but hard for laptops.

The top level uses either 'Network Manager' (which is standard in Ubuntu), or a different tool called 'wicd' to manage alternative settings and remember keys for different networks, and to do all the low level management for us. This is the best way for laptops. I use Network Manager (NM).

With the sketch of how it all links together out of the way, I'd like to suggest some checks on how you have everything configured. I'm assuming you're happy with the command line since the things you've tried need it.

1. When the computer starts, it needs to be told to load the ndiswrapper module. The usual way to do this is to add a line to /etc/modules, so that the file looks something like this:

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

loop
# lp
fuse
ndiswrapper
This is the list from my TC1100 - I use ndiswrapper too.

2. Secondly, we need to prevent the native Linux driver from loading as well - otherwise it will interfere with ndiswrapper. This is done by adding a line to /etc/modprobe.d/blacklist - here is the last part of mine, after the standard entries:
blacklist ipv6
blacklist pcspkr

# Nvidia hibernation
blacklist intel_agp
blacklist agpgart

# Using ndiswrapper
blacklist ath_pci
blacklist ath_hal
blacklist ath_rate_sample
Here you can see at the end that I am blacklisting the three parts of the atheros driver. I'm afraid I don't know what the equivalent intel driver is called that you would need to use, but see the next step for a clue.
EDIT: Looks like it should be 'blacklist ipw2100'

3. When you install the Windows driver, you do something like this to register the driver, naming the relevant .inf file:
sudo ndiswrapper -i driver.infI believe you have done this - the way to check is to run
sudo ndiswrapper -lAs a bonus, this will probably tell you the name of the native driver you need to blacklist :-) For me, the output of this command is
net5211 : driver installed
device (168C:0013) present (alternate driver: ath_pci)

4. To give Network Manager control over the wireless hardware, the file /etc/network/interfaces must look something like this:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
#auto eth0
#iface eth0 inet dhcp
Note that on my system, the only used entry is that for the network loopback device 'lo'. The 'eth0' entry is commented out, and there is no entry for the wireless interface at all. This allows NM to take control. The message you are seeing suggests that on your system NM cannot control the wireless, and this might be a reason why. This behaviour varies a little between Ubuntu releases - which version are you using? (Mine is 8.10, called 'Intrepid Ibex').

5. With all that in place (for consistency, reboot if you have had to change things), Network Manager should be able to scan for networks. However, it is possible to tell NM to not use wireless at all, by right-clicking on its icon in the task bar and unchecking the 'Enable Wireless' checkbox. This checkbox is greyed out if no usable wireless hardware is found. Make sure that your system allows it to be checked.
EDIT: I should add that if NM finds a network, it will list it when you left-click on the icon in the task bar. If you then click on the network, it will ask you for the passphrase, and save it for future use, while attempting to connect. While it is doing that, the icon changes to a whirling dot with (eventually) two green indicators.

6. After doing all this, the next stage is to figure out what is going wrong. You can use the command 'dmesg | more' to look through the system log to see if ndiswrapper is complaining about the hardware, and you can look through '/var/log/daemon.log' to see what Network Manager is up to. Post anything suspicious here, or attach the log file if you wish. It would also be useful to see the output from
sudo lshw -C network

Please let us know how you get on!

EDIT: I just thought of something else. If you are using 8.04 (Hardy Heron), there is no way to turn the radio transmitter on or off - you have to do it from Windows XP and then reboot, unless there is a BIOS setting - but there isn't for mine. However, if you are using 8.10, you can turn it on like this:
sudo modprobe tc1100-wmi # only needed once per restart
echo 1 > /sys/devices/platform/tc1100-wmi/wirelessAfter this, to turn it off do
echo 0 > /sys/devices/platform/tc1100-wmi/wirelessThere's no need for sudo with the echo command. On my TC1100, this turns the wireless indicator on and off when using ndiswrapper, but not with the native drivers. Since the light is on with your TC1100, I suspect the wireless is already on. There may be a note in the logs about the kill switch if it is off - there's no other way to tell, since 'cat /sys/devices/platform/tc1100-wmi/wireless' always returns 0 regardless.

I added the 'modprobe tc1100-wmi' command to /etc/rc.local, and I can't really remember why now - it ought to be loaded by adding 'tc1100-wmi' to /etc/modules, like ndiswrapper. I suspect it was while I was testing the native driver, and I wanted to have tc1100-wmi loaded and usable, with the wireless turned on, before loading the native driver.

JHavok
December 28th, 2008, 04:12 PM
I am very happy to report that I was able to get my wireless working with very minimal effort. I was following everything you suggested and had pretty much tried all of it already before posting last night. The one part I had not seen was "echo 1 >...." while the status light on the TC1100 had been on the whole time, I figured I'd give it a shot. When I ran those commands, the light flickered for a second and then I was able to see the several wireless networks. I am still new to Linux so pardon my ignorance in asking; how do I make sure that the wireless turns on when the system boots up? Also, I would be interested to know if there was a way that I could script this to turn the card on or off by using one of the pen activated button on the TC1100. My thought is to create a script and bind it to the button for the OSK.

thank you for all the help.

EDIT: I forgot to mention that I am on 8.10.

Aearenda
December 29th, 2008, 12:00 AM
That's great! Well done.

You can add the echo command to start the radio to the file /etc/rc.local, which gets run late in the startup process. It will only work if tc1100-wmi is loaded first - I suggest you add that to the end of /etc/modules.

I have never bothered with the pen-activated buttons, since I don't use the pen very often. This was also true using XP. I have seen discussions of how to make them work, so you should be able to find a way (EDIT: See http://ubuntuforums.org/showthread.php?p=3672701 as linked in Phenest's original howto at the top of this thread). I do use the side buttons, as described earlier in this thread, one for rotation and one for switching the screen to external or projection. I have been experimenting with a wireless on/off toggle script triggered through the normal menu.

In it's simplest form it could look like this:

#!/bin/bash
# Toggle TC1100 wireless on or off

if [ -a ~/.wireless-on ] ; then
echo "Switching wireless off"
echo 0 > /sys/devices/platform/tc1100-wmi/wireless
rm ~/.wireless-on
else
echo "Switching wireless on"
echo 1 > /sys/devices/platform/tc1100-wmi/wireless
touch ~/.wireless-on
sudo service NetworkManager restart
fi

This uses a hidden flag file in the home directory to remember the state of the wireless, since the kernel won't tell us. It's not really satisfactory without adding a session-start script to do 'touch ~/.wireless-on' assuming /etc/rc.local has turned the wireless on (or doing that in rc.local too, but you can't use the '~' abbreviation there so it would have to be 'touch /home/your-user/.wireless-on' followed by 'chown your-user /home/your-user/.wireless-on' so that you own it not root); and even then, it needs to be made aware of what happens during standby and hibernate.
I find that NM gets confused if the radio is turned off, and needs to be restarted when the radio is turned back on by 'sudo service NetworkManager restart' in order to reconnect properly, and this needs a password - but here's a way round that:

1. In a terminal run 'sudo visudo'.

2. At the end of the file that is presented, add:
your-user ALL=(ALL) NOPASSWD:/home/your-user/.NMrestartReplace 'your-user' with your username :-)
EDIT: Take care here! If you are not familiar with the 'vi' editor, it is easy to mess this up and lose admin access. Remember that to exit vi without saving changes you press :q! and to add a new line, simply move the cursor to the last line by holding <cursor-down>, press A, then type <enter> and the new line, and finish with <esc>:wq

3. Create the file .NMrestart in your home directory containing:
#!/bin/bash
/etc/init.d/NetworkManager restart

4. Make root own that file (otherwise you have a security hole) and set permissions:
chown root.your-user .NMrestart
chmod 750 .NMrestart750 is full for root, read and execute for the owning group (which contains you), and nothing for anyone else. From now on, you'll have to use sudo to edit this file.

5. Replace 'sudo service NetworkManager restart' in the script with 'sudo ~/.NMrestart'

Now you should be able to toggle the network and restart NM without a password. I should add that I haven't tested these instructions!

serversphere
January 4th, 2009, 05:55 PM
Great thread! Successfully running 8.10 on my ebay-acquired TC1100. Thanks to everyone who contributed to this thread.

In a video outlining the TC (HP promotional I believe), it showed someone rotate the tablet on a desk and the orientation changed without them hitting a button. Is this something the tablet did in Windows? I installed Ubuntu on the machine as soon as I received it, so I have no experience with this function (if it is one). I'm left wondering if this is something that can be tapped and applied to the rotate shell script here?

Aearenda
January 4th, 2009, 11:39 PM
It used to work like that in Windows XP for me (I have had a TC1100 from new, in 2004), until one day the nvidia drivers got updated, and after that it did strange things like start up normal, rotate when it shouldn't, and then take ages to rotate back again when told to. I gradually began to hate it, and then I discovered Ubuntu :-)

AFAIK, nobody has ever worked out how to detect the hardware rotation state automatically in Linux, either from the docking station or from the keyboard. If we could, then it would be easy to do the script automatically.

serversphere
January 6th, 2009, 08:24 AM
Just sent mine back to my ebay seller, as it had some screen burn in and he agreed to replace it with another. When I get mine back figuring out what switches when you rotate will become my new mission this weekend. :D

serversphere
January 9th, 2009, 04:55 PM
Got my TC back and after doing some research, looks like there was a driver for the accelerometer in Windows called sensor.dll. I have just ordered recovery disks from HP, so again the waiting game on the delivery man...

kdub
January 23rd, 2009, 04:55 AM
Just got a tc1100 and am trying to install 8.10, I'm stuck at step 1 tried this command after alt f2:
sudo nano /etc/X11/xorg.conf-
and got this what am I doing wrong?
GNU nano 2.0.7 File: /etc/X11/xorg.conf

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg
[ Read 42 lines ]
^G Get Help ^O WriteOut ^R Read File ^Y Prev Page ^K Cut Text ^C Cur Pos
^X Exit ^J Justify ^W Where Is ^V Next Page ^U UnCut Text^T To Spell
thanx
ken

Aearenda
January 23rd, 2009, 05:40 AM
Hi kdub - you're not doing anything wrong - that's what the top of that file looks like. 'nano' is a text editor for use inside terminal sessions. You may be more comfortable by doing
gksudo gedit /etc/X11/xorg.confinstead of using nano - gedit is more like 'notepad' on Windows in how you use it.

Please note that the top post of this thread was written for 7.04, but you are installing 8.10. There will be differences. You will find my notes on 8.10 in post 116 (http://ubuntuforums.org/showpost.php?p=6123218&postcount=116) but I'm afraid that's not really a how-to but rather a set of notes for those who have a bit of experience already. I haven't got time right now, but I will look through Post 1 and add some comments about it here if I see anything that need attention.

EDIT: Three things that come to mind so far:
1. Post 136 (http://ubuntuforums.org/showpost.php?p=6420225&postcount=136) contains an up to date version of what should appear in /etc/X11/xorg.conf for a standard TC1100 on Intrepid.
2. Standby is different in 8.10 from 7.04 - you should modify /etc/pm/config.d/00SleepModule as discussed in Post 116 (http://ubuntuforums.org/showpost.php?p=6123218&postcount=116) step 3.
3. In spite of what it currently says in Post 116, I have resumed using ath_pci for the wireless driver; ndiswrapper was crashing on suspend sometimes. The Network-Manager updates seem to have fixed the association delay problem in the meantime. I need to fix Post 116.

kdub
January 23rd, 2009, 06:55 AM
Aearenda,
Thanks.I was starting to feel retarded!
ken

kdub
January 24th, 2009, 04:34 AM
So,
I cut and pasted your print out, reinstalled the wacom drivers and now my pen works , and my wireless has worked fine since the initial install.
Next is how do I get rotate, and my buttons to work. After that I need to find a Tablet Journal type program (is that what cellwriter is?) and work on some way to hibernate/sleep.
thanks,
kdub

Aearenda
January 24th, 2009, 04:46 AM
Well done! You should be able to get rotation to work based on the earlier posts in this thread.

Cellwriter is a pen input tool for non-pen-aware programs. Take a look at Xournal for a Journal equivalent!

kdub
January 24th, 2009, 11:42 AM
Aearenda,
So the commands from before #116 will work with 8.10?
thanks for the help, I really didn't think that I'd ever be able to get this thing up.
thank you,
ken

Aearenda
January 24th, 2009, 12:06 PM
Yes, rotation itself hasn't changed - the assignment of side buttons (I use the 'Q' button for rotation) has though, it needs the hotkey setup shifted later in startup - like this:

sudo mv /etc/rc2.d/S20hotkey-setup /etc/rc2.d/S99hotkey-setupEDIT: Post 146 (http://ubuntuforums.org/showpost.php?p=6421826&postcount=146) has more on the side buttons.

Also note that you need to rotate both the screen and the tablet!

To rotate the tablet sensors and screen to portrait mode use
xrandr -o left
xsetwacom set stylus rotate ccwccw means counter-clockwise.
To set it back do
xrandr -o normal
xsetwacom set stylus rotate none

I also reset the tablet calibration after hibernate or suspend, like this for portrait:

xsetwacom set stylus BottomY 21240
xsetwacom set stylus BottomX 15980
And landscape:

xsetwacom set stylus BottomY 15980
xsetwacom set stylus BottomX 21240
Your calibration may be different - here's how to check, do this after a normal boot and before any hibernate or standby:

xsetwacom get stylus TopX BottomX TopY BottomYThis will list the co-ordinates in order.


Here is the full script I now use for rotation - on my TC1100 it is called without parameters by the 'Q' button.

#!/bin/bash
# Based on work from Patrick Coke & Tim Pope
# Modified for TC1100 by Francisco Athens
# Rewritten for current xsetwacom and xrandr vesrions by Krzysztof Kosiński
# Adapted to work as a toggle - Aearenda

# Takes one parameter:
# normal = go to landscape
# left = go to portrait
# fixcalib = just reset the tablet calibration, don't rotate
# fix = set rotation as it was before standby or hibernate, based on the ~/.screen-rotated flag file
# If absent, toggles rotation based on current X settings
#
# This is the Ubuntu 8.10 version

# Usually we will want to set X rotation
SKIPX="no"


# Look at parameters and fix things up for later
case $1 in
normal) # Pretend we found left-rotation
ROTATION="left"
;;
left) # Pretend we found normal rotation
ROTATION="normal"
;;
fixcalib) # Just fix the wacom calibration
SKIPX="yes"
if [ -a ~/.screen-rotated ] ; then
# Remember this is reversed...
ROTATION="normal"
else
ROTATION="left"
fi
;;
fix) # use the flag and reset
if [ -a ~/.screen-rotated ] ; then
# Remember this is reversed...
ROTATION="normal"
else
ROTATION="left"
fi
;;
*) # Detect what it is now so we can toggle it
ROTATION=`xrandr --verbose --query | \
grep 'default connected' | \
sed -e 's/^.*(.*) \(.*\) (.*).*$/\1/'`
;;
esac

# Now do the required action
case $ROTATION in

normal) xsetwacom set stylus rotate ccw
xsetwacom set stylus TopX 0
xsetwacom set stylus TopY 0
xsetwacom set stylus BottomY 21240
xsetwacom set stylus BottomX 15980
[ "$SKIPX" = "yes" ] && exit 0
touch ~/.screen-rotated
xrandr -o left ;;

left) xsetwacom set stylus rotate none
xsetwacom set stylus TopX 0
xsetwacom set stylus TopY 0
xsetwacom set stylus BottomY 15980
xsetwacom set stylus BottomX 21240
[ "$SKIPX" = "yes" ] && exit 0
rm ~/.screen-rotated
xrandr -o normal ;;

esac

kdub
January 24th, 2009, 03:31 PM
So I would open up a terminal and cut/paste this script in?
thanx
ken

Aearenda
January 24th, 2009, 10:45 PM
Sorry, I keep assuming you know things - you can do that with the individual commands I gave - but the script at the end needs to be saved in a file. One way would be to:
1. Start the text editor (gedit) from the menu, paste it in there, then save the file as 'rotate-screen'.
2. Then find the 'rotate-screen' file in your home folder using the File Browser (Nautilus), right-click on it and choose 'Properties', select the 'Permissions' tab, and click on 'Allow executing file as a program'.
3. Now you can create an entry for it using the Menu Editor (there's a shortcut to starting that by right-clicking on the Ubuntu logo that opens the menu), by clicking on the menu folder where you want the menu entry to be, and then adding a new item. Give it a meaningful name and comment, browse to the file 'rotate-screen' for the command, and click on the icon button to find a suitable icon - look in /usr/share/icons for lots of choices.

I hope that makes sense - I've got to go out.

kdub
January 25th, 2009, 05:00 AM
A,
the screen rotates on Q button!!! Thank You!! How did you get cell writer to work to fill in name and password at the login screen?
thanks,
Ken

Aearenda
January 25th, 2009, 06:16 AM
Well done again! I don't bother with a logon password, I just set it to log me on automatically in 4 seconds so I can choose a different user if I want to by typing quickly. That's on the 'Security' tab in 'Login Window' under 'Administration' from the 'System' menu - except that it only goes to 10 seconds minimum. But do it anyway, and then do 'gksudo gedit /etc/gdm/gdm.conf-custom', find the line that now reads 'TimedLoginDelay=10' and change it to 5, then save the file.

If you don't want to do that, there is a way - see Post 1! But I haven't tried that with 8.10.

Also, you'll want to allow cellwriter to supply gksudo passwords - one way should be to enable 'password dialogs as normal windows', which is now under 'Preferences'->'Assistive Technologies', but I haven't tried that method with 8.10. It is ticked on my system, so maybe I'm just setting the underlying feature. Anyway, here's how I allow this:
1. Press ALT/F2, type 'gconf-editor' and press <ENTER>.
2. Find and click once on 'gksu' under 'apps' in the tree on the left.
3. On the right, check 'disable-grab'.
4. Close gconf-editor

Like most GNOME settings, it takes effect straight away. This opens a possible security hole, in that other malicious apps could intervene and capture your password, but frankly, I think it is extremely unlikely. You'll notice that the screen no longer dims when passwords are requested.

groadin
January 25th, 2009, 08:23 PM
Hello thanks for this great topic but I have strange problem with stylus.

Everything that should work is working, except stylus sync after rotation. When I rotate the screen, it seems like stylus still have old axis (which should be X now, is still Y and vice versa).

I searched a lot but with no luck. I have full updated ubuntu 8.10. I tried to use wacom-tools from repo, or self compiled using instructions from this forum, or from here (http://wiki.linuxquestions.org/wiki/Tc1100). I also tried to use different xsetwacom commands (like xsetwacom set stylus rotate ccw, or xsetwacom set "stylus" Rotate CCW), but no luck.

I dont know what is the problem. I had installed ubuntu 8.10 on TC1100 before, and then rotation was working. Please help, where should I search, and what should I check to get the problem solved?

Aearenda
January 26th, 2009, 12:33 AM
Groadin, the wiki page you linked hasn't been updated for 8.10. It seems likely to me that the version of xserver-xorg-input-wacom you have installed is confused. I have never installed anything but the standard version of this or wacom-tools in the repository, and it just works on my TC1100.

I would make sure all traces of the non-standard wacom-tools packages are removed, then reinstall wacom-tools and xserver-xorg-input-wacom using Synaptic.

kdub
January 26th, 2009, 12:52 AM
Well done again! I don't bother with a logon password, I just set it to log me on automatically in 4 seconds so I can choose a different user if I want to by typing quickly. That's on the 'Security' tab in 'Login Window' under 'Administration' from the 'System' menu - except that it only goes to 10 seconds minimum. But do it anyway, and then do 'gksudo gedit /etc/gdm/gdm.conf-custom', find the line that now reads 'TimedLoginDelay=10' and change it to 5, then save the file.

If you don't want to do that, there is a way - see Post 1! But I haven't tried that with 8.10.

Also, you'll want to allow cellwriter to supply gksudo passwords - one way should be to enable 'password dialogs as normal windows', which is now under 'Preferences'->'Assistive Technologies', but I haven't tried that method with 8.10. It is ticked on my system, so maybe I'm just setting the underlying feature. Anyway, here's how I allow this:
1. Press ALT/F2, type 'gconf-editor' and press <ENTER>.
2. Find and click once on 'gksu' under 'apps' in the tree on the left.
3. On the right, check 'disable-grab'.
4. Close gconf-editor

Like most GNOME settings, it takes effect straight away. This opens a possible security hole, in that other malicious apps could intervene and capture your password, but frankly, I think it is extremely unlikely. You'll notice that the screen no longer dims when passwords are requested.

Aearenda,
WoooHoooo! I emailed Mike Levin and asked him about his Cellwriter program.He emailed me this link:
http://www.krizka.net/2008/01/02/cellwriter-handwritting-recognition-for-gnome/
Seems to work great!!
Now to reread and figure out how to map the monitor button to rotate and Q
to Xournal.
thanks for all your help and patience with this know nothing newbie (gotta give props to my youngest-15-he gave me the look,sat me down and held my hand step by step also) Man this thing is like using a GIANT version of my Nokia n800 now!
Again
THANK YOU!!!,
ken
- Show quoted text -

Aearenda
January 26th, 2009, 01:08 AM
Kdub, I'm glad it's all good. I use the monitor button to tell X to toggle the output to the external screen and/or projector, just like on Windows - that's why I use Q for rotation. IIRC the Q button keycode is 159 (9f in hex), the monitor is 151 (0x97) - this should be enough info for you to set the other button as you desire, since you already have Q doing rotation!

kdub
January 26th, 2009, 04:40 AM
Kdub, I'm glad it's all good. I use the monitor button to tell X to toggle the output to the external screen and/or projector, just like on Windows - that's why I use Q for rotation. IIRC the Q button keycode is 159 (9f in hex), the monitor is 151 (0x97) - this should be enough info for you to set the other button as you desire, since you already have Q doing rotation!

Wellll,
Not so fast-guess there is a "small problem" with cellwriter the way I have it set up.Seems that when I need to put in an admin password for say synaptic the password window comes forward and will not allow the cell keyboard to function. Anyone got any ideas?
ken

Aearenda
January 26th, 2009, 04:47 AM
See the 3rd paragraph in Post 167 (http://ubuntuforums.org/showpost.php?p=6612730&postcount=167) :-)

kdub
January 26th, 2009, 12:27 PM
See the 3rd paragraph in Post 167 (http://ubuntuforums.org/showpost.php?p=6612730&postcount=167) :-)

Aearenda,
In your debt again! Thankyou that worked!
ken

groadin
January 26th, 2009, 04:07 PM
Groadin, the wiki page you linked hasn't been updated for 8.10. It seems likely to me that the version of xserver-xorg-input-wacom you have installed is confused. I have never installed anything but the standard version of this or wacom-tools in the repository, and it just works on my TC1100.

I would make sure all traces of the non-standard wacom-tools packages are removed, then reinstall wacom-tools and xserver-xorg-input-wacom using Synaptic.

Thank you. I've just done a clean install, without bothering about compiling wacom-tools. All just updated from repo, and wacom-tools installed by synaptic. Now rotate works perfect.

Almost all works - except stylus buttons. Earlier, I followed instructions from this topic (http://ubuntuforums.org/showthread.php?t=574310). It's a little messy but I managed to get stylus buttons working, but rotation wasn't.

Could you post some instructions about enabling these three stylus buttons? How to do it with Ubuntu 8.10 in the proper way?

Aearenda
January 27th, 2009, 04:13 AM
Unfortunately, I don't know how to make them work on 8.10 - I never used these three buttons on Windows either, they felt too far out of the way. It's easy to set up launchers on the task bar that do the same job, just by right-clicking on the relevant entry in the menu and choosing 'add this launcher to panel'.

galileon
January 31st, 2009, 07:26 PM
Dear Aearenda, Thanks a lot for the tidbits, I managed to get my TC1100 working in perfect shape with Intrepid using your notes :). On another note, I've just cobbled together a Q Button, here http://galileon.co.uk/qbutton/qbutton.php, hope this helps.

Anyways, I've tried to get the wacom buttons to work, using the tutorial here: http://wiki.linuxquestions.org/wiki/Tc1100#Hibernate_and_suspend_to_RAM, but it fails with some undeclared constants or something. I'm not in the mood to go driver hacking atm, but I'll look into it when I have some time. :D

Aearenda
January 31st, 2009, 10:37 PM
That's great, I'm sure people will find your Q-button program useful! The use of sudo that way isn't a complete security hole so long as the executable file belongs to root and is execute-only for ordinary users.

justnice980
January 31st, 2009, 11:16 PM
if you can find the time. i could really use you help in this issue. i am having similar issues in getting pen functionality. i followed the steps of this tutorial as best i could, but as i am new to ubuntu and the whole linux community i fear i may have done something wrong. i still have xp running on my machine so it's not a huge issue, but i would very much like to get full functionality if i could. thanks for your consideration in this matter. i'm sure you get many questions from noobtards such as myself, so any help at all would be greatly appreciated.

Aearenda
February 1st, 2009, 03:29 AM
justnice980: Welcome to Ubuntu! I'm happy to help, but I need you to tell us a bit more to get started. Don't worry about everything feeling awkward at first, Linux is not Windows and several things are quite different.

Start a reply to this message now, so you can fill in the answers as we go on.

First what version of Ubuntu do you have? You can check by pressing ALT and F2 to bring up the 'Run Application' box, and then typing (or copying and pasting)
gedit /etc/lsb-releaseand pressing <ENTER>. On mine it looks like this:
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.10
DISTRIB_CODENAME=intrepid
DISTRIB_DESCRIPTION="Ubuntu 8.10"The most recent is 8.10; tell us what version you have in your reply message. Close gedit without saving by pressing ALT and F4 or using the mouse.

Next, please tell us what version of wacom-tools is installed. You can do that this way:
1. Start 'Synaptic Package Manager' from the system->administration menu, and supply your password if asked.
2. In the 'Quick Search' box type wacom and press <Enter> - it should show two packages in the top-right pane. If not,
2.1. Click once on the 'search' button.
2.2. Type wacom and press <Enter>
4. You should find that the wacom-tools and xserver-xorg-input-wacom packages are showing in the top-right pane. Do they both have a green box next to them, indicating that they are installed?
5. What is the version number showing as installed and as latest for each of the two packages? The version for Ubuntu 8.10 is currently 1:0.8.1.4-0ubuntu3 for both. If you have different versions, or if either package is not installed, please tell us in your reply.
6. Close Synaptic - don't change anything in there yet.

Finally, please post the contents of your /etc/X11/xorg.conf file, like this:
1. Press ALT and F2 and then type or paste the following command, followed by <ENTER>
gedit /etc/X11/xorg.conf
2. In the text editor, press CTRL and A to select all, then CTRL and C to copy it.
3. In your reply to this message, click on the 'quote' button above the reply box (it looks like a cartoon speech balloon) and then press CTRL and V to paste the file contents between the markers that appeared.
4. Now switch back to the text editor and press ALT and F4 to close it.

Then post your reply, and we'll see what needs to be done next!

MyR
February 2nd, 2009, 04:08 AM
Hello!
So no one has been able to get the soft buttons working?
I patched the drivers following the instructions on the wiki mentioned above with no luck.
I know I can map the side buttons or add a launcher, but those aren't as "cool".
Thanks

mr_deimos
February 14th, 2009, 08:56 PM
It used to work like that in Windows XP for me (I have had a TC1100 from new, in 2004), until one day the nvidia drivers got updated, and after that it did strange things like start up normal, rotate when it shouldn't, and then take ages to rotate back again when told to. I gradually began to hate it, and then I discovered Ubuntu :-)

AFAIK, nobody has ever worked out how to detect the hardware rotation state automatically in Linux, either from the docking station or from the keyboard. If we could, then it would be easy to do the script automatically.

How exactly did the automatic rotating work in windows? Do you mean rotating to portrait mode after folding/detaching the keyboard and using the tablet in slate mode, and rotating back to landscape as soon as you opened up the keyboard? Or was it rotating based on device's actual orientation, as modern pda-phones do?

If you mean the second option, there is a dirty way of detecting if tc1100 is in laptop or slate mode. As you might have noticed, the tc1100 fan runs faster when you use it in slate mode. That's because it has hardcoded thermal thresholds that are different for laptop and slate mode. By reading the /proc/acpi/thermal_zone/THRM/trip_points file you can determine this thresholds, and therefore the state of the keyboard.
A script/daemon that would periodically monitor these values and rotate the screen accordingly shouldn't be hard to make.
I found this info by looking for some workaround preventing the fan from speeding up:
http://tabletpcbuzz.com/showpost.php?p=203353&postcount=19

Personally, i don't really like this feature and i'll probably hack the keyboard to disable the position sensor and have the fan run a bit slower in slate mode. But if someone likes the auto rotation and isn't bothered by the fan, checking thermal trip points be the way to go.

And one more thing about rotation: there's a nice daemon written by author of easystroke (great gesture recognition software, highly recommended). It monitors current screen orientation and sets digitizer orientation and subpixel font smoothing (aka cleartype) mode appropriately (works only for gnome).
You can grab it here:
http://easystroke.wiki.sourceforge.net/TipsAndTricks (scroll down to "Don't use Rotate Scripts" section). The great advantage of using it is that the digitizer will always be properly aligned, no matter how you rotated the screen (by a script, by xrandr panel applet, by hand from console).
I think i'll try to modify it a bit to make it remember digitzier calibration data for every screen orientation, since it seems that wacom driver doesn't support different calibration for portrait and landscape modes (or am i wrong?).


Anyway, thanks to everyone contributing to this tread - it was really helpful :D And here's a small contribution from me, a simple wireless toggle script. I have it inserted as a a launcher in gnome-panel:


#!/bin/bash
WIRELESS_STATE=`lsusb|grep Bluetooth`
if [ "x$WIRELESS_STATE" == "x" ] ; then
echo "WiFi Off, turning on"
echo 1 > /sys/devices/platform/tc1100-wmi/wireless
else
echo "WiFi On, turning off"
echo 0 > /sys/devices/platform/tc1100-wmi/wireless
fi

As you might have noticed, doing cat /sys/devices/platform/tc1100-wmi/wireless returns 0 no matter if wireless is on or off, so it's not possible to determine wireless state with that. But disabling wifi also disables bluetooth, and we can detect this easily :D I guess it's a better solution than doing a toggle based on existence of some file, as proposed earlier in this tread.

Aearenda
February 14th, 2009, 10:47 PM
How exactly did the automatic rotating work in windows? Do you mean rotating to portrait mode after folding/detaching the keyboard and using the tablet in slate mode, and rotating back to landscape as soon as you opened up the keyboard? Or was it rotating based on device's actual orientation, as modern pda-phones do?
It was the keyboard way. I experimented years ago with the connector link that thread discusses but in the end didn't bother with it as my fan was relatively quiet. I was still using Windows then.

Thanks for that great info about detecting the fan settings and the wireless - it's much better than what I was doing! Though I still think I need a flag file for persistence of the wireless on/off setting across reboots.

mr_deimos
February 14th, 2009, 11:40 PM
It was the keyboard way. I experimented years ago with the connector link that thread discusses but in the end didn't bother with it as my fan was relatively quiet. I was still using Windows then.

Ok, thanks for the info. I was beginning to think that maybe threr was another way of detecting rotation and i just screwed up something with windows drivers (using dual boot) ;)



Though I still think I need a flag file for persistence of the wireless on/off setting across reboots.
But why? If you boot up with wireless disabled, bluetooth will be disabled as well and 'lsusb|grep Bluetooth' command will return an empty string. So you can use bluetooth's presence as a flag. Not very clean solution, but does the trick ;)
I actually came up with it, because a simple flag file wasn't enough - if i changed wireless setting in windows, the toggle script needed to be run twice, since the flag wasn't matching real wireless state.

Aearenda
February 15th, 2009, 03:00 AM
Hmm, I think it might depend on which drivers are in use, but I'm sure I found the wireless was getting switched on automatically on reboot in Intrepid, regardless of its previous state. Maybe I'm wrong. I don't dual boot so it isn't an issue for me.

EDIT: I just tried it again, and the state does persist over a reboot using ath_pci or ndiswrapper. Maybe it was the ath5k driver that reset it every time, or maybe I was dreaming it. I've modified my script to use lsusb to detect the state and it works fine.

MyR
February 18th, 2009, 09:11 AM
I got the wireless to turn on automatically after a resume from suspend.


sudo gedit /etc/pm/sleep.d/15-TurnWirelessOn
and enter:

sleep 1
echo 1 > /sys/devices/platform/tc1100-wmi/wireless
save and exit
then

sudo chmod +x /etc/pm/sleep.d/15-TurnWirelessOn
and you should be all set

Thanks everyone! Your posts have been helpful.

mr_deimos
March 2nd, 2009, 12:26 PM
Hello!
So no one has been able to get the soft buttons working?
I patched the drivers following the instructions on the wiki mentioned above with no luck.
I know I can map the side buttons or add a launcher, but those aren't as "cool".
Thanks

I got these screen buttons to work. I just needed to follow instructions in post #1 and #4 of this tread:
http://ubuntuforums.org/showthread.php?p=3672701#post3672701
Are you sure you patched both src/xdrv/wcmCommon.c and src/xdrv/wcmISDV4.c?
What exactly doesn't work for you?

MyR
March 3rd, 2009, 09:00 AM
I got these screen buttons to work. I just needed to follow instructions in post #1 and #4 of this tread:
http://ubuntuforums.org/showthread.php?p=3672701#post3672701
Are you sure you patched both src/xdrv/wcmCommon.c and src/xdrv/wcmISDV4.c?
What exactly doesn't work for you?

I followed the new instructions on the wiki (http://wiki.linuxquestions.org/wiki/Tc1100#Stylus_buttons). So now they work perfectly! Awesome! I can delete my xournal and rotate launchers.

Now.. any way to get the SD card reader working? ;]

peace

cstorozuk
March 4th, 2009, 05:40 PM
Hi, don`t know if I should start a new post, but I was hoping you could help me with my TC1000. I can`t seem to find a USB flash drive boot option in my Select Boot Device window. The items available are:
Removable Devices
ATAPI CD-ROM
Hard Drive

Thanks,
Chris

MyR
March 4th, 2009, 07:57 PM
I can`t seem to find a USB flash drive boot option in my Select Boot Device window. The items available are:
Removable Devices
ATAPI CD-ROM
Hard Drive

The USB drive is a "removable device".

peace

Aearenda
March 4th, 2009, 09:58 PM
I have a memory of failing to boot a TC1000 (not TC1100) from a USB flash drive - it would only boot from a Compact Flash device in the CF socket, or from a USB CD drive. This would be a BIOS limitation. Maybe it didn't apply to all BIOS versions, and maybe I'm wrong.

On a different note, my 5-year-old TC1100 is failing - the Nvidia GPU is not found on (re-)boot when it is warm, and the BIOS screen is corrupted along with all later text-mode screens. This is the second TC1100 I've had that did this. I suspect I'm going to have to retire it :-(

bigbamboo
March 22nd, 2009, 03:50 AM
Hi everybody,
I'm a beginner with Ubuntu and I have a problem in configuring 2 things:
1. when I try to install the software to handle the Q-Key, I get the following error:

ifdown: failed to open statefile /var/run/network/ifstate: Permission denied
sh: cannot create /proc/acpi/wmi/WMID/bluetooth: Directory nonexistent
it seems I don't have the tc1100-wmi 'module but I don't Know How to get it (I'm on Ubuntu 8.10)
2. I have compiz running so xbindkeys doesn't work:

displayName = :0.0
rc file = /home/eugenio/.xbindkeysrc
rc guile file = /home/eugenio/.xbindkeysrc.scm
getting rc guile file /home/eugenio/.xbindkeysrc.scm.
WARNING : /home/eugenio/.xbindkeysrc.scm not found or reading not allowed.
3 keys in /home/eugenio/.xbindkeysrc

min_keycode=8 max_keycode=255 (ie: know keycodes)
"/usr/bin/rotate"
m:0x0 + b:4 (mouse)
"xournal"
m:0x0 + b:5 (mouse)
"cellwriter"
m:0x0 + b:6 (mouse)
starting loop...

*** Warning ***
Please verify that there is not another program running
which captures one of the keys captured by xbindkeys.
It seems that there is a conflict, and xbindkeys can't
grab all the keys defined in its configuration file.

but I don't know how to configure Compiz to make the pen-button work.

Any advice?

thanks

E. .

MyR
March 22nd, 2009, 06:18 AM
Hi everybody,
I'm a beginner with Ubuntu and I have a problem in configuring 2 things:
1. when I try to install the software to handle the Q-Key, I get the following error:

ifdown: failed to open statefile /var/run/network/ifstate: Permission denied
sh: cannot create /proc/acpi/wmi/WMID/bluetooth: Directory nonexistent
it seems I don't have the tc1100-wmi 'module but I don't Know How to get it (I'm on Ubuntu 8.10)
2. I have compiz running so xbindkeys doesn't work:

displayName = :0.0
rc file = /home/eugenio/.xbindkeysrc
rc guile file = /home/eugenio/.xbindkeysrc.scm
getting rc guile file /home/eugenio/.xbindkeysrc.scm.
WARNING : /home/eugenio/.xbindkeysrc.scm not found or reading not allowed.
3 keys in /home/eugenio/.xbindkeysrc

min_keycode=8 max_keycode=255 (ie: know keycodes)
"/usr/bin/rotate"
m:0x0 + b:4 (mouse)
"xournal"
m:0x0 + b:5 (mouse)
"cellwriter"
m:0x0 + b:6 (mouse)
starting loop...

*** Warning ***
Please verify that there is not another program running
which captures one of the keys captured by xbindkeys.
It seems that there is a conflict, and xbindkeys can't
grab all the keys defined in its configuration file.

but I don't know how to configure Compiz to make the pen-button work.

Any advice?

thanks

E. .
1. in a terminal enter:

gksu gedit /etc/modules
and on a new line add:

tc1100-wmi
then close and save
2. Turn off compiz because you don't really need it? (gasp) Or maybe you could use compiz to launch your apps instead of xbindkeys.
sudo aptitude install compizconfig-settings-manager
then system > preferences > compizconfig.
next general options > commands > key bindings.
enter the command such as cellwriter. This is just a suggestion; I don't use compiz on the tablet.

peace

bigbamboo
March 22nd, 2009, 11:40 AM
thanks MyR for the quick reply,

1. I already added the line but nothing changed, any further advice?

2. I'm compiz-addicted :) is it unstable on the tablet? I tried to add custom Key-bindings but I don't Know the correct values for pen-buttons (the key combination I have to bind with cellwriter, xournal and rotation script)


P.S. cellwriter Keeps asking me for training everytime I reboot, is there a way to save the training?

MyR
March 22nd, 2009, 06:05 PM
thanks MyR for the quick reply,

1. I already added the line but nothing changed, any further advice?

2. I'm compiz-addicted :) is it unstable on the tablet? I tried to add custom Key-bindings but I don't Know the correct values for pen-buttons (the key combination I have to bind with cellwriter, xournal and rotation script)


P.S. cellwriter Keeps asking me for training everytime I reboot, is there a way to save the training?

1. in a terminal type: modprobe tc1100-wmi
to see if you have the module
then type: lsmod | grep tc1100
to see if it is loaded

2. I just tested it out and the stylus buttons work perfectly with compiz without needing to configure it. Maybe you have some plugins enabled that I don't. So I can't help you there, sorry

cellwriter: make sure you trained all the characters

peace

bigbamboo
March 22nd, 2009, 07:39 PM
1. in a terminal type: modprobe tc1100-wmi
to see if you have the module
then type: lsmod | grep tc1100
to see if it is loaded

2. I just tested it out and the stylus buttons work perfectly with compiz without needing to configure it. Maybe you have some plugins enabled that I don't. So I can't help you there, sorry

cellwriter: make sure you trained all the characters

peace

well,
it seems that I managed to fix tc1100-wmi module (many many thanks for your support), now I can use Tabatha and q.py.

I still can't bind stylus buttons to something, I turned off Compiz but still the message is that there's "something else" is taking control of that buttons.
Moreover, I can't even bind the "Q" button (same error).

Is there any way I can check what is happening? there are no clues either on "top" command result and on "ps -ef|grep bind" command.

PS cellwriter also fixed!

bigbamboo
March 22nd, 2009, 08:48 PM
I made a little step ahead in figuring out what is happening.

I installed xbindkeys-config to create the xbindkeysrc file instead of writing it by hand (literally!).

Now the "q" key works (with Compiz running!), the correct configuration line is:


# Q-key
"path/to/script/"
m:0x0 + c:156
XF86Launch1


and not just "c:156"

I can't configure the stylus buttons because as soon as I try to get the configuration code by clicking on "get key" button (as made with the "Q-key") the application crashes with a IO error.

Can you post your .xbindkeysrc file?

MyR
March 22nd, 2009, 09:02 PM
my .xbindkeysrc looks like this:

"rotate"
b:30
"xournal"
b:31
"cellwriter"
b:32

bigbamboo
March 22nd, 2009, 09:54 PM
d'oh!

I have to give up.

alastair.mac
March 26th, 2009, 01:12 PM
the trick is: xbindkeys-config screws up your manualy edited xbindkeysrc.

so use xbindkeys-config to set the Q key, save and exit, then use gedit to add the lines for the screen buttons.


Save a backup of xbindkeysr as xbindkeys-config will trash it if you use it again for anything else.

xobx
March 27th, 2009, 04:55 PM
Hello
I am not using Linux and my English is very bad.
Is there a ready-made image of Ubuntu for HP TC1100?
I use it to read PDF and surfing.

Translate wit GOOGLE

xobx
March 29th, 2009, 09:18 PM
No One??

MyR
March 29th, 2009, 09:21 PM
Hello
I am not using Linux and my English is very bad.
Is there a ready-made image of Ubuntu for HP TC1100?
I use it to read PDF and surfing.

Translate wit GOOGLE

I doubt it

xobx
March 29th, 2009, 10:20 PM
Why not?
If there are many to work with but do not create themselves.
It would be very nice. :P
Install is not difficult, but the Wacom digitizer with the keys is difficult, when dealing with the terminal can not start.
Windows users also:(

pvhoward
March 30th, 2009, 12:44 AM
Hey guys, can anyone offer any help regarding the tc1000?

Aearenda
March 30th, 2009, 03:11 AM
I used to use a TC1000 before I got my TC1100, which is itself now retired, since it has become impossible to restart without losing access to the Nvidia hardware when warm.

I have tried Debian on the TC1000, and Gentoo, and most recently an Ubuntu Intrepid minimal installation with LXDE; but there is no persistent translation service for the Crusoe processor, as there is in Windows, and as a result it is very slow to start up, and to start programs such as Firefox.

pvhoward
March 30th, 2009, 03:37 AM
ya Im currently successfully running Ubuntu 8.10 and it is very slow (about 5.5 min boot time when my main laptop does hardy heron in about 30-45 seconds),but I was hoping you, or someone else could help me set it up so that it works in either ubuntu or xubuntu, but im not opposed to going what ever distro would work thanks for the reply

Aearenda
March 30th, 2009, 04:41 AM
Take a look at the LXDE instructions at http://ubuntu-lxde.wikidot.com/intrepid. It uses a lightweight desktop environment called LXDE instead of GNOME but underneath it is Ubuntu.See http://www.lxde.org/ for more details of LXDE.

I use this on the TC1000, and it is much faster than Gnome or Xubuntu. I don't use the built-in wireless on the TC1000, since it is not capable of 54g working. I have never been able to get the TC1000 pen working either.

Once installed, I recommend using hibernate rather than shut-down to speed up your power-on process - it works on mine, but I have to pull the PCMCIA wireless network card out and plug it back in to get it to work on restart.

Overall, though, I'm not sure it's all worth the bother, unless you enjoy trying things like LXDE!

pvhoward
March 30th, 2009, 06:34 PM
ahhh... ill give it a try thanks, i appreciate it

pvhoward
March 30th, 2009, 08:59 PM
Hey, when the instructions that you linked me to say...

"now we have to edit the slim settings, just as before. However, it can be done without having to log in at all:

sudo nano /etc/slim.conf
nano ~/.xinitrd "

where does the "nano ~/.xinitrd" command go?

Aearenda
March 30th, 2009, 10:35 PM
Both of these steps assume that you are still using the console from which you did the installation of the lxde packages earlier. You can't use leafpad since there is no previously-installed GUI in the Intrepid instructions, unlike the Hardy instructions. After opening nano on /etc/slim.conf you should make the change from 'xfce4-session' to 'startlxde' as described on the linked page http://ubuntu-lxde.wikidot.com/slim (but nano uses different keystrokes from leafpad - F6 or CTRL and W are used for searching, and F2 (or CTRL and X) then Y and ENTER to save); then you save that file, and do the second command, which creates ~/.xinitrc (note, not ~/.xinitrd) containing the one line 'exec startlxde'. I hope this makes sense!

pvhoward
March 31st, 2009, 06:26 AM
excellent thanks!... I have finished the LXDE install, I really like it, except that I cannot get my wireless working, can you offer any tips?

Aearenda
March 31st, 2009, 09:08 AM
The TC1000 wireless is an Atmel device I think - it needs firmware. I remember getting it going and then giving up on it since it is so slow (10Mb/s max, not 54), and it always hung the machine on shutdown. I recommend you get an external wireless device (USB or PCMCIA), or buy a dead TC1100 on ebay and use the mini-pci wireless from that (which does work in a TC1000 - I've done it), or indeed get another wireless card from almost any source!

PS - you could try using ndiswrapper to run the wireless using the Windows XP driver, downloaded from HP's website. But again, it's slow, and it only does WEP not WPA, so I suggest you ditch the internal wireless.

pvhoward
March 31st, 2009, 04:22 PM
Thanks man, I appreciate it.

mr_deimos
April 1st, 2009, 12:56 AM
I recommend you get an external wireless device (USB or PCMCIA), or buy a dead TC1100 on ebay and use the mini-pci wireless from that (which does work in a TC1000 - I've done it), or indeed get another wireless card from almost any source!


Just run a search for intel pro wireless cards on ebay, they're 100% supported by ubuntu (and they're really solid hardware too):
http://shop.ebay.com/?_from=R40&_trksid=p3907.m38.l1313&_nkw=intel+pro+wireless+mini-pci&_sacat=See-All-Categories
You can get them as cheap as 9$ including shipping. TC1100 uses 2100 model, but if you get the newer 2200 - that's even better. Just make sure it's mini-pci, not mini pci-e

Aearenda
April 25th, 2009, 04:39 AM
Just FYI - I did a fresh install of 9.04 (Jaunty) on my crippled TC1100, and it is working well - much faster start up.

I installed the Nvidia driver, copied my xorg.conf unchanged from Intrepid to get the tablet to work, and I installed the latest madwifi wireless driver from source. I added tc1100-wmi to /etc/modules. It still takes a long time to associate on wireless. Since I no longer use this away from home (it will not restart properly when warm - Nvidia goes AWOL), I didn't bother with the side buttons.

Rayaz
April 25th, 2009, 08:37 PM
Hi all,

I've just installed Jaunty on my TC1100 and cannot seem to get the screen rotation going properly. With a rotate script I can get the screen to rotate by not the cursor nor stylus. Any help would be much appreciated.

Regards
Rayaz

Favux
April 25th, 2009, 09:23 PM
Hi Rayaz,

The problem is that the callout in the 10-wacom.fdi file returns HAL/D-BUS names that are not recognized by linuxwacom. So xsetwacom doesn't work. No rotation of wacom devices or wacomcpl. Rec discovered this and came up with a script to fix it here: http://ubuntuforums.org/showthread.php?t=1122952

If you read Jaunty Users near the top here you'll see there seems to be two ways to go. One is to use rec's script. The link takes you to a HOW TO at post #104 on page 11: http://ubuntuforums.org/showthread.php?t=1038949 Since you have a serial tablet you shouldn't need to worry about the wacom.ko stuff.

Timo Aaltonen (who patched the "native" Jaunty 0.8.2-2 linuxwacom to work with HAL and Xserver 1.6) also has a ppa for xorg-xserver where he may have fixed the problem. It's been up a few days so who knows when it'll be in an update.

bigbamboo
April 27th, 2009, 03:21 PM
Hi Rayaz,
I've just installed Ubuntu 9.04 on my TC1100 to get rid of some issues with stylus button and a PCMCIA Aircard.

The rotation works properly, this is the code I used (get from internet):


IFS=$'\n'
DEVS=`xsetwacom list dev | \
sed -e 's/ *$//g' -e 's/\(.*\) .*/\1/g' -e 's/ *$//g'`
ROTATION=`xrandr --verbose --query | \
grep 'default connected' | \
sed -e 's/^.*(.*) \(.*\) (.*).*$/\1/'`

# Rotate all detected wacom devices to the given direction.
function rotate_devices()
{
for DEV in $DEVS; do
xsetwacom set $DEV rotate $1
done
}

if [[ ! $ROTATION == "normal" ]]; then
xrandr -o normal
rotate_devices none
else
xrandr -o left
rotate_devices ccw
fi
exit 0


Initially I wasn't able to make the sylus rotate, but this was because the stylus wasn't recognized as mouse device in xorg.conf file.

here's the code I added to xorg.conf:


Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Type" "stylus"
Option "Device" "/dev/input/wacom"
#Option "Device" "/dev/ttyS0"
Option "ForceDevice" "ISDV4"
Option "Button2" "3"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "stylus" "SendCoreEvents"
EndSection

A problem I have is that the stylus have to be activated by terminal command:

echo "1" > /dev/input/wacom
So I'm trying to set this command on system startup (but I don't know how).

Another problem I have with 9.04 release is that xbindkeys doesn't work at all, so I'm still not able to have the stylus and Q buttons working.

@Aearenda
I didn't install the madwifi wireless driver since the wi-fi connection is fast and smoothly working, do you suggest to install this driver anyway?

Aearenda
April 27th, 2009, 11:45 PM
If your wi-fi is working, don't mess with it! I installed the latest to see if it would associate faster, and it doesn't.

You can add system startup commands to /etc/rc.local - but I didn't have to do anything to make the stylus work apart from the xorg.conf change.

MyR
April 28th, 2009, 02:02 PM
I added the command to /etc/rc.local and it doesn't work - I still have to manually enter it.

Aearenda
April 29th, 2009, 12:36 AM
Maybe doing it in rc.local is too soon in the startup process - try making a file in your home directory called something like .start-wacom, like this:

#!/bin/bash
echo "1" > /dev/input/wacom
Make it executable with
chmod u+x .start-wacom
Then add it to your session start programs by creating an extra entry under system->preferences->Startup applications

MyR
April 29th, 2009, 12:48 AM
try making a file in your home directory called something like .start-wacom

That did it! Thanks! Don't know why I didn't think of that..

peace

olaoni
April 29th, 2009, 12:54 AM
Hi Aearenda,

I did a fresh install of ubuntu 9.04, but unlike your success story I can't get my stylus side buttons to work any longer.

Before I did this new install I had everything working as clock work but now I can't get any of the tablet function on my machine.

Unfortunately I did not save my previous xorg.conf file. So I had to edit the current one with the following entry


Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Type" "stylus"
Option "Device" "/dev/input/wacom"
#Option "Device" "/dev/ttyS0"
Option "ForceDevice" "ISDV4"
Option "Button2" "3"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "stylus" "SendCoreEvents"
EndSection

When I restart my machine, the screen remains blank, and does not give me the opportunity to log in.

To continue I have to shut down and restart in "recovery mode" then remove the new entry from the xorg.conf file.


Any pointers will be appreciated.

Aearenda
April 29th, 2009, 07:43 AM
By "stylus side buttons" do you mean the three buttons on the front of the tablet, or the right-click button on the side of the stylus?

Assuming you mean the three on the front, I have never bothered with them - they needed patches to the wacom driver - so I can't help there, sorry.

Right-clicking with the stylus works fine for me. You need a complete xorg.conf file - I think yours is missing some bits. Here is mine:
Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "Button2" "3" # This is the line you need for the stylus button to right click
EndSection
Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "Button2" "3" # This is the line you need for the stylus button to right click
EndSection


Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
Option "RandRRotation" "on"
# Next line was "1", SET TO "0" TO SEE IF STANDBY WILL WORK
Option "NvAGP" "0"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
EndSection

Section "ServerFlags"
Option "AutoAddDevices" "false"
EndSection

Section "Extensions"
Option "Composite" "Enabled"
EndSection
This was copied straight from Intrepid.

olaoni
April 29th, 2009, 08:34 AM
Aearenda,

Thanks the xorg.conf file you posted. The stylus is now working properly again.

Regards

Aearenda
April 29th, 2009, 12:12 PM
Glad to hear it! I just wish my TC1100 was still reliable :-(

bigbamboo
April 29th, 2009, 04:24 PM
Hi olaoni,
in ubuntu 8.10 it was possible to use the stylus buttons by patching the wacom tools 0.8.1.4
(http://wiki.linuxquestions.org/wiki/Tc1100#Stylus_buttons)

By the way I wasn't able to patch the new wacom tool I use in ubuntu 9.04, so the buttons still doesn't work.

Did you find a solution?

MyR
April 29th, 2009, 05:00 PM
Hi olaoni,
in ubuntu 8.10 it was possible to use the stylus buttons by patching the wacom tools 0.8.1.4
(http://wiki.linuxquestions.org/wiki/Tc1100#Stylus_buttons)

By the way I wasn't able to patch the new wacom tool I use in ubuntu 9.04, so the buttons still doesn't work.

Did you find a solution?

I just patched the new wacom-tools without any trouble. The only difference is the version number (from 0.8.1.4 to 0.8.2.2) used in the commands. The patch is exactly the same.

peace

olaoni
April 29th, 2009, 06:34 PM
Hi bigbamboo,

In ubuntu 8.10 I did have the stylus buttons working (cellwriter, xournal and screen rotation).
To get these buttons to work. The process involved downloading and compiling wacom source. The version I built was linuxwacom-0.8.2-2.
After the compilation is successful, copying the wacom_drv.so generated file to
/usr/lib/xorg/modules/input/wacom_drv.so ( I have not tried this for 9.04 yet).
I will not be able to test this for the next 6 hours or so. But I will keep you posted on my progress. See http://http://ubuntuforums.org/showthread.php?p=3672701#post3672701

bigbamboo
April 30th, 2009, 03:03 PM
MyR,
I tried to patch the new wacom-tools but the process ends up in a bunch of errors, maybe I miss something.

I'll try again.

bigbamboo
April 30th, 2009, 04:06 PM
this is the error I get when trying to compile wacom-tools-0.8.2.2 :

admin@tc1100:/usr/src/wacom-tools-0.8.2.2/linuxwacom$ sudo patch -p1 < ~/wacom.patch
patching file src/xdrv/wcmISDV4.c
Hunk #1 FAILED at 231.
1 out of 1 hunk FAILED -- saving rejects to file src/xdrv/wcmISDV4.c.rej

the wacom.patch file I used is attached.

olaoni
April 30th, 2009, 10:32 PM
Hey bigbamboo,

I am not an expert at building source, but I did manage to build the wacom-tools-0.8.2.2 driver.

I have attached to this reply my wcmISDV4.c file which I used to build my source.

I have renamed the file extension to a .txt to allow attaching to this reply I hope it helps.

MyR
May 1st, 2009, 01:07 AM
bigbamboo
The patch you used is correct. Sorry, I'm not sure what would cause that error. One difference is that I upgraded from 8.10 rather than freshly installing 9.04. If something goes wrong you can start over by deleting the source and starting again from the beginning:
cd /usr/src
sudo rm -r wacom*
sudo rm xserver*

Before I ran the commands I switched to root using:
sudo su
because nearly all of them need to be run as root.

One last thing: I'm not sure the wiki mentions but you need build-essential installed.
sudo aptitude install build-essential

hope this helps. peace

mu3en
May 2nd, 2009, 05:54 AM
fresh install of Jaunty actually does work out of the box. There are a couple of caveats though, as noted in the following entry.
https://bugs.launchpad.net/ubuntu/+source/wacom-tools/+bug/358643
everything needed to get fully functional should be there. have not patched the wacom driver for stylus buttons but according to posts on this page, should not be an issue.
hope that gets everyone up & running.

ishtob
May 22nd, 2009, 01:26 PM
i got devscript and the debuild command worked like a charm. XEV is now reading the 3 buttons.

I am having issues with the screen rotation, it only rotates the screen, but not the stylus.
I think the problem is with my xorg.conf, i can't add the line:

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
EndSection

because that will cause the table to get stuck in a virtual terminal and unable to start X with the /etc/ini.d/kdm restart

help!

mr_deimos
May 29th, 2009, 12:00 AM
i got devscript and the debuild command worked like a charm. XEV is now reading the 3 buttons.

I am having issues with the screen rotation, it only rotates the screen, but not the stylus.


It's a normal behavior. screen rotation is done by xrandr and the digitizer rotation is done by wacom-tools. So whenever you rotate the screen, you also have to notify the wacom driver about this. One way is to create a script that will both rotate the screen and digitizer. But it will only work if you only rotate the screen using this script. If you use something else (like a gnome panel applet), you will once again have screen and digitizer in different orientations.
Much better solution is a simple daemon monitoring current screen orientation and setting digitizer orientation accordingly. This way the screen and cursor will always stay aligned, no matter how the screen got rotated.
There's a nice example of such a daemon written by author of easystroke, see here (scroll down to "don't use rotate scripts" section):
http://easystroke.wiki.sourceforge.net/TipsAndTricks
Just compile the rotate.c program and add it to your session startup programs.
One feature i really miss from it is using different calibration data for portrait and landscape modes. I hacked this daemon a bit to support such a feature, but it's done in such a way that it's not even worth posting :P I did it by (manually) creating two bash scripts, one setting calibration data for portrait mode, and the other for landscape. After rotating the digitizer, the modified daemon launches the proper (portrait or landscape) calibration script.
I tried to make it read and store calibration data before rotating so that you wouldn't have to create additional scripts manually, but you would only need to calibrate the screen in landscape mode, rotate, calibrate it again in portrait mode and rotate again. However i've been unsuccessful with that so far. Maybe someone more familiar with coding for linux than me will be able to develop something like that?

ishtob
June 8th, 2009, 09:46 PM
thanks, got the stylus buttons working and binded using xbindkeys. rotation also works thanks to that script :D

I do have one more question, what command do I use to bring up cellwriter's window? I tried in the .xbindlkeysrc


"cellwriter"
b:32

nothing happens, then I tried


"cellwriter --show-window"
b:32


no cellwriter poping up when the button is pressed.
I'm sure the buttons are working since the xournal and rotate scripts are working perfectly

MyR
June 9th, 2009, 12:50 AM
thanks, got the stylus buttons working and binded using xbindkeys. rotation also works thanks to that script :D

I do have one more question, what command do I use to bring up cellwriter's window? I tried in the .xbindlkeysrc


"cellwriter"
b:32

nothing happens, then I tried


"cellwriter --show-window"
b:32


no cellwriter poping up when the button is pressed.
I'm sure the buttons are working since the xournal and rotate scripts are working perfectly

Try entering "cellwriter" into a terminal and see if that works. Otherwise it will probably tell you what the problem is.

peace

ishtob
June 9th, 2009, 08:06 PM
looks like a reboot did the trick :P and just cellwriter works. I am wondering if there is a way so that if I press that button it will close cellwriter if its open

another thing, has anyone noticed that alignment of the stylus goes off on resume if you go on suspend to RAM in portrait mode? I tired using this script in /etc/acpi/resume.d/99-scripts.sh

#!/bin/bash

while true; do

## is X on?
display=`echo $DISPLAY`
## Check if it is detected
if [ "$display" = :0.0 ]; then

##get out of the loop
break
fi
done



else

sudo -u *username* $/home/andy/scripts/calibrate.sh &
exit 0
replaceing *username* with your username
calibrate.sh script:


#!/usr/bin/env bash

IFS=$'\n'
DEVS=`xsetwacom list dev | \
sed -e 's/ *$//g' -e 's/\(.*\) .*/\1/g' -e 's/ *$//g'`
ROTATION=`xrandr --verbose --query | \
grep 'default connected' | \
sed -e 's/^.*(.*) \(.*\) (.*).*$/\1/'`

# Rotate all detected wacom devices to the given direction.
function rotate_devices()
{
for DEV in $DEVS; do
xsetwacom set $DEV rotate $1
done
}

if [[ ! $ROTATION == "normal" ]]; then
xsetwacom set stylus BottomY 21240
xsetwacom set stylus BottomX 15980
xsetwacom set stylus TopY 0
xsetwacom set stylus TopX 0
xsetwacom set eraser BottomY 21240
xsetwacom set eraser BottomX 15980
xsetwacom set eraser TopY 0
xsetwacom set eraser TopX 0
else
xsetwacom set stylus BottomX 21240
xsetwacom set stylus BottomY 15980
xsetwacom set stylus TopY 0
xsetwacom set stylus TopX 0
xsetwacom set eraser BottomX 21240
xsetwacom set eraser BottomY 15980
xsetwacom set eraser TopY 0
xsetwacom set eraser TopX 0

fi
exit 0
(i use an eraser stylus so you can omit the set eraser lines if u dont own one.)

but for some reason, this script doesn't take effect I come back from suspend. and the alighnment of the stylus would still be off. I;m sure my calibrate script works because that's what I use to get my sylus synced again, but I have to do that manually after every resume. (i bound it to one of the side buttons) I am still trying to find a way to have it run automatically after each resume.... anyone has an idea on how to do this?

update: i took out the "else" after done in the resume script, and now it will aligh the stylus to the landscape position regardless of the orientation of the screan (yes, even if it's in portrait)

MyR
June 10th, 2009, 03:03 AM
I notice "andy" is the user hard-coded into the first script you have there. Not sure if that's you or the original author.

Alternately you can use the script from a related thread on launchpad:
wget http://launchpadlibrarian.net/23072115/03calibrate.sh
chmod +x 03calibrate.sh
sudo mv 03calibrate.sh /etc/pm/sleep.d/03calibrate.sh

I've been thinking about putting all the tweaks on a page on my website, but I don't know how many people it would help.

peace

ishtob
June 10th, 2009, 03:36 AM
andy is my user name :P looks like I missed it, giving your script a shot

Aearenda
June 10th, 2009, 07:03 AM
MyR said:
I've been thinking about putting all the tweaks on a page on my website, but I don't know how many people it would help.I think this would be a great idea - or on the Ubuntu Wiki, in the style of this one (https://help.ubuntu.com/community/AspireOne). This thread has grown too long to be easily understood. I just wish my poor old TC1100 still worked properly!

MyR
June 11th, 2009, 09:37 PM
Here's what I've put together:

Set up Ubuntu 9.04 on the HP TC1100 (http://www.unifyingtheory.net/tabletbuntu.html)

Enjoy!

josemasaga
June 12th, 2009, 07:18 PM
Thank you very much for this.
Now, I'll try to make it work...

kdub
June 14th, 2009, 03:31 PM
Thankyou for the excellent how-to - http://www.unifyingtheory.net/tabletbuntu.html - It took me a couple tries-I way over think stuff.:D
Quit thinking, followed the instructions and all is good!
agian thankyou,
ken

MyR
June 15th, 2009, 12:28 AM
If you rotate the screen & then suspend, the stylus calibration is off upon resume.
Does anyone have a workaround?

ishtob
June 15th, 2009, 03:13 AM
MyR, that's the same problem I am having

I think it is off because the screen is oriented as landscape when the resume scripts are running, and X starts later on in the resume chain of scripts... I have tried doing loops and delay scripts, but none of them seems to work, resume seems to just waits for that to finish and then keeps going.

does anyone knows how to make a script activate after X has started on resume?

update: I written a script that I can run by manually pressing a button after X has started... but this is still not a real solution.

MyR
June 15th, 2009, 03:16 AM
does anyone knows how to make a script activate after X has started on resume?

update: I written a script that I can run by manually pressing a button after X has started... but this is still not a real solution.

Any executable in /etc/pm/sleep.d/ should run upon resume.
Would you mind sharing your script?

peace

Aearenda
June 15th, 2009, 03:33 AM
I suspect the recalibration script has to run under your logged-on username, inside its X environment, rather than in root as it would from sleep.d. Some way to trigger that to occur from the restart code is needed.

Before my TC1100 died, I was mucking around with a polling script started at login, that tested the screen orientation using xrandr and reset the calibration to suit every few minutes. I didn't keep it after migrating to my netbook, sadly.