View Full Version : Steam, Crossover, and Sound

September 23rd, 2007, 03:03 PM
Help, I've gotten steam to work in crossover office, and even got team fortress 2 up and running, but I don't have sound! What should I do?

September 23rd, 2007, 03:08 PM
steam works fine for me, in WINE

September 23rd, 2007, 03:39 PM
Yes but he wants sound.

September 23rd, 2007, 03:50 PM
team fortress 2 doesnt even launch in wine, it instantly crashes. css works, but yet no sound.

September 23rd, 2007, 03:57 PM
got sound working in css with wine, but tf2 still doesnt launch. Also css looks like pure **** lighting wise and it crashed after a few minutes

September 23rd, 2007, 04:58 PM
Hm what version of WINE

September 23rd, 2007, 05:12 PM
Are you using OSS for your sound driver, or ALSA?

ALSA doesn't work (well or at all?) with CS:S.

September 23rd, 2007, 05:13 PM
alsa, where can i get OSS?

September 23rd, 2007, 05:21 PM
alsa, where can i get OSS?

You should just be able to run "winecfg" in the terminal. Then, open up the "Audio" tab. Uncheck the ALSA driver, and check OSS Driver.

Good luck, and I hope this helps!

September 23rd, 2007, 05:24 PM
no sound when I do that

September 23rd, 2007, 06:31 PM
no sound when I do that

Well, try following this guide:


If it still doesn't work, submit a bug and application data.

UPDATE: Hmm, looks like you're not the only one having this problem


September 23rd, 2007, 08:46 PM
no good,

on the second link he doesnt have sound at all, even with alsa. I have sound with alsa but its ****.

December 21st, 2007, 09:29 AM

I first got no sound in steam and steam apps. Afer I ran Crossover Office, I had no any system sounds.

Here is what I did:

in /home/youruser/cxoffice/bin
'click' cxsetup
then you see some entries of applications/games installed
click steam and 'configure'
there is something like 'load sound drivers' - and for me it was empty
--> click change
I have ALSA enabled first, so I put in first ALSA, then did it again with OSS
After that ALSA, OSS were my sound drivers.

I did this with any steam game too.

After starting up the game I had sound.

To get sound after stop playing steam and stopping steam I go to:

there I click cxreset --> choose allbottles --> reset

The above worked for me and I have system sound after playing steam games through cxoffice.

Hope it helps someone.

Best regards,