PDA

View Full Version : Connexió PC-Tv [no va fina]



prostata
September 17th, 2007, 09:55 AM
Bon dia:

Desprès de fer totes les proves amb la configuració de nvidia-settings, que hi han, encara no puc arreglar el problema de poder veure a la pantalla de la TV tota la imatge que si puc veure en la pantalla del PC.

Desprès de tots aquests dies de provar i provar no he aconseguit, fer un pas endevant.....si us plau podeu ajudar-me una mica més....gràcies

guillemsola
September 17th, 2007, 06:25 PM
Potser hauries de donar mes informacio. Esta clar q tens els drivers nvidia instalats pero se m'acud que potser no n'estas fent us d'ells i per aixo no actua nvidia-settings. Comprova-ho a sistema -administracio -controladors restringits que estiguin activats.

Tanbe podries adjuntar el resultat de lspci i potser el fitxer /etc/X11/xorg.conf.
Has probat a fer sudo dpkg-reconfigure nvidia..no alguna cosa com aquesta?

Salut

prostata
September 18th, 2007, 11:03 AM
Potser hauries de donar mes informacio. Esta clar q tens els drivers nvidia instalats pero se m'acud que potser no n'estas fent us d'ells i per aixo no actua nvidia-settings. Comprova-ho a sistema -administracio -controladors restringits que estiguin activats.

Si, estan activats

Tanbe podries adjuntar el resultat de lspci i potser el fitxer /etc/X11/xorg.conf.

lspci
josep@josep-desktop:~$ lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 741/741GX/M741 Host (rev 03)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO] (rev 25)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)
00:0a.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)

fitxer /etc/X11/xorg.conf.
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
Fontpath "/usr/share/fonts/X11/misc"
Fontpath "/usr/share/fonts/X11/cyrillic"
Fontpath "/usr/share/fonts/X11/100dpi/:unscaled"
Fontpath "/usr/share/fonts/X11/75dpi/:unscaled"
Fontpath "/usr/share/fonts/X11/Type1"
Fontpath "/usr/share/fonts/X11/100dpi"
Fontpath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
Fontpath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "es"
Option "XkbVariant" "cat"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
Identifier "nVidia Corporation NV34 [GeForce FX 5200]"
Driver "nvidia"
Busid "PCI:1:0:0"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "LCD72VM"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV34 [GeForce FX 5200]"
Monitor "LCD72VM"
Defaultdepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"
Inputdevice "stylus" "SendCoreEvents"
Inputdevice "cursor" "SendCoreEvents"
Inputdevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection


Has probat a fer sudo dpkg-reconfigure nvidia..no alguna cosa com aquesta?

josep@josep-desktop:~$ sudo dpkg-reconfigure nvidia
El paquete `nvidia' no está instalado y no hay ninguna información disponible.
Utilice dpkg --info (= dpkg-deb --info) para examinar archivos,
y dpkg --contents (= dpkg-deb --contents) para listar su contenido.
/usr/sbin/dpkg-reconfigure: nvidia no está instalado
josep@josep-desktop:~$


Salut

Això es tot el que tinc, si et fa falta més info, si us plau demana. Gràcies

guillemsola
September 18th, 2007, 09:11 PM
Ok, jo tinc un portàtil amb una nvidia i em funciona sense masses problemes. He mirat els teu xorg.conf i ho tens si fa o no com jo.

A mi em funciona amb sudo nvidia-settings. Suposo que has provat a exectuar això des de una tereminal no? Això si abans de executar això has de tenir conectat el cable de la tv-out per que detecti el segon monitor. Aleshores desde X server Dsiplay Configuration hi veuras dues pantalles que son les que tens per configurar i escollir. Arrives a veure tot això?

Si no has d'editar el xorg.conf a mà que és una mica rotllo per exemple com explica aquí

http://ubuntuforums.org/showthread.php?t=98456

Si has de modificar el xorg.conf recorda fer una còpia abans que corres el perill de remenar massa i perdre la configuració.

Respecte al sudo dpkg-reconfigure nvidia... els tres punts em refereia a que no se exactament com es deia el driver. Si fas tabulador t'ho completarà automàticament o et mostrara una llista d'opcions.
En aquest cas et mostraria
nvidia-glx nvidia-kernel-common

i podries probar a reconfigurar el nvidia-glx per si quelcom ha quedat malament.

Ja diràs i paciència o google que tot s'arregla.

Salut!

prostata
September 19th, 2007, 11:47 AM
Doncs fins ara el resultat continua sent "raro,raro,raro", mira el que em respon la consola quan faig:

josep@josep-desktop:~$ sudo nvidia-settings
/usr/share/themes/Blubuntu/gtk-2.0/gtkrc:169: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.

(nvidia-settings:9070): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

Què és això? :(

He seguit pas per pas totes les teves indicacions, veig les dues pantalles del Xserver Configuration, faig proves am la configuració Twin Wiew però sur tan sols mitja panatlla en vertical, si agafo la que diu Separate X Screen no surt res de res per la TV.

Bé continuaré i miraré per google i d'altres fòrums, ja que en aquests moments no sé que més fer....

salut