PDA

View Full Version : [SOLVED] Escriure accents amb l'AMSN



nickpage
August 19th, 2007, 05:12 PM
Hola companys,

tinc la versiˇ 7.04 d'ubuntu, i he instalat la versiˇ de l'aMSN 0.97.
Funciona molt be per˛ tinc l'inconvenient que no puc escriure accents ni els carÓcters š i ˝.

Hi ha alg˙ amb el mateix problema que ho hagi solucionat.

GrÓcies

papapep
August 19th, 2007, 07:13 PM
Sembla ser que Ús un problema ja detectat i que estÓ pendent de resoluciˇ en properes versions.

nickpage
August 19th, 2007, 08:30 PM
GrÓcies per la resposta....

esperarem a veure que passa en les noves versions.
De fet he perdut molt de temps aquest cap de setmana buscant la soluciˇ...

patrickfromspain
August 19th, 2007, 09:22 PM
es molt facil. Has de modificar l'arxiu langlist de l'amsn. Per veure on es, en una terminal:

sudo updatedb
locate langlist

Aquesta ultima ordre et dira on es, sera de l'estil de: /carpetes/share/amsn/langlist

gksudo gedit /......./share/amsn/langlist

i alla, busques:

<lang>
<langcode>ca</langcode>
<name>Catalan-Valencian (CatalÓ-ValenciÓ)</name>
<version>1.123</version>
<encoding>iso8859-1</encoding>
</lang>

i cambies l'iso8859-1 de l'encoding per utf-8

Guardes i reinicies l'amsn i ja hauria d'estar.

salut!

nickpage
August 20th, 2007, 09:57 AM
GrÓcies,

aquesta tarda ho provarÚ quan torni de la feina. Ja dirÚ si m'ha anat be o no.

Salut

nickpage
August 20th, 2007, 10:10 PM
Hola patrickfromspain,

doncs he provat com dius i continuo sense poder posar accents...:(

SeguirÚ investigant, si ho trobo ja us informarÚ

Salut i grÓcies

patrickfromspain
August 21st, 2007, 02:18 PM
proba aixo:

sudo locale-gen --purge

nickpage
August 21st, 2007, 10:25 PM
Doncs ho he provat i tampoc funciona.

GrÓcies per l'interŔs. ;)

pabloiran
August 24th, 2007, 09:55 PM
Passa't per acÝ i mira si et funciona el que comenten:

http://forum.somgnu.cat/viewtopic.php?f=5&t=532&p=2882&hilit=amsn#p2858

pespin
August 24th, 2007, 10:57 PM
Doncs sÝ, a mi em funciona, i sÝ, tambÚ tenia la 'versiˇ' valenciana activada.

Per a que funcionin els accents i '˝' abans haig de fer un


export LANG=ca_ES.UTF-8

i cˇrrer l'amsn des de la terminal.

Alg˙ pot explicar com es fa per a possar-ho de manera global i automÓtica?

nickpage
August 26th, 2007, 10:53 PM
Efectivament, si llanšo l'amsn pel terminal els accents funcionen perfectament... m'agradarÝa saber si hi ha alguna manera de fer-ho amb una llanšadora

Salut i grÓcies

patrickfromspain
August 27th, 2007, 02:26 PM
Perque no probeu a anar a Sistema -> Administracio -> Suport d'idioma i hi poseu Catalan (Spain)?

Si voleu fer la llanšadora.. feu una llanšadora nova i poseu-hi de comanda export LANG=ca.ES.UTF-8 && amsn o el que sigui. O a /usr/local/bin/amsn-cat hi poseu:

#!/bin/bash

export LANG=ca_ES.UTF-8
amsn

i feu una llanšadora a amsn-cat

salut!

pespin
August 27th, 2007, 02:41 PM
Hmm a mi m'intereseria mÚs saber quina ordre o quin arxiu haig d'editar per a deixar el ca_ES.UTF-8 i treure'm el ca_ES.UTF-8@Valencia

lluisanunez
August 27th, 2007, 04:07 PM
I no pots instaŀlar Language-suport-ca, assignar-lo per defecte i desinstaŀlar el valenciÓ?

pespin
August 27th, 2007, 04:31 PM
En aquest ordinador tinc el KDE, i no veig a cap lloc que posi ValenciÓ, nomÚs posa CatalÓ a la configuraciˇ d'idiomes.

i el paquet "language-support-ca" ja el tinc instalĚlat :)

Per aix˛ preguntava on parava l'arxiu de configuraciˇ, perquŔ suposo k nomÚs serÓ canviar la variable $LANG

patrickfromspain
August 27th, 2007, 09:25 PM
/etc/default/locale

/etc/environment

igual has de reinicia per a que els canvis facin efecte, o al menys entra i sortir de la sessiˇ.

salut!

nickpage
August 27th, 2007, 10:14 PM
Hola,

als arxius que comenta patrickfromspain tinc el segŘent:

LANG="ca_ES.UTF-8@valencia"

en canvi al suport d'idioma tinc posat CatalÓ(Espanya).

Per tenir el catalÓ que no sigui valenciÓ com ho puc canviar.

GrÓcies

patrickfromspain
August 27th, 2007, 10:26 PM
canviant ca_ES.UTF-8@valencia per ca_ES.UTF-8

nickpage
August 28th, 2007, 08:10 PM
Solucionat!!!!!!!

Efectivament, he editat els arxius
/etc/default/locale
/etc/environment

i he substitu´t ca_ES.UTF-8@valencia per ca_ES.UTF-8

he re iniciat el PC i el amsn funciona correctament :popcorn:

la pregunta que em queda es per quŔ tenia posat valenciÓ???:confused:

GrÓcies a tots per la vostra ajuda.

CarlesOriol
August 29th, 2007, 07:47 AM
En Toni Hermoso ha corretgit aquest error de les variants del ca_XX a les X. Crec que a la propera versiˇ ho tindrem arregladet.