PDA

View Full Version : [SOLVED] steam on wine crash on 26% fix has no effect.



nickajeglin
August 10th, 2007, 07:25 PM
I've installed the latest version of wine and steam, and also the mozilla activex thingee from transgaming. I've tried the SteamTemp.exe fix a million times and still get the exact same problem, error message and all. The message is "steam is already running. you may only run one copy of steam at a time." If anyone could help me it would be greatly appreciated.

cogadh
August 10th, 2007, 07:27 PM
Someone alse may have a better idea, but the only way I could get past this is to copy a Steam installation from a Windows machine over my Wine installation of Steam, then delete the ClientRegistry.blob file and launch Steam. It recreates the blob file and runs normally at that point.

nickajeglin
August 10th, 2007, 07:30 PM
that's a great idea, because the one on my windows machine is already updated. :) I'll try it. and thank you for being so amazingly fast.

nickajeglin
August 11th, 2007, 01:00 AM
Hmm. no dice. Exact same error as before. Nothing I do seems to touch this one.

DoktorSeven
August 11th, 2007, 01:28 AM
Seems like I remember running it using nice from some instructions on how to get it past that point:

nice -n 19 wine Steam.exe

nickajeglin
August 11th, 2007, 02:51 AM
that got it past the 26% thing and I signed in. Thanks a bunch.:) Now it just crashes with this error: "steam.exe (main exception): win32 structuredException at a7b1c381: attempt to read from virtual address 2813444993 without appropriate access rights." after login. I seem to remember seeing something about this somewhere else. I'll take a look around

nickajeglin
August 11th, 2007, 04:08 AM
I got it!!!! I got it!!!!
Ok. Here's what I did to make it work.

1. Completely uninstall wine and delete .wine

2.Reinstall wine, reinstall steam with the newest version from their site.

3. Try it, it'll stick at 26%

4. Did recommended fix: that thing with steamtemp.exe this made my Steam.exe disappear.

5. do wine start SteamInstall.msi again and select repair when it asks.

then it worked.