PDA

View Full Version : USN-480-1: Gimp vulnerability



rss-bot
July 5th, 2007, 02:40 AM
Referenced CVEs:
CVE-2007-2949


Description:
================================================== ========= Ubuntu Security Notice USN-480-1 July 04, 2007 gimp vulnerability CVE-2007-2949 ================================================== ========= A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 6.10 Ubuntu 7.04 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 6.06 LTS: gimp 2.2.11-1ubuntu3.3 Ubuntu 6.10: gimp 2.2.13-1ubuntu3.2 Ubuntu 7.04: gimp 2.2.13-1ubuntu4.2 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: Stefan Cornelius discovered that Gimp could miscalculate the size of heap buffers when processing PSD images. By tricking a user into opening a specially crafted PSD file with Gimp, an attacker could exploit this to execute arbitrary code with the user's privileges.





More... (http://www.ubuntu.com/usn/usn-480-1)