PDA

View Full Version : TeamSpeak (No sound & can't talk)



Incarnadine
July 4th, 2007, 05:56 PM
I downloaded TeamSpeak from the add/remove list and I don't get any sound nor can I talk. I have my mic set on "Push To Talk" and when I press my caps lock down the green light doesn't even light up. I checked to see if maybe my mic or speakers were muted in TS or my Volume Control, but everything was set-up right. Maybe it's a problem with my mixer? I checked to see what mixer TS was set-up for and only seen oss/dev/dsp. Where is the ALSA mixer? Do I have to add that somehow? Any advice or help would be great. Thanks.

Haz13r
July 4th, 2007, 06:23 PM
Yea i had the same exact problem. I cant hear anybody or even talk to anyone. Although i installed it a different way by installing it from the Website. goteamspeak.com.

Insomn1a
July 4th, 2007, 09:13 PM
if your using a USB headset, click on other in the TS options, and type /dev/dsp1



that fixed my problem.

Incarnadine
July 4th, 2007, 09:29 PM
No I'm not using a USB headset. I am running TS on my laptop and the microphone and speakers are intergrated in the laptop. I know my mic and speakers work fine because I can record my voice and listen to music. It just doesn't work for TS. I have no clue what's wrong here.

Insomn1a
July 4th, 2007, 09:39 PM
is your operation system currently using the OSS drivers? or ALSA?

Incarnadine
July 4th, 2007, 09:46 PM
It is using ALSA. I checked the supported mixers in TS and I only saw oss/dev/dsp. Where is the ALSA? Should I add this somehow?

Insomn1a
July 5th, 2007, 12:43 AM
i remember seeing a thread on linux-gamers.net about running TS with alsa, ill start looking and edit this thread with the link.

splintercellguy
July 5th, 2007, 09:09 AM
Solution: use the alsa-oss wrapper.

sudo apt-get install alsa-oss

aoss ./TeamSpeak

Incarnadine
July 5th, 2007, 06:48 PM
Ok I installed alsa-oss, but I don't know what you mean with "aoss ./TeamSpeak". I don't understand that. Maybe that's why my problem isn't fixed.

Insomn1a
July 5th, 2007, 10:58 PM
go to accessories then go to terminal



type aoss ./teamspeak

Incarnadine
July 7th, 2007, 09:39 PM
I typed that in the terminal, but this is my result.

incarn@Incarnadine:~$ aoss ./teamspeak
exec: 13: ./teamspeak: not found

splintercellguy
July 7th, 2007, 09:54 PM
Well, you would do that in the directory where TS is installed, or alternative supply the full path.

Incarnadine
July 9th, 2007, 11:17 PM
I don't exactly understand what you mean. Are you talking about typing in the whole directory and then the command? If so then I already tried that and got nothing as a result. It didn't register as a proper command. Could you give me a example of what you mean?

Delirious
July 10th, 2007, 03:53 AM
I have a similar problem except i can hear but not speak, when i hold down the button to talk it llights up and others can hear themselves through my speakers but cant hear me.

I tried that aoss ./TeamSpeak and it didnt work.

Tried that wrapper for alsa and it said i already had the latest.

I have no idea what else to try

Haz13r
July 10th, 2007, 09:15 AM
Well, if anyone finds a solution to this, please PM me.

Incarnadine
July 10th, 2007, 01:53 PM
Delirious it sounds like you have the wrong capture input checked in your volume control. Go into your volume control and then click on the "Switches" tab. Then check your "Microphone Capture". That should solve your problem. Post back on the forum and let me know if everything went ok. Good luck.

Quasimodo316
July 10th, 2007, 10:23 PM
I just right click on the shortcut, add to panel then edit the properties of the panel to be 'aoss teamspeak'. It seems to work ok (as long as aoss supports your card).

Praill
January 14th, 2008, 02:54 AM
I had this same problem. Incarnadine is on the right track, but isn't explaining very well. What I had to do is double click the speaker icon on the main bar by the time. This brings up your volume and sound devices settings.

I had to click on Edit-->Preferences and then check all the unchecked options. Then go over to the recording tab and turn both devices on. Then go over to the Options tab and set to mic.

I also set my teamspeak sound driver device to /dev/audio and ran the teamspeak executable through the aoss wrapper by typing
aoss teamspeak in a terminal.

marmiteOlz
January 14th, 2008, 08:14 PM
ok i had the same / similar problem i could hear but no one could hear me
i double clicked the volume button on the sys tray
on edit-preferences i clicked on the analogue source check box
then selected mic and for me it worked
mine was using alsa as default when i checked
hope it helps

asipi
January 29th, 2008, 08:20 PM
u need a full hardware duplex soundcard in either to teamspeak to get it work (e.g. SB Live!) nowadays integrated 'soundcards' are not the proper hw to use it.
unfortunatelly TS uses the old oss interface for streaming and capture sound data and that is obsolote.
the new teamspeak 3.0 platform will use alsa, but it has not finished yet.

Sugi
October 21st, 2008, 05:28 AM
Sorry to breath life to this old thread.

I installed TeamSpeak through their website, but I was having issuess with audio. Thanks to this thread. Everything is working.


wget
ftp://213.202.254.114/teamspeak/releases/ts2_client_rc2_2032.tar.bz2
cd /home/USR/Desktop
tar -jxf ts2_client_rc2_2032.tar.bz2
cd ts2_client_rc2_2032
sudo chmod 755 setup.sh
sudo ./setup.sh
sudo apt-get install alsa-oss
aoss /opt/teamSpeak2RC2/TeamSpeak
(^to run TeamSpeak)

**Note: I ran TeamSpeak after having Opera and Wine open. So with the aoss command I can use audio with TeamSpeak and having working audio with Opera and Wine.

Specs:
Ubuntu Hardy Heron
TeamSpeak Linux Client 2.0.32.60
Audio Mic Slot Logitech

Sugi