PDA

View Full Version : Steam and no text! Anyone manage to fix this?



dezgot
July 4th, 2005, 05:23 PM
I managed to get wine 20050111 set up properly i think, and i got steam installed, but when i run it, there is absolutely no text in the Steam windows. The buttons and all seem to work and I can blindly login, but beyond that i have no clue what's going on. I have tried putting the Tahoma and Marlett every which place with no luck.

Anyone have this happen and fix it one way or another?

claydoh
July 4th, 2005, 07:36 PM
Valve worked with Transgaming to get Steam/Half-life 2/etc to run using Cedega, (http://digital-conquest.ath.cx/wiki/index.php/Half_Life_2) and there is a special Mozilla activex control that needs to be installed (http://digital-conquest.ath.cx/wiki/index.php/Cedega-4.2#New_Mozilla_Control) (http://a%20special%20Mozilla%20activex%20control%20that%2 0needs%20to%20be%20installed%20)in order to get cedega to show text. I am not sure if anyone has gotten steam to run in "normal" wine just yet, but it works wonderfully for me using Cedega.

Xoomer-Linux
July 22nd, 2007, 10:10 PM
I got the same problem, but cedega is NOT FREE!.. Can't we fix this problem alone?

(sorry i bumped one year old thread but it's annouing that cedega is not free.. i don't use any credit card, but i still need to use steam.. and i bought the steam games on an official Game of the year edition DVD)

BlahMan_of.Doom
July 22nd, 2007, 10:25 PM
Put tahoma.ttf in ~/.wine/drive_c/windows/fonts

Xoomer-Linux
July 22nd, 2007, 10:31 PM
yes, sey i know i just saw it on the valve developer community

Steam uses the font Tahoma which is included in all Windows versions, but is not available on Linux. This will result in invisible text when running Steam without installing Tahoma first.
The easiest way to work around this issue is to put a copy of tahoma.ttf from a Windows installation (%WINDIR%\Fonts) to ~/.wine/drive_c/windows/fonts.

jacob01
July 23rd, 2007, 12:14 AM
or you could down lod the font just search it. also i ran into a problem were i didnt have a plugin installed and could not see the market place what prob are you getting

jacob01
July 23rd, 2007, 12:17 AM
i had the same problem i got a the font but it didnt work so i downloaded another and restarted the install and it worked

FunkDip
March 27th, 2008, 03:20 AM
I had immediate success when I copied tahoma.ttf to /usr/share/wine/fonts and restarted Steam through PlayOnLinux.