PDA

View Full Version : Kdevelop Is Not Working In Ubuntu 7.04!!!



knadoor
May 10th, 2007, 06:04 AM
Hi

please help. Every time I go 'build project" amd choose "run them" from the next box. In Fedora 6 KDE it compiled the files and ran the program in console.

However even a simple hello world program generated by the program itself I tested, does not compile.

This is the messages I get:
cd '/home/knadoor/Desktop/jygutu/yuiyui' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" make -f Makefile.cvs && mkdir '/home/krishna/Desktop/jygutu/yuiyui/debug' && cd '/home/knadoor/Desktop/jygutu/yuiyui/debug' && CXXFLAGS="-O0 -g3" "/home/knadoor/Desktop/jygutu/yuiyui/configure" --enable-debug=full && cd '/home/knadoor/Desktop/jygutu/yuiyui/debug' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" make -k
aclocal
make: aclocal: Command not found
make: *** [all] Error 127
*** Exited with status: 2 ***


Please help! The source code is correct since it was directly generated via KDevelop's hello world sample program I used to test.

Thanks! :(

ps: Sorry for the caps in title, wanted to catch attention.

GeneralZod
May 10th, 2007, 08:29 AM
Have you installed automake?

knadoor
May 10th, 2007, 09:16 AM
yes

GeneralZod
May 10th, 2007, 09:20 AM
yes

build-essential? libtool? autoconf?

If you run



aclocal


from the terminal, what happens?

knadoor
May 10th, 2007, 10:00 AM
If I run aclocal:
knadoor@knadoor-desktop:~$ aclocal
aclocal: `configure.ac' or `configure.in' is required
knadoor@knadoor-desktop:~$

By the way I already have build essential installed, autoconf and automake as well. First it compiled just fine after I installed these, then it said I needed the KDE Konsole to view the program I just made, so I installed Konsole from add/remove and it works. Now when I try to compile again it won't work, instead it gives me:
cd '/home/knadoor/Desktop/LAB8 C++/oiuouio' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" make -f Makefile.cvs && mkdir '/home/knadoor/Desktop/LAB8 C++/oiuouio/debug' && cd '/home/knadoor/Desktop/LAB8 C++/oiuouio/debug' && CXXFLAGS="-O0 -g3" "/home/knadoor/Desktop/LAB8 C++/oiuouio/configure" --enable-debug=full && cd '/home/knadoor/Desktop/LAB8 C++/oiuouio/debug' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" make -k
aclocal
autoheader
automake
autoconf
installing -c
checking whether build environment is sane...
configure: error: ls -t appears to fail. Make sure there is not a broken
alias in your environment
configure: error: newly created file is older than distributed files!
Check your system clock
*** Exited with status: 1 ***

I hope I can get KDevelop working properly since it's very easy to use and is my favourite. I have also gotten Eclipse working with C/C++ but as of right now it's too tedious for me to get used to, and I prefer to use KDevelop instead since thats what we use at Uni.

knadoor
May 10th, 2007, 10:02 AM
ah yes and I have libtool installed as well.

GeneralZod
May 10th, 2007, 10:12 AM
Try doing a "make clean" to sort all that out. Also, ensure that "ls -t", when run, lists the files in the directory in order of "newest first". Does your .bashrc/ .bash_profile have any aliases for "ls"?

knadoor
May 10th, 2007, 10:27 AM
I'll check this out later, all I know is that Fedora Core 6 was the best for KDevelop programming.

knadoor
May 14th, 2007, 02:25 PM
Ok I take back my above statement partially.

Anyways, I fixed this problem. :)
I un-installed KDevelop, and installed several mroe libraries and KDEbase files, basically whatever was related to KDE I downloaded and installed from the package manager. I re-installed KDevelop and now it works.

However for test purposes, I created a simple Hello! World application, it will run in KDE Konsole, but not in Gnome Terminal (is this normal under Ubuntu gnome desktop?). Also in the "Konsole" view in KDevlop it runs just fine.

However in the messages area, even though it says it compiled successfully I get:

aclocal
autoheader
automake
autoconf
installing -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for g++... g++
checking for C++ compiler default output file name... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking how to run the C++ preprocessor... g++ -E
checking for g77... no
checking for xlf... no
checking for f77... no
checking for frt... no
checking for pgf77... no
checking for cf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for xlf90... no
checking for f90... no
checking for pgf90... no
checking for pghpf... no
checking for epcf90... no
checking for gfortran... no
checking for g95... no
checking for xlf95... no
checking for f95... no
checking for fort... no
checking for ifort... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for ftn... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether accepts -g... no
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... yes
compiling yes (gcc)
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics...
cat: /etc/ld.so.conf.d/*.conf: No such file or directory
GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
configure: creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by g++... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking for g++ option to produce PIC... -fPIC
checking if g++ PIC flag -fPIC works... yes
checking if g++ static flag -static works... yes
compiling yes (g++)
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics...
cat: /etc/ld.so.conf.d/*.conf: No such file or directory
GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
appending configuration tag "F77" to libtool
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating config.h
config.status: executing depfiles commands
make all-recursive
Making all in src
compiling lab8.cpp (g++)
mv -f .deps/lab8.Tpo .deps/lab8.Po
linking lab8 (g++)
mkdir .libs
linking lab8 (g++)
make[2]: Nothing to be done for `all-am'.
*** Success ***


What are these 2 above "red" error messages? Are they a cause of concern and how to get rid of them?

Also keep in mind that I'm not a hard core Linux user, I've had about 1-2 months experience in Fedora Core 6 and learnt a lot, however the commands in Ubuntu are different with Bash and Sudo. So speak English, not Ubuntu language :)

thanks!

knadoor
May 14th, 2007, 02:26 PM
And I do have that "conf" files installed from synaptic package manager.

EDIT: I just noticed, for all the ones the compiler checked as "No" as shown in the messages, are they of any cause of concern as well!!??? Since I'm expected to right command line programs that take input arguments on launch to read/write from external file for University assignments and etc.

knadoor
May 17th, 2007, 04:36 AM
bump!!