PDA

View Full Version : Eclipse CDT using a lot of CPU



Mirrorball
May 9th, 2007, 09:46 PM
Eclipse CDT was using a lot of CPU for code completion. I have turned it off but when I typed the ">" in std::set<AClass>, CPU usage went up again. What could the problem be? It's running on Sun Java 6 64bits. I love this IDE but it's too slow. I don't think it was this slow on Edgy.

darreng
May 10th, 2007, 05:49 PM
I'm having the same problem... every few minutes Eclipse just goes away for about 30-40 seconds and top shows java using 100% of the CPU. No indication from Eclipse about what it might be doing.

Mirrorball
May 10th, 2007, 06:03 PM
I'm having the same problem... every few minutes Eclipse just goes away for about 30-40 seconds and top shows java using 100% of the CPU. No indication from Eclipse about what it might be doing.
Exactly what is happening here. I think it's trying to do code completion, although I turned it off.

HP-X
May 17th, 2007, 01:51 PM
This one helped me. Hopefully it can be helpful to you too.

http://ubuntuforums.org/showthread.php?t=201378

Mirrorball
May 17th, 2007, 04:16 PM
Thanks, but I'm already using Sun's Java.

olejorgen
May 17th, 2007, 04:24 PM
You're sure *eclipse* is using java-sun? I think you need to edit some config files. I't s not enough to do update-java-alternatives or install java-sun.

Just to be sure. :)

PartickThistle
May 17th, 2007, 07:51 PM
Try this from the command line to ensure you're using Sun's java.


JAVA_HOME="/path/to/sun-jre/" eclipse

I'm currently using 64bit jrockit for eclipse and it's speeding along. I have also disabled/uninstalled every add-in I don't/won't use.

Mirrorball
May 18th, 2007, 02:54 AM
You're sure *eclipse* is using java-sun? I think you need to edit some config files. I't s not enough to do update-java-alternatives or install java-sun.
Interesting, I didn't know that. I'm going to check tomorrow, thanks!

HP-X
May 18th, 2007, 12:32 PM
Add /usr/lib/jvm/java-6-sun to your /etc/eclipse/java_home and it will probably work.