PDA

View Full Version : Howto: Configure Pidgin for Google Talk



FakeOutdoorsman
May 8th, 2007, 07:23 AM
Note: This post is very out of date. See the official Google instructions on how to do this: How do I configure Pidgin for Google Talk? (http://www.google.com/support/talk/bin/answer.py?hl=en&answer=24073)

Pidgin (http://pidgin.im/), formerly known as GAIM, can be configured to connect to Google Talk (http://www.google.com/talk/).

1) The first time you open Pidgin you will see the welcome window.

2) Click Add.

3)In the Add Account window, add the following:

Protocol: XMPP (This used to be "Jabber" in GAIM)
Screen name: your Google Talk screen name without @gmail.com
Server: gmail.com
Password: If you want Pidgin to log in automatically, enter your Google Talk password and check the Remember password box. The password is stored unencrypted on your computer under the .purple directory in your home folder, so you may not want Pidgin to remember your password for security reasons. It should look like the first attached image below.

4) Click the Advanced tab and add the following:

Connect server: talk.google.com

It should look like the second attached image below.

5) Click Save and you're done.

chipwhisperer
May 10th, 2007, 06:12 PM
Hi,

Thanks for the tutorial! However, I'm running Edgy and I get the error that

<username>/Home disconnected

Server requires TLS/SSL for login. No TLS/SSL support found.


Any idea what I can do? I tried to click the force SSL option but that did not seem to work.

Thanks for any help!

FakeOutdoorsman
May 10th, 2007, 07:08 PM
My guess is that the necessary ports are being blocked by your firewall, proxy, or router.

In order to connect to Google Talk and start sending IMs, you'll need to enable TCP connections to talk.google.com on port 5222, or on port 443. From What ports does Google Talk require? (http://www.google.com/support/talk/bin/answer.py?answer=27930)

You can test to see if you can connect to talk.google.com, port 5222 with the following command in a terminal:


telnet talk.google.com 5222


A successful connection will look like this:


telnet talk.google.com 5222
Trying 72.14.253.125...
Connected to talk.l.google.com.
Escape character is '^]'.
^Connection closed by foreign host.

Elrohir
May 11th, 2007, 07:57 AM
Hi,

Thanks for the tutorial! However, I'm running Edgy and I get the error that

<username>/Home disconnected

Server requires TLS/SSL for login. No TLS/SSL support found.


Any idea what I can do? I tried to click the force SSL option but that did not seem to work.

Thanks for any help!
did you built Pidgin from source? in that case you need a SSL Library, I used Mozilla's SSL Library, libnspr-dev, libssl-dev, and libnss-dev... not sure why those three worked together, but they did... maybe just a combination of two of them or not sure... but those are the libs I installed when I compiled and worked... cheers!

PS: If you need help with the source compiling, PM me and I'll help you step by step...

morneHeru
May 11th, 2007, 03:56 PM
Thanks FakeOutdoorsman, works great for me :)

Fylk
May 11th, 2007, 04:55 PM
Hey, thanks. I was wondering why I wasn't seeing Jabber under the add accounts.

chipwhisperer
May 12th, 2007, 10:51 PM
Hey everyone,

thanks for all of your suggestions! It looks like it was a combo of both FakeOutdoorsman's and Elrohir's sugesstions, but now it's working fine. Thanks all! I'm grateful for your help!

dnoble
May 17th, 2007, 10:46 PM
If you're using Google Talk with a Google Apps domain, you'll need to do a couple things differently:


Configure Pidgin for a Google Apps domain (http://softwaredave.blogspot.com/2007/05/configuring-pidgin-for-google-apps.html)

macness
May 22nd, 2007, 05:46 AM
I upgraded from GAIM and all my user settings ported over from my old .gaim file so all my accounts were added automatically.

However, My Google Talk would continually get SSL Handshake failed. After a few hours the following worked for me.


Delete the old Google Talk/Jabber account that gets ported over
Recreate it using Google's instructions (http://www.google.com/support/talk/bin/answer.py?answer=24073) WORD FOR WORD
go to the advanced tab (as mentioned before in this tread) and change the server to talk.google.com (not in Google's instructions)


Happy Trails. :D

kanna1620
May 23rd, 2007, 10:32 AM
I upgraded from GAIM and all my user settings ported over from my old .gaim file so all my accounts were added automatically.

However, My Google Talk would continually get SSL Handshake failed. After a few hours the following worked for me.


Delete the old Google Talk/Jabber account that gets ported over
Recreate it using Google's instructions (http://www.google.com/support/talk/bin/answer.py?answer=24073) WORD FOR WORD
go to the advanced tab (as mentioned before in this tread) and change the server to talk.google.com (not in Google's instructions)


Happy Trails. :D
I did what you said with no luck. I got the following error.
Read Error
What to do?

scape
May 24th, 2007, 11:29 PM
Hi,
i'm having the same problem has chipwhisperer,

Server requires TLS/SSL for login. No TLS/SSL support found.

i followed Elrohir advice and installed libnspr-dev, libssl-dev, and libnss-dev. I also installed openssl and gnutls-dev, but it still doesn't work.

Any more ideas ?

Thanks for the help

fornix
June 2nd, 2007, 06:12 PM
I get this SSL handshake error too very often. But sometimes gtalk account works. I have the same problem when i connect to gtalk via pidgin on XP too. So i guess it has nothin to do with ubuntu. But the gtalk client works fine on XP.

starlily
June 27th, 2007, 06:00 PM
HOT TO FIX THE TLS ERROR FOR GOOGLE TALK IN PIDGIN!

In a couple of Really Easy Steps:

Since there is no Pidgin Package for Ubuntu yet, I assume you are already building from the source.

do 'make clean' if you have already built it and you get the error.

Open Synaptic Package Manager, search for and install 'libgnutls-dev'

When you run ./configure to build Pidgin, do './configure --enable-gnutls=yes', then look for
SSL Library/Libraries......... : GnuTLS
when it finishes.

do sudo make install (as normal) to finish.

You're Welcome.

Lily

toadtwo
July 2nd, 2007, 04:07 PM
Is there a way to send files from pidgin gtalk to people using the official gtalk client? What about the other way?

cooldudeny
August 16th, 2007, 01:08 AM
i did the same setting on pidgin but i m still getting an error message

and not been able to connect ?

FakeOutdoorsman
August 16th, 2007, 01:22 AM
cooldudeny: What is the error message you get?

ElliottMarlow
August 17th, 2007, 05:40 AM
HOT TO FIX THE TLS ERROR FOR GOOGLE TALK IN PIDGIN!

In a couple of Really Easy Steps:

Since there is no Pidgin Package for Ubuntu yet, I assume you are already building from the source.

do 'make clean' if you have already built it and you get the error.

Open Synaptic Package Manager, search for and install 'libgnutls-dev'

When you run ./configure to build Pidgin, do './configure --enable-gnutls=yes', then look for
SSL Library/Libraries......... : GnuTLS
when it finishes.

do sudo make install (as normal) to finish.

You're Welcome.

Lily

Worked like a charm! Thanks.

meowsus
October 19th, 2007, 12:35 AM
you need a SSL Library, I used Mozilla's SSL Library, libnspr-dev, libssl-dev, and libnss-dev...

You are truly a genius sir. Thank you!

Envirnux
October 26th, 2007, 03:17 PM
Great suggestion for how to build the install. Without that switch it wasn't working for me. Thanks!

gabizu
October 30th, 2007, 08:56 PM
hy! i have that little problem with the pigin proxy i set my proxy for apt(acquaire::.... in apt.conf) the apt is working, for the synaptic and is working too. but when i select in pidgin use GNOME proxy settings is not working! i tried all the combinations (http proxy ->all the settings) and is not working i don't know what to do! tell me pls if is a file that i must modify or write! tks a lot

brunoscunha
November 5th, 2007, 10:10 PM
I think I have the same problem. I'm running gutsy from a fiesty upgrade. Trying to setup a googletalk account, and the message I get is "Not authorized". I'm runing pidgin 2.2.1 and going to upgrade it to 2.2.2
Some help please.

jspam
December 1st, 2007, 02:58 AM
HOT TO FIX THE TLS ERROR FOR GOOGLE TALK IN PIDGIN!

In a couple of Really Easy Steps:

Since there is no Pidgin Package for Ubuntu yet, I assume you are already building from the source.

do 'make clean' if you have already built it and you get the error.

Open Synaptic Package Manager, search for and install 'libgnutls-dev'

When you run ./configure to build Pidgin, do './configure --enable-gnutls=yes', then look for
SSL Library/Libraries......... : GnuTLS
when it finishes.

do sudo make install (as normal) to finish.

You're Welcome.

Lily

This helped me a bunch. Thanks!

dunbrokin
May 23rd, 2008, 06:17 AM
The above all seems to refer to a previous version of Ubuntu so I am wondering if it is relevant to my problem. I am running 8.04 and cannot get the pidgin to work with Google talk...I have followed the set up instructions for Google Talk but I get

XXX@gmail.com/Home disabled
Not Authorised

I have tried re-enable and modify account...but still get the same message.

jrusso2
May 23rd, 2008, 06:30 AM
The above all seems to refer to a previous version of Ubuntu so I am wondering if it is relevant to my problem. I am running 8.04 and cannot get the pidgin to work with Google talk...I have followed the set up instructions for Google Talk but I get

XXX@gmail.com/Home disabled
Not Authorised

I have tried re-enable and modify account...but still get the same message.

Don't add the .gmail.com to your user name it adds it automagically so if you add it it will be username@gmail.com.gmail.com

dunbrokin
May 23rd, 2008, 07:05 AM
Don't add the .gmail.com to your user name it adds it automagically so if you add it it will be username@gmail.com.gmail.com

Thanks, I got it to work...no that was not the problem...for some reason it only works with manual input of password and not automatic...

teledyn
May 23rd, 2008, 07:03 PM
I had this working just fine for a long time, but as of some recent upgrades, it has stopped connecting -- there were some recent changes to the openssl iirc, and I've also upgraded to Heron although I think this
was broken before then.

is there some sort of certificate that i need to refetch or regenerated?

Wheazel
June 5th, 2008, 08:31 PM
Thanks, I got it to work...no that was not the problem...for some reason it only works with manual input of password and not automatic...

Same problem here.

K.Mandla
June 13th, 2008, 12:35 AM
Moved to Outdated Tutorials and Tips at the request of the OPer.

sriram.vr
November 10th, 2008, 02:28 PM
Here is a workaround for having voice chat with google talk users.

http://sriramblox.blogspot.com/2008/08/making-voice-call-to-google-contact.html

http://sriramblox.blogspot.com/2008/10/voice-chat-with-google-talk-user-using.html

I hope this helps.

pepemosca
January 11th, 2009, 07:00 PM
If you're using Google Talk with a Google Apps domain, you'll need to do a couple things differently:


Configure Pidgin for a Google Apps domain (http://softwaredave.blogspot.com/2007/05/configuring-pidgin-for-google-apps.html)
Thanks!

shantzg001
March 22nd, 2009, 06:07 PM
There can be more issues with gtalk and pidgin, e.g., if you company blocks it. Here is a method to overcome this :P:
http://tech.shantanugoel.com/2008/09/08/hack-pidgin-gtalk-connection-problems-get-around-the-corporate-firewall.html

asaturn
July 7th, 2009, 01:55 PM
there is a more official way of keeping Pidgin more up to date shown here:

http://www.pidgin.im/download/ubuntu/

chiques
September 8th, 2009, 07:30 PM
Excellent! Thanks

devilspirit
October 4th, 2009, 06:11 PM
did you built Pidgin from source? in that case you need a SSL Library, I used Mozilla's SSL Library, libnspr-dev, libssl-dev, and libnss-dev... not sure why those three worked together, but they did... maybe just a combination of two of them or not sure... but those are the libs I installed when I compiled and worked... cheers!

PS: If you need help with the source compiling, PM me and I'll help you step by step...


i'm getting messge like

username@gmail.com/host disconnected
ssl connection failed.
i checked force old port(5223)ssl
port 433

even port 5222 doesnt work


i'm behind a proxy sever and the proxy settings work well vth the web browser.

plz suggest some solution to this problem

devilspirit
October 5th, 2009, 10:21 AM
My guess is that the necessary ports are being blocked by your firewall, proxy, or router.

In order to connect to Google Talk and start sending IMs, you'll need to enable TCP connections to talk.google.com on port 5222, or on port 443. From What ports does Google Talk require? (http://www.google.com/support/talk/bin/answer.py?answer=27930)

You can test to see if you can connect to talk.google.com, port 5222 with the following command in a terminal:


telnet talk.google.com 5222
A successful connection will look like this:


telnet talk.google.com 5222
Trying 72.14.253.125...
Connected to talk.l.google.com.
Escape character is '^]'.
^Connection closed by foreign host.



hi , i'm using pidgin on xubuntu.
the above settings work well and i got same result as u said. but the problem still persists
it shows ssl connection failed . i'm behind a proxy network. can u plz suggest some solution.

dipspesh
October 18th, 2009, 03:14 PM
I had installed an earlier version on pidgin and made it to connect to the servers using the methods told here..but since it didn't support file sharing i upgraded to pidgin 2.6.1 and now i'm not able to connect to any of the servers(i.e yahoo and google )
these error messages are being displayed
for google->(Unable to find alternative XMPP connection methods after failing to connect directly.)
for yahoo->Unable to connect: Error resolving scsa.msg.yahoo.com:
No address associated with hostname

please help resolving this error!!

kevdog
October 19th, 2009, 01:15 AM
Honestly -- I don't think pidgin works with google talk anymore but I could be wrong. I thought that capability was halted around Sept/Oct 2009.

stephanecharette
November 20th, 2009, 06:11 PM
I don't think pidgin works with google talk anymore but I could be wrong.

Still works for me. I'm using 2.6.2 in Ubuntu 9.10. I doubt the Pidgin team would let support lapse very long for one of the biggest networks of users.

Stéphane

skywalker_7421
November 25th, 2009, 07:54 PM
I ran gtalk on pidgin like this :

Step 1 : Checked which ports were open for me to connect to talk.google.com at console

http://i50.tinypic.com/5wlfkh.png

As u see none worked, as i am behind a proxy.

Step 2: Installed latest pidgin available in my local repo (pidgin 2.5.5).

Step 3: Settings in account

Select the account --> Modify Account

Basic settings

http://i45.tinypic.com/1zc1d2x.png

Advanced settings

http://i50.tinypic.com/211j4t4.png

In addition, i played with Tools-->Preferences-->Network too. Well the final setting was following -

http://i47.tinypic.com/243n5tk.png

...

Aruz
November 29th, 2009, 09:33 PM
If you use google apps. Must be activated "Google Talk" on Google Apps.

andy_butcher
February 4th, 2010, 01:35 PM
I tried various things mentioned above, including the installing the libssl libraries, and configuring my firewall but in the end I logged into google.com and saw that my username was shown with an @googlemail.com at the end (not gmail.com)

Once I changed that in Pidgin, it worked just fine.

Endolith
May 4th, 2010, 11:24 PM
this has worked fine for me for years, but now one account disconnects and says "not authorized" while the other works fine. empathy says authentication failed

Sutur
August 2nd, 2010, 07:13 AM
Thanks mate, heaps of guides skip the "talk.google.com" section. No WONDER is wasn't connecting before!

sandeepch
August 16th, 2010, 07:53 AM
after configuration how can i make audio call.no tabs for audio and vidio call

sonicleung
September 3rd, 2010, 02:08 AM
just google it.a lot of password finder tools support IM.
like:password recovery bundle (http://www.********************)

robinpaschal
September 20th, 2010, 10:57 AM
Thanks for help...

Nightcrawlers
August 10th, 2011, 02:00 PM
Thanks for this info! I switched to Ubuntu 10.10 and was wondering how to configure Pidgin! Very helpful! May the Gnome Gods bless you lol