PDA

View Full Version : HOWTO: RT61 on Egdy Eft with WPA



Pages : 1 [2]

whayong
March 3rd, 2007, 05:46 PM
Alright, I got the wireless card to connect to an AP at school with DHCP and no security. I just need to try it at work which has WEP and static IP.

All I did was edited the /etc/Wireless/RT61STA/rt61sta.dat and removed the values I entered for the SSID, encyption type, password, etc...... Baisically, I edited the file back to it's "unedited version" and I can now connect to other AP's.

mesmerize
March 15th, 2007, 10:35 PM
I have a desktop with Ubuntu 6.10 and Windows Xp and a laptop with Xp. I connect to the Internet through the ethernet card to the cable modem (it's not wifi). I have created and ad-hoc lan in windows to connect the laptop to Internet. I'd do the same with Ubuntu, so I'd not have to boot windows to do that.
I have the linksys wmp54g v4.1 and I think it's properly configurated.

George M. Harkin
March 16th, 2007, 08:11 AM
It seems these drivers are completely unstable. It does the same on my system and is reported to the same on most systems. I really would not recommend anyone to install it. If you have a wlan NIC with ralink chip your best solution is to get a refund and buy a card that actually is supported by Ubuntu. Ralinks drivers are horribly messed up anyways. Etc, a company that creates drivers where you have to specify encryption mode (among other things) in the driver dat file?!!!. Thats even more retarded than ATi's drivers. :}

Althou, if someone eventually finds a solution for them I would be interested in how.

The drivers seem to be working fine for me. My only issue is that NetworkManager does not want to manage it. I'm looking into fixing that now.

So, great card, with great linux support. More than you can ask from Dell.

Phophos
March 17th, 2007, 03:50 AM
Ahh, ignore my last post - this is now working in 32-bit Edgy. I followed this walkthrough with a little help from some other areas too.

If anyone is having problems here, http://www.ubuntuforums.org/printthread.php?t=132980&pp=75 is bloomin' marvellous. The scripts to place in init.d work rather well.

The main little twist is using iwpriv instead of iwconfig. No clue as to why this works, but by Jove it does.

One point, I've not yet tested it with WPAPSK, only WEP. This is plenty secure for my neighbourhood though - they're not really out of the Stone Age around here, or even past dial-up...

Anyway! More tips:


Look around at all of the walkthroughs you can! Also, if you don't understand something, man it or ask in the IRC channels.
After following any procedure such as this, don't ever use the GUI managers that come as standard again, or you'll break things...
Download rtutilt. It's handy!
Learn how to use vim before you attempt to fix that rt61sta.dat, or stuff starts breaking.


I'm posting this wirelessly after a week of trying. The most important point? Never give up! Giving up hope is for the weak!

In the meantime, I hope y'all sort your RT61 problems out.

The Phopsynator.

Andrew MacDonald
March 18th, 2007, 10:01 PM
If you're having trouble downloading the driver try here:

http://www.ralinktech.com.tw/data/RT61_Linux_STA_Drv1.1.0.0.tar.gz

new_pingu
March 18th, 2007, 10:31 PM
Thanks PH,
I have been trying to connect using my wireless card for weeks with no luck. followed your guide and was up with an hour. A well written step by step for RT61.

Best Regards
New_pingu :)

Andrew MacDonald
March 19th, 2007, 07:03 AM
If you are using a post-2.6.18 kernel the driver supplied by ralink won't compile. get_wireless_stats has been removed from netdevice.h as discussed here:
http://www.linuxquestions.org/questions/showthread.php?t=529973

Instead, get the latest cvs tarball from:
http://rt2x00.serialmonkey.com/wiki/index.php?title=Downloads
and follow the same method.

lime4x4
March 23rd, 2007, 03:26 AM
do i still need t load the proper drivers yet

00:0a.0 Network controller: RaLink RT2561/RT61 802.11g PCI

this is on a fresh install of edgy after running the lspci command. I can't connect wirelessly yet.just trying to figure if i still need to compile the newer drivers if edgy already detects the card properly

Frak
March 24th, 2007, 06:33 PM
I created a HOWTO: and a script to install the driver automatically for anybody who needs it, I've tested it and it works fine.
http://ubuntuforums.org/showthread.php?p=2344944#post2344944
Hopefully this will help.

zophiel
March 25th, 2007, 10:53 AM
Has anyone tried using the rt61 to turn the installation into a router?

namely this:

http://www.ubuntuforums.org/showthread.php?t=376283

I tried the iwconfig ra0 mode master
and it gave the predictable:

# iwconfig ra0 mode master
Error for wireless request "Set Mode" (8B06) :
SET failed on device ra0 ; Invalid argument.

here is the relevant iwconfig:ra0 RT61 Wireless ESSID:""
Mode:Auto Frequency:2.412 GHz Bit Rate=54 Mb/s
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality=0/100 Signal level:-121 dBm Noise level:-111 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

anyone know?

sbyrne
March 25th, 2007, 03:14 PM
Thanks PHQ,

I am continually amazed at how easy it is to get support for even the more esoteric problems. I used your guide and had wireless in less than 15 minutes. I have had no success whatsoever with the ndiswrapper approach under any configuration :(

I am now using WPA to connect to an Airport Extreme. The guide worked the first time on a relatively clean edgy 6.10 install.

I have given up trying to get my on-board BCM4316 working with any of the every suggested fix and simply use a Netgear WG111v2 plugged into a USB port on my Dell XPS m140. Worked almost immediately after plugging it in. Now if only I can get that to work with WPA....

BeachBum
March 25th, 2007, 11:55 PM
Has anyone tried using the rt61 to turn the installation into a router?

namely this:

http://www.ubuntuforums.org/showthread.php?t=376283

I tried the iwconfig ra0 mode master
and it gave the predictable:

# iwconfig ra0 mode master
Error for wireless request "Set Mode" (8B06) :
SET failed on device ra0 ; Invalid argument.


The RaLink driver does not support master mode; you'd need the rt2x00 serialmonkey driver, which is still beta software.

radio_flyer
March 26th, 2007, 07:48 AM
I have to agree with stormfrog. I'm surprised that so many people are having success with this HOWTO. The system I'm installing this on is an AMD Sempron with 32-bit Edgy. I successfully compiled and installed the rt61.ko module from the latest 1.1.0.0 sources from Ralink. At first iwconfig showed the ra0 link up but I couldn't get a DHCP IP address assignment. A few minutes later the kernel froze solid. Rebooting the system produced a blank screen. Attempts to reboot in 'safe mode' resulted in 'soft lockup detected on CPU#0'. I eventually had to boot using my Gentoo rescue CD and remove the rt61 module from /etc/modules and the ra0 interface from /etc/network/interfaces (the latter because of the 'ra0 rt61' alias BTW) before Ubuntu would boot back up.

I find this whole wireless situation really disappointing. I've been using Linux for a decade (currently running Gentoo on my primary system) so I'm no stranger to the issues involved with OSS and Linux. However, I'm building this new system for my niece and wanted something easy to use and as GUI-driven as possible. I shopped carefully, bought hardware I knew had good Linux support, and choose Ubuntu for it's ease-of-use and automagic installation. Overall the out-of-the-box experience has been great. Except for the wireless connection. Heck, the box even says 'Linux drivers included' on it. Of course, if I try to modprobe those I get symbol mismatch errors. So I do the source compile thing using code direct from the manufacturer web site. And my system freezes so solid I have to revert to my beyond-noob skills to rescue it. That is really sad.

I will get this thing working eventually (probably with a different manufacturer's card) but it pains me to see Linux getting SO close to being a real OS option for the average PC user and yet fail so miserably on a few key items. Walk into a coffee shop with Mac OSX, scroll through the list of access points and connect. Fire up your office WinXP, enter the office SSID and WPA2 password and hit enter. So simple. That day still seems a long way off for Linux.

radio_flyer
March 26th, 2007, 08:27 AM
Now I'm really surprised this is working so well for so many people. Here's a bug report from the serialmonkey site:

http://sourceforge.net/tracker/index.php?func=detail&aid=1687350&group_id=107832&atid=648844

which indicates that the rt61 driver has issues with an SMP kernel (like Ubuntu's.) Yeah, I know this is the rt61 thread not serialmonkey, but read the whole report. It appears to be the 1.1.0.0 rt61 driver, not the serialmonkey one, that hangs.

Junge
March 26th, 2007, 05:49 PM
Hi,

I think the tutorial works fine, so that's great. When I come to the end and assign an ip with ifconfig I can actually ping my wireless router.

Except i'm wondering about two things:

1) How doe I get it to start at boot? Because the echo command doesn't seem to work. Each time the computer boots I have to load the module and assign an ip with ifconfig, even though the router is DHCP.

2) The internet still doesn't work?

Grtz,

Jeroen
(newbie)

Frak
March 26th, 2007, 11:07 PM
Have you tried iwpriv? Instead of iwconfig?
just use

man iwpriv

Junge
March 27th, 2007, 10:16 PM
Have you tried iwpriv? Instead of iwconfig?
just use

man iwpriv

It worked with that! Made a auto startup script to. Many thnx!

tictacman
April 1st, 2007, 06:17 PM
How are you supposed create a passphrase that's less than 52 characters long? Every time I type wpa_passphrase myssid mypassword not matter how short mypassword is it always creates a string larger than 52 characters.

Andrew MacDonald
April 2nd, 2007, 02:23 AM
I believe the passphrase should be your ASCII password. At least that's what I have in my rt61sta.dat file.

tictacman
April 2nd, 2007, 06:42 PM
I've just managed to get the card working after spending the whole weekend trying. I know this going over old ground but I thought I would post exactly what I did to get it working, in the hope it might benefit other rt61 victims. Following the guide on pg1 word for word did not work for me, and I tried several different drivers.

I'm using kubuntu 6.10 with the latest updates and the serial monkey driver which I downloaded (rt61-cvs-2007040123). First off I tried to get the card working without encyrption.I installed the driver as page1 of the howto instructed except copying makefile.6 to makefile as there wasn't makefile.6 and ignoring the encyrption settings. My user defined setting in rt6sta.dat looked like this:

SSID=mdkgroup
NetworkType=OPEN
Channel=8
PSMode=CAM

Everything else commented out with #.

In /etc/network/interface I kept the entry for ra0 simple:

auto ra0
iface ra0 inet dhcp

When I booted into recovery mode it worked, when I loaded up into kde it failed. I figured out that it was my mobo's fault because it has via graphics (k8mm3 - via k8m800+vt82374/823475 + chipset). I found a workaround by going into /etc/X11/xorg.conf and under the via driver adding the option: Option "DisableIRQ" "true" and also adding irqpoll to the default kernel line in /boot/grub/menu.lst. After this everything working well. The card now connected everytime.

However when I tried setup wpapsk as per instructions (except keeping network type as OPEN) it failed miserably. This time I commented the ra0 section in /etc/network/interface. I tried removing the module so I could add it again, but the system said ra0 busy. I commented out the rt61 entry in /etc/module so it wouldn't load on boot. Shut the system down rebooted in recovery mode, removed the module.


modprobe --remove
depmod -a
modprobe rt61
dhclient ra0

Bam!! it worked. Just a case now of creating a script to load the card at boot.

The last section of the rt61sta.dat without the commented out lines now looks like this.:

SSID=notworkgroup
NetworkType=OPEN
Channel=8
AuthMode=WPAPSK
WPAPSK=forbiddenfruit
PSMode=CAM

ep2011
April 3rd, 2007, 04:28 AM
This didn't work for me, so heres what I did to make it work perfectly.

1.) Download the latest original Ralink RT61 drivers from:

$> wget http://www.ralinktech.com/drivers/Linux/RT61_Linux_STA_Drv1.1.0.0.tar.gz

Note: I wrote the guide for 1.0.4.0, but it is no longer available for download. However, it should work with the new driver as well. If it does, please post that.
2.) Compile the Module
Install the kernel headers corresponding to your kernel (In most cases it should be installed by default, but it seems there are derivates which won't do that)

sudo apt-get install linux-headers-`uname -r`
^^ Did NOT need to do.


$> tar xvfz RT61_Linux_STA_Drv1.0.4.0.tar.gz
$> cd RT61_Linux_STA_Drv1.0.4.0/Module/
$> cp -f Makefile.6 Makefile
$> make all

3.) Get root

$> sudo su

4.) Prepare Config directory for the module

#> mkdir -p /etc/Wireless/RT61STA/
#> cp *.bin /etc/Wireless/RT61STA/
#> cp rt61sta.dat /etc/Wireless/RT61STA/

5.) Install Kernel Module

#> cp rt61.ko /lib/modules/`uname -r`/kernel/drivers/net/
#> depmod

6.) Configure module via rt61sta.dat (use binary edit mode)

#> vi -b /etc/Wireless/RT61STA/rt61sta.dat
ENTER FOLLOWING:


[Default]
NetworkType=Infra
AuthMode=SHARED
EncrypType=WEP
DefaultKeyID=1
Key1=<KEY>
SSID=<WIRELESS SSID>

7.) Remove broken preinstalled Module


8.) Load module rt61

#> modprobe rt61

Edit modprobe and network config files

Add broken module to blacklist:

#> echo 'blacklist rt61pci' >> /etc/modprobe.d/blacklist

Add the new module to module autostart

#> echo 'rt61' >> /etc/modules

and create an alias

#> echo 'alias ra0 rt61' >> /etc/modprobe.d/aliases

Create file named StartWifi.sh in /etc/init.d/

#!/bin/sh
sudo modprobe --remove rt61pci
sudo modprobe rt61
sudo iwpriv ra0 set NetworkType=Infra
sudo iwpriv ra0 set AuthMode=SHARED
sudo iwpriv ra0 set EncrypType=WEP
sudo iwpriv ra0 set DefaultKeyID=1
sudo iwpriv ra0 set Key1=<KEY>
sudo iwpriv ra0 set SSID=<WIRELESS SSID>
sudo dhclient ra0


Enter the following terminal commands


sudo chmod 0755 /etc/init.d/StartWifi.sh
sudo ln -s /etc/init.d/STartWifi.sh /etc/rc2.d/S90StartWifi.sh


Reboot - Try - Be Happy! :-D

Now, If you do a kernel update do the following:

copy rt61.ko from /lib/modules/(OLD KERNEL)/kernel/drivers/net to /lib/modules/(NEW KERNEL)/kernel/drivers/net

then run the following terminal command:

sudo depmod

And that should be it!!!

I did not make this up myself, I took some of the info from this post, some from another post, and some from help from very nice people in IRC.

Dj Delta9
April 14th, 2007, 08:44 AM
:guitar: YES! SUCCESS! Thank you so much! This has taken me an entire week to figure out since Im noobtastic, but now all is well in the universe! I can go on with my life.=D>

ultranoize
April 19th, 2007, 06:17 PM
Has anyone upgraded to Feisty yet? I've thought about doing it but if it means that the wireless is not going to work then i'd rather not. Any suggestions? I read here http://ubuntuforums.org/showthread.php?t=408987 something about not being able to use WAP. Is this true?

Any suggestions???

Frak
April 19th, 2007, 09:46 PM
Has anyone upgraded to Feisty yet? I've thought about doing it but if it means that the wireless is not going to work then i'd rather not. Any suggestions? I read here http://ubuntuforums.org/showthread.php?t=408987 something about not being able to use WAP. Is this true?

Any suggestions???
I was unable to connect to any network, let alone see any network.

sunburst01
May 20th, 2007, 11:41 AM
Following this howto, seems to work ok, on my freshly installed 2.6.20-15 Feisty Fawn system with Lynksys wmp54g and BT Wireless service. One deviation from the procedure...

My "make all" did not work when building the driver as downloaded from ralinktech.com. I had to comment out one line (197) in file RT61_Linux_STA_Drv1.1.0.0/Module/rtmp_main.c to get it to build:

#if WIRELESS_EXT >= 12
// net_dev->get_wireless_stats = RT61_get_wireless_stats;
net_dev->wireless_handlers = (struct iw_handler_def *) &rt61_iw_handler_def;
#endif

The wireless.h file on my system has been changed to remove get_wireless_stats.

Aside from that, procedure works fine. My rt61sta.dat file reads:

[Default]
CountryRegion=0
CountryRegionABand=7
WirelessMode=0
SSID=BTHomeHub-181B
NetworkType=Infra
Channel=0
AuthMode=OPEN
EncrypType=WEP
DefaultKeyID=1
Key1Type=hexadecimal
Key1Str=.......... (my 10 digit hex key entered in here)
Key2Type=0
Key2Str=
Key3Type=0
Key3Str=
Key4Type=0
Key4Str=
WPAPSK=abcdefghijklmnopqrstuvwxyz
TxBurst=0
PktAggregate=0
WmmCapable=0
APSDCapable=0
APSDAC=0;0;0;0
BGProtection=0
IEEE80211H=0
TxRate=0
RTSThreshold=2347
FragThreshold=2346
RoamThreshold=75
PSMode=CAM
TxPreamble=0
FastRoaming=0

Hope this helps!
Ciao...

gatoruss
June 1st, 2007, 11:58 AM
I have been wrestling with wifi and Feisty for over a week. Everything worked fine until I upgraded to 7.04!

Well, after some tinkering, I have gotten the wifi to work following the tutorial mentioned in post #4 of this thread (http://http://ubuntuforums.org/showthread.php?t=415693), as modified by post #1. However, it only boots up manually and I cannot get wifi to fire up on start up...I need to manually launch every time I boot up?" But it does not fire up wifi on start up....any suggestions?

hanspb
August 29th, 2007, 11:22 AM
I'm bringing this thread up again.
I have a machine with Fluxbuntu (based on Ubuntu Dapper drake) and the rt61 wireless. Previously my network has had WEP encryption. Back then everything worked fine and I had my network connection working. I recently changed that to WPA-PSK. Now, I tried to change the setup for this Fluxbuntu-machine to use WPA-PSK. What I did was the following:

-Changed to WPA-PSK in /etc/wireless/RT61STA/rt61sta.dat according to this guide.

-In /etc/network/interfaces I commented out the unused interfaces and I added



iface ra0 inet dhcp
wireless-essid <MYESSID>
auto ra0


Then I tested the setup with


ifup ra0

All worked fine, I got on the net like a piece of cake. Ok, reboot to see that it works like it should...

BANG!

The #%& machine won't boot! it hangs on "starting ra0" and I don't get any further!:(
Can anybody help me? Obviously I need to use a live CD to fix this, but what should I do?

Also, at the same time this happened, I lost my wireless connection on my laptop, which I had running in order to read this guide while working. Now I can't connect to the wireless network, neither in Ubuntu (Feisty) nor in Windows (it's a dual-boot system):(
Cabled network is fine.

Hans Petter

woZa
September 12th, 2007, 08:44 PM
Thanks for the HOWTO... Seems to have got my card up and running... Only issue I am now having is that I can't see the base station when scanning...


sudo iwlist ra0 scan

ra0 Scan completed :
Cell 01 - Address: 00:14:7F:57:1C:4B
ESSID:"BTHomeHub-E488"
Mode:Managed
Channel:6
Encryption key:on
Bit Rates:0 kb/s
Cell 02 - Address: 00:14:C1:04:C1:50
ESSID:"USR9108"
Mode:Managed
Channel:11
Encryption key:off
Bit Rates:0 kb/s
Cell 03 - Address: 00:13:49:A0:BA:EE
ESSID:"ZyXEL"
Mode:Managed
Channel:6
Encryption key:off
Bit Rates:0 kb/s

Great. Only those are my neighbours - mine is not showing up. It is an apple airport extreme base station. I have tried turning off ALL security on it and it still won't show up in the scans.


iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

ra0 RT61 Wireless ESSID:"" Nickname:""
Mode:Auto Frequency:2.412 GHz Bit Rate=54 Mb/s
RTS thr:off Fragment thr:off



cat /etc/Wireless/RT61STA/rt61sta.dat

[Default]
CountryRegion=0
CountryRegionABand=7
WirelessMode=0
SSID=Wireless
NetworkType=Infra
Channel=0
AuthMode=WPAPSK
EncrypType=TKIP
DefaultKeyID=1
Key1Type=0
Key1Str=0123456789
Key2Type=0
Key2Str=
Key3Type=0
Key3Str=
Key4Type=0
Key4Str=
WPAPSK=myplaintextpassword
TxBurst=0
PktAggregate=0
WmmCapable=0
APSDCapable=0
APSDAC=0;0;0;0
BGProtection=0
IEEE80211H=0
TxRate=0
RTSThreshold=2347
FragThreshold=2346
RoamThreshold=75
PSMode=CAM
TxPreamble=0
FastRoaming=0

Anyone any ideas about this?

Oh. And I am running a fresh install of feisty 7.04...

Thanks
Alex

googlah
October 26th, 2007, 04:43 PM
The link to the actual driver at Ralinktech.com seem to be down. Can't get further without this.. :)

Thanks for a nice How-to anyway, just hope this helps. ^^

Frak
October 26th, 2007, 09:41 PM
The link to the actual driver at Ralinktech.com seem to be down. Can't get further without this.. :)

Thanks for a nice How-to anyway, just hope this helps. ^^
Newer versions of Ubuntu have the RT61 driver module already.

vilwarin
September 15th, 2008, 10:03 AM
finishing this howto didn't connect me yet, I had to do one more step independent whether you compile the module yourself or use the new module rt61pci included in hardy.

network-manager only cause trouble, I removed it
wicd looked promising but was also not able to connect me
iwconfig could not connect me either
iwpriv same here
rt61sta.dat RAlinks config method also lead in a cul-de-sac

what finally did the trick was using the RALink Utility Tools (rutilt). Using this tool I finally can connect to my Access Point. Get it from the standard package list by typing


apt-get install build-essential rutilt

and find it in


Applications > Internet > RUtilt WLAN Manager
(hardy)

good luck
vilwarin

wamubu
October 7th, 2008, 05:24 AM
Latest driver version:
1.2.2.2 @ 7/23/2008 (http://www.ralinktech.com.tw/data/drivers/2008_0723_RT61_Linux_STA_v1.1.2.2.tar.bz2) 902kB
1.2.2.2 Doc (http://www.ralinktech.com.tw/data/drivers/ReleaseNote-RT61STA-v1122.txt)

omax
November 1st, 2008, 10:19 PM
Hi and thank you for an excellent guide!

Though I'm having some troubles, because after a few hours of uptime the network crashes. iwconfig does not show that I'm connected to my AP but ifconfig still shows my internal IP.

Here's the error code when I try to restart networking:


$ sudo /etc/init.d/networking restart
* Reconfiguring network interfaces... ioctl[SIOCSIWMODE]: Network is down
Could not configure driver to use managed mode
SIOCADDRT: No such process
Failed to bring up ra0.
[ OK ]
t$ sudo /etc/init.d/networking restart
* Reconfiguring network interfaces...




ioctl[SIOCSIWENCODEEXT]: Network is down
ioctl[SIOCSIWENCODEEXT]: Network is down
ioctl[SIOCSIWENCODEEXT]: Network is down
ioctl[SIOCSIWENCODEEXT]: Network is down
SIOCADDRT: No such process
Failed to bring up ra0.
[ OK ]


$ sudo /etc/init.d/networking restart
* Reconfiguring network interfaces... ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/ra0' manually if it is not used anymore
Failed to initialize control interface '/var/run/wpa_supplicant'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

ioctl[SIOCSIWAP]: Network is down
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
SIOCADDRT: No such process
Failed to bring up ra0.
[ OK ]


Dmesg from the time of crash and trying to restart networking:

[ 2051.421375] e2:1a:09:be:b3:44:5f:1b:82:79:82:c0:05:e9:15:02:
[ 2051.421391] d8:a0:05:0e:89:da:b7:4a:
[ 2051.421394] e0:f7:3e:90:01:eb:ff:65:
[ 5654.032581] 06:1a:85:07:99:d2:2a:5c:76:d3:30:77:f4:71:7f:a5:
[ 5654.032592] 11:fb:78:99:e2:31:55:87:
[ 5654.032595] 6f:9f:02:01:3d:75:3e:94:
[ 5657.031476] 06:1a:85:07:99:d2:2a:5c:76:d3:30:77:f4:71:7f:a5:
[ 5657.031486] 11:fb:78:99:e2:31:55:87:
[ 5657.031489] 6f:9f:02:01:3d:75:3e:94:
[ 9256.667820] 5a:61:00:fb:29:4d:4d:2a:61:90:a2:1d:ed:85:34:27:
[ 9256.667829] 26:a1:9a:c7:c5:a3:2e:3b:
[ 9256.667832] b1:ba:ea:46:1f:e5:f4:a1:
[ 9259.650342] 5a:61:00:fb:29:4d:4d:2a:61:90:a2:1d:ed:85:34:27:
[ 9259.650355] 26:a1:9a:c7:c5:a3:2e:3b:
[ 9259.650359] b1:ba:ea:46:1f:e5:f4:a1:
[ 9262.649764] 5a:61:00:fb:29:4d:4d:2a:61:90:a2:1d:ed:85:34:27:
[ 9262.649777] 26:a1:9a:c7:c5:a3:2e:3b:
[ 9262.649781] b1:ba:ea:46:1f:e5:f4:a1:
[12862.277547] 24:90:d2:9e:d9:67:ed:d1:f3:4a:62:42:95:85:01:fa:
[12862.277557] d7:f9:8e:27:48:47:45:fa:
[12862.277560] bb:0b:24:30:c4:6a:51:41:
[12942.258465] Before wrapper, AuthMode=7, wepStatus=6, pCipher=6, gCipher=4, IEEE8021X=0
[12942.258473] After wrapper, the AuthMode=7! wepStatus=6!
[12942.904273] RT61: RfIcType= 3
[12946.007071] Before wrapper, AuthMode=0, wepStatus=1, pCipher=1, gCipher=1, IEEE8021X=0
[12946.007077] After wrapper, the AuthMode=7! wepStatus=6!
[12946.115317] ReqVarIELen=36! RespIELen=120!
[12946.115323] infoLen=343!
[12946.115338] wext_notify_event_assoc():AssocInfo=
[12946.115340] ASSOCINFO(ReqIE0100000fac020100000fac040100000fac0 20000 RespIEff000000000000000000000000000000000000000000 dd1a00904c340807050000000f000000000000000000000000 00000030180100000fac020200000fac02000fac040100000f ac020000dd1a0050f20101000050f20202000050f2020050f2 0401000050f202)!
[12946.115346] ra0 (WE) : Wireless Event too big (343)
[12946.388562] c3:65:1b:44:21:49:65:7e:ea:13:87:2c:75:58:9a:19:
[12946.388572] 00:00:00:00:00:00:00:00:
[12946.388575] 00:00:00:00:00:00:00:00:
[12946.388614] 24:90:d2:9e:d9:67:ed:d1:f3:4a:62:42:95:85:01:fa:
[12946.388622] d7:f9:8e:27:48:47:45:fa:
[12946.388627] bb:0b:24:30:c4:6a:51:41:
[12953.509193] ra0: no IPv6 routers present
[12969.226399] Before wrapper, AuthMode=7, wepStatus=6, pCipher=6, gCipher=4, IEEE8021X=0
[12969.226406] After wrapper, the AuthMode=7! wepStatus=6!
[12969.935980] RT61: RfIcType= 3
[12976.912359] Before wrapper, AuthMode=0, wepStatus=1, pCipher=1, gCipher=1, IEEE8021X=0
[12976.912366] After wrapper, the AuthMode=7! wepStatus=6!
[12976.932449] ReqVarIELen=36! RespIELen=120!
[12976.932454] infoLen=343!
[12976.932470] wext_notify_event_assoc():AssocInfo=
[12976.932471] ASSOCINFO(ReqIE0100000fac020100000fac040100000fac0 20000 RespIEff000000000000000000000000000000000000000000 dd1a00904c340807050000000f000000000000000000000000 00000030180100000fac020200000fac02000fac040100000f ac020000dd1a0050f20101000050f20202000050f2020050f2 0401000050f202)!
[12976.932477] ra0 (WE) : Wireless Event too big (343)
[12980.023802] ra0: no IPv6 routers present
[12989.962312] Before wrapper, AuthMode=7, wepStatus=6, pCipher=6, gCipher=6, IEEE8021X=0
[12989.962319] After wrapper, the AuthMode=7! wepStatus=6!
[12989.977579] ReqVarIELen=36! RespIELen=120!
[12989.977586] infoLen=343!
[12989.977601] wext_notify_event_assoc():AssocInfo=
[12989.977602] ASSOCINFO(ReqIE0100000fac020100000fac040100000fac0 20000 RespIEff000000000000000000000000000000000000000000 dd1a00904c340807050000000f000000000000000000000000 00000030180100000fac020200000fac02000fac040100000f ac020000dd1a0050f20101000050f20202000050f2020050f2 0401000050f202)!
[12989.977608] ra0 (WE) : Wireless Event too big (343)
[12991.314335] Before wrapper, AuthMode=7, wepStatus=6, pCipher=6, gCipher=6, IEEE8021X=0
[12991.314341] After wrapper, the AuthMode=7! wepStatus=6!
[12991.895662] RT61: RfIcType= 3
[12993.933879] Before wrapper, AuthMode=0, wepStatus=1, pCipher=1, gCipher=1, IEEE8021X=0
[12993.933886] After wrapper, the AuthMode=3! wepStatus=1!
[12994.536898] RT61: RfIcType= 3
[12995.233538] Before wrapper, AuthMode=0, wepStatus=1, pCipher=1, gCipher=1, IEEE8021X=0
[12995.233545] After wrapper, the AuthMode=3! wepStatus=1!
[12995.825391] RT61: RfIcType= 3
[12996.477280] Before wrapper, AuthMode=0, wepStatus=1, pCipher=1, gCipher=1, IEEE8021X=0
[12996.477288] After wrapper, the AuthMode=3! wepStatus=1!
[12997.056009] RT61: RfIcType= 3
[12997.701039] Before wrapper, AuthMode=0, wepStatus=1, pCipher=1, gCipher=1, IEEE8021X=0
[12997.701046] After wrapper, the AuthMode=3! wepStatus=1!
[12998.312059] RT61: RfIcType= 3
[12999.408292] Before wrapper, AuthMode=0, wepStatus=1, pCipher=1, gCipher=1, IEEE8021X=0
[12999.408299] After wrapper, the AuthMode=3! wepStatus=1!
[12999.993904] RT61: RfIcType= 3
[13010.453626] ra0: no IPv6 routers present


Has anyone had any similar problems? What could be wrong?