PDA

View Full Version : [ubuntu] "move to workspace" option not available on maximized window



abulawa
February 3rd, 2013, 04:08 PM
In Ubuntu 12.04, the "move to workspace" option appears by clicking on the title bar of a non-maximized window. However, it is not available by right clicking on the title bar of a maximized window.

Is this a bug? Is there a workaround?

I'm aware that the keyboard shortcut Alt-space will bring up the option, but I was hoping to find a mouse-only solution.

ibjsb4
February 3rd, 2013, 04:19 PM
You may want to look into Devilspie.

https://help.ubuntu.com/community/Devilspie

stinkeye
February 3rd, 2013, 09:11 PM
Install xdotool and use ccsm (compizconfig-settings-manager) to set the command

xdotool key alt+space
to be initiated when you click the top of the screen with right mouse.

zombifier25
February 4th, 2013, 01:39 PM
Install xdotool and use ccsm (compizconfig-settings-manager) to set the command

xdotool key alt+space
to be initiated when you click the top of the screen with right mouse.

That's a pretty neat trick. Thanks!

abulawa
February 5th, 2013, 11:23 PM
Install xdotool and use ccsm (compizconfig-settings-manager) to set the command

xdotool key alt+space
to be initiated when you click the top of the screen with right mouse.
Thank you! That works very well!