PDA

View Full Version : NFS Setup Problem



SnoopFogg
January 12th, 2013, 07:08 PM
Hi, I'm trying to set up NFS, but I'm getting this error on the client:

russ@studio:~$ sudo mount 192.168.1.84:/home/videos /home/russ
[sudo] password for russ:
mount.nfs: rpc.statd is not running but is required for remote locking.
mount.nfs: Either use '-o nolock' to keep locks local, or start statd.
mount.nfs: an incorrect mount option was specified

Can anyone help? Let me know what other information would be useful.

Cheers

steeldriver
January 12th, 2013, 09:11 PM
Have you installed the nfs-common package on the client machine?


$ apt-cache show nfs-common
Package: nfs-common
Priority: optional
Section: net
.
.
.
Description-en: NFS support files common to client and server
Use this package on any machine that uses NFS, either as client or
server. Programs included: lockd, statd, showmount, nfsstat, gssd,
idmapd and mount.nfs.
.
.
.


Also are you sure you want to mount it over /home/russ (rather than a subdir e.g. /home/russ/videos)?

SnoopFogg
January 12th, 2013, 11:08 PM
Hi, I have been following these instructions which include setting up nfs-common: https://help.ubuntu.com/community/SettingUpNFSHowTo

Also tried the suggested mount point but I get the same error.

One part of the client setup I wasn't clear on was mounting an exported subtree with this:

# mount -t nfs4 -o proto=tcp,port=2049 nfs-server:/users /home/users

Is the "nfs-server" part literally just that? Or is it the name or IP address of the server? Similarly the instruction to mount the complete export tree with:

# mount -t nfs4 -o proto=tcp,port=2049 nfs-server:/ /mnt

bab1
January 12th, 2013, 11:21 PM
Hi, I have been following these instructions which include setting up nfs-common: https://help.ubuntu.com/community/SettingUpNFSHowTo

Also tried the suggested mount point but I get the same error.

One part of the client setup I wasn't clear on was mounting an exported subtree with this:

# mount -t nfs4 -o proto=tcp,port=2049 nfs-server:/users /home/users

Is the "nfs-server" part literally just that? Or is it the name or IP address of the server?

It should be the IP address or hostname.

You should also use mount -t nfs (not nfs4) on the latest Ubuntu versions.

Merrattic
January 13th, 2013, 02:43 AM
This howto has always worked for me:

http://ubuntuforums.org/showthread.php?t=249889

bab1
January 13th, 2013, 04:28 AM
This howto has always worked for me:

http://ubuntuforums.org/showthread.php?t=249889
The link is from 6 years ago (2006). It may work with NFSv3 and Ubunutu 6.04. It documents a system the is not in the current package. NFS doesn't use portmap any more for one thing.

SnoopFogg
January 13th, 2013, 10:42 AM
Thanks everyone. Got it sorted. I just hadn't created the mount point correctly. Everything working fine and the server mounts when it boots up.

Cheers

Merrattic
January 13th, 2013, 09:36 PM
The link is from 6 years ago (2006). It may work with NFSv3 and Ubunutu 6.04. It documents a system the is not in the current package. NFS doesn't use portmap any more for one thing.

It still works regardless, the basic principles are the same. I followed the howto for my 12.04 server and workstations and it works. I might get round to updating it ;)