PDA

View Full Version : [ubuntu] NVIDIA Geforce 8600GTS rendering problem on dual monitor



raczzoli
December 25th, 2012, 04:13 PM
Hi.

I have Ubuntu 12.04 with NVIDIA`s proprietary driver (310.19) installed, and my problem is the following: When I open any kind of window on the primary monitor and start to drag it a little bit faster, a horizontal line appears in the middle, which splits the window in two. Below this line the window`s horizontal position is displaced with 10-15 pixels, and if I continue dragging, the line slowly moves up until it reaches the top of the window and disappears. After a few seconds it appears again at the bottom. The same thing happens when I watch some movie on full screen. (It`s like when you have two graphics cards in SLI, which are not 100% compatible with each other sometimes and while playing a game a horizontal line appears because one of them is processing a little bit slower then the other.) Unfortunately I`m unable to make a print screen of this, probably because while making the screenshot, the dragging stops.

The interesting thing is that if I do the same thing on the second monitor, doesn`t matter how fast I drag the window, nothing happens.

I`m guessing that there is some kind of problem with the graphics driver, because with the Nouveau driver I don`t have this problem. On Ubuntu 10.04 I`ve had the same problem, but it was less disturbing.

Can somebody give me an idea, what can I do, to solve this problem? It`s not that I can`t live with it, but it`s a little annoying.


My computer has the following configuration:
CPU: Core 2 Duo, 3.0 GHZ
Memory: 4GB RAM
Graphics: NVIDIA 8600GTS
2 monitors:
Primary: DELL E248WFP (1920x1200, 60Hz)
Secondary: Asus VB171D (1280x1024, 60Hz)


And this is how my xorg.conf looks:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 310.19 (buildmeister@swio-display-x86-rhel47-08.nvidia.com) Thu Nov 8 02:09:12 PST 2012

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 310.19 (buildmeister@swio-display-x86-rhel47-08.nvidia.com) Thu Nov 8 02:08:55 PST 2012
# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#Section "InputDevice"
#
# # generated from default
# Identifier "Mouse0"
# Driver "mouse"
# Option "Protocol" "auto"
# Option "Device" "/dev/psaux"
# Option "Emulate3Buttons" "no"
# Option "ZAxisMapping" "4 5"
#EndSection
# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#Section "InputDevice"
#
# # generated from default
# Identifier "Keyboard0"
# Driver "kbd"
#EndSection

Section "ServerLayout"

# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
# InputDevice "Keyboard0" "CoreKeyboard"
# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
# InputDevice "Mouse0" "CorePointer"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Ancor Communications Inc ASUS VB171"
HorizSync 30.0 - 83.0
VertRefresh 55.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8600 GTS"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "Stereo" "0"
Option "nvidiaXineramaInfoOrder" "DFP-0"
Option "metamodes" "CRT: nvidia-auto-select +1920+0, DFP: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

raczzoli
December 26th, 2012, 03:48 PM
Somebody? Any idea will do.