View Full Version : failed to boot on a UEFI computer (ThinkCentre Edge 92)

December 18th, 2012, 01:56 AM

I've installed Ubuntu 12.10 desktop x86-64 into a ThinkCentre Edge 92 PC. The install process went through just fine but it failed to boot. The computer says:

Error 1962: No operating system found

The boot info can be found in:


The firmware has been configured to boot in UEFI mode and QuickBoot has been disabled. The ubuntu live USB boots just fine.

Please help me on how I can troubleshoot this thing. For example, is it possible to invoke the UEFI shell or check any boot log?


December 18th, 2012, 02:10 AM
It looks like Boot-Repair made fixes.

Did you go back into UEFI menu and choose to boot the ubuntu entry? And does Windows boot from UEFI menu directly? If so the new entry Boot-Repair added should work.

grub2's os-prober creates wrong style (BIOS) chain boot entry
These style entries will not work.
'Windows ...) (on /dev/sdXY)'

BootOrder: 0001,0005,0006,000B,0007,000C,0000,0004
Boot0001* ubuntu

December 18th, 2012, 06:46 AM
Thanks for the reply. The problem is, there is no boot menu at all. The first thing appears on the screen is that error message.

December 18th, 2012, 08:06 AM
It is likely due to this issue: http://mjg59.dreamwidth.org/20187.html?thread=774619

December 18th, 2012, 09:03 AM
sorry, that error ("no operating system found") was caused by the enable status of compatibility mode (CSM). After disabling that, the grub menu is displayed and I can boot into Windows. But choosing the ubuntu entry will boot into busybox. So, the problem is still not solved yet.

December 18th, 2012, 09:43 AM
Sorry, actually I screwed up that ubuntu partition. So, now it is working fine.

December 18th, 2012, 04:45 PM
Whatever it takes to get it working. Glad you resolved it. :)