PDA

View Full Version : [ubuntu] Disable automount of encrypted partition



selepo
December 2nd, 2012, 06:39 PM
Hi, I'm running a headless server and have an encrypted partition (fileserver). It is encrypted with LUKS.

I would like to mount it manually, but it keeps asking for a password at startup which is kind of annoying on a headless server.
I have tried all combinations of setting it to noauto/deleting the entry entirely in fstab and crypttab.

I get a feeling it ignores these files and prompts for password based on something else during startup.

Please help!

/Selepo

Ms. Daisy
December 2nd, 2012, 06:45 PM
automount options are set in fstab.

https://help.ubuntu.com/community/Fstab
https://help.ubuntu.com/community/AutomaticallyMountPartitions

selepo
December 2nd, 2012, 06:56 PM
automount options are set in fstab.

https://help.ubuntu.com/community/Fstab
https://help.ubuntu.com/community/AutomaticallyMountPartitions
Thanks for the quick reply. I realize that, as i stated above I have tried both setting options to "rw,noauto" and totally editing out the entry for this drive in fstab. I can confirm that does work for non-encrypted drives (that is they are no longer mounted on startup).
/selepo

selepo
December 4th, 2012, 12:39 PM
Anyone ?
/Selepo

tubbygweilo
December 4th, 2012, 09:22 PM
selepo,
At time of posting 112 people have given your problem some thought, some may be considering your problem, some may not have the knowledge to answer you question, some may have other things to do.

Give it a bit of time and those who can contribute may well do so.

ATB

howefield
December 4th, 2012, 10:11 PM
Thread moved to the "Server Platforms" forum.