PDA

View Full Version : [ubuntu] 12.04 root open file limits



JameZer
November 23rd, 2012, 09:50 AM
I have an issue with ulimits on ubuntu server 12.04 .

I've set a custom ulimit for open files .

root soft nofile 20000

root hard nofile 60000

This setting doesn't work , i've tried setting >pam_limits.so in /etc/pam.d/common-session

But still , nothing .

I want to mention that setting a limit for an user , on root it has the same value .

If you set all (*) the root limits works .

I want to set the limits only for the root account .

Anyone had this issue ? Does pam.d have any effect on this ?

Thanks ,

rnerwein
November 23rd, 2012, 10:35 AM
I have an issue with ulimits on ubuntu server 12.04 .

I've set a custom ulimit for open files .

root soft nofile 20000

root hard nofile 60000

This setting doesn't work , i've tried setting >pam_limits.so in /etc/pam.d/common-session

But still , nothing .

I want to mention that setting a limit for an user , on root it has the same value .

If you set all (*) the root limits works .

I want to set the limits only for the root account .

Anyone had this issue ? Does pam.d have any effect on this ?

Thanks ,

if root works with an asterisk - then it must be a bug - see man limits.conf

--> man limits.conf
NOTE: group and wildcard limits are not applied to the root user.
To set a limit for the root user, this field must contain the
literal username root.

i set in /etc/pam.d/login and /etc/pam.d/login /etc/pam.d/sshd
session required pam_limits.so

NOTE: all limit settings are set per login

this limits work for the user testuser.
but be careful with "as" as you see i comment it because with that limit the
testuses can't login (only black scren after typing the password !!!!
<domain> <type> <item> <value>
testuser soft data 512000
testuser hard data 1000000
testuser soft stack 8192
testuser hard stack 16384
#testuser soft as 512000
#testuser hard as 1000000

compiz get more than 1000 MB virtual size

lisati
November 24th, 2012, 08:34 AM
Thread moved to Server Platforms.